#mahara-dev Meeting

Meeting started by elky at 07:37:31 UTC (full logs).

Meeting summary

    1. elky is melissa draper, catalyst it, nz (elky, 07:38:24)
    2. hughdavenport is Hugh Davenport, Catalyst IT, NZ (hughdavenport, 07:38:39)
    3. anzeljg is Gregor Anzelj, Gimnazija Bezigrad, Slovenia (anzeljg, 07:38:45)
    4. kevinmoilar is Kevin Mueller, Liip AG, Switzerland (kevinmoilar, 07:39:37)
    5. https://wiki.mahara.org/index.php/Developer_Area/Developer_Meetings/2012-07-31 (elky, 07:39:51)

  1. items from past meetings (elky, 07:40:17)
  2. dajan to raise appropriate issues in the tracker (elky, 07:40:25)
    1. iarenaza is IƱaki Arenaza (Mondragon Unibertsitatea) (iarenaza, 07:42:08)
    2. http://meetbot.mahara.org/mahara-dev/2012/mahara-dev.2012-04-25-20.02.log.html has it (hughdavenport, 07:43:42)

  3. anzeljg To put together a quick wiki page with some information (possibly code too) <= wiki page done, code not yet. (elky, 07:43:52)
    1. https://wiki.mahara.org/index.php/Developer_Area/Specifications_in_Development/Cloud_Services (elky, 07:44:03)
    2. https://wiki.mahara.org/index.php/Developer_Area/Specifications_in_Development/Cloud_Services (anzeljg, 07:44:22)
    3. https://github.com/anzeljg/mahara-cloud (anzeljg, 07:45:12)
    4. Currently Cloud plugin has support/integration for Box, Dropbox, SugarSync and Zotero (elky, 07:46:03)

  4. alanmc to post to dev forum post about the mobile api (elky, 07:48:28)
    1. https://mahara.org/interaction/forum/topic.php?id=4747#post20953 (elky, 07:48:35)
    2. ACTION: hugh to work with alan on maharadroid/api stuff before feature freeze (elky, 07:52:20)

  5. elky look into removing google apps block from the core (elky, 07:52:51)
    1. elky's not had a chance (elky, 07:53:03)
    2. should be noted that much of it would be replaced by anzeljg's cloudy stuff which is yay (elky, 07:53:44)

  6. elky/hughdavenport update code guidelines and extend it to other than php (elky, 07:54:15)
    1. kevinmoilar concerned about non-committal regarding messaging/commenting support in api (elky, 07:57:42)
    2. ACTION: elky to confirm plans with alan (elky, 07:58:14)
    3. hughdavenport suggests alan give "a general overview on how they may be extended in the commit message (and/or wiki)" (elky, 08:00:23)
    4. kevinmoilar asks about iOS support. answer; currently we don't know of an iOS developer, but if one magically appeared we'd not turn them away (elky, 08:02:57)

  7. dajan to raise appropriate issues in the tracker (elky, 08:05:52)
    1. http://meetbot.mahara.org/mahara-dev/2012/mahara-dev.2012-04-25-20.02.log.html has it (hughdavenport, 08:06:28)
    2. Ruslan Kabalin - Lancaster University, UK (rkabalin, 08:07:34)
    3. dobedobedoh is Andrew Nicols - Lancaster University, UK (dobedobedoh, 08:07:49)
    4. dajan says: i will write in the tracker a few revommendations about extresource plugin to find a way to fusion Laurent Emprecht's plugin eith the actual external resources plugins we have nowadays in Mahara (elky, 08:08:29)
    5. dajan: we should find a way of having just one block to embed all the different external sources that works in collaboration with the code for iframes (elky, 08:13:44)
    6. elky: maintainability needs to be considered carefully too (elky, 08:13:59)
    7. ACTION: kristina, dajan and anzeljg to coordinate and extend anzeljg's spec to work out similarities and differences etc (elky, 08:20:53)

  8. Continued: Discuss safeiframe xss vulnerabilities (elky, 08:24:23)
    1. still no resolution about the best way forward. will need to play it by ear (elky, 08:34:00)

  9. Next meeting and Chair (elky, 08:41:34)
    1. next meeting is wednesday August 29th 2012 utc 8pm, iarenaza will chair (elky, 08:53:17)
    2. http://www.timeanddate.com/worldclock/fixedtime.html?msg=20th+Mahara+Developer+Meeting&iso=20120829T20 (elky, 08:55:59)

  10. Other business: (elky, 08:56:17)
    1. Mahara 1.4.3 and 1.5.2 went out a few hours ago, yay! (elky, 08:56:35)
    2. security releases, fix for that mysql can't cope with lots of things problem (elky, 08:57:04)
    3. iaranza has a svg patch for the manual, will talk to elky in email about it (elky, 09:01:30)
    4. <dajan> Could we at some point (next meeting) speak about webservices I see a huge potentialvfor moodle and other services integration with Mahara but i think there is a lack of info and example on this (elky, 09:01:47)


Meeting ended at 09:03:07 UTC (full logs).

Action items

  1. hugh to work with alan on maharadroid/api stuff before feature freeze
  2. elky to confirm plans with alan
  3. kristina, dajan and anzeljg to coordinate and extend anzeljg's spec to work out similarities and differences etc


Action items, by person

  1. anzeljg
    1. kristina, dajan and anzeljg to coordinate and extend anzeljg's spec to work out similarities and differences etc
  2. dajan
    1. kristina, dajan and anzeljg to coordinate and extend anzeljg's spec to work out similarities and differences etc
  3. elky
    1. elky to confirm plans with alan


People present (lines said)

  1. elky (133)
  2. anzeljg (50)
  3. iarenaza (34)
  4. hughdavenport (29)
  5. dajan (29)
  6. kevinmoilar (29)
  7. rkabalin (19)
  8. dobedobedoh (11)
  9. maharameet (4)
  10. lukecarrier (1)


Generated by MeetBot 0.1.4.