20:02:47 <dobedobedoh> #startmeeting
20:02:47 <maharameet> Meeting started Wed Apr 25 20:02:47 2012 UTC.  The chair is dobedobedoh. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:02:47 <maharameet> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:02:50 <dobedobedoh> Welcome to the 16th Mahara Developer Meeting.
20:02:52 <dobedobedoh> Please introduce yourself with #info <name>[, <organisation>], <location>
20:02:54 <dobedobedoh> #info Andrew Nicols, Lancaster University, UK
20:03:02 <fmarier> #info Francois Marier
20:03:09 <anzeljg> #info anzeljg is Gregor Anzelj, translator and developer from Ljubljana, Slovenia
20:03:10 <rkabalin_> #info Ruslan Kabalin, Lancaster University, UK
20:03:13 <richardm> #info Richard Mansfield, Catalyst IT, Wellington
20:03:26 <anitsirk> #info Kristina Hoeppner, Catalyst IT, Wellington
20:03:33 <hughdavenport`> #info Hugh Davenport, Catalyst IT, Wellington
20:03:39 <anitsirk> fmarier: awesome. the bay area at this time of the year is great.
20:04:24 * dobedobedoh prods dajan ;)
20:04:25 <dajan> #info Dominique-Alain JAN french translator - Lausanne Switzerland
20:04:36 <dobedobedoh> I think that's everyone so far
20:04:39 <dobedobedoh> #topic Items from last meeting
20:04:41 <dobedobedoh> #info The minutes from the last meeting are available at http://meetbot.mahara.org/mahara-dev/2012/mahara-dev.2012-03-27-07.41.html
20:04:50 <dobedobedoh> #info fmarier completed his two action items during the last meeting. Check the minutes of that meeting for details
20:04:59 <dobedobedoh> #info anzeljg has joined the slovenian team on launchpad so that we could make it the owner of the mahara translation
20:05:10 <anzeljg> done some minutes after the meeting
20:05:26 <dobedobedoh> Was there anything else from the previous meeting that should have been in the Actions that should be discussed here?
20:05:43 <anitsirk> anzeljg: yep. it is just to confirm that these things were already long done due to you and fmarier being so quick. :-)
20:06:04 <anzeljg> ;)
20:06:07 <dobedobedoh> :)
20:06:12 <dobedobedoh> In which case, we shall press on.
20:06:16 <anitsirk> dobedobedoh: not that i can think of. though i think we kept CIA in mahara-commits
20:06:33 <dobedobedoh> We've got 9 further items on the agenda. I have adjusted the order slightly
20:06:55 <dobedobedoh> #info CIA stays in #mahara-commits and has not made it to #mahara-dev
20:07:19 <dobedobedoh> If anyone has any objections to that decision, then can they raise them in AOB...
20:07:49 <dobedobedoh> As a quick reminder from previous meetings, if you are writing multiple lines
20:07:59 <dobedobedoh> Then can you signify when you finish by ending in ...
20:08:02 <dobedobedoh> #topic Roadmap for Mahara 1.6 (dajan)
20:08:11 <dobedobedoh> Over to you dajan
20:08:57 <dajan> Yes. I was on the wiki last day and I noticed that the roadmap was for 1.3 and 1.4. Now 1.5 is out, maybe it is time to rewrite the wiki to give users and institutions a clear view of what is coming next.
20:09:40 <dobedobedoh> #info The roadmap on the wiki is vastly out of date
20:09:43 <dajan> So for you and the community to decide/discuss what feature to work on for 1.6.
20:09:54 <dobedobedoh> #link https://wiki.mahara.org/index.php/Roadmap
20:10:12 <anitsirk> we haven't updated the wiki pages as there is not really a roadmap. things get into mahara when there is either funding for new features or we fix things as far as i see it
20:10:34 <anitsirk> as funding is not necessarily confirmed at the beginning of a release, drawing up a full roadmap would be tricky.
20:10:36 <dobedobedoh> I think that it would be great to have some guidance from Catalyst here. There are features lined up and waiting to go in (we're discussing some of those later)
20:10:41 <fmarier> last time anitsirk and I talked about it, we came to the conclusion that a roadmap doesn't make sense for Mahara given that nobody is really driving the new features in the project
20:11:12 <dajan> So maybe the time has come to delete the page. It is not a good marketing to have outdated pages for a roadmap. What do you think?
20:11:29 <fmarier> Catalyst is funding the maintenance of the project (and that's quite a lot of work) but contributors and funders are the ones who drive new feature development when it comes down to it
20:11:56 <fmarier> dajan: that's a fair comment and not a bad idea
20:12:04 <anitsirk> +1
20:12:06 <fmarier> i don't really see the purpose of that page anymore
20:12:10 <anitsirk> hi iarenaza
20:12:13 <hughdavenport`> i would agree
20:12:17 <richardm> melissa has also created some launchpad blueprints for some of the new proposed features
20:12:23 <iarenaza> hi
20:12:25 <richardm> and we can put milestones against those
20:12:32 <dobedobedoh> I think that it is important to have some kind of idea as to what's coming up in future releases
20:12:37 <dobedobedoh> even if they are pie-in-the-sky
20:12:46 <anitsirk> i think the blueprints and the associated pages under "Specifications in development" are better than the roadmap
20:12:54 <richardm> i agree
20:12:59 <anzeljg> +1
20:13:11 <fmarier> dobedobedoh: but if you publish something that people want, they'll be disappointed if it's not in the next release
20:13:16 <anzeljg> hi iarenaza
20:13:18 <anitsirk> dobedobedoh: i don't agree because that might raise expectations too high, e.g. skins etc.
20:13:30 <dajan> I agree, that if we already know what new features will be in .1.6, to communicate about this. Public is sensitive to such message.
20:13:39 <dobedobedoh> fmarier: true, but there should be a single source of information for people to find out what's in the pipeline
20:13:45 <dobedobedoh> even if it doesn't have specific targets against it
20:13:54 <dobedobedoh> and it may help to get some of those features funded into core
20:14:03 <anitsirk> but isn't that "specifications in development"?
20:14:06 <fmarier> i personally like the milestone/blueprint idea
20:14:13 <dobedobedoh> well probably
20:14:16 <anitsirk> there we have a bunch of things listed and move them to "completed" once done.
20:14:21 <fmarier> anitsirk: spec in dev doesn't really show what's being worked on
20:14:34 <fmarier> there's a lot of things on there that were proposed but will never get done
20:14:37 <fmarier> (and that's ok)
20:14:40 <rkabalin_> then roadmap page can probably contain the link to blueprints
20:14:42 <dajan> We could say aside of some interesting features to come : Need funding. This will maybe raise the interest of some people with money
20:14:52 <anitsirk> that's where the blueprints can help because there we can change the status
20:14:57 <dobedobedoh> Perhaps it would be helpful to also include links to launchpad searches showing what's happening/happened recently
20:15:02 <dobedobedoh> or for a specific version
20:15:04 <dobedobedoh> ...
20:15:08 <iarenaza> #info iarenaza Iñaki Arenaza, Mondragon Unibertsitatea, Spain
20:15:21 <dobedobedoh> Hi iarenaza
20:15:25 <anitsirk> #info blueprints for mahara started at http://manual.mahara.org/en/1.5_STABLE/genindex.html#N
20:15:36 <anitsirk> oops. sorry. wrong link
20:15:45 <anitsirk> could you try to undo this please, dobedobedoh ?
20:15:49 <dobedobedoh> #undo
20:15:49 <maharameet> Removing item from minutes: <MeetBot.items.Info object at 0x99318ec>
20:15:59 <dobedobedoh> #info Specs in Development are on the wiki at https://wiki.mahara.org/index.php/Developer_Area/Specifications_in_Development
20:16:18 <anitsirk> #info blueprints for mahara started at https://blueprints.launchpad.net/mahara
20:16:23 <anitsirk> thanks dobedobedoh
20:16:42 <dajan> Thanks. This is interesting and should replace the roadmap page. My opinion.
20:16:42 <dobedobedoh> Perhaps the existing roadmap page should link to the relevant pages then?
20:17:13 <anitsirk> and on the blueprints we can change the status and see what is going on.
20:17:15 <dobedobedoh> +1
20:17:21 <anzeljg> +1
20:17:42 <dajan> +1
20:17:45 <dobedobedoh> #idea Those who have made a suggestion which is on the blueprints page should add more detail to save elky doing all of the work
20:17:48 <dobedobedoh> Any objections?
20:18:01 <hughdavenport`> sounds good
20:18:04 <anitsirk> nope
20:18:05 <dajan> ok
20:18:11 <dobedobedoh> #agreed The Roadmap page should link to the blueprints page
20:18:11 <anzeljg> agree
20:18:17 <dobedobedoh> Would anyone like to take on the task?
20:18:24 <anitsirk> i'll do it
20:18:46 <anitsirk> i already put a link to the manual on hopefully all user guide pages on the wiki. so i have the initial code. ;-)
20:18:49 <dobedobedoh> #info anitsirk to update the roadmap
20:18:56 <dobedobedoh> #undo
20:18:56 <maharameet> Removing item from minutes: <MeetBot.items.Info object at 0x992c6cc>
20:19:05 <dobedobedoh> #action anitsirk to update the roadmap
20:19:25 <dobedobedoh> Is there anything else to discuss on the roadmap..?
20:19:31 <dajan> nope
20:19:57 <dobedobedoh> related to the roadmap, how will things work for those trying to get features in?
20:20:08 <dobedobedoh> If things are primarily driven by funding at the moment?
20:21:53 <dobedobedoh> Okay... I'll move onto the next topic for the moment
20:21:58 <dobedobedoh> #topic Laurent Opprecht's "Notes" plugin (University of Geneva) as a way to improve the actual "Notes" block in Mahara (dajan)
20:22:02 <anitsirk> dobedobedoh: by funding i mean for example: somebody wants to funds / develops a feature that should go into core -> it is developed -> goes into review. more experienced reviewers (not just catalyst) would help because then things don't get stuck in the queue
20:22:22 <anitsirk> oh my "wants to fund / develop"
20:22:45 <dobedobedoh> okay. Thanks for clarifying :)
20:23:09 <anitsirk> ideally, the funding also includes time for going through the review system. ;-)
20:23:19 <dobedobedoh> heh qutie
20:23:39 <anitsirk> it's like testing that needs to be done.
20:24:34 <dajan> did we change the topic?
20:24:37 <dobedobedoh> we did :)
20:24:40 <dajan> Ok
20:24:47 <dajan> Laurent Opprecht from University of Geneva is really doing interesting things around Mahara and he has already developped some plugins for Mahara.
20:24:55 <dajan> I spoke to him and the whole Geneva team weeks agon
20:24:55 <dobedobedoh> (but we carried on talking about the old one for a moment)
20:24:59 <dajan> sorry ago
20:25:32 <dajan> Before 1.5 he developped and interesting alternative to the Mahara blocktype Note (his plugin is available on the wiki on my request)
20:25:41 <dajan> In 1.5 we can re-use Notes blocks in other pages. But we can't create notes from the "Content" section of Mahara. Laurent's plugin does that. It separates the collection/creation process (in Content) from the diplay process (in Pages).
20:26:53 <lamiette> hi everyone, sorry to interupt and sorry I'm late :)
20:27:16 <anitsirk> dajan: i think a combination of the current functionality (1.5) and laurent's idea might be good. i like being able to create notes directly on a page. users sometimes complain that they can't do that for journals, for example. oursourcing it to just the content would be a step back. but i agree that it would be good to be able to create a note under "Content" as well as with files
20:27:43 <dajan> I think that his way is better than what we can do with 1.5 and the Note block type. It is less confusing for users and separate the task of creating things from the one of presenting them.
20:28:04 <richardm> dajan: Is creation under content the only extra feature?  would it be easier for us to just add a new create note button to 1.5?
20:28:28 <dajan> Yes I agree with you Kristina. But it is a bit confusing to create a new page to add a note for a future use. Isn't it?
20:28:28 <dobedobedoh> #info Luarent Opprecht (University of Geneva) has developed a Notes artefact for Mahara which separates content creation from display
20:29:01 <anitsirk> but we already mix that with the upload of files from the page. i think being able to do that in both places and collect them all under content would be nice. furthermore, we still need the possibility to copy notes as is possible in 1.5.
20:29:11 <dajan> yes richardm, it is the only thing I saw that make it different. But interesting.
20:29:43 <anitsirk> dajan: so far notes were text boxes and created for immediate use. having the "create note" feature on the content tab would be good for the future use.
20:29:43 <dajan> It is possible to copy and edit note in Laurent's plugin as in 1.5
20:29:55 <anitsirk> cool.
20:30:16 <dajan> Just have a look and maybe use what you think good to improve Mahara.
20:30:18 <anitsirk> forgot about that.
20:30:56 <dobedobedoh> #idea Look at integrating missing features from Laurent's Note plugin into Mahara
20:31:02 <anitsirk> https://mahara.org/interaction/forum/topic.php?id=4352 is where we discussed it.
20:31:50 <dobedobedoh> Perhaps a blueprint task?
20:32:12 <richardm> maybe, adding the create note button, and letting "edit note" should be pretty easy though
20:32:27 <richardm> er letting "edit note" create notes i mean
20:32:53 <richardm> maybe it's more a bug rather than a blueprint
20:32:56 <richardm> ..
20:33:03 <dobedobedoh> agreed
20:33:07 <anitsirk> +1
20:33:13 <dajan> +1
20:33:14 <anzeljg> +1
20:33:37 <dobedobedoh> dajan, would you be able to raise appropriate bugs/feature requests in the tracker for this?
20:33:51 <dajan> Wilco
20:33:56 <richardm> :)
20:34:01 <dajan> ricahrdm : This guy has other jewels in his cases. Stay in touch with him. Uni Geneva are doing great things w/ Mahara.
20:34:16 <dobedobedoh> #action dajan to raise appropriate issues in the tracker
20:34:28 <anitsirk> dajan: which will bring us to his other plugin ;-)
20:34:28 <dobedobedoh> Perhaps we can persuade them to take part in core...
20:34:32 <dobedobedoh> indeed
20:34:35 <dobedobedoh> #topic Laurent Opprecht's "Extresource" plugin with OEmbed protocol to improve the way of embedding "things"in Mahara (dajan)
20:34:53 <dobedobedoh> dajan has the floor again
20:35:11 <richardm> dajan: yes, he's done a lot of work on one of the auth plugins too, hasn't he?
20:35:28 <dajan> Ok. Nothing much to say about this, after having seen a post today from Kristina saying that Laurent will put this into the core (exresource I mean)
20:35:43 <anitsirk> https://blueprints.launchpad.net/mahara/+spec/external-media-oembed - blueprint already exists :-)
20:35:55 <dobedobedoh> #info Laurent to submit Extresource to core
20:36:15 <anitsirk> he was just waiting for us to finish something. richardm has just pushed these changes. they were around the external media block
20:36:20 <anzeljg> Haven't looked at the source code, but what is the difference with Emed.ly? I belive Embed.ly also uses OEmbed protocol...
20:36:20 <dajan> The auth plugin (CAS) was made by Mr Pollet Uni of Lyon (France) I turned him from developing things for Moodle to Mahara
20:36:35 <dobedobedoh> Nice conversion dajan :)
20:36:45 <richardm> :)
20:37:03 <anitsirk> anzeljg: as far as i can see it does not rely on an external service like embed.ly that might be turned off at some point.
20:37:13 <anzeljg> I see
20:37:42 <dajan> Yes your are right. Embdly need the access to embed.ly what extresource doesn't
20:37:53 <anzeljg> cool
20:38:21 <dobedobedoh> #idea It would be nice if some of the plugins being 'replaced' in this sense would provide upgrade paths if appropriate
20:38:23 <anzeljg> So embedly will "die" eventually...
20:38:57 <anitsirk> anzeljg: not necessarily as not every service allows for oembed yet.
20:39:03 <dajan> I think we should keep the block type External media and Extresource together. Because Exeternal media can control which service we agree (important for some institution) where Extresource embed anything that accept OEmbed protocol
20:39:32 <anitsirk> dajan: it will become part of the external media one. he posted his addition on the same specs page.
20:39:40 <anitsirk> at least that's the proposal
20:40:04 <dajan> Well. Having both separated make sense to me.
20:40:11 <dobedobedoh> That's good. Keeps things in the same place
20:40:42 <anitsirk> what could be replaced to avoid constant updated (as google tends to change things all the time) would be the google apps block now that we have the safeiframes. but that is a discussion for another day.
20:40:52 <dajan> If I don't want students embedding things I can control them with External media. Or we have to provide such a control in the new Extresrouce plugin
20:41:35 <anzeljg> anitsirk: +1, I think googledocs should go into repository plugin. More about that later...
20:42:01 <dobedobedoh> dajan: It might be an idea to add that suggestion to the sid wiki: https://wiki.mahara.org/index.php/Developer_Area/Specifications_in_Development/External_media_block_extension
20:42:09 <dajan> Ummm repository plugin. Sounds nice.
20:42:15 <dobedobedoh> Is there anything else to discuss re UoG's submissions, or Extresource/External Media changes, or related before we move on?
20:42:30 <dajan> I will add my comment into the wiki. Next week is it ok?
20:42:32 <dobedobedoh> Forewarning, I have swapped over the next few items so that Repos are next
20:42:56 <dobedobedoh> I should think so
20:43:27 <dobedobedoh> Right, without further ado...
20:43:27 <dobedobedoh> #topic Repository Plugins (anzeljg)
20:43:36 <dobedobedoh> anzeljg: Your turn for a spot in the limelight
20:43:51 <anzeljg> I am very visual person, so instead of writing spec for repository plugin I've coded an initial thing.
20:44:02 <anzeljg> It is coded in such manner that it should be fairly easy to add additional services
20:44:11 <anzeljg> (it is planned that the plugin will be released with support for Box, Dropbox, Windows Live SkyDrive and GoogleDocs; maybe Picasa and Flickr).
20:44:18 <anzeljg> Each service will extend PluginBlocktypeRepository. PluginBlocktypeRepository extends PluginBlocktype and adds additional methods to use with accessing data over REST (with OAuth authentication).
20:44:27 <anzeljg> You can see demo at http://screencast.com/t/wxfDwcc3UHdk
20:44:34 <dobedobedoh> #info anzeljg has written a proof of concept for a repository system for mahara
20:44:34 <anzeljg> The edit/delete functionallity for files/folders don't exist yet, and I don't quite know how to write a blocktype config form for users to select files (folders) they whis to include in view/page.
20:44:42 <anzeljg> It should be something like files in Mahara (artefact chooser?), but I don't quite get it. So any support and/or ideas would be very appreciated.
20:44:45 <anzeljg> ...
20:44:48 <dobedobedoh> #info demo available at  http://screencast.com/t/wxfDwcc3UHdk
20:45:07 <hughdavenport`> awesome!
20:45:14 <rkabalin_> repo system sounds very good
20:45:15 <dobedobedoh> #info suggestions/ideas on how to finalise it would be appreciated
20:46:16 <dobedobedoh> anzeljg: That looks great. Can't wait to get a glimpse at the code
20:46:19 <dajan> I am looking at the demo. Great so far
20:47:32 <anitsirk> <sidenote>it would be great to have links like that before the meeting in case we have time to look at it beforehand instead of during the meeting ;-) </sidenote>
20:47:55 <dobedobedoh> anzeljg: Does it support repositories similar to moodle repos?
20:48:05 <anzeljg> anitsirk: was making the video and uploading just before the meeting ;)
20:48:21 <anzeljg> dobedobedoh: wha do you mean?
20:48:25 <anitsirk> anzeljg: hehe. no worries. just in case things like that are available in advance next time :-)
20:48:31 <dajan> How files are then added to my Pages? or my Local file management in Mahara?
20:48:43 <dobedobedoh> Well, for example integration to externally hosted content?
20:49:01 <dobedobedoh> Something like a flash media server
20:49:02 <anzeljg> dajan: taht's the part I'm having trobule with
20:49:15 <dajan> :-)
20:49:23 <dajan> sorry :-(
20:49:26 <iarenaza> anzeljg: quite impressive anyway!
20:49:28 <dobedobedoh> or a content host where files are hosted externaly
20:49:31 <dobedobedoh> That's looking really good
20:49:32 <anzeljg> it should work like files in Mahara... user select file(s) and adds them to page... same here
20:49:50 <dobedobedoh> And should we convert the current internal media to a repo perhaps
20:50:04 <rkabalin_> +1
20:50:04 <anzeljg> i don't think so
20:50:04 <dajan> +1
20:50:07 <richardm> very cool anzeljg
20:50:11 <anzeljg> don't know
20:50:28 <dobedobedoh> If a repository coudl provide both an accessor, and a blocktype perhaps, or provide code to fit into an existing blocktype
20:50:32 * dobedobedoh dreams of pies in the sky
20:50:40 <dajan> Why the internal file system is a repo.
20:50:48 <anzeljg> all repos are accessed wia oauth (box and dropbox) or oauth2 (skydrive, googledocs)
20:51:06 <dajan> Maybe not. I forgot about the TAGS !
20:51:27 <anzeljg> dobedobedoh: explain accessor
20:51:34 <anitsirk> anzeljg: would you then just link to the files in the repository or copy them?
20:51:35 <dajan> You can tags files in the internal file system, not on Dropbox. Tags are important.
20:51:53 <dobedobedoh> something to handle account setup, handshaking, etc
20:52:13 <anzeljg> link to them (or in skydrive/googledocs case also have an option to embed them)
20:52:53 <anitsirk> anzeljg: thanks. the latter can be done already through safeiframes and will have an admin interface in 1.6 :-)
20:53:09 <dajan> Could we open a page on the wiki to discuss the features. Because this is a very very  important feature and this will maybe change things in core?
20:53:18 <dobedobedoh> +1
20:53:24 <dobedobedoh> Is the code available anyhwere?
20:53:53 <anzeljg> anitsirk: i mean without iframes/embed code, user just picks the file, clicks embed option and it gets embedded (don't really know if it is possible, but that's the "plan")
20:54:11 <anzeljg> dobedobedoh: not yet
20:54:29 <anitsirk> what about alfresco? that question came up again.
20:54:38 <anzeljg> will try to make it available, but will have very little time in next 4-6 weeks!
20:54:43 <elky> gah, sorry, here now
20:54:45 <anitsirk> would that also be supported or only software-as-a-service repositories?
20:54:56 <dobedobedoh> Welcome elky
20:55:04 <dajan> they also tried for Moodle but, I think there are still issues with Alfresco.
20:55:09 <anzeljg> I looked at alfresco, but the Alfresco Cloud doesn't have API...
20:56:04 <anzeljg> only Alfresco has API - but don't have it installed and don't know anything about it...
20:56:14 <anzeljg> sorry :(
20:56:33 <anzeljg> (note: Alfresco != Alfresco Cloud)
20:56:38 <anzeljg> ..
20:57:29 <dobedobedoh> This looks like a really impressive and important development for mahara. Thanks anzeljg
20:57:41 <anzeljg> :)
20:58:00 <dobedobedoh> Will you be able to put a wiki page together, and possibly the code so that we can comment?
20:58:11 <anzeljg> will try...
20:58:31 <anitsirk> i think a wiki page in "specs in development" and a forum discussion would be good
20:58:46 <dobedobedoh> #action anzeljg To put together a quick wiki page with some information (possibly code too)
20:58:58 <anzeljg> firstly I would like to finnish it with support for Box and Dropbox...
20:59:22 <dobedobedoh> Anything else to discuss before we move onto skins?
20:59:28 <anzeljg> nope
20:59:50 <hughdavenport`> hi all, I'll have to head off shortly, will catch up on the minutes tomorrow
20:59:58 <dobedobedoh> Thanks hughdavenport`
21:00:07 <dobedobedoh> Right, we've moving on to discuss skins
21:00:07 <dobedobedoh> #topic Update on Skins work (anzeljg)
21:00:11 <anzeljg> Started to create skin live preview (as Mike Kelly once suggested), because IMO average user would greately benefit from it.
21:00:19 <anzeljg> Currently I have a problem, because I don't know how to allow uploading background image for skin, that would show up in live preview, without the need to refresh/reload the page
21:00:25 <anzeljg> (everything else works dinamically without refreshing/reloading the page).
21:00:33 <anzeljg> You can see a quick demo of skin live preview at http://screencast.com/t/CWoznCHjJG (no sound)
21:00:39 <anzeljg> Any idea on how to upload images without the need for refreshing/reloading would be very welcome.
21:00:49 <anzeljg> Will not have much time in next 4-6 week so I might merge existing skins code and add live preview later?
21:00:50 <anzeljg> ..
21:02:04 <dobedobedoh> #info anzeljg is adding 'life preview' support to skins to give users a preview of their changes
21:02:19 <dobedobedoh> #info screencast available at http://screencast.com/t/CWoznCHjJG
21:03:58 <dobedobedoh> It'd be great if the dialogue to make changes was in a floating overlay
21:04:37 <anzeljg> above the preview content?
21:04:41 <dobedobedoh> yeah
21:04:45 <anzeljg> ok
21:04:49 <dobedobedoh> I notice in the screencast you keep scrolling down to view changes
21:04:54 <dobedobedoh> just a thought
21:05:31 <anzeljg> if user click on the up arrow than the form hides...
21:05:37 <anzeljg> click = clicks
21:05:43 <dobedobedoh> again though, looks like a great improvement
21:06:54 <iarenaza> yes, definitely a great improvement!
21:07:10 <dobedobedoh> Is there anything else people want to discuss on skins?
21:07:25 <anitsirk> the functionality looks great.
21:07:37 <anzeljg> So should I merge skins without 'live preview' code to get it to review system and add 'live preview' later, because it doen't affect the core files???
21:09:49 <dobedobedoh> If it doesn't require changes to skins, I'd be tempted to leave it
21:09:57 <dobedobedoh> that woudl reduce the amount of review time to get skins into core
21:10:02 <dobedobedoh> anyone else got any thoughts?
21:10:14 <dobedobedoh> It could then go in as a separate patchset on top of skins
21:10:30 <iarenaza> +1
21:10:32 <rkabalin_> I agree
21:10:34 <richardm> yeah, anzeljg anything you can do to split it up will make review easier
21:10:53 <anzeljg> I intend to split it up as much as i can.
21:11:43 <richardm> live preview looks great
21:11:44 <anzeljg> So if i understand i should merge everything (except live preview) to gitorious to get it to review nd add live preview later (on top of skins)
21:12:04 <anzeljg> nd = and
21:13:44 <richardm> anzeljg: you should rebase all your patches on top of the latest master, and then submit the resulting branch to gerrit using a 'skins' topic
21:14:34 <anzeljg> richardm: will contact you via email when I finnish the rebase...
21:14:55 <richardm> ok
21:15:26 <dobedobedoh> Anything else to discuss on skins?
21:15:31 <anzeljg> no
21:16:41 <dobedobedoh> Moving on...
21:16:42 <dobedobedoh> #topic Demo site (anitsirk)
21:16:49 <anitsirk> rigth.
21:17:05 <anitsirk> i just wanted to let you know that http://demo.mahara.org is now up-to-date on mahara 1.5
21:17:18 <anitsirk> it should be really fast in the UK as it sits on a server over there right now
21:17:38 <anitsirk> #info http://demo.mahara.org showcases mahara 1.5 now
21:17:46 <anitsirk> that's it. :-)
21:17:53 <dobedobedoh> nice and short
21:17:56 <dobedobedoh> #topic Upcoming Mahara Events:
21:17:58 <dobedobedoh> #info  First Maharamoot francophone in Nîmes, May 20-22nd. Spread the word around you (dajan)
21:18:03 <dobedobedoh> Anything more to mention here dajan?
21:18:14 <dajan> No. Just spread the word.
21:18:20 <dobedobedoh> #info MaharaUK 2012 3rd July 2012 in Lancaster (dobedobedoh)
21:18:40 <dobedobedoh> rkabalin_ and I will be spreading the word more on this and opening for registration hopefully this week
21:18:42 <dajan> I will be the first FR Maharamoot. We are all thrilled to help you to spread mahara use further
21:19:17 <dobedobedoh> We still have our call for presentations open. If you'd like to do any, either in person or via video conferencing, please drop us a line
21:19:23 * dobedobedoh stops plugging
21:19:28 <dobedobedoh> Any other events coming up?
21:19:31 <anitsirk> there'll also be a mahoodlemoot at purchase college (NY) in july
21:19:48 <dobedobedoh> #info mahoodlemoot at Purchase College (NY) in July
21:19:48 <dajan> I will deliver a speech in Lancaster
21:20:03 <dobedobedoh> #info dajan will be one of our keynote speakers at maharauk2012 :)
21:20:13 <dajan> They asked me to present 1.5 new features as a Keynote
21:20:15 <anitsirk> the next MUG meeting hasn't been decided on. yesterday's was great showcasing student portfolios
21:20:31 <anitsirk> cool :-)
21:20:55 <dobedobedoh> Last call for events
21:21:25 <dobedobedoh> #info yesterday's MUG saw showcasing of student portfolios
21:21:33 <dobedobedoh> #info next MUG dates to be announced when available
21:22:05 <dobedobedoh> #topic Next meeting and Chair
21:22:31 <iarenaza> dajan: what's the web site for the French Maharamoot?
21:22:31 <dobedobedoh> The next meeting is likely to be at about 07:00 UTC in about a month
21:22:45 <dajan> http://moodlemoot2012.unimes.fr/
21:22:52 <iarenaza> dajan: thanks!
21:23:00 <dobedobedoh> #info website for french maharamoot is  http://moodlemoot2012.unimes.fr/
21:24:07 <dobedobedoh> So, next meeting. I'd suggest middle of June..?
21:24:31 <anitsirk> sounds good to me
21:24:55 <dajan> ok
21:24:59 <_anzeljg_> ok
21:25:03 <iarenaza> dobedobedoh: did you talk about spacing meetings 3 weeks apart (and making them shorter) at the last meeting? Or am I just dreaming?
21:25:20 <dobedobedoh> I think I suggested making them slightly further apart
21:25:30 <iarenaza> Oops! :-)
21:25:47 <dobedobedoh> ah
21:25:49 <_anzeljg_> anitsirk was talking about making them aprox. one hour long
21:25:51 * dobedobedoh rereads
21:26:10 <dobedobedoh> yeah, the alternative suggestion was frequent meetings @ 1 hour long
21:26:16 <dajan> Have to leave you now. Some test to prepare for my students tomorrow.
21:26:21 <dobedobedoh> So shall we say in about 4 weeks time?
21:26:25 <dobedobedoh> Thanks for joining us dajan
21:26:36 <anitsirk> bye dajan
21:26:40 <_anzeljg_> bye dajan.
21:26:41 <iarenaza> bye dajan
21:26:48 <rkabalin_> bye dajan
21:26:49 <dobedobedoh> Making it the Wednesday 23rd May
21:26:52 <iarenaza> dobedobedoh: fine with me
21:26:58 <rkabalin_> fine with me
21:27:02 <_anzeljg_> ok
21:27:04 <dobedobedoh> at 07:00 UTC
21:27:20 <dobedobedoh> Actually, 07:30 would be better for us I suspect
21:27:27 <dajan> To the one who asked before: my knee is still hurting. But tomorrow must go to work. Thanks to have asked.
21:27:27 <_anzeljg_> agree
21:27:55 <dobedobedoh> http://www.timeanddate.com/worldclock/fixedtime.html?msg=17th+Mahara+Developer+Meeting&iso=20120523T0730
21:27:55 <_anzeljg_> dajan: will look into Europass tomorrow or in couple of days
21:28:30 <iarenaza> dobedobedoh: 7:30 UTC is fine for us in CET/DST :-)
21:28:41 <anitsirk> fine by me
21:28:48 <dajan> Ok fine. I think we already (you already) did a lot editing and killing the bugs these last days. Thanks
21:29:47 <dajan> Next meeting I will be teaching at 9am. So will be without me. cheers
21:30:48 <dobedobedoh> And anyone (preferably in nz) willing to chair?
21:31:03 * anitsirk prods elky ;-)
21:31:12 <anitsirk> as it's in the evening
21:31:19 <elky> yep
21:31:45 <elky> put me down for it
21:32:10 <dobedobedoh> #info elky to chair the next developer meeting at 07:30 UTC on 23rd May 2012
21:32:19 <dobedobedoh> Finally
21:32:19 <dobedobedoh> #topic Any other business
21:32:54 <anitsirk> i have one
21:33:00 <_anzeljg_> ;)
21:34:03 <anitsirk> Just that we didn't mention the release of 1.5 at all. break out the champagne, dance around in circles and be happy. another release is out thanks to the work of many people.
21:34:19 <dobedobedoh> #info Mahara 1.5 is now out
21:34:23 <dobedobedoh> Thanks to all for their hard work
21:34:34 <dajan> Did you make a new mug?
21:34:56 <anitsirk> dajan: nope. that would have been too predictive. ;-)
21:35:05 <anitsirk> oh i have another one
21:35:11 <_anzeljg_> An umbrella then ;)
21:35:19 <dajan> I wanted to start a collection  :|
21:35:47 <anitsirk> #info Mahara has a security bug bounty program https://wiki.mahara.org/index.php/Security#Mahara_Security_Bug_Bounty_Program
21:35:47 <dobedobedoh> aww, I was looking forward to another mug
21:35:59 <_anzeljg_> me too
21:36:17 <elky> dajan, step 1: buy a mug from the market. step 2: Write "mahara 1.5" on it. Step 3: add to collection
21:36:20 <dobedobedoh> I guess that core devs don't get the bonus if they contributed the buggy code ;)
21:36:50 <_anzeljg_> elky: what about the cool graphics?
21:36:50 <dajan> Will do. Thanks for the tip elky
21:36:51 <iarenaza> dobedobedoh: that reminds me of Nigel's recent tweet XD
21:37:02 <fmarier> dobedobedoh: that would be a lucrative loophole ;)
21:37:06 <_anzeljg_> Nigel is here, right?
21:37:23 <dobedobedoh> Wgh's putting up the bounties?
21:37:27 <_anzeljg_> not anymore...
21:38:01 <dobedobedoh> Who*
21:38:09 <fmarier> dobedobedoh: Richard Wyles
21:38:25 <dobedobedoh> #info Thanks to Richard Wyles for putting up security bounties
21:38:35 <dobedobedoh> Any other business to discuss before I call endmeeting?
21:38:47 <iarenaza> not from me
21:38:55 <_anzeljg_> no, not from me
21:38:58 <anitsirk> no. 2 is enough ;-)
21:39:00 <dobedobedoh> Thank you all
21:39:06 <dobedobedoh> #endmeeting