#mahara-dev Meeting

Meeting started by iarenaza at 07:31:14 UTC (full logs).

Meeting summary

  1. Meeting attendees (iarenaza, 07:31:26)
    1. iarenaza is Iñaki Arenaza (iarenaza, 07:31:32)
    2. anitsirk is Kristina Hoeppner (anitsirk, 07:31:45)
    3. anzeljg is Gregor An�elj (anzeljg, 07:32:01)
    4. rkabalin_ is Ruslan Kabalin, LUNS Ltd., UK (rkabalin_, 07:32:06)
    5. Andrew Nicols - LUNS Litd, UK (dobedobedoh, 07:32:07)
    6. fmarier is Francois Marier (fmarier, 07:32:14)
    7. dobedobedoh is Andrew Nicols - LUNS Ltd, UK (dobedobedoh, 07:32:24)
    8. dan_p is Dan Poltawski - LUNS Ltd, UK (dan_p, 07:32:28)
    9. richardm is Richard Mansfield (iarenaza, 07:32:54)
    10. lordp is Darryl Hamilton (lordp, 07:33:17)

  2. Items from previous meeting (iarenaza, 07:35:47)
    1. rkabalin fill in more details about improving objectionable content (iarenaza, 07:36:14)
    2. AGREED: details about improving objectionable content are enough so far. We'll bring the topic again when someone starts designing that feature (iarenaza, 07:40:50)
    3. fmarier_ ping wiki contributors one last time and then make the license change (iarenaza, 07:41:02)
    4. fmarier_ investigate whether gerrit could have a hook that would add a note to launchpad (with a link to the gerrit changeset) for patchsets that got merged and mentioned a bug number (iarenaza, 07:41:28)
    5. fmarier says gerrit can have a hook to add a note to launchpad (already has a script for it). (iarenaza, 07:42:51)
    6. only missing part is GPG-signing the emails and sending them to launchpad (iarenaza, 07:43:13)
    7. fmarier_ investigate hook to send an email to patchset submitter once it's been merged (to remind them to update bug status in tracker) (iarenaza, 07:43:47)
    8. sample email for the gerrit hook http://paste.dollyfish.net.nz/98033d (iarenaza, 07:44:27)
    9. Don't send any email to patchset submitter once it's been merged (she already gets a lot of them from the tracker :-) (iarenaza, 07:48:18)
    10. The hook from gerrit will send one email per changeset merged by gerrit to all of the bugs mentioned in the commit msg (iarenaza, 07:52:51)
    11. that means one for each branch (iarenaza, 07:53:08)
    12. anitsirk proceed with asciidoc trial and come up with more info (iarenaza, 07:54:10)
    13. https://wiki.mahara.org/index.php/Developer_Area/Current_Tasks (iarenaza, 07:56:04)
    14. elky has done a great work on the dev area of the wiki (iarenaza, 07:58:16)
    15. don't hesitate to give feedback about it! (iarenaza, 07:58:37)
    16. elky is Melissa Draper (iarenaza, 07:59:31)
    17. future home of the Mahara manual: https://www.gitorious.org/mahara/manual (fmarier, 08:01:24)
    18. http://meetbot.mahara.org/mahara-dev/2011/mahara-dev.2011-03-23-07.31.log.html <-- we discussed it at about 08:55 (dobedobedoh, 08:06:09)
    19. http://www.at.xemacs.org/Documentation/21.5/html/texinfo_25.html is an example (dobedobedoh, 08:08:18)
    20. whoever has an opinion about what the manual should use should get in touch with anitsirk (iarenaza, 08:08:23)
    21. some alternatives proposed include asciidoc and texinfo (iarenaza, 08:09:14)
    22. http://en.wikipedia.org/wiki/Texinfo (rkabalin_, 08:09:26)
    23. anitsirk gets to decide what she thinks is the best as she'll be doing the bulk of the work on it (iarenaza, 08:09:57)
    24. AGREED: anitsirk gets to decide what markup language is the best as she'll be doing the bulk of the work on it (iarenaza, 08:12:37)
    25. richardm have a look at launchpad translation tool and discuss whether or not to try to find funding to port AMOS (iarenaza, 08:13:50)
    26. richardm says they have all the po file scripts done, and fmarier has tested launchpad with another project (iarenaza, 08:14:50)
    27. we're almost there, still need a little more time, and it's probably not worth spending too much on amos yet (richardm, 08:15:59)
    28. iarenaza to be a launchpad translation guinea pig (iarenaza, 08:18:02)
    29. ACTION: richardm to send es, eu .po files to iarenaza so translators can start (richardm, 08:18:03)
    30. https://launchpad.net/~fmarier/+editlanguages (fmarier, 08:19:13)
    31. ACTION: iarenaza anitsirk and anzeljg to check out how launchpad translations work (iarenaza, 08:24:05)
    32. https://wiki.mahara.org/index.php/Code_of_Conduct (dobedobedoh, 08:26:21)
    33. dobedobedoh has put the forum code of conduct at https://wiki.mahara.org/index.php/Code_of_Conduct (iarenaza, 08:26:44)
    34. it's based on the Ubuntu Code of Conduct (under CCAS license) (iarenaza, 08:28:30)
    35. http://mahara.org/terms.php (fmarier, 08:29:13)
    36. fmarier says our trademark policy is also "stolen" from Ubuntu (iarenaza, 08:31:46)
    37. https://wiki.mahara.org/index.php/Marketing/Trademark_Policy (iarenaza, 08:31:51)

  3. Walled Gardens status? (iarenaza, 08:33:32)
    1. The patch is difficult to merge in small chunks, as it is interweaved with too many things (iarenaza, 08:38:35)
    2. fmarier says they could take a good look at it and then have a meeting to plan how they'll go about merging it (iarenaza, 08:39:59)
    3. ACTION: rkabalin_ update relevant pages to use Isolated institutions instead of Walled Garden (rkabalin_, 08:42:17)
    4. AGREED: Use the term "Isolated Institutions" everywhere, instead of "Walled Gardens" (iarenaza, 08:46:43)
    5. The review will probably wait until July (due to work load) (iarenaza, 08:48:41)

  4. Guide on how to do code reviews (iarenaza, 08:51:14)
    1. https://wiki.mahara.org/index.php/Developer_Area/How_to_Review_Code (iarenaza, 08:52:02)
    2. if you disagree with something that someone has added, then discuss with them and/or on the developer forum (iarenaza, 08:53:03)
    3. see also https://wiki.mahara.org/index.php/Developer_Area/Contributing_Code (iarenaza, 08:54:20)
    4. ACTION: fmarier to link to the "how to review" page in the gerrit page header (fmarier, 08:59:41)
    5. http://mahara.org/interaction/forum/topic.php?id=3637 (fmarier, 09:06:38)
    6. http://paste.dollyfish.net.nz/f0fc80 (fmarier, 09:08:14)
    7. to sum it up: 1. have a look at the code review guide, 2. propose enhancements to it (as in "click edit at the top of the page" then hit "submit"), 3. Link to those two pages (code review, contributing code) from gerrit (iarenaza, 09:09:58)

  5. Status of the 1.4 release (iarenaza, 09:11:26)
    1. 1.4rc1 was released last week and rc2 will be released in a couple of days (looks like the last rc before release) (iarenaza, 09:12:38)
    2. unless serious bugs are reported, we should have a release in the first week of June (iarenaza, 09:13:37)
    3. ACTION: iarenaza to try the upgrade to 1.4 on a copy of his production site (iarenaza, 09:15:27)
    4. https://launchpad.net/mahara/+series (fmarier, 09:20:23)
    5. ACTION: rkabalin_ to add a link to https://launchpad.net/mahara/+series from the release policy page (iarenaza, 09:22:10)

  6. 1.5 release: time-based or feature-based (iarenaza, 09:23:00)
    1. do we want to commit to a time-based release or do we want to stick to a mixture of feature-based and time-based? (iarenaza, 09:35:19)
    2. anitsirk the only strong opinion i have is that we align something with the academic calendar, because most upgrades happen during the longer summer vacation time (iarenaza, 09:36:03)
    3. ACTION: discuss this topic again (time-based vs feature-based releases) at a later meeting (iarenaza, 09:39:58)

  7. Next meeting (iarenaza, 09:40:32)
    1. AGREED: Next meeting on Wednesday, 29 June 2011, 19:30:00 UTC (iarenaza, 09:47:53)
    2. https://wiki.mahara.org/index.php/Developer_Area/Developer_Meetings/Chair_Duties (fmarier, 09:49:00)
    3. AGREED: lamiette to chair next meeting (iarenaza, 09:49:44)

  8. Any other business (iarenaza, 09:50:05)
    1. As the next meeting is 1 day before the next newsletter, if you have anything that should be mentioned in it, please send anitsirk the text (iarenaza, 09:51:55)
    2. http://www.google.com/webfonts (anzeljg, 09:52:34)


Meeting ended at 09:58:29 UTC (full logs).

Action items

  1. richardm to send es, eu .po files to iarenaza so translators can start
  2. iarenaza anitsirk and anzeljg to check out how launchpad translations work
  3. rkabalin_ update relevant pages to use Isolated institutions instead of Walled Garden
  4. fmarier to link to the "how to review" page in the gerrit page header
  5. iarenaza to try the upgrade to 1.4 on a copy of his production site
  6. rkabalin_ to add a link to https://launchpad.net/mahara/+series from the release policy page
  7. discuss this topic again (time-based vs feature-based releases) at a later meeting


Action items, by person

  1. anitsirk
    1. iarenaza anitsirk and anzeljg to check out how launchpad translations work
  2. anzeljg
    1. iarenaza anitsirk and anzeljg to check out how launchpad translations work
  3. fmarier
    1. fmarier to link to the "how to review" page in the gerrit page header
  4. iarenaza
    1. richardm to send es, eu .po files to iarenaza so translators can start
    2. iarenaza anitsirk and anzeljg to check out how launchpad translations work
    3. iarenaza to try the upgrade to 1.4 on a copy of his production site
  5. richardm
    1. richardm to send es, eu .po files to iarenaza so translators can start
  6. rkabalin_
    1. rkabalin_ update relevant pages to use Isolated institutions instead of Walled Garden
    2. rkabalin_ to add a link to https://launchpad.net/mahara/+series from the release policy page


People present (lines said)

  1. fmarier (212)
  2. iarenaza (172)
  3. anitsirk (54)
  4. rkabalin_ (54)
  5. dobedobedoh (45)
  6. anzeljg (34)
  7. richardm (29)
  8. elky (24)
  9. lamiette (14)
  10. dan_p (5)
  11. lordp (4)
  12. maharameet (4)


Generated by MeetBot 0.1.4.