07:31:14 <iarenaza> #startmeeting
07:31:14 <maharameet> Meeting started Wed May 25 07:31:14 2011 UTC.  The chair is iarenaza. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:31:14 <maharameet> Useful Commands: #action #agreed #help #info #idea #link #topic.
07:31:26 <iarenaza> #topic Meeting attendees
07:31:32 <iarenaza> #info iarenaza is Iñaki Arenaza
07:31:45 <anitsirk> #info anitsirk is Kristina Hoeppner
07:32:01 <anzeljg> #info anzeljg is Gregor An�elj
07:32:06 <rkabalin_> #info rkabalin_ is Ruslan Kabalin, LUNS Ltd., UK
07:32:07 <dobedobedoh> #info Andrew Nicols - LUNS Litd, UK
07:32:14 <fmarier> #info fmarier is Francois Marier
07:32:24 <dobedobedoh> #info dobedobedoh is Andrew Nicols - LUNS Ltd, UK
07:32:28 <dan_p> #info dan_p is Dan Poltawski - LUNS Ltd, UK
07:32:54 <iarenaza> #info richardm is Richard Mansfield
07:33:14 <iarenaza> I think that's everybody
07:33:17 <lordp> #info lordp is Darryl Hamilton
07:33:30 <lordp> Sorry I'm late :)
07:33:35 <anitsirk> hi darryl
07:33:38 <iarenaza> lordp: no problem :)
07:33:54 <iarenaza> Anyone else?
07:34:14 <iarenaza> ok, let's go for the first topic.
07:34:19 <fmarier> before we start
07:34:26 <iarenaza> yes?
07:34:33 <fmarier> i just want to remind people (especially those who weren't there last time)
07:34:37 <fmarier> about the .. thingie
07:34:44 <iarenaza> ok, good idea!
07:34:53 <fmarier> basically, if you can put ".." on a line by itself when you're done talking
07:35:01 <fmarier> that will help show people that you're done
07:35:17 <fmarier> so that we don't wait for you if we were waiting to avoid cutting you off
07:35:20 <fmarier> ..
07:35:31 <iarenaza> nice
07:35:47 <iarenaza> #topic Items from previous meeting
07:36:14 <iarenaza> #info rkabalin fill in more details about improving objectionable content
07:36:40 <rkabalin_> right
07:37:10 <rkabalin_> I did not add anything else to https://wiki.mahara.org/index.php/Developer_Area/Specifications_in_Development/Objectionable_content_reporting
07:37:44 <iarenaza> Do you plan to add anything else or shall we close the topic as done?
07:37:46 <fmarier> rkabalin_: it looks fairly complete already
07:37:50 <rkabalin_> just because we do not implement it right now and I do not really think about particular implementation
07:38:46 <rkabalin_> I think it will be extended once me or someone else decise to start with designing that feature
07:38:50 <rkabalin_> ..
07:39:06 <fmarier> that sounds good
07:39:19 <rkabalin_> iarenaza: yes please close it for now
07:39:23 <iarenaza> If so, we can bring the topic again then.
07:39:39 <iarenaza> rkabalin_ ok
07:40:02 <fmarier> i don't think it needs to stay on the meeting agenda, it's on the wiki already
07:40:50 <iarenaza> #agreed details about improving objectionable content are enough so far. We'll bring the topic again when someone starts designing that feature
07:41:02 <iarenaza> #info fmarier_ ping wiki contributors one last time and then make the license change
07:41:07 <iarenaza> This should be fast :)
07:41:12 <fmarier> done :D
07:41:23 <fmarier> basically nobody objected
07:41:28 <iarenaza> #info fmarier_ investigate whether gerrit could have a hook that would add a note to launchpad (with a link to the gerrit changeset) for patchsets that got merged and mentioned a bug number
07:41:32 <fmarier> very few people didn't respond after the second ping
07:41:52 <fmarier> the answer to that second one is yes, it can be done
07:42:15 <fmarier> i've got a script already for it
07:42:21 <fmarier> and right now it sends emails to me
07:42:40 <fmarier> all i need to do to finish this off is to GPG-sign the emails and then send them to Launchpad
07:42:51 <iarenaza> #info fmarier says gerrit can have a hook to add a note to launchpad (already has a script for it).
07:43:13 <iarenaza> #info only missing part is GPG-signing the emails and sending them to launchpad
07:43:21 <iarenaza> good!
07:43:45 <iarenaza> related to the previous,
07:43:47 <iarenaza> #info fmarier_ investigate hook to send an email to patchset submitter once it's been merged (to remind them to update bug status in tracker)
07:43:57 <fmarier> here's a sample email: http://paste.dollyfish.net.nz/98033d
07:44:09 <fmarier> when the commit has a bug number, it gets extracted properly
07:44:27 <iarenaza> #info sample email for the gerrit hook http://paste.dollyfish.net.nz/98033d
07:44:28 <fmarier> that one wasn't the best example, but trust me, it works ;-)
07:44:30 <fmarier> ..
07:45:05 <iarenaza> fmarier: that example is for the launchpad email, isn't it?
07:45:13 <fmarier> yes
07:45:27 <fmarier> the email to launchpad will be an abridged version of that
07:45:28 * elky waves hi
07:45:44 <iarenaza> ok, just to be clear (as the other pending item is also about emailing the patchset submitter)
07:45:52 <iarenaza> ..
07:46:20 <fmarier> i'm not entirely sure that one is necessary
07:46:31 <fmarier> because as the patch submitter you'll get emails from gerrit
07:46:43 <anitsirk> hi elky
07:46:48 <fmarier> and you'll be assigned to the bug on the tracker so you'll get an email when gerrit sends a note to the tracker
07:47:03 <fmarier> so you'll probably be getting enough of a notice already
07:47:03 <fmarier> ..
07:47:34 <iarenaza> fair enough. So we can drop the item from the pending list too :-)
07:47:45 <fmarier> sure
07:47:49 <dobedobedoh> The e-mail throughput has gone up quite a bit thanks to gerrit and jenkins
07:48:16 <anitsirk> thank goodness for filters, dobedobedoh :-)
07:48:18 <iarenaza> #info Don't send any email to patchset submitter once it's been merged (she already gets a lot of them from the tracker :-)
07:48:19 <fmarier> yes, i wrote some procmail filters on my end :)
07:48:53 <iarenaza> Next item
07:48:58 <fmarier> iarenaza: you can skip that next one
07:49:01 <fmarier> it's already on the agenda
07:49:04 <rkabalin_> sorry, I have not got it completely, the email to launchpad will mark the bug as commited automatically or not
07:49:13 <iarenaza> fmarier: ok
07:49:22 <fmarier> rkabalin_: no it will just say that it was reviewed and merged
07:49:33 <fmarier> it's still up to a human to change the status
07:49:46 <rkabalin_> it will say that in the bug comments?
07:49:47 <fmarier> we could potentially change that, but let's see how it goes first
07:50:04 <fmarier> it will say something like the email i posted earlier
07:50:28 <rkabalin_> ok
07:50:45 <fmarier> basically what the email has currently minus the bug number
07:51:00 <iarenaza> I agree with fmarier, let's see how it goes first
07:51:04 <rkabalin_> I see, thanks fmarier
07:51:10 <dobedobedoh> Will it send multiple e-mails -- one for each branch?
07:51:25 <fmarier> dobedobedoh: yes
07:51:37 <fmarier> one email per changeset merged by gerrit
07:51:49 <fmarier> to all of the bugs that are mentioned in the commit msg
07:51:54 <fmarier> ..
07:52:51 <iarenaza> #info The hook from gerrit will send one email per changeset merged by gerrit to all of the bugs mentioned in the commit msg
07:53:08 <iarenaza> #info that means one for each branch
07:53:42 <iarenaza> Any other questions about this?
07:54:03 <iarenaza> okey, next item
07:54:10 <iarenaza> #info anitsirk proceed with asciidoc trial and come up with more info
07:54:29 <anitsirk> mhh. i thought we had just moved that to the wiki.
07:54:58 <anitsirk> i got on git and gerrit thanks to fmarier, but i haven't had the time to look into moving the documentation.
07:54:59 <anitsirk> ..
07:55:47 <fmarier> it's on here: https://wiki.mahara.org/index.php/Developer_Area/Current_Tasks
07:56:04 <iarenaza> #link https://wiki.mahara.org/index.php/Developer_Area/Current_Tasks
07:56:21 <richardm> finally got here, sorry i'm late
07:56:50 <elky> Also, if there's feedback to give on the dev docs rearrangement, please don't hold back
07:57:41 <fmarier> yeah we should talk about elky's great work on the dev area of the wiki during "any other business"
07:58:16 <iarenaza> #info elky has done a great work on the dev area of the wiki
07:58:37 <iarenaza> #info don't hesitate to give feedback about it!
07:59:12 <elky> <-- melissa draper, i don't think i've been introduced?
07:59:31 <iarenaza> #info elky is Melissa Draper
08:00:17 <iarenaza> So to sum it up: the manual in in git and asciidoc is the markup language we will use. Is this right?
08:00:29 <iarenaza> s/in in/is in/
08:00:50 <fmarier> iarenaza: except it's not started yet
08:00:57 <fmarier> so right now it's an empty git repo
08:01:11 <iarenaza> I know :)
08:01:24 <fmarier> #link future home of the Mahara manual: https://www.gitorious.org/mahara/manual
08:01:40 <iarenaza> But at least we have decided which tools to use, haven't we?
08:02:04 <anzeljg> Is it going to be user manual or developer manual?
08:02:08 <anitsirk> i would start with asciidoc as it doesn't require XML markup when writing.
08:02:12 <anitsirk> it is the user manual, anzeljg
08:02:30 <anitsirk> but it can still output to docbook, PDF, HTML etc.
08:02:34 <iarenaza> anitsirk: I think asciidoc should be good enough for most purposes
08:02:40 <fmarier> anzeljg: the developer docs will stay on the wiki
08:02:48 <anitsirk> i think so, too.
08:03:13 <iarenaza> anitsirk: docbook-xml is more flexible, but it's a bit daunting at first :-)
08:04:01 <iarenaza> Anyone against using asciidoc? :-)
08:04:25 <rkabalin_> no, did we consider texinfo?
08:04:40 <iarenaza> I don't remember anyone proposing it
08:04:40 <iarenaza> ..
08:05:07 <fmarier> rkabalin_: i don't think so
08:05:23 <anitsirk> i hadn't looked at that. fmarier had a tip for publican, but that was again a lot of xml that is not so easy to read when you want to review what you've written
08:05:27 <anitsirk> ..
08:05:51 <fmarier> tex would be great for printed stuff, but not so much for the online version i suspect
08:06:01 <rkabalin_> might worth checking if suits better in fact
08:06:09 <fmarier> and publican is a set of tools for docbook as far as I know
08:06:09 <dobedobedoh> http://meetbot.mahara.org/mahara-dev/2011/mahara-dev.2011-03-23-07.31.log.html <-- we discussed it at about 08:55
08:06:19 <dobedobedoh> and I did mention texinfo, but it wasn't really discussed more than that
08:06:25 <anitsirk> i think in asciidoc you can import tex
08:06:36 <dobedobedoh> texinfo can generate html relatively nicely
08:06:48 <dobedobedoh> texinfo != tex
08:06:58 <rkabalin_> all Linux HOWTO is designed using texinfo
08:07:10 <fmarier> ah ok, i don't know what texinfo is then
08:07:11 <rkabalin_> s/ia/are
08:07:19 <fmarier> or rather i've never seen a source file
08:07:49 <iarenaza> fmarier: is the GNU project documentation markup language for most of their software.
08:07:58 <fmarier> i propose that whoever has an opinion about what the manual should use should get in touch with anitsirk
08:08:11 <fmarier> and then she gets to decide what she thinks is the best
08:08:16 <rkabalin_> yep
08:08:18 <dobedobedoh> http://www.at.xemacs.org/Documentation/21.5/html/texinfo_25.html is an example
08:08:23 <fmarier> afterall, she'll be doing the bulk of the work on it
08:08:23 <iarenaza> #info whoever has an opinion about what the manual should use should get in touch with anitsirk
08:08:24 <dobedobedoh> But it's possible to include sub-files
08:08:24 <fmarier> ..
08:08:40 <anitsirk> as i'll be writing / converting most of it in the beginning ;-)
08:08:40 <dobedobedoh> ..
08:09:14 <iarenaza> #info some alternatives proposed include asciidoc and texinfo
08:09:26 <rkabalin_> #link http://en.wikipedia.org/wiki/Texinfo
08:09:39 <dobedobedoh> The texinfo site is currently down (typically)
08:09:48 <dobedobedoh> ls
08:09:48 <anitsirk> not a good sign ;-)
08:09:56 <dobedobedoh> first time I've seen it down actually
08:09:57 <iarenaza> #info anitsirk gets to decide what she thinks is the best as she'll be doing the bulk of the work on it
08:10:26 <fmarier> iarenaza: that last thing was a suggestion, do other people agree?
08:10:37 <iarenaza> I agree :)
08:10:42 <anzeljg> agree
08:10:43 <rkabalin_> me too
08:11:00 <dobedobedoh> For the most part
08:11:27 <richardm> agree
08:11:27 <dobedobedoh> I should think that asciidoc is fine :)
08:11:39 <lordp> agree
08:12:14 <fmarier> alright, it's all yours anitsirk :)
08:12:37 <iarenaza> #agreed anitsirk gets to decide what markup language is the best as she'll be doing the bulk of the work on it
08:12:40 <iarenaza> #save
08:12:45 <anitsirk> alright. i'll do my best to have something soon.
08:13:27 <iarenaza> Shall we move onto next item?
08:13:33 <fmarier> i think so
08:13:47 <iarenaza> ok
08:13:50 <iarenaza> #info richardm have a look at launchpad translation tool and discuss whether or not to try to find funding to port AMOS
08:14:23 <richardm> ah, well we have all the po file scripts done, and fmarier has tested launchpad with another project
08:14:30 <richardm> fmarier: care to comment?
08:14:50 <iarenaza> #info richardm says they have all the po file scripts done, and fmarier has tested launchpad with another project
08:15:14 <fmarier> we'll test it for real when we import the maori translation i guess
08:15:59 <richardm> #info we're almost there, still need a little more time, and it's probably not worth spending too much on amos yet
08:16:21 <iarenaza> ok
08:16:46 <richardm> iarenaza: would you care to be the launchpad guinea pig?
08:16:53 <fmarier> if you want to have a play with the translation interface, you can have a look here: https://translations.launchpad.net/libravatar/trunk/+translations
08:17:14 <iarenaza> richardm: ok
08:17:16 <richardm> iarenaza: perhaps helping out the spanish & basque translators
08:17:20 <fmarier> feel free to contribute a translation to that project ;-)
08:17:24 <richardm> iarenaza: that would be great
08:18:02 <iarenaza> #info iarenaza to be a launchpad translation guinea pig
08:18:03 <richardm> #action richardm to send es, eu .po files to iarenaza so translators can start
08:18:16 <fmarier> richardm: you don't need to send them po files
08:18:18 <anitsirk> fmarier: as german is already on the list, i should definitely try it out. learning by doing. :-D
08:18:21 <fmarier> they can get them from launchpad
08:18:39 <richardm> fmarier: they're already up?
08:18:41 <richardm> cool
08:18:54 <fmarier> anitsirk: the list of languages that show up there are the ones that you have configured in your launchpad account
08:18:55 <anzeljg> I would also like to try with sl language
08:19:13 <fmarier> https://launchpad.net/~fmarier/+editlanguages
08:19:21 <fmarier> ^^^ replace fmarier with your launchpad username
08:19:23 <anitsirk> ah. makes sense that i see that immediately
08:19:49 <fmarier> but launchpad does a first pass automatically based on translations from other projects hosted on launchpad
08:20:02 <fmarier> it works for really simple things
08:20:13 <fmarier> but for more complicated ones, you need to write it yourself
08:20:24 <elky> fmarier, haha, nice plug.
08:20:51 <fmarier> richardm: we'll need to do an import of the POT file to launchpad before iarenaza can get started
08:20:59 <iarenaza> #action iarenaza anitsirk and anzeljg to start working on launchpad translations for .es, .eu, .de and .sl
08:21:21 <richardm> fmarier: yeah ok will do
08:21:40 <fmarier> richardm: it would be good to investigate the auto-imports as well
08:21:54 <anitsirk> uff, iarenaza i only said i'd check it out. ;-)
08:21:59 <anzeljg> Just to clarify - we'll be translating Mahara or Launchpad? I'm confused...
08:22:03 <iarenaza> #undo
08:22:03 <maharameet> Removing item from minutes: <MeetBot.items.Action object at 0x8805b4c>
08:22:07 <fmarier> because we don't want to be uploading manual pot files everytime someone adds a langstring
08:22:08 <richardm> the only thing is we can't really have both the old mahara langpacks & .po langpacks both beign updated at once
08:22:13 <iarenaza> anitsirk: listo! :)
08:22:24 <fmarier> anzeljg: translating mahara using the translation tool on Launchpad.net
08:22:30 <anzeljg> cool
08:22:38 <fmarier> it will be here once we have set it up correctly: https://translations.launchpad.net/mahara/trunk/+translations
08:23:11 <fmarier> the other link i gave was an example of what it looks like when it's enabled: https://translations.launchpad.net/libravatar/trunk/+translations
08:23:20 <fmarier> but it's for a different project of mine
08:23:21 <fmarier> ..
08:23:27 <anzeljg> now i get it ;)
08:24:05 <iarenaza> #action iarenaza anitsirk and anzeljg to check out how launchpad translations work
08:24:13 <iarenaza> anitsirk: better like that?
08:24:19 <anitsirk> that's better. thanks :-)
08:24:55 <fmarier> what else have we got from previous meetings?
08:25:07 <iarenaza> Nothing else, that I know of.
08:25:28 <fmarier> cool, so we can move to your agenda item then I guess
08:25:41 <iarenaza> ok
08:25:44 <dobedobedoh> I have one
08:25:56 <iarenaza> dobedobedoh: go ahead
08:26:03 <dobedobedoh> dobedobedoh to beg/borrow/steal/invent a forum code of conduct and place on the wiki
08:26:07 <dobedobedoh> It's now there!!!
08:26:15 <iarenaza> dobedobedoh: well done!!!
08:26:21 <dobedobedoh> https://wiki.mahara.org/index.php/Code_of_Conduct
08:26:44 <iarenaza> #info dobedobedoh has put the forum code of conduct at https://wiki.mahara.org/index.php/Code_of_Conduct
08:26:54 <elky> hmm, oddly familiar ;)
08:26:57 <rkabalin_> which of beg/borrow/steal/invent did you use? ;)
08:27:15 <elky> looks like steal to me :P
08:27:19 <anitsirk> "About this Code of Conduct" elky :-)
08:27:21 <iarenaza> XD
08:27:39 <anitsirk> it's CC BY-SA in the original
08:27:41 <elky> anitsirk, i know it rather intimately
08:27:42 <dobedobedoh> I stole the Ubuntu Code of Conduct (under CCAS license) and adjusted it accordingly, attributing it back to them
08:28:05 <anzeljg> there's a typo: wbich is licensed under the
08:28:16 <rkabalin_> that is great, thanks dobedobedoh
08:28:30 <iarenaza> #info it's based on the Ubuntu Code of Conduct (under CCAS license)
08:28:56 <dobedobedoh> what typo ;)
08:29:13 <fmarier> #link http://mahara.org/terms.php
08:29:18 <fmarier> ^^^ just before account expiry
08:29:30 <anzeljg> faster tha me... ;)
08:30:23 <iarenaza> Ok, anything else before we move to next agenda topic?
08:30:28 <fmarier> good job dobedobedoh
08:31:00 <fmarier> we've also stolen our trademark policy from Ubuntu: https://wiki.mahara.org/index.php/Marketing/Trademark_Policy
08:31:12 <dobedobedoh> Sorry that it's taken me so long
08:31:18 <anzeljg> why inventing the wheel???
08:31:46 <iarenaza> #info fmarier says our trademark policy is also "stolen" from Ubuntu
08:31:51 <iarenaza> #link https://wiki.mahara.org/index.php/Marketing/Trademark_Policy
08:32:12 <fmarier> stolen with their explicit permission :)
08:32:30 <iarenaza> That's why I used the quotation marks :-)
08:33:15 <iarenaza> Ok, next topic (this time for real :-))
08:33:32 <iarenaza> #topic Walled Gardens status?
08:33:57 <rkabalin_> interesting topic ;)
08:34:13 <iarenaza> I hoped the walled gardens feature would make it to 1.4, but it hasn't
08:34:28 <iarenaza> so I wonder what's the status of it :)
08:34:46 <fmarier> could it be merged in small chunks?
08:34:50 <iarenaza> is it planned for 1.5? later?
08:34:53 <fmarier> i mean it's quite a daunting task
08:35:18 <rkabalin_> we did not have time to review it before 1.4 unfortinately
08:35:46 <rkabalin_> we may aim it to 1.5
08:36:15 <fmarier> that will tie in nicely with the 1.5 agenda item :)
08:36:56 <rkabalin_> fmarier: it is difficult to merge it in a small chunks I think, it is interweaved with too many things
08:37:08 <iarenaza> I'm not proposing to get it 1.5 (there can be other priorities), I just wanted to know what's the plan for it.
08:37:47 <anzeljg> BRB
08:38:35 <iarenaza> #info The patch is difficult to merge in small chunks, as it is interweaved with too many things
08:38:42 <fmarier> rkabalin_: it sounds like we would need to take a good look at it and then have a meeting to plan how we'll go about merging it
08:38:45 <dobedobedoh> I think that gerrit will probably make life simpler
08:39:03 <rkabalin_> I am going to present Walled garden on maharaUK11, it might be that someone will be interested to fund revision and merging
08:39:03 <fmarier> it there are any dependencies that can be merged separately though that would be a good thing to do first
08:39:04 <dobedobedoh> but I think that it will require some effort from both LUNS and catalyst
08:39:28 <dobedobedoh> There are a couple of related features which allow per-institution disabling of plugins for example
08:39:47 <fmarier> i would also like to suggest that we avoid the phrase "walled garden" as it has a very negative connotation
08:39:59 <iarenaza> #info fmarier says they could take a good look at it and then have a meeting to plan how they'll go about merging it
08:39:59 <rkabalin_> fmarier: good point
08:40:18 <iarenaza> #fmarier also suggests that we avoid the phrase "walled garden" as it has a very negative connotation
08:40:20 <dan_p> Since its been a while since it was written - and was also was done at speed, I think we at LUNS should do an internal review
08:40:21 <fmarier> i've put down "fully separated institutions" on the wiki somewhere
08:40:25 <rkabalin_> I was just about to suggest remaing it to Isolated Institutions
08:40:33 <fmarier> yeah isolated is good too
08:40:43 <iarenaza> fmarier: yes, at https://wiki.mahara.org/index.php/Developer_Area/Current_Tasks
08:41:07 <rkabalin_> I am going to use Isolated Institutions term in my presentation
08:41:24 <fmarier> rkabalin_: feel free to update the above page with the new name too
08:41:29 <fmarier> (the current tasks page)
08:41:34 <rkabalin_> yep
08:42:17 <rkabalin_> #action rkabalin_ update relevant pages to use Isolated institutions instead of Walled Garden
08:43:07 <iarenaza> So from now on, we all should refer to it as "Isolated Institutions" everywhere, shouldn't we?
08:43:18 <fmarier> that sounds good to me
08:43:29 <anzeljg> I'm back...
08:43:36 <iarenaza> Can I add an agree item with that proposal?
08:44:01 <richardm> dobedobedoh: didn't you have some patches for institution configuration? that would be a good thing to start with in terms of submiting to gerrit
08:44:17 <rkabalin_> dan_p: and probably we need to update it with master before asking catalyst to looking into it
08:44:40 <rkabalin_> iarenaza: yes, go ahead
08:44:56 <dobedobedoh> richardm: Yup - I had those too
08:45:01 <dobedobedoh> They should merge relatively easily
08:45:31 <fmarier> also, as a side note, we (catalyst) are very busy until the end of June
08:45:49 <fmarier> with the 1.4 release and a bunch of new 1.5 features
08:45:53 <dan_p> fmarier: this is something we'd really like to coordinate with
08:45:59 <dobedobedoh> I guess it'll depend upon the 1.5 release cycle too?
08:46:05 <fmarier> so i would suggest bringing that up in July
08:46:07 <fmarier> ..
08:46:24 <dan_p> fmarier: not really much point us updating for merge if you guys doont have time to look at it
08:46:43 <iarenaza> #agreed Use the term "Isolated Institutions" everywhere, instead of "Walled Gardens"
08:47:08 <richardm> dan_p: there's a lot of point in trying to split the feature up into nice reviewable bits!
08:47:14 <fmarier> dan_p: i agree. let's park it until July but feel free to submit the dependencies before then
08:47:38 <fmarier> (the dependencies that dobedobedoh was talking about)
08:48:41 <iarenaza> #info The review will probably wait until July (due to work load)
08:49:26 <dan_p> i have to go
08:49:38 <rkabalin_> also we might find someone on the conference who will be interested in speeding it up ;) (which is the end of June)
08:49:45 <anitsirk> have a nice day, dan_p
08:49:50 <iarenaza> bye dan_p
08:49:51 <fmarier> thanks for coming dan_p
08:49:54 <anzeljg> bye dan_p
08:50:07 <fmarier> iarenaza: does this answer your question about the status of it?
08:50:19 <iarenaza> completely! :-)
08:50:51 <iarenaza> next topic
08:51:14 <iarenaza> #topic Guide on how to do code reviews
08:51:17 <iarenaza> #save
08:51:30 <iarenaza> fmarier: all yours
08:51:38 <fmarier> so this is related to the action item i had from the last meeting
08:51:55 <fmarier> i have put my thoughts (based on the reviews i've done and seen other people do) here: https://wiki.mahara.org/index.php/Developer_Area/How_to_Review_Code
08:52:02 <iarenaza> #link https://wiki.mahara.org/index.php/Developer_Area/How_to_Review_Code
08:52:15 <fmarier> basically if other reviewers could have a look at it and add what's missing, that would be great
08:52:34 <richardm> yeah looks good fmarier. might add some stuff to it, like small patches!
08:52:35 <fmarier> if you disagree with something that someone has added, then discuss with them and/or on the developer forum
08:52:52 <fmarier> ..
08:53:03 <iarenaza> #info if you disagree with something that someone has added, then discuss with them and/or on the developer forum
08:53:33 <fmarier> richardm: maybe just linking to https://wiki.mahara.org/index.php/Developer_Area/Contributing_Code#Preparing_.2F_organising_your_changes ?
08:53:53 <richardm> fmarier: awesome!
08:54:20 <iarenaza> #info see also https://wiki.mahara.org/index.php/Developer_Area/Contributing_Code
08:54:49 <fmarier> that's pretty much all i had for this topic
08:54:51 <dobedobedoh> Is it worth adding a link to it in Gerrit too?
08:55:07 <fmarier> please contribute to the page :)
08:55:09 <iarenaza> dobedobedoh: I'd say that's a good idea :)
08:55:12 <fmarier> dobedobedoh: good point
08:55:13 <richardm> ah yeah a link in gerrit would be great
08:55:18 <fmarier> i will add one
08:55:55 <rkabalin_> it probably should mention that +2 is only allowed to "reviewers"
08:56:14 <iarenaza> #action fmarier to add a link in gerrit pointing to the review guide
08:56:15 <elky> yeah, the first of that kind of word under each linkable heading ought to be linkified.
08:56:32 <anitsirk> what should be done if i come across a commit that uses old language strings and should be changed? would that be a new commit even if it is just a couple of words?
08:56:34 <elky> (in the wiki, that is)
08:56:38 <fmarier> rkabalin_: that's on this page: https://wiki.mahara.org/index.php/Developer_Area/Code_Review
08:56:48 <fmarier> iarenaza: that action item is done already :)
08:57:22 <fmarier> anitsirk: i'm not sure i understand what you mean
08:57:25 <iarenaza> #undo
08:57:25 <maharameet> Removing item from minutes: <MeetBot.items.Action object at 0x88182ec>
08:57:29 <dobedobedoh> Might be worth adding a link to https://wiki.mahara.org/index.php/Developer_Area/Contributing_Code in gerrit too while you're at it
08:57:50 <elky> anitsirk, you mean a new patchset under an existing change-id?
08:57:52 <fmarier> dobedobedoh: you mean on reviews.mahara.org itself?
08:57:57 <rkabalin_> fmarier: yes, but that is not obvious for the newcomer. And nothing said about verify
08:58:08 <anitsirk> fmarier: in brett's commit for the External Video block i would exchange video for media thus reading "External media" block because now that we have glogster etc. it's not just video anymore
08:58:33 <dobedobedoh> fmarier: Yup
08:58:58 <iarenaza> anitsirk: then I think we should reject the commit in gerrit and ask for a new patchset using the right language string
08:58:59 <dobedobedoh> fmarier: It'd be good to make relevant information really easily available to make it easier for people to get involved
08:59:02 <anitsirk> elky: i don't know if that's it
08:59:18 <dobedobedoh> elky: That sounds right
08:59:41 <fmarier> #action fmarier to link to the "how to review" page in the gerrit page header
09:00:19 <fmarier> anitsirk: you should ask the submitter for that. i don't think taking over someone else's changeset is good practice
09:00:24 <anitsirk> but the language strings affect other patches as well. so it may be an overarching thing rather than for just one patch. e.g. if one patch is to add glogster to the video block and another is prezi, then the language string affects both
09:00:33 <fmarier> but it's a valid reason to -1 a code review
09:00:51 <fmarier> just like iarenaza said...
09:00:52 <anitsirk> i wouldn't want to take anyone's changes over. ;-)
09:00:58 * fmarier catches up with the irc log
09:01:04 <elky> anitsirk, iirc that means there's too much change in a single commit ;)
09:01:35 <iarenaza> We are just over an hour and a half, is it ok for everyone to extend the meeting? (just in case someone needs to go)
09:01:41 <fmarier> dobedobedoh: regarding making the relevant info easy to find, what exactly do you have in mind?
09:01:46 <anitsirk> and if the code has been merged already, it would be a new patch because then it could be fixed for all?
09:02:09 <fmarier> because elky has been working on that : https://wiki.mahara.org/index.php/Developer_Area
09:02:10 <anzeljg> prezi can be embeded with embed.ly also...
09:02:17 <dobedobedoh> Just a link to the pages on how to review, and to the contributing code page
09:02:26 <fmarier> reorganising and cleanup the developer section
09:02:37 <iarenaza> anitsirk: if it's been merged, there's nothing you can do in the review stage any more :)
09:02:39 <iarenaza> ..
09:02:40 <fmarier> dobedobedoh: right, from gerrit itself
09:02:56 <elky> by working he means a lot of staring at the screen going "wth, where do i separate this?"
09:02:59 <anitsirk> iarenaza: i learned that yesterday :-)
09:03:28 <iarenaza> anitsirk: you file a new bug, fix it and submit the fix for review. That's all you can do.
09:03:30 <iarenaza> ..
09:03:56 <anitsirk> sounds good to me. thanks.
09:04:21 <fmarier> anitsirk: if the code has been merged, you need to submit a new change
09:04:25 <fmarier> this topic is starting to get a bit messy :)
09:04:38 <iarenaza> So to sum it up:
09:04:40 <anitsirk> but actually, wouldn't i just have to go into launchpad in the future and change the lang string there? ;-)
09:05:05 <fmarier> anitsirk: not for the english translation, that one will be in git still
09:05:27 <anitsirk> ok. bug report and patch it is then. ta.
09:05:36 <fmarier> anitsirk: yes
09:05:41 <fmarier> or push to gerrit
09:05:49 <fmarier> once i show you how to do it :)
09:06:02 <anitsirk> :-) yes. :-)
09:06:33 <fmarier> btw, i just wanted to mention this:
09:06:38 <fmarier> #link http://mahara.org/interaction/forum/topic.php?id=3637
09:06:59 <fmarier> some keen users are taking interest in the reviews we do to learn about new features and bug fixes as they happen :)
09:07:08 <fmarier> in real time
09:07:16 <fmarier> ..
09:07:34 <anzeljg> can't see it... :(
09:07:47 <anitsirk> you need to log in, anzeljg and probably join the group
09:08:09 <iarenaza> So to sum it up: 1. have a look at the code review guide, 2. propose enhancements to it, 3. Link to those two pages (code review, contributing code) from gerrit itself. Is that it?
09:08:14 <fmarier> http://paste.dollyfish.net.nz/f0fc80
09:08:19 <fmarier> for a copy of the main post in that group
09:08:25 <richardm> anitsirk: you joined and you're not canadian? naughty
09:08:26 <anzeljg> joining the group did it.
09:08:44 <fmarier> iarenaza: i think that's it, yes
09:08:51 <anitsirk> richardm: ;-)
09:09:07 <fmarier> "propose" as in "click edit at the top of the page" then hit "submit"
09:09:10 <fmarier> :)
09:09:58 <iarenaza> #info to sum it up: 1. have a look at the code review guide, 2. propose enhancements to it (as in "click edit at the top of the page" then hit "submit"), 3. Link to those two pages (code review, contributing code) from gerrit
09:10:12 <iarenaza> anything else on this topic?
09:10:24 <fmarier> not from me
09:10:43 <iarenaza> ok, next topic
09:11:26 <iarenaza> #topic Status of the 1.4 release
09:11:41 <fmarier> rc1 was released last week
09:11:54 <fmarier> thinking of cutting rc2 tomorrow or the day after
09:12:09 <fmarier> there are not many major bugs in it, but there is a small db upgrade
09:12:22 <fmarier> it looks like it will be the last rc before the release
09:12:38 <iarenaza> #info 1.4rc1 was released last week and rc2 will be released in a couple of days (looks like the last rc before release)
09:12:52 <fmarier> so unless serious bugs are reported against rc2, we should have a release in the first week of June
09:13:00 <elky> \o/
09:13:06 <fmarier> ..
09:13:09 <iarenaza> party!!!!
09:13:35 <dobedobedoh> Excellent news
09:13:37 <iarenaza> #info unless serious bugs are reported, we should have a release in the first week of June
09:13:39 <fmarier> any help testing the upgrade on large production DBs will be greatly appreciated
09:13:57 <anzeljg> excellent
09:14:11 <anitsirk> is there anything specific besides the upgrade that should be tested?
09:14:28 <iarenaza> fmarier: ours is not very large (around 600 users, but around 50-100 or so active)
09:14:39 <iarenaza> but it'll give it a try
09:14:39 <fmarier> iarenaza: it would still be good
09:14:40 <iarenaza> ..
09:14:50 * rkabalin_ thinks that we do not have a wiki page about branching policy
09:14:54 <fmarier> because it would be different from my really basic developer db ;-)
09:15:14 <fmarier> rkabalin_: what sort of page do you have in mind?
09:15:15 <elky> rkabalin_, that sounds like volunteering to me :P
09:15:27 <iarenaza> #action iarenaza to try the upgrade to 1.4 on a copy of his production site
09:15:39 <rkabalin_> fmarier: git branching map
09:16:00 <fmarier> we have this https://wiki.mahara.org/index.php/Developer_Area/Release_Policy
09:16:09 <fmarier> which talks about different release types
09:16:19 <elky> rkabalin, i believe gerrit makes the actual branching easy enough for a trained monkey
09:16:43 <fmarier> and this https://wiki.mahara.org/index.php/Developer_Area/Release_Instructions/Major_Release which talks about how to create a branch for a new major release
09:17:04 <fmarier> elky: a trained monkey with admin rights
09:17:14 <rkabalin_> I ma thinking about the map that would dispaly when we use tags and when the actual branches are created
09:17:18 <anzeljg> elky: so I should consider myself a monkey, but not trained one...
09:17:27 <elky> fmarier, I shall make a plaque for your desk with those words.
09:17:49 <fmarier> elky: :)
09:18:15 <fmarier> rkabalin_: are these pages enough or was there something else you were after?
09:19:31 <rkabalin_> generally they are sufficient, it was just a thought that it would be good to display a parallel between release policy and git branching
09:19:44 <fmarier> what do you mean by that?
09:19:51 <rkabalin_> an image probably
09:19:52 <iarenaza> Are you talking about something like this http://docs.moodle.org/en/CVS_for_Developers#Working_with_branches
09:20:02 <iarenaza> (I'm referring to the image)
09:20:03 <iarenaza> ..
09:20:23 <fmarier> #link https://launchpad.net/mahara/+series
09:20:27 <fmarier> ^^^ pretty graph
09:21:12 <rkabalin_> ah, true
09:21:37 <rkabalin_> then I will add the link to that from policy page
09:22:10 <iarenaza> #action rkabalin_ to add a link to https://launchpad.net/mahara/+series from the release policy page
09:22:41 <iarenaza> anything else on this topic?
09:22:42 <fmarier> ok, if there's nothing else, i suggest we move to talking about 1.5
09:22:46 <iarenaza> yeah
09:22:49 <rkabalin_> yep
09:23:00 <iarenaza> #topic 1.5 release: time-based or feature-based
09:23:03 <iarenaza> #save
09:23:34 <fmarier> ok, so i wanted to have a discussion on just one aspect of 1.5 for now
09:23:47 <fmarier> because we're still busy with 1.4 and a bunch of development
09:23:59 <fmarier> and it's a bit early to talk about what exactly will go in to 1.5
09:24:25 <fmarier> but do we want to commit to a time-based release or do we want to stick to a mixture of feature-based and time-based?
09:24:28 <fmarier> ..
09:25:02 <richardm> fmarier: why would we commit now when we can commit later?
09:25:17 <fmarier> the main thing about a time-based release is that the schedule would be published in advance (like https://wiki.ubuntu.com/NattyReleaseSchedule)
09:25:51 <fmarier> richardm: it's not a time-based release unless the date is fixed in advance
09:26:04 <fmarier> but that's exactly what i wanted to discuss here
09:26:17 <fmarier> ..
09:26:25 <iarenaza> are people already asking for time-based releases? (I know a lot of people are in the case of Moodle, to synch the upgrades with course beginnings and so on)
09:26:26 <iarenaza> ..
09:27:08 <richardm> i have a preference for time-based, but sometimes things like work can get in the way
09:27:28 <richardm> ..
09:27:56 <fmarier> well a time-based release is one where you release what is ready by a certain date and push everything else to the next release
09:28:07 <iarenaza> Moodle HQ is now doing time-based, leaving things out if they are not ready for the release date.
09:28:11 <fmarier> so if a feature is not ready, it gets dropped (reverted if need be)
09:28:31 <fmarier> there are different levels of freezes (e.g. feature freeze, bugfix freeze, string freeze, etc.)
09:28:34 <fmarier> ..
09:28:53 <iarenaza> But I know Moodle HQ is using SCRUM, so that aligns better with time-based releases.
09:29:49 <fmarier> what we've been trying to do recently is aim for 6-12 months between releases
09:30:11 <dobedobedoh> major releases, or point releases?
09:30:20 <anitsirk> major releases
09:30:23 <fmarier> but i was wondering whether others thought that we should go all the way to time-based
09:30:29 <fmarier> yeah major releases
09:30:36 <fmarier> ..
09:30:38 <iarenaza> I wonder which option would help more with getting funding (as an additional argument to choose one or the other) :-?
09:30:38 <iarenaza> ..
09:31:01 <elky> Perhaps poll the people who have to do the upgrades?
09:31:04 <elky> ..
09:31:20 <fmarier> iarenaza: if you have a time-based release cycle then you know what release the feature you funded and got merged will be in
09:31:41 <fmarier> but it may mean that it will be in the next release if you're past the current release's feature freeze
09:31:41 <iarenaza> I think 6-12 months for major releases is good enough for most people. You don't have to retrain people during scholar year
09:32:29 <fmarier> we also support 2 stable releases, so you don't have to upgrade now if you're running 1.3
09:32:33 <fmarier> not until 1.5 is released
09:32:35 <anitsirk> time-based release may also give more certainty that a new release will be out at that time -> easier for planning resources for upgrading, training etc.
09:34:06 <iarenaza> I don't have a strong opinion on this, to be honest
09:34:21 <fmarier> does anybody have a strong opinion?
09:34:33 <fmarier> (either personal or based on client preferences, etc.)
09:34:51 <anitsirk> the only strong opinion i have is that we align something with the academic calendar
09:35:09 <anitsirk> because most upgrades happen during the longer summer vacation time
09:35:14 <anitsirk> ..
09:35:19 <iarenaza> #info do we want to commit to a time-based release or do we want to stick to a mixture of feature-based and time-based?
09:36:03 <iarenaza> #info anitsirk the only strong opinion i have is that we align something with the academic calendar, because most upgrades happen during the longer summer vacation time
09:36:37 <fmarier> and the challenge is that to reach a specific date, we pretty much need the rest of the things that a time-based release cycle gives us
09:36:38 <rkabalin_> time-based is good from the academic point - new term or year - new mahara release
09:36:46 <anitsirk> (and summer happens to be twice a year ;-) but I don't know if we can always stick to 6-monthly)
09:37:24 <fmarier> anitsirk: we can, but it may mean that a release doesn't have much to offer in the way of new stuff or bug fixes
09:38:07 <iarenaza> anitsirk: if you support 2 stable versions, you can update once a year (in your summer holidays) from version n to version n+2
09:38:08 <iarenaza> ..
09:38:23 <fmarier> anyways, maybe we should all think about it and discuss it again at a later meeting
09:38:37 <anitsirk> +1
09:38:48 <iarenaza> +1
09:39:56 <fmarier> should we move to the next topic then?
09:39:58 <iarenaza> #action discuss this topic again (time-based vs feature-based releases) at a later meeting
09:40:18 <iarenaza> I think we should :)
09:40:19 <elky> fmarier, i think so
09:40:32 <iarenaza> #topic Next meeting
09:41:34 <iarenaza> June, 23rd ? (going back to thursdays, like we did before?)
09:41:50 <dobedobedoh> ummm
09:41:57 <rkabalin_> sounds good
09:42:02 <fmarier> how about the week after?
09:42:06 <lamiette> does that work around the Mahara UK conf okay?
09:42:14 <rkabalin_> yep
09:42:17 <lamiette> (btw hi everyone! sorry I was WAY WAY late)
09:42:20 <dobedobedoh> That's the day after MaharaUK
09:42:20 <fmarier> when is maharauk?
09:42:22 <dobedobedoh> So that should be fine
09:42:25 <iarenaza> the week after is ok for me
09:42:31 <iarenaza> hi lamiette
09:42:31 <dobedobedoh> 21st/22nd
09:42:45 <iarenaza> 21st/22nd is also ok for me
09:42:55 <rkabalin_> ^ that was the conf days
09:42:56 <anitsirk> are you going to MaharaUK, iarenaza ?
09:43:05 <lamiette> hands up who is going?
09:43:12 <fmarier> 21 is lesss than 1 month away though
09:43:17 <iarenaza> I didn't plan to
09:43:25 <rkabalin_> I go
09:43:26 <fmarier> if we wait an extra week, we'll have more to talk about :)
09:43:31 <dobedobedoh> I am
09:43:35 <dobedobedoh> as are Ruslan and Dan
09:43:50 <anzeljg> I may be there via videoconference...
09:43:57 <anitsirk> +1
09:43:59 <lamiette> I agree with fmarier about the week after if possible :)
09:44:03 <iarenaza> June, 30th? June 29th?
09:44:05 <fmarier> and from a Catalyst point of view, we'll be done with a large chunk of work
09:44:59 <anitsirk> June 30 / 29 sounds good to me
09:45:05 <dobedobedoh> Either is fine with me
09:45:31 <richardm> me to
09:45:33 <richardm> o
09:45:51 <rkabalin_> fine with me
09:45:58 <lamiette> me too
09:46:17 <lordp> and me
09:46:45 <iarenaza> Ok, Wednesday, 29 June 2011, 19:30:00 UTC then? (http://www.timeanddate.com/worldclock/fixedtime.html?day=29&month=6&year=2011&hour=19&min=30&sec=0&p1=0)
09:46:57 <anitsirk> +1
09:47:02 <rkabalin_> yep
09:47:10 <dobedobedoh> Yup
09:47:28 <iarenaza> Who's gonna chair it?
09:47:53 <iarenaza> #agreed Next meeting on Wednesday, 29 June 2011, 19:30:00 UTC
09:48:10 <fmarier> #agree
09:48:25 <lamiette> I could give chairing ago
09:48:30 <lamiette> haven't done it yet
09:48:55 <fmarier> thanks for volunteering lamiette
09:49:00 <fmarier> https://wiki.mahara.org/index.php/Developer_Area/Developer_Meetings/Chair_Duties
09:49:03 <iarenaza> yes, thanks a lot
09:49:15 <lamiette> ta fmarier :)
09:49:19 <iarenaza> lamiette: the link fmarier has posted is really useful!
09:49:44 <iarenaza> #agreed lamiette to chair next meeting
09:49:54 <iarenaza> final topic
09:49:55 <rkabalin_> thanks lamiette
09:50:01 <lamiette> np
09:50:05 <iarenaza> #topic Any other business
09:50:15 <fmarier> i have an item
09:50:24 <anitsirk> got one too
09:50:24 <anzeljg> me too
09:50:24 <lamiette> uh oh ..
09:50:28 <lamiette> :)
09:50:30 <iarenaza> fmarier: I knew! :-)
09:50:31 <fmarier> a big thank you to iarenaza for chairing the meeting!
09:50:39 <elky> +1
09:50:41 * fmarier is done
09:50:42 <richardm> :)
09:50:45 <anzeljg> +1
09:50:46 <anitsirk> +1
09:50:54 <rkabalin_> thanks elky for wiki dev area reordering
09:50:55 * iarenaza blushes
09:51:01 <elky> :D
09:51:02 <fmarier> rkabalin_: that too :)
09:51:10 <lamiette> oh yeah +1 for that!
09:51:12 <richardm> +1
09:51:16 <iarenaza> rkabalin_ +1 for that
09:51:18 <rkabalin_> iarenaza: thanks for chair
09:51:21 <lamiette> elky looks so much better
09:51:26 <fmarier> +2, i'm a reviewer, i can give +2 ;-)
09:51:28 <lamiette> (there's a comma in there somewhere)
09:51:29 * anzeljg has a question(s) for framier or richardm or both
09:51:35 <anitsirk> As the next meeting is 1 day before the next newsletter, if you have anything that should be mentioned in it, please send me the text.
09:51:55 <iarenaza> #info As the next meeting is 1 day before the next newsletter, if you have anything that should be mentioned in it, please send anitsirk the text
09:52:00 <richardm> anzeljg: fire away
09:52:02 <anzeljg> Regarding Skin support - when it will be reviewed
09:52:07 <anitsirk> sorry. forgot the info. thanks iarenaza
09:52:25 <anzeljg> I'm quite happy with it, but found that
09:52:32 <fmarier> anzeljg: it's on my personal list of priorities for 1.5
09:52:34 <anzeljg> #link http://www.google.com/webfonts
09:52:54 <fmarier> will not happen before july though, as per the discussion we have about isolated institutions
09:53:01 <anzeljg> and was wondering if I could try to get the support for that also..
09:53:21 <anzeljg> I mean, you can begin reviewing, and I'll update the things?!?
09:53:21 <anzeljg> ..
09:53:37 <richardm> 'Francois One' is in there!
09:53:59 <anzeljg> OK, so I can update everything and let you know?!?
09:54:23 <richardm> ... and 'Ruslan Display"
09:54:24 <elky> Is this like Airforce One, richardm?
09:54:36 <fmarier> richardm: then we definitely need it in core! :)
09:55:03 <fmarier> elky: i don't know, but i like the sound of it. /me emails Mark S. to ask him what model I should buy
09:55:16 <elky> fmarier, bwahaha!
09:55:34 <fmarier> anzeljg: personally, i would wait until july because master will change a lot in June
09:55:44 <fmarier> we're getting paid to add lots of new features
09:56:20 <elky> woot progress.
09:56:42 <anzeljg> fmarier: so a new rebase in july?
09:56:49 <anzeljg> or earlier?
09:56:51 <anzeljg> ..
09:57:06 <fmarier> anzeljg: yep, let's talk about it then. before that, we're not gonna have time to look at it, so it's probably not worth rebasing
09:57:18 <anzeljg> sounds good
09:57:36 <iarenaza> any other thing?
09:57:46 <anitsirk> nope
09:57:53 <anzeljg> not at the moment
09:57:55 <rkabalin_> no
09:58:18 <iarenaza> ok, so let's close it :)
09:58:29 <iarenaza> #endmeeting