07:31:17 <rkabalin_> #startmeeting
07:31:17 <maharameet> Meeting started Wed Mar 23 07:31:17 2011 UTC.  The chair is rkabalin_. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:31:17 <maharameet> Useful Commands: #action #agreed #help #info #idea #link #topic.
07:31:29 <rkabalin_> #topic Meeting attendees.
07:31:52 <rkabalin_> Please put #info in from of your names
07:31:53 <anitsirk> #info anitsirk: Kristina Hoeppner from Catalyst IT, Wellington, NZ
07:32:01 <dobedobedoh> #info Andrew Nicols, LUNS Ltd, UK
07:32:15 <lamiette> #info Stacey Walker Catalyst IT Europe
07:32:22 <rkabalin_> #info rkabalin_ Ruslan Kabalin from LUNS Ltd., Lancaster, UK
07:32:26 <anzeljg> #info anzeljg: Gregor Anzelj, Slovenian langpack maintainer, plugin developer
07:32:43 <aguri> #info David Drummond from Catalyst
07:32:53 <richardm> #info richardm: Richard Mansfield from Catalyst
07:33:22 <anitsirk> fmarier should be around as well
07:33:39 <fmarier> #info fmarier Francois Marier
07:34:15 <rkabalin_> ok, that is everyone I guess
07:34:25 <rkabalin_> #topic Items from previous meetings
07:34:47 <rkabalin_> #info dobedobedoh to check the ubuntu code of conduct which is CC licensed for the mahara code of conduct
07:34:50 <anitsirk> iarenaza sent an email saying that he can't attend, but he sent some info through regarding his action items
07:35:15 <rkabalin_> anitsirk: that is fine
07:35:19 <dobedobedoh> rkabalin: Sorry, but I *still* haven't had a chance to do this. My current workload should ease off on Friday
07:36:21 <rkabalin_> OK, I move it to the next meeting then
07:36:29 <dobedobedoh> :)
07:36:46 <rkabalin_> #action dobedobedoh to check the ubuntu code of conduct
07:37:03 <rkabalin_> #info dobedobedoh and azeljg to go over skins patches to try and get them into 1.4, richardm will also take a look at them
07:37:36 <richardm> rkabalin_: I still haven't done that
07:37:42 <anzeljg> I'll try to rebase with current mahara master
07:38:33 <rkabalin_> #action anzeljg try to rebase his skins patches with current mahara master
07:38:37 <anzeljg> I talked with richardm and he said that including it in 1.4 may not be possible
07:38:39 <fmarier> anzeljg: is the current version pushed anywhere?
07:38:58 <anzeljg> just a moment...
07:39:42 <anitsirk> #info the new url of anzeljg's test server is http://mahara.ledina.org/DEV/ login and pwd stayed the same
07:39:59 <anitsirk> #info there you can test the skins
07:40:07 <richardm> yeah, I was thinking it's getting a bit tight if we keep to the end of april deadline
07:40:20 <anzeljg> the latest (unchanged version) is here: #link http://gitorious.org/~anzeljg/mahara/anzeljg-mahara
07:40:46 <anzeljg> there is only skin support on this clone
07:41:15 <rkabalin_> dobedobedoh: will you be able to go through patches in April?
07:41:26 <richardm> ok cool, I will try to take a look at it, but will go through the high priority bugs first
07:41:47 <dobedobedoh> I'm not sure -- it depends on my other commitments
07:42:02 <anzeljg> richardm, dobedobedoh and fmarier all have admin privileges at that clone
07:42:05 <dobedobedoh> I'd like to but since I first volunteered, I haven't acually had a chance :(
07:42:28 <rkabalin_> ok, then I re-assign it to richardm and you both
07:42:56 <richardm> Ok that sounds good
07:43:21 <rkabalin_> #action richardm dobedobedoh Go through azeljg's skins patches to try and get them into 1.4
07:43:37 <rkabalin_> #info iarenaza to draft language pack release policy
07:43:44 <anitsirk> that is done
07:44:01 <anitsirk> #link http://wiki.mahara.org/Language_Packs/Language_Pack_Release_Policy
07:44:11 <rkabalin_> Great
07:44:27 <rkabalin_> #info Graphs in Mahara Statistics proposal (anzeljg)
07:44:33 <anitsirk> #info iarenaza also writes: H31nz was in touch with me and provided some valuable feedback that
07:44:33 <anitsirk> has been incorporated to the draft
07:45:36 <anitsirk> sorry for being so slow in copying. that's all that he had to say for this item
07:46:13 <anzeljg> Graphs: I just proposed this. I wanted to include it in the survey artefact, I'm working on, but haven't had the time to do it.
07:48:36 <anitsirk> anzeljg: i like the plugins you produce because they add great functionality to mahara. i think you are the plugin developer par exellence for mahara
07:49:07 <rkabalin_> OK, shall I postpone this as action?
07:49:08 <fmarier> +1 to that :)
07:49:15 <anzeljg> thank you for kind words anitsirk, I'm blushing now...
07:49:26 <fmarier> i think the action (proposing the idea) is done
07:49:28 <anitsirk> it's true :-)
07:49:47 <fmarier> and we all agreed that it sounds like a good idea
07:49:56 <anzeljg> fine with me
07:50:02 <rkabalin_> ah, yep
07:50:46 <rkabalin_> that is indeed a good idea having them added to mahara
07:50:55 <rkabalin_> #info rkabalin to summarize his ideas of notifications of objectionable content on a subpage
07:51:44 <rkabalin_> I have written a very brief spec on that http://wiki.mahara.org/Developer_Area/Specifications_in_Development/Objectionable_content_reporting
07:53:15 * fmarier agrees with the destination user in rkabalin_'s spec
07:53:46 <anitsirk> should we then have objectionable content reporting for any artefact? you have blog in there, but images and other docs also have their own artefact page. they should be treated equally, i think.
07:54:06 <dobedobedoh> One thing I'd like to add -- it would be good to be able to object to Users as a whole and have notifications sent to the site/institution admin
07:54:22 <richardm> I don't think we even have notifications of wall posts yet either
07:54:30 <anitsirk> nope we don't
07:54:55 <anitsirk> dobedobedoh: isn't the objection to one user based on his actions?
07:55:36 <dobedobedoh> anitsirk: Possibly, but if someone reports objectional content in a forum, then the forum moderators receive the message
07:55:56 <dobedobedoh> If the forum mods determine that the user is actually a spammer/bot, but they aren't site/institution admins, they can't remove the users
07:55:59 <dobedobedoh> user*
07:56:07 <dobedobedoh> So they need an escalation method
07:56:10 <rkabalin_> dobedobedoh: good point
07:56:17 <anitsirk> that's true
07:56:35 <rkabalin_> perhaps moderator should be able ot disable the user
07:56:46 <dobedobedoh> Case in point is mahara.org -- I'm a forum mod and can remove messages, and remove users from the groups, but not disable the user in any useful fashion
07:56:52 <dobedobedoh> So spammers can just rejoin the group and spam again
07:57:03 <fmarier> rkabalin_: that would give too much power to moderators i think
07:57:04 <anitsirk> forum: do you mean "moderators" also in the sense of admins of the group if there is no official forum moderator, dobedobedoh ?
07:57:21 <lamiette> I wonder if the objections could add the user to a watchlist that the admins could then monitor if they keep getting objections etc?
07:57:22 <dobedobedoh> anitsirk: I was thinking as a group admin
07:57:32 <fmarier> i guess what you want is a way for a group admin to ban a user from joining the group
07:58:03 <dobedobedoh> fmarier: Something like that would be good
07:58:09 <anitsirk> +1
07:58:17 <rkabalin_> #info perhaps what we want is a way for a group admin to ban a user from joining the group
07:58:25 <anzeljg> +1
07:58:30 <rkabalin_> #agree
07:58:40 <fmarier> anyways, maybe we should move on since we have quite a few items left on the "previous actions" list as well as on the agenda :)
07:58:54 <rkabalin_> ;) ok
07:59:01 <fmarier> what's the next step on this particular feature?
07:59:10 <fmarier> is this something you're planning on implementing?
07:59:45 <rkabalin_> just an idea at the moment
07:59:52 <fmarier> or was it mostly to write a spec before filing a wishlist bug on the tracker?
08:00:45 <fmarier> ok, in that case, i would suggest: action for ruslan - file a wishlist bug on the tracker :)
08:00:46 <rkabalin_> a sort of, but I think we should start with forums if the time for this feature will be allocated
08:01:29 <rkabalin_> #action rkabalin_ file a wishlist bug on the tracker with objectionable content report items
08:01:43 <rkabalin_> #info richardm checks if objectionable content notifications already go to institution admins besides site admins
08:01:50 <rkabalin_> that is done I think
08:02:10 <anitsirk> do you mean that richardm checked or that notifications go to institution admin as well?
08:02:39 <rkabalin_> there was I patch if I remeber correctly
08:02:43 <richardm> I was afraid of looking bad at the next meeting so i did it.
08:03:02 <richardm> Should be working now
08:03:05 <rkabalin_> well done richardm!
08:03:08 <anitsirk> cool
08:03:16 <rkabalin_> #info anzeljg will put more details about using pChart as framework for rendering graphs in Mahara on the bug tracker
08:04:00 <fmarier> done: https://bugs.launchpad.net/mahara/+bug/721496
08:04:31 <rkabalin_> fine
08:04:47 <rkabalin_> #anzeljg to further look into flickr and picasa photo block
08:04:52 <rkabalin_> #undo
08:04:52 <maharameet> Removing item from minutes: <MeetBot.items.Info object at 0x858b90c>
08:05:04 <rkabalin_> #info anzeljg to further look into flickr and picasa photo block
08:05:23 <anzeljg> I did that by extending galler block
08:05:31 <fmarier> awesome
08:05:33 <anzeljg> it works on my localhost
08:05:59 * dobedobedoh learns a new meetbot feature
08:06:09 <anzeljg> tried to show it to you guys and uploaded it to our school server http://mahara.ledina.org/DEV/, but got error message
08:06:26 <anzeljg> URL file-access is disabled in the server configuration
08:06:32 <anzeljg> that is the error
08:06:54 <anzeljg> need some time (days) to sort it out, than send you an e-mail with details...
08:07:31 <rkabalin_> #action  anzeljg send an e-mail with details on flickr and picasa photo block
08:08:00 <rkabalin_> #info iarenaza to provide anzeljg with google apps for education account(s) for further testing of the google apps plugin
08:08:02 <anzeljg> a brief descritption: gallery block is extended so the user can add photos from mahara or from external gallery (Flickr, Picasa, Panoramio and Photobucket currently supported - having troubles with Windows Live Photo Gallery)
08:08:22 <anzeljg> user can also choose thumbnails, square thumbnails or slideshow
08:08:43 <fmarier> wow, i'm looking forward to seeing that!
08:08:52 <rkabalin_> would be initersting to have a look
08:09:09 <rkabalin_> ok, next item
08:09:11 <anitsirk> sounds great
08:09:11 <anzeljg> gallery block now uses slimbox2 (http://www.digitalia.be/software/slimbox2) fore rendering photos when user clicks on thumbnail
08:10:03 <rkabalin_> anzeljg: that sounds cool
08:10:05 <richardm> anzeljg: cool, sounds much better than the basic one in the old gallery block
08:10:50 * richardm is sucked in by the page title
08:11:05 <anzeljg> i'll try to sort it out in a couple of next days - got newborn two days ago, so i don't have much time currently :)
08:11:17 <fmarier> anzeljg: congratulations! :)
08:11:23 <anzeljg> thanx
08:11:27 <rkabalin_> anzeljg: congratulations!
08:11:27 <richardm> wow, congratulations
08:11:27 <dobedobedoh> congrats anzeljg!
08:11:28 <anitsirk> congratulations, anzeljg
08:12:15 <rkabalin_> #info iarenaza to provide anzeljg with google apps for education account(s) for further  testing of the google apps plugin
08:12:20 <anitsirk> #info from iarenaza: I have the Google Apps domain up and running already (so I can provide accounts as needed), but haven't looked anything about Live@edu yet (terms and conditions, technical requirements, etc.). I hope I'll have a bit of free time at the end of next week to have a look at it.
08:12:42 <anitsirk> we can combine google apps and live@edu updates
08:13:13 <anitsirk> i had an email conversation with live@edu support but they didn't quite understand my query though i thought it was clear. :-( maybe i should have drawn an image
08:13:28 <rkabalin_> ;)
08:13:52 <anitsirk> they didn't know if their url's were different for live@edu account created documents to the regular live account
08:14:02 <anitsirk> anyway, thanks to iarenaza, we'll soon know
08:14:26 <anitsirk> i guess, we can make it an action item that iarenaza will sort out the live@edu account details
08:15:01 <rkabalin_> #action iarenaza further look at Live@edu accounts
08:15:36 <anitsirk> rkabalin_: we can skip action items 12 and 13 from last meeting :-)
08:15:43 <rkabalin_> yep
08:15:53 <rkabalin_> #info richardm to add a list of plugins-in-use for the weekly stats push
08:16:17 <richardm> Yep, done i think
08:16:30 <rkabalin_> great
08:17:32 <dobedobedoh> Ace
08:17:40 <rkabalin_> I am wondering if stats available for ordinary users?
08:17:58 <richardm> Nope, not yet, they're in the admin area only
08:18:06 <rkabalin_> ok
08:18:07 <anitsirk> which stats would you show normal users?
08:18:47 <richardm> Well there's a graph of the number of sites, it's boring but not revealing
08:18:54 <fmarier> something like this would be cool: http://moodle.org/stats/
08:19:28 <rkabalin_> we can get country distribution for instance in terms of sites and users
08:19:28 <anitsirk> #agree
08:19:50 <fmarier> but we may not have all the info yet
08:20:09 <fmarier> however, it's a good guide in terms of what information can be made public
08:20:59 <anitsirk> they've added a lot of stats. they also started out small. :-)
08:21:29 <rkabalin_> perhaps richardm or fmarier can write a spec for what we can have on public stats page
08:21:56 <rkabalin_> just outline it on wiki
08:22:10 <richardm> I don't think we'll have time for that before the next meeting
08:22:23 <fmarier> yeah, i think we have lots of things on our plates already :)
08:22:33 <fmarier> releasing 1.4 comes to mind :)
08:22:52 <rkabalin_> ok, let's leave it for the moment
08:23:05 <rkabalin_> #info fmarier is going to try to get in touch with Mjollnir` and get the unit test work she did merge into master
08:23:36 <fmarier> done: richardm found the code and pushed it here: http://gitorious.org/mahara/mahara-shared/commits/phpunit-old
08:23:42 * anitsirk is wondering how to keep track of action items for the meeting after next or even after that. probably just create wiki pages and put the info in.
08:23:44 <fmarier> not merged yet though
08:24:09 <dobedobedoh> It'd be really good to have the phpunit tests
08:24:13 <rkabalin_> anitsirk: good idea
08:24:22 <fmarier> anitsirk: http://wiki.mahara.org/Developer_Area/Current_Tasks
08:24:30 <fmarier> i've added the stats thing to the backlog
08:24:43 <rkabalin_> thanks fmarier
08:24:56 <anitsirk> ah even better
08:25:00 <anitsirk> thanks fmarier
08:25:23 <fmarier> so we don't have to keep those as action items for meetings
08:25:46 <anitsirk> yeah. is better place, esp. with items for which we don't know yet in which meeting they can be addressed
08:25:55 <fmarier> also: the backlog is not ordered by priority
08:26:23 <anitsirk> #info tasks / action items that we want to keep track of, but can't address until the next developer meeting are tracked at http://wiki.mahara.org/Developer_Area/Current_Tasks
08:26:42 <rkabalin_> thanks anitsirk
08:26:47 <rkabalin_> #agree
08:26:48 <fmarier> that also shows what tasks we're working on by the way
08:27:16 <fmarier> lamiette and i (mostly lamiette actually) are doing the stable release
08:27:22 <fmarier> and i'm setting up gerrit
08:27:33 <rkabalin_> #info phpunit code is pushed here http://gitorious.org/mahara/mahara-shared/commits/phpunit-old
08:28:23 <fmarier> feel free to take something from the backlog and put your name beside it of course :)
08:28:45 <rkabalin_> any idea when gerrit will go live?
08:29:15 <fmarier> rkabalin_: yes and it's on the agenda :)
08:29:19 <richardm> :)
08:29:47 <fmarier> so we can skip that item as we'll get back to it shortly
08:31:08 <rkabalin_> ah, I have not updated agenda page since yesterday
08:31:27 <rkabalin_> ok, let us move to the agenda then
08:31:29 <anitsirk> there've been some additions ;-)
08:32:00 <rkabalin_> #topic lang.mahara.org and AMOS roadmap and funding? [iarenaza]
08:32:36 <anitsirk> he's not here and i don't have any info on this item.
08:32:50 <rkabalin_> true, sorry
08:33:01 <anitsirk> no worries. could have been in his email. ;-)
08:33:19 <rkabalin_> I will move this to the next meeting then
08:34:01 <anitsirk> it was great that he had provided info on his action items. i think we'll revisit the lang.mahara.org stuff next time
08:34:13 <rkabalin_> #action rkabalin_ move lang.mahara.org agenda item to the next meeting as iarenaza is not present
08:34:32 <rkabalin_> #topic Forum post editing (bug #731990) [Francois]
08:34:37 <fmarier> I suggest starting by giving everybody a chance to take a look at https://bugs.launchpad.net/mahara/+bug/731990
08:34:55 <fmarier> that we can discuss what we think we should do
08:35:28 <dobedobedoh> I had considered an alternative -- providing a countdown timer (JS) on the edit post page telling the user how long they have to edit their post
08:35:43 <dobedobedoh> And not extending the time allowed to post
08:35:51 <fmarier> i put that bug on the agenda there because we didn't reach a conclusion on the tracker and was hoping for a larger discussion
08:36:12 <rkabalin_> dobedobedoh: that is slightly unusual for the forum ;)
08:36:58 <rkabalin_> will create a feeling of exam ;)
08:37:20 <dobedobedoh> there is that
08:37:25 <fmarier> on the other hand, it's a reflection of what is happening
08:37:37 <fmarier> there is a countdown as soon as the post is submitted :)
08:37:49 <dobedobedoh> But why should we extend the time limit -- if the limit has been set, it's probably there for a reason
08:37:52 <anitsirk> what about having a message after the submission of the forum post saying "You have 30 min to edit your post before it is sent out" (like Moodle)?
08:38:04 <anitsirk> currently nobody knows how long the editing period is
08:38:33 <rkabalin_> anitsirk: that sounds reasonable
08:38:47 <rkabalin_> #info  having a message after the submission of the forum post saying "You have 30 min
08:39:11 <fmarier> that's a good idea
08:39:20 <fmarier> what do others think?
08:39:27 <richardm> Why should you even get an editing period?  I think it's only there because of moodle.  But if you mess up, you could just delete the post & post it again.
08:39:43 <dobedobedoh> I'm surprised we don't already have that message
08:39:46 <fmarier> richardm: it's useful to fix typos
08:39:47 <anitsirk> we shouldn't make it too complicated. ;-) the editing possibility of a forum post is for small spelling mistakes, small additions etc. but not for major edits. that's when you write a new forum post. therefore, a simple message should suffice
08:40:14 <dobedobedoh> And if you have less than $x minutes, the timer too?
08:40:24 <anitsirk> richardm: can a normal user delete the post after the editing period?
08:40:38 <richardm> Hm, maybe not, I don't knwo
08:40:46 <anitsirk> i would not include a time. that sounds very much like exam time.
08:40:54 <anitsirk> include a timer i meant
08:41:26 <rkabalin_> I think we probably should just indicate how much time left when editing page is open rather than doing complicated stuff
08:41:35 <fmarier> rkabalin_: agreed
08:41:35 <anitsirk> #agree
08:41:46 <dobedobedoh> Yeah - that would be good #agree
08:41:51 <anzeljg> #agree
08:42:21 <fmarier> should i update the bug on the tracker?
08:42:25 <rkabalin_> #action rkabalin_ add time left indication to forum editing page
08:42:28 <anitsirk> that'd be great
08:42:41 <rkabalin_> yes plese, and assign it to me
08:43:00 <fmarier> rkabalin_: you can remove the action item, since there's a bug for it already
08:43:41 <rkabalin_> fmarier: good question, probably not
08:43:58 <fmarier> how about that magic #undo ? :)
08:44:11 <anitsirk> might only work for the previous line
08:44:26 <rkabalin_> undo only removes the last line I guess
08:44:29 <fmarier> #undo
08:44:35 <rkabalin_> #undo
08:44:35 <maharameet> Removing item from minutes: <MeetBot.items.Action object at 0x85a930c>
08:44:36 <fmarier> let's try it :)
08:44:41 <fmarier> it worked!
08:44:59 <fmarier> it was, after all, the last line that starts with a #
08:45:14 <rkabalin_> good to know
08:45:17 <fmarier> cool, i think we can now move to the next item
08:45:39 <rkabalin_> #topic Status on code reviews [Francois]
08:45:50 <fmarier> ok, so first of all
08:45:59 <fmarier> #link https://reviews.mahara.org/
08:46:08 <fmarier> (is that the right way to add links?)
08:46:27 <anitsirk> yep
08:46:29 <rkabalin_> yes
08:46:42 <fmarier> so gerrit is running, but it's not 100% finished yet
08:46:47 <anitsirk> though if the line starts with a link you don't necessarily need the #link
08:46:54 <rkabalin_> though it should work without #link as well
08:46:58 <fmarier> i will be testing it with richardm in the next few days
08:47:55 <fmarier> once it's ready, i'll post about it on the forum
08:48:03 <rkabalin_> #info Mahara code review #link https://reviews.mahara.org/
08:48:08 <anitsirk> BTW: #undo: Remove the last item from the meeting minutes. Only applies to commands which appear in the final output. (Chairs only.) from http://meetbot.debian.net/Manual.html
08:48:26 <fmarier> but basically, we will be making this repo read-only: http://gitorious.org/mahara/mahara
08:48:42 <fmarier> only the gerrit user will be pushing to it
08:48:59 <fmarier> developers will instead be pushing their code to a separate gerrit repo
08:49:15 <fmarier> and they'll get pushed to the real repo by gerrit once they have been reviewed
08:49:49 <rkabalin_> sounds good
08:50:13 <fmarier> because the main repo will turn read-only, i've created http://gitorious.org/mahara/mahara-shared for times when we need to collaborate on a branch
08:50:25 <rkabalin_> #info basically, we will be making this repo read-only: http://gitorious.org/mahara/mahara only the gerrit user will be pushing to it developers will instead be pushing their code to a separate gerrit repo and they'll get pushed to the real repo by gerrit once they have been reviewed
08:50:37 <fmarier> so if you want multiple devs to pull and push on a branch, you can use that
08:50:50 <fmarier> the main repo now only has the release branches and the master branch
08:51:32 <fmarier> the only other thing i wanted to say about gerrit is that you can all create your account now. the instructions are here: http://wiki.mahara.org/Developer_Area/Git_Repository_Policy
08:51:37 <rkabalin_> #info  http://gitorious.org/mahara/mahara-shared to be used for devs collaboration
08:53:32 <rkabalin_> #info gerrit account instructions: http://wiki.mahara.org/Developer_Area/Git_Repository_Policy
08:53:43 <fmarier> right, so if nobody has questions, we can move to anitsirk's item
08:53:52 <dobedobedoh> fmarier: All looking good
08:54:08 <rkabalin_> sounds good to me
08:54:21 <fmarier> if you want to play with gerrit, feel free to comment on the merge request i put there :)
08:54:35 <fmarier> https://reviews.mahara.org/1
08:54:47 <anitsirk> #topic Documentation management
08:54:52 <anitsirk> #idea the idea is to improve the mahara documentation.
08:54:53 <anitsirk> #info currently, the documentation sits in the wiki and is not really updated. most information is very old and often only applicable for 1.2. craig made an effort to put 1.3 things into the user guide. however, i think the current system of doing documentation does not work very well and some re-thinking is necessary.
08:54:53 <anitsirk> #info the way koha manages their documentation is interesting: have everything in git, use an xml editor and docbook to produce the documentation which has the output format html but can also be printed easily as pdf manual.
08:54:53 <anitsirk> i like that approach because it allows the documentation to sit in one place and different output formats are generated easily.
08:55:39 <rkabalin_> thanks Kristina
08:55:47 <dobedobedoh> I was just about to suggest having it in git and to use that approach
08:55:58 * fmarier would love to submit patches to the documentation manager using git-send-email :)
08:56:14 <anitsirk> chris cormack, a colleague who is involved in the koha project, suggested to use asciidoc instead of the xml editor and docbook because it is easier, more readable and highly versatile.
08:56:14 <anitsirk> #link http://www.methods.co.nz/asciidoc/
08:56:15 <dobedobedoh> It's something that we currently do for some of our internal docs using texinfo
08:56:15 <anitsirk> another colleague, brenda wallace, suggested doxygen.
08:56:15 <anitsirk> #link http://www.stack.nl/~dimitri/doxygen/
08:56:15 <anitsirk> doxygen is geared towards generating documentation directly from comments in the code. that would be an idea for a developer documentation but not for the user documentation.
08:56:15 <anitsirk> #info: does anyone of you have any suggestions for a tool combination because you have already worked with one or like one in particular? so far, i have not made any changes and am still in the investigation phase, but lean towards trying out asciidoc.
08:56:21 <anitsirk> that would be great, fmarier.
08:56:57 <fmarier> it's surprisingly readable: http://www.methods.co.nz/asciidoc/asciidoc.txt
08:57:06 <fmarier> (that's the source file)
08:57:09 <anitsirk> the idea was to have it in git so that developers who use git all the time anyway, might submit something
08:57:30 <anitsirk> fmarier: that's why chris suggested it instead of xml because you can actually read it and it's easy to write.
08:57:30 <fmarier> anitsirk: yeah doxygen is for API documentation, not for a user manual
08:57:56 <anitsirk> should we consider it for a developer documentation?
08:57:59 <fmarier> the fact that it's not XML means that git diffs will actually be useful
08:58:07 <anzeljg> just a question or consideration: what about translating documentation in other languages?
08:58:24 <anitsirk> the japanese lang maintainer does that already, i think
08:58:31 <anzeljg> i mean, i have too much work with translating mahara - there's no time for documentation...
08:58:35 <fmarier> anitsirk: API documentation is a very large task, but yes, something like doxygen makes sense
08:59:24 <anitsirk> anzeljg: maybe there's a way to tag pages and include content from other languages
08:59:32 <fmarier> anitsirk or rangi: how is the koha manual translated?
08:59:33 <anitsirk> in terms of the documentation content: i'd like to separate it into mahara pre 1.4 and mahara 1.4 and not combine everything in one because i think that will get too messy.
08:59:48 <anitsirk> mhh. good question. i don't know actually.
09:00:05 <anitsirk> but nicole's english manual is definitely the bible.
09:00:06 <fmarier> anitsirk: if it's in git, you can have a 1.3_STABLE branch as well as a master branch :)
09:00:19 <anitsirk> oh yeah. :-)
09:00:24 <fmarier> so the manual repo would have the same branches as the code
09:00:47 * dobedobedoh afks for 10 minutes and wants to be around for httpswwwroot talking
09:00:56 <anitsirk> i would also like to incorporate the "user generated tutorials" into the documentation so that they aren't separate anymore as many make very good screencasts.
09:01:04 <rangi> fmarier: its docbook, people are doing it manually
09:01:14 <anitsirk> hi rangi :-)
09:01:29 <fmarier> rangi:  so using asciidoc would work the same way i guess
09:01:37 <rkabalin_> hi rangi
09:02:10 <fmarier> does anybody have a better suggestion than asciidoc?
09:02:14 <anitsirk> if nobody has objections to asciidoc, i'd like to proceed with a trial that way and see what i'd have to do next, whom to ask for the set up etc.
09:02:41 <rkabalin_> sounds good to me
09:02:47 <anzeljg> fine
09:02:54 <rangi> fmarier: yep id imagine so
09:02:59 <rangi> http://git.koha-community.org/gitweb/?p=kohadocs.git;a=tree
09:03:55 <rangi> hi rkabalin_
09:04:03 <rkabalin_> #action anitsirk proceed with asciidoc trial and come up with more info
09:04:24 <anitsirk> sounds good to me.
09:04:33 <fmarier> anitsirk: you now have a git repo for it: http://gitorious.org/mahara/manual
09:04:45 <fmarier> i can assist with setup and initial pushing
09:04:52 <anitsirk> and i know whom to ask if i have questions. :-) thanks fm
09:04:55 <anitsirk> thansk fmarier
09:05:03 <rkabalin_> #info repo for mahara manual http://gitorious.org/mahara/manual
09:05:37 <rkabalin_> next item?
09:05:46 <anitsirk> yep
09:05:52 <rkabalin_> #topic Proposing to license the Mahara wiki content under CC BY-SA 3.0 Unported [Francois]
09:05:56 <rangi> fmarier: we had jenkins running xml validation on the docbook files too, im picking you can do the same with asciidoc
09:06:18 <fmarier> yeah it would be good to create a test suite for the user manual
09:06:30 <fmarier> it we can find a "lint" checker-type of program
09:07:10 <rangi> ill ask the evergreen devs, they use asciidoc for their docs
09:07:18 <fmarier> awesome
09:07:18 * rangi will let you get back to your meeting now :)
09:07:29 <anitsirk> hey, you are part of it, rangi :-)
09:07:41 <fmarier> rkabalin_: that looks like an action item for rangi ;-)
09:07:50 <anitsirk> thanks for your input and for asking the evergreen guys
09:09:04 <anitsirk> #action rangi to ask the evergreen guys if they have a test suite for their asciidoc manual
09:09:08 <rkabalin_> #action rangi ask evergreen devs about using asciidoc for docs
09:09:16 <fmarier> #undo
09:09:20 <rkabalin_> #undo
09:09:20 <maharameet> Removing item from minutes: <MeetBot.items.Action object at 0x85b4a0c>
09:09:27 <fmarier> oops :)
09:09:31 <anitsirk> fmarier: only the chair can undo :-)
09:09:35 <fmarier> ah good then
09:09:37 <rkabalin_> yep
09:09:57 <fmarier> alright, back to the wiki
09:10:31 <fmarier> i have proposed on the community forum that we license it under CC BY-SA which is the CC license closest to the license that the Mahara code is under
09:10:45 <fmarier> i have made a list of all contributors to the wiki
09:10:51 <anitsirk> #agree with your proposal
09:11:04 * rkabalin_ I probably should have undo the previous topic command and enter it again since we continued discussion
09:11:05 <fmarier> i have 43 people who have made more than 1 non-triviall contribution to the wiki
09:11:38 <fmarier> basically i'm going to email all of them to ask for their permission
09:12:11 <fmarier> since nobody has objected publicly or privately
09:12:39 <fmarier> however, i could skip emailing all of you if you could just type #agree here :)
09:12:41 <richardm> I objected privately :)
09:12:45 <richardm> (just kidding)
09:12:53 <rkabalin_> #agree
09:12:53 <anitsirk> sounds good. i guess that needs to be done as not everybody may have read the forum thread
09:12:55 <richardm> #agree
09:13:00 <anitsirk> #agree
09:13:06 <anzeljg> #agree and did that privately if memory serves correctly ;)
09:13:50 <fmarier> anzeljg: yeah i think you did (one or two people did already but i forgot to write it down in my spreadsheet)
09:14:11 * dobedobedoh returns
09:14:47 <fmarier> dobedobedoh: do you agree to licensing the wiki under CC BY-SA ?
09:14:53 <rkabalin_> ok, is that everyone I guess
09:15:09 <dobedobedoh> Yup
09:15:11 <dobedobedoh> #agree :)
09:15:15 <fmarier> awesome
09:15:27 <fmarier> i have only 38 people to email now ;-)
09:16:12 <fmarier> now that dobedobedoh is back, we can move to the https item
09:16:31 <dobedobedoh> Thanks for waiting!
09:16:34 <fmarier> however, i was hoping that inaki would be here
09:17:00 <rkabalin_> #action fmarier email 38 people to ask lisence permissions
09:17:12 <fmarier> because based on his last comment, i'm not sure whether he agrees or is angry about the proposal
09:17:23 <richardm> i think he's cool with it
09:17:32 <rkabalin_> #topic Removal of httpswwwroot (bug 646713) [Francois]
09:17:34 <fmarier> ( we are talking about https://bugs.launchpad.net/mahara/+bug/646713 )
09:18:51 <fmarier> the proposal for that bug is to get rid of https logins and encourage full https
09:18:56 <rkabalin_> as I mentioned on tracker, I agree that we should depricate httpswwwroot
09:19:16 <dobedobedoh> And since I made the original suggestion, I think you can assume that I #agree
09:19:34 <rkabalin_> fmarier: you gave a good argument why partial https implemetation is not a good idea
09:20:09 <rkabalin_> so, I guess inaki would not object
09:20:37 <fmarier> we'll have to be careful about the upgrade
09:21:00 <dobedobedoh> fmarier: Do you think it should go into 1.4?
09:21:09 <fmarier> dobedobedoh: i think so
09:21:12 <dobedobedoh> good :)
09:21:22 <fmarier> lots of sites are switching to https these days
09:21:27 <fmarier> thanks to firesheep
09:21:37 <fmarier> but we have to be careful on upgrades
09:21:53 <fmarier> if someone has set httpsroot, maybe we should refuse to do the upgrade
09:22:04 <rkabalin_> to support backward compatibility we may just make httpwwwroot = httpswwwroot
09:22:05 <dobedobedoh> Yeah - until they fix it
09:22:09 <fmarier> so that it forces them to take it out and move their httproot to https
09:22:23 <fmarier> or to forgo https entirely if they can't handle the load
09:22:24 <dobedobedoh> I doubt whether anyone has any fruity mod_rewrite rules
09:22:28 <fmarier> which apparently is not that bad
09:22:47 <fmarier> but basically the site admin needs to make a decision and we can't silently make one for them
09:23:22 <rkabalin_> true, then notification during upgrade sounds the most reasonable
09:23:46 <fmarier> yeah i'm thinking upgrade failure if httpsroot is set
09:23:51 <rkabalin_> and rejection to perform it until variable is removed
09:24:04 <fmarier> a pre-upgrade check of some sort
09:24:05 <dobedobedoh> Perhaps with a link to the appropriate wiki page?
09:24:18 <dobedobedoh> explaining ratinale
09:24:22 <fmarier> dobedobedoh: or a link to the bug tracker?
09:24:31 <rkabalin_> or both
09:24:33 <dobedobedoh> Either -- whichever is most static
09:24:58 <rkabalin_> bug tracker link cold be on wiki page
09:25:17 <fmarier> "HTTPS logins have been deprecated, you need to remove the httpswwwroot variable and switch your wwwroot to http."
09:25:41 <fmarier> "See [link to bug tracker] for more details on why this was changed."
09:26:11 <dobedobedoh> There are also quite a few forum threads
09:26:41 <rkabalin_> and also mention that https can be used for entire site instead
09:26:52 <dobedobedoh> And that we recommend it?
09:27:23 <rkabalin_> perhaps
09:27:41 <dobedobedoh> I guess this is all really more for the implementation though than for discussion here
09:27:50 <rkabalin_> true
09:28:38 <rkabalin_> fmarier: I guess will you take that bug then
09:28:52 <fmarier> ok, i've got a start of a wiki page here: http://wiki.mahara.org/Release_Notes/1.4.0/Removal_of_httpswwwroot
09:29:19 <fmarier> feel free to add anything you think is appropriate
09:29:29 <fmarier> like the forum links that dobedobedoh mentioned
09:29:50 <rkabalin_> #info httpswwwroot removal discussion: http://wiki.mahara.org/Release_Notes/1.4.0/Removal_of_httpswwwroot
09:30:57 <rkabalin_> do we need an action to return to this topic next time?
09:31:07 <fmarier> no, there's a bug for it
09:31:10 <fmarier> i'm updating the tracker
09:31:17 <rkabalin_> ok
09:31:35 <rkabalin_> let's move to the next topic then?
09:32:15 <fmarier> done: https://bugs.launchpad.net/mahara/+bug/646713
09:32:35 <fmarier> dobedobedoh: if you could add the forum thread you know of to the wiki, that would be awesome
09:32:44 <rkabalin_> thanks fmarier
09:32:51 <dobedobedoh> fmarier: Will do
09:33:22 <rkabalin_> #topic Leap2A evaluation benchmark research [Kristina]
09:33:25 <anitsirk> #info I was asked to participate in an interview for the VET E-portfolios Leap2A Specification Evaluation Research performed by the Australian Flexible Learning Framework
09:33:36 <anitsirk> the key questions are:
09:33:36 <anitsirk> How effective is the Leap 2A specification in enabling the migration of e-portfolio content between different e-portfolio systems?
09:33:37 <anitsirk> What work is required to improve the portability of e-portfolio user content between different e-portfolio systems?
09:33:57 <anitsirk> the e-portfolio systems looked at in particular are pebblepad and mahara
09:34:40 <anitsirk> if you have been involved in any conversions, please let me know and i think they can invite you to a skype interview. i have not been involved in such a conversion and thus can't provide that much info for this item point
09:35:23 <anitsirk> or also let me know if you are actively working on expanding leap2a support for mahara, have ideas how to improve it, what to include in a benchmark etc.
09:35:53 <anitsirk> anyone?
09:36:18 <fmarier> anitsirk: it's too bad that Mjollnir` isn't here
09:36:23 <richardm> well pebblepad imports suck, there's lots to be done to improve it
09:36:32 <anitsirk> fmarier: just thinking the same
09:36:43 <dobedobedoh> anitsirk: One suggestion that I discussed with Mjollnir` a while back was adding theme support to exports/imports (only naming the theme, not actually importing/exporting it)
09:36:48 <anitsirk> going to send her an email
09:36:56 <dobedobedoh> But that's more mahara -> mahara
09:37:17 <anitsirk> yeah. they were interested in moving between different systems
09:37:22 <Mjollnir`> hello?
09:37:24 <richardm> I think getting their webfolio things to import as mahara views is much higher priority
09:37:33 <anitsirk> hi Mjollnir`
09:37:39 * Mjollnir` is sort of here :)
09:37:40 <anitsirk> were were just talking about leap2a
09:37:50 <rkabalin_> Hello Mjollnir
09:38:20 * fmarier waves at Mjollnir`
09:38:33 <anitsirk> were it possible that i gave the australian flexbile learning framework your email so that they can invite you to an interview re leap2a, benchmarking, improvements, future plans, working between pebblepad and mahara etc.?
09:38:40 <richardm> Hi Mjollnir`!
09:39:16 <Mjollnir`> anitsirk: i already got that email a week or so ago
09:39:19 <Mjollnir`> if it's the same one
09:39:31 <anitsirk> Mjollnir`: yeah. most likely
09:39:56 <Mjollnir`> 15 march, subject: Participating in research to establish a Leap2A evaluation benchmark
09:40:02 <anitsirk> sent by Allison Miller and Dennis is conducting the interviews
09:40:03 <Mjollnir`> i didn't reply :(
09:40:18 <anitsirk> were it possible, Mjollnir` as you are the leap2a expert?
09:40:33 <anitsirk> i think they just started the interviews.
09:41:04 <anitsirk> deadline for replying if you want to participate, Mjollnir` is friday, the 25th :-)
09:41:17 <Mjollnir`> it's a bit difficult. i'm currently not employed by anyone doing any elearning work and am going to be probably making a complete professional shift...
09:41:27 <Mjollnir`> not sure it's sustainable for mahara that i continue to be the leap2a entry point really
09:42:49 <anitsirk> betretene stille...
09:43:37 <anitsirk> [sorry. couldn't find an english translation]
09:43:40 * Mjollnir` blinks
09:43:41 <fmarier> so our two leap2a experts are Mjollnir` and waawaamilk :)
09:43:50 <fmarier> anitsirk: http://translate.google.com/#auto|en|betretene stille
09:43:52 <rkabalin_> we probaly should think who may start lookign after leap2a to take that responsibilities from Mjollnir`
09:44:01 <Mjollnir`> well i mean, i'm still here and can help
09:44:06 <anzeljg> #me will have to leave...
09:44:07 <Mjollnir`> but it would be good to handover probably yeah
09:44:15 * anzeljg will have toleave...
09:44:17 <Mjollnir`> it would be best if it was a uk person probably
09:44:20 <anzeljg> bye
09:44:31 <anitsirk> fmarier: i guess you could say that if you say that in english
09:44:32 <rkabalin_> bye anzeljg
09:44:38 <anitsirk> bye anzeljg
09:44:51 <fmarier> Mjollnir`:  a uk person like lamiette? ;-)
09:44:55 <anitsirk> Mjollnir`: why?
09:44:57 <dobedobedoh> bye
09:45:19 <anitsirk> because the "founders" (?) are there?
09:48:06 <fmarier> well, i guess we need to keep this leap handover in mind and think about it some more
09:48:23 <rkabalin_> #agree
09:48:25 <fmarier> thanks Mjollnir` for bringing that up and offering your help during the transition
09:49:40 <rkabalin_> I guess Mjollnir` has gone or typing something large
09:49:41 <anitsirk> shall we move on?
09:49:44 <fmarier> let's move to the next item
09:49:51 <fmarier> we're almost done!
09:49:58 <rkabalin_> #topic Chair Duties wiki page [Francois]
09:50:06 <anitsirk> looks good :-)
09:50:09 <rkabalin_> I agree, we have to document it
09:50:14 <dobedobedoh> I've added some suggestions
09:50:36 <fmarier> so i've started, but maybe the last two chairs could fill in the other bits?
09:50:51 <fmarier> and a link to the meetbot docs I guess
09:51:03 <rkabalin_> probaly it should include useful command and talk examples
09:51:09 <anitsirk> yes, i can add a couple of things
09:51:20 <anitsirk> there are good ones in the meetbot manual
09:51:22 * fmarier volunteers to chair the next meeting if others can volunteer to fill in the wiki page :)
09:51:26 <dobedobedoh> heh
09:51:41 <dobedobedoh> I'll add some notes from my experience
09:51:48 <anitsirk> fmarier: great :-)
09:51:59 <dobedobedoh> One thing we shoudl probably use more of is #time
09:52:00 <dobedobedoh> #time
09:52:09 <dobedobedoh> Hmmm -- probably only works for the chair then
09:52:19 <rkabalin_> #action past chairs to fill in http://wiki.mahara.org/Developer_Area/Developer_Meetings/Chair_Duties
09:52:37 <rkabalin_> #time
09:52:44 <dobedobedoh> nope -- just me misreadin ghow to use it
09:52:54 <dobedobedoh> Anyway, I'll investigate some of the other useful commands
09:53:29 <rkabalin_> #info more info here http://meetbot.debian.net/Manual.html
09:54:38 <anitsirk> #info fmarier volunteered to chair april 2011 dev meeting
09:54:53 <anitsirk> anything else for this agenda item?
09:54:57 <fmarier> nope
09:55:07 <rkabalin_> next meeting then
09:55:16 <rkabalin_> #topic Next meeting
09:55:51 <anitsirk> would be early in the day for nz again
09:56:08 <fmarier> daylight saving will be over in NZ
09:56:20 <dobedobedoh> A month today is Wednesday 20th/Thursday 21st April
09:56:34 <rkabalin_> that sound good to me
09:56:42 <anitsirk> +1
09:57:29 <dobedobedoh> 7:30pm GMT -- what will that be in .nz?
09:58:08 <anitsirk> 7:30 a.m.
09:58:28 <fmarier> works for me
09:58:39 <anitsirk> yep.
09:58:58 <anitsirk> richardm?
09:59:24 <Mjollnir`> here again
09:59:49 <Mjollnir`> a uk person because all the community is there and it really helps to go to meetings and such
10:00:18 <anitsirk> shall we say april 20 at 7:30 p.m. / april 21 at 7:30 a.m.? anybody in europe not ok with that date?
10:00:33 <anitsirk> Mjollnir`: good point
10:01:01 <rkabalin_> that is fine with me
10:01:56 <anitsirk> ok. then the 20th it is. it seems like the others have left.
10:01:58 <rkabalin_> #agreed next meeting april 20 at 7:30 p.m. GMT / april 21 at 7:30 a.m. NZ
10:02:18 <rkabalin_> #action rkabalin_ create next meeting item on wiki
10:02:36 <anitsirk> on to the last item on the agenda...
10:02:53 <rkabalin_> #topic Any other business
10:02:58 <anitsirk> #idea produce a quarterly online mahara newsletter that highlights achievements during that period, sites that use mahara in an exemplary way, tips for mahara, new sites that use mahara, current developments / finished developments of features etc., recent presentations -> any stories are welcome; can be in form of blog post so that the newsletter would link to them; not that they are all written by the newsletter editor ;-)
10:02:58 <anitsirk> #info projected first issue to be out around april 1
10:03:38 <dobedobedoh> Might be worth posting in the partner forum too
10:03:40 <anitsirk> ehm should have been #idea projected...
10:03:51 <fmarier> Mjollnir`: that's a very good point. i'll talk to stacey to see if she's keen
10:03:52 <anitsirk> good idea
10:03:55 <rkabalin_> or even mahara blog with this newsletter and other things
10:04:15 <anitsirk> the idea comes from the koha project.
10:04:18 <rkabalin_> I mean where this newsletter will be published
10:04:29 <anitsirk> their newsletter is published on their blog
10:04:45 <anitsirk> and it has an issn number :-)
10:04:46 <dobedobedoh> I'm guessing this is a newsletter for digital distribution, and not a pdf/print copy
10:05:00 <anitsirk> yep. no pdf / print.
10:05:12 <fmarier> rkabalin_ has a good point, we should have an RSS feed for that newsletter too
10:05:47 <anitsirk> yes. that was a given for me so that people can subscribe to it :-)
10:06:40 <rkabalin_> I guess a standard mahara blog should suit for that
10:06:47 <anitsirk> any opposing thoughts to this idea or further suggestions?
10:07:14 <anitsirk> rkabalin_: most likely as it's not going to be pretty straight forward. then the integration in the website is easy
10:07:27 <anitsirk> and we already have rss for public blogs :-)
10:07:53 <anitsirk> ehm. it is going to be pretty straight forward.
10:07:59 <richardm> anitsirk: er yep 21st is good for me; & a newsletter written by people who aren't me sounds great
10:09:00 <anitsirk> richardm: if you would help with anything git if fmarier doesn't have time, i'd gladly write the pieces ;-)
10:09:11 <rkabalin_> #agreed we should produce quarterly online mahara newsletter in a form of blog
10:09:53 <anitsirk> i'll be soliciting for content then :-)
10:10:27 <anitsirk> that's all from me.
10:10:47 <fmarier> does anybody else have "other business" ?
10:11:20 <fmarier> (not me)
10:11:33 <rkabalin_> then the meeting is over I guess
10:11:49 <anitsirk> thanks for chairing, rkabalin_
10:11:58 <rkabalin_> #endmeeting