#mahara-dev: 68th Mahara Developer Meeting on 6 November 2018

Meeting started by robertl at 23:27:09 UTC (full logs).

Meeting summary

    1. Robert Lyon, Catalyst IT, Wellington (robertl, 23:27:09)
    2. Kristina Hoeppner, Catalyst IT, Wellington (robertl, 23:27:09)
    3. Cecilia Vela-Gurovic, Catalyst IT, Wellington (robertl, 23:27:09)
    4. Judith Schittenkopf, Teacher Training College Thurgau, Switzerland (robertl, 23:27:09)
    5. Rebecca Blundell, Catalyst IT, Wellington (robertl, 23:27:10)
    6. apologies from Australia. (robertl, 23:27:11)

  1. 18.10 release (Kristina) (robertl, 23:27:13)
    1. Congratulations to everyone for a fantastic release of Mahara 18.10. It was a very big release with lots of new features. (robertl, 23:27:17)
    2. https://mahara.org/interaction/forum/topic.php?id=8365 (robertl, 23:27:20)
    3. We now support PHP 7.2 and thus people can move to Ubuntu 18.04. (robertl, 23:27:22)
    4. A shortish video (ca. 13 minutes) is available (robertl, 23:27:24)
    5. https://www.youtube.com/watch?v=8kH3t0vbxMA (robertl, 23:27:26)
    6. A longer video (25 minutes) shows highlighted features in action (robertl, 23:27:28)
    7. https://www.youtube.com/watch?v=AZkpBxpK1Gs (robertl, 23:27:30)
    8. robertl: Quite impressive how much stuff we got into the 18.10 release and have so many people work on it. Sometimes it was a bit of a juggle, but we made it happen. (robertl, 23:27:32)
    9. Judith: We have Mahara 18.10 in test and are looker more into it. We are particularly interested in assessment features. Lecturers want to comment on individual artefacts instead of just at the bottom of the page. (robertl, 23:27:35)
    10. Kristina: Judith, look into allowing comments on the artefacts as that will then give them the chance to comment directly on the artefacts rather than the page. Let us know if that is not enough. (robertl, 23:27:38)
    11. IDEA: Kristina: When allowing comments when sharing a page, use that setting for the artefacts on the pages as well rather than just for the entire page. Wishlist item created. (robertl, 23:27:41)
    12. https://bugs.launchpad.net/mahara/+bug/1801881 (robertl, 23:27:44)

  2. Ideas and plans for 19.04 (Kristina) (robertl, 23:27:48)
    1. Robert: Focus on look and feel on certain parts of Mahara -> make it feel more modern and exciting (robertl, 23:27:50)
    2. Kristina: Mahara pages can be very analytical and certain elements cannot be removed / removed easily having less flexibility in a modern look of a page. Today, Evonne, our designer, and I started to look at what we can do there. She's going to make an initial proposal to discuss next week and use as basis for further explorations. (robertl, 23:27:53)
    3. IDEA: Hide "administrative" elements so they don't clutter the page, e.g. links to artefact comments, the details page, and make the page title more prominent and less tide to the buttons so that we can achieve a modern look and also start looking more into having a background behind the page title for example. (robertl, 23:27:57)
    4. The difficulty is that we can't just use hover effects, but need to keep mobile in mind (no hover) as well as keyboard-only use. We'll share with the community once we have an initial proposal. (robertl, 23:28:01)
    5. We are upgrading to Bootstrap 4. That is a major project, which will be progressed over summer more intensely. (robertl, 23:28:04)
    6. We will also look into possibilities of making it easier for people upgrading custom themes, but don't yet have a clear idea on what that could look like. (robertl, 23:28:07)
    7. IDEA: Move away from the current restrictive layouts to something like Gridstack for more flexibility in defining blocks as well as an easier way to change layouts. (robertl, 23:28:10)
    8. http://gridstackjs.com (robertl, 23:28:13)
    9. We will need to see how that mashes up with the above work on simplifying the page, but should have a bette handle on that next week and see how to go forward. (robertl, 23:28:17)
    10. These are the big things for the 19.04 release besides any client work that we will have coming up that we can include into Mahara core as well as community contributions. (robertl, 23:28:20)

  3. Moving bugs and wishlist items from Launchpad to Gitlab (robertl, 23:28:23)
    1. IDEA: We want to move our bugs and wishlist items from Launchpad to Gitlab in order to consolidate tools a bit and have better control over the information presented. Since we host our own Gitlab site, we can make more changes that suit the project. At some point that could also mean to use Gitlab for code review and thus having everything in fewer tools. (robertl, 23:28:25)
    2. Another reason for looking into this is to present a Mahara roadmap for each release in a better way than Launchpad would allow us and move bugs and wishlist items around better. (robertl, 23:28:30)
    3. Furthermore, Gitlab offers a more modern interface that people are also used to from Github. (robertl, 23:28:33)
    4. Robert: There is a script that we are using as basis. (robertl, 23:28:35)
    5. https://gist.github.com/fperez/835577 (robertl, 23:28:37)
    6. We can use the script to also add a line to each bug / wishlist item to say that it came from Launchpad and link to the respective Launchpad item. (robertl, 23:28:39)
    7. We are expanding on it to bring in all the things we want to keep in Gitlab. (robertl, 23:28:42)
    8. IDEA: Shall we import all Launchpad commens in one comment into Mahara instead of separate ones? That seems to be a good idea. We can retain time stamps and names of people who reported things, but could have all of that in one comment rather than needing to put everything into separate comment areas. (robertl, 23:28:44)
    9. IDEA: Use SAML SSO to authenticate. This would allow us to sha (robertl, 23:28:50)
    10. There is still more to explore, but it's looking good already. (robertl, 23:28:52)
    11. ACTION: Robert to look more into the authentication between mahara.org and git.mahara.org. (robertl, 23:28:54)
    12. ACTION: Robert to look more into migrating items from Launchpad into git.mahara.org for testing purposes so we can get a better understanding of what it'll look like in the end. (robertl, 23:28:56)

  4. Next meeting, chair, and minute taker (robertl, 23:28:59)
    1. No meeting in December as many people will be busy with holiday prep. (robertl, 23:29:01)
    2. 69th meeting on Tuesday, 22 January 2019 at 7:00 UTC (robertl, 23:29:03)
    3. https://www.timeanddate.com/worldclock/fixedtime.html?iso=20190122T07&p1=1440 (robertl, 23:29:05)
    4. Chair: Cecilia; Minute taker: Rebecca (robertl, 23:29:07)

  5. Any other business? (robertl, 23:29:11)


Meeting ended at 23:29:15 UTC (full logs).

Action items

  1. Robert to look more into the authentication between mahara.org and git.mahara.org.
  2. Robert to look more into migrating items from Launchpad into git.mahara.org for testing purposes so we can get a better understanding of what it'll look like in the end.


People present (lines said)

  1. robertl (53)
  2. mahara-meetbot (3)


Generated by MeetBot 0.1.4.