23:27:09 <robertl> #startmeeting 68th Mahara Developer Meeting on 6 November 2018
23:27:09 <mahara-meetbot> Meeting started Wed Jan 16 23:27:09 2019 UTC and is due to finish in 60 minutes.  The chair is robertl. Information about MeetBot at https://wiki.mahara.org/wiki/Developer_Area/Developer_Meetings/Chair_Duties#Meetbot_commands.
23:27:09 <mahara-meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
23:27:09 <mahara-meetbot> The meeting name has been set to '68th_mahara_developer_meeting_on_6_november_2018'
23:27:09 <robertl> #info Robert Lyon, Catalyst IT, Wellington
23:27:09 <robertl> #info Kristina Hoeppner, Catalyst IT, Wellington
23:27:09 <robertl> #info Cecilia Vela-Gurovic, Catalyst IT, Wellington
23:27:09 <robertl> #info Judith Schittenkopf, Teacher Training College Thurgau, Switzerland
23:27:10 <robertl> #info Rebecca Blundell, Catalyst IT, Wellington
23:27:11 <robertl> #info apologies from Australia.
23:27:13 <robertl> #topic 18.10 release (Kristina)
23:27:17 <robertl> #info Congratulations to everyone for a fantastic release of Mahara 18.10. It was a very big release with lots of new features.
23:27:20 <robertl> https://mahara.org/interaction/forum/topic.php?id=8365
23:27:22 <robertl> #info We now support PHP 7.2 and thus people can move to Ubuntu 18.04.
23:27:24 <robertl> #info A shortish video (ca. 13 minutes) is available
23:27:26 <robertl> https://www.youtube.com/watch?v=8kH3t0vbxMA
23:27:28 <robertl> #info A longer video (25 minutes) shows highlighted features in action
23:27:30 <robertl> https://www.youtube.com/watch?v=AZkpBxpK1Gs
23:27:32 <robertl> #info robertl: Quite impressive how much stuff we got into the 18.10 release and have so many people work on it. Sometimes it was a bit of a juggle, but we made it happen.
23:27:35 <robertl> #info Judith: We have Mahara 18.10 in test and are looker more into it. We are particularly interested in assessment features. Lecturers want to comment on individual artefacts instead of just at the bottom of the page.
23:27:38 <robertl> #info Kristina: Judith, look into allowing comments on the artefacts as that will then give them the chance to comment directly on the artefacts rather than the page. Let us know if that is not enough.
23:27:41 <robertl> #idea Kristina: When allowing comments when sharing a page, use that setting for the artefacts on the pages as well rather than just for the entire page. Wishlist item created.
23:27:44 <robertl> https://bugs.launchpad.net/mahara/+bug/1801881
23:27:48 <robertl> #topic Ideas and plans for 19.04 (Kristina)
23:27:50 <robertl> #info Robert: Focus on look and feel on certain parts of Mahara -> make it feel more modern and exciting
23:27:53 <robertl> #info Kristina: Mahara pages can be very analytical and certain elements cannot be removed / removed easily having less flexibility in a modern look of a page. Today, Evonne, our designer, and I started to look at what we can do there. She's going to make an initial proposal to discuss next week and use as basis for further explorations.
23:27:57 <robertl> #idea Hide "administrative" elements so they don't clutter the page, e.g. links to artefact comments, the details page, and make the page title more prominent and less tide to the buttons so that we can achieve a modern look and also start looking more into having a background behind the page title for example.
23:28:01 <robertl> #info The difficulty is that we can't just use hover effects, but need to keep mobile in mind (no hover) as well as keyboard-only use. We'll share with the community once we have an initial proposal.
23:28:04 <robertl> #info We are upgrading to Bootstrap 4. That is a major project, which will be progressed over summer more intensely.
23:28:07 <robertl> #info We will also look into possibilities of making it easier for people upgrading custom themes, but don't yet have a clear idea on what that could look like.
23:28:10 <robertl> #idea Move away from the current restrictive layouts to something like Gridstack for more flexibility in defining blocks as well as an easier way to change layouts.
23:28:13 <robertl> http://gridstackjs.com
23:28:17 <robertl> #info We will need to see how that mashes up with the above work on simplifying the page, but should have a bette handle on that next week and see how to go forward.
23:28:20 <robertl> #info These are the big things for the 19.04 release besides any client work that we will have coming up that we can include into Mahara core as well as community contributions.
23:28:23 <robertl> #topic Moving bugs and wishlist items from Launchpad to Gitlab
23:28:25 <robertl> #idea We want to move our bugs and wishlist items from Launchpad to Gitlab in order to consolidate tools a bit and have better control over the information presented. Since we host our own Gitlab site, we can make more changes that suit the project. At some point that could also mean to use Gitlab for code review and thus having everything in fewer tools.
23:28:30 <robertl> #info Another reason for looking into this is to present a Mahara roadmap for each release in a better way than Launchpad would allow us and move bugs and wishlist items around better.
23:28:33 <robertl> #info Furthermore, Gitlab offers a more modern interface that people are also used to from Github.
23:28:35 <robertl> #info Robert: There is a script that we are using as basis.
23:28:37 <robertl> https://gist.github.com/fperez/835577
23:28:39 <robertl> #info We can use the script to also add a line to each bug / wishlist item to say that it came from Launchpad and link to the respective Launchpad item.
23:28:42 <robertl> #info We are expanding on it to bring in all the things we want to keep in Gitlab.
23:28:44 <robertl> #idea Shall we import all Launchpad commens in one comment into Mahara instead of separate ones? That seems to be a good idea. We can retain time stamps and names of people who reported things, but could have all of that in one comment rather than needing to put everything into separate comment areas.
23:28:50 <robertl> #idea Use SAML SSO to authenticate. This would allow us to sha
23:28:52 <robertl> #info There is still more to explore, but it's looking good already.
23:28:54 <robertl> #action Robert to look more into the authentication between mahara.org and git.mahara.org.
23:28:56 <robertl> #action Robert to look more into migrating items from Launchpad into git.mahara.org for testing purposes so we can get a better understanding of what it'll look like in the end.
23:28:59 <robertl> #topic Next meeting, chair, and minute taker
23:29:01 <robertl> #info No meeting in December as many people will be busy with holiday prep.
23:29:03 <robertl> #info 69th meeting on Tuesday, 22 January 2019 at 7:00 UTC
23:29:05 <robertl> https://www.timeanddate.com/worldclock/fixedtime.html?iso=20190122T07&p1=1440
23:29:07 <robertl> #info Chair: Cecilia; Minute taker: Rebecca
23:29:09 <robertl> Thank you.
23:29:11 <robertl> #topic Any other business?
23:29:13 <robertl> No.
23:29:15 <robertl> #endmeeting