#mahara-dev: 67th Mahara developer meeting

Meeting started by rebeccablundell at 22:35:50 UTC (full logs).

Meeting summary

    1. Rebecca Blundell @ Catalyst IT in Wellington (rebeccablundell, 22:36:05)
    2. Kristina Hoeppner, Catalyst NZ, Wellington, NZ (rebeccablundell, 22:36:05)
    3. Cecilia Vela Gurovic, Catalyst NZ, Wellington, NZ (rebeccablundell, 22:36:06)
    4. Robert Lyon, Catalyst in Wellington, NZ (rebeccablundell, 22:36:06)
    5. Gregor Pirker, Danube University Krems, Austria (rebeccablundell, 22:36:06)
    6. Ghada El-Zoghbi, Catalyst AU, Sydney, Australia (rebeccablundell, 22:36:06)

  1. 18.10 release and feature freeze (rebeccablundell, 22:36:29)
    1. Rebecca's PHP7.2 changes are still in progress, with web services still to be upgraded. (rebeccablundell, 22:36:30)
    2. We already have a number of new features for Mahara 18.10. (rebeccablundell, 22:36:30)
    3. https://bugs.launchpad.net/mahara/+bugs?field.milestone%3Alist=85083&field.tag=nominatedfeature (rebeccablundell, 22:36:30)
    4. Some great new features are getting in for tags, for example institution tags to have official tags and being able to fill a portfolio page with content for a tag or more. (rebeccablundell, 22:36:30)
    5. We are still working on getting the assignment submission via LTI integrated, and Matt has been making good progress on it. We are planning on getting all of https://wiki.mahara.org/wiki/Developer_Area/Specifications_in_Development/MNet_replacement/LTI_implementation#Proposal_for_initial_implementation in for October 2018. (rebeccablundell, 22:36:31)
    6. There are a number of other features still in progress that we'll see over the next couple of weeks if we can get them ready for 18.10 or not. (rebeccablundell, 22:36:39)
    7. We will work on integrating LTI into the Moodle assignment plugin for a client at Catalyst NZ later this year (not for 18.10). That'll be a good proof of concept to see how that works. (rebeccablundell, 22:36:39)
    8. The plan is to be in design freeze / feature freeze by the end of August / early September. (rebeccablundell, 22:36:41)
    9. Cecilia's jquery upgrades are being merged into master. Kristina would like them to be included in the 18.10 release. It's been a major change that will be good to have in before Bootstrap 4. (rebeccablundell, 22:36:43)
    10. Liam is working on upgrading to Bootstrap 4 and has made significant progress, but is having issues with different themes that still need to be resolved. (rebeccablundell, 22:36:50)
    11. IDEA: Will there be a migration tool for existing custom themes to make the upgrade easier? (rebeccablundell, 22:36:53)
    12. Since we are still in the middle of the upgrade to Bootstrap 4, we do not yet know how difficult it will be to upgrade custom themes and will take a look at that later on to figure out if it were possible to write a script to do some of the migration work. (rebeccablundell, 22:36:55)
    13. Bootstrap 4 is planned to arrive in Mahara 19.04. (rebeccablundell, 22:36:59)

  2. Remove triggers from Mahara - in particular Elasticsearch DB triggers (rebeccablundell, 22:37:01)
    1. Ghada would like to change away from using DB triggers in Mahara. (rebeccablundell, 22:37:03)
    2. Robert is in favour of it. (rebeccablundell, 22:37:05)
    3. Mahara events could be used instead of triggers. Events can be filtered depending on what is happening, e.g. to avoid doing certain things during an upgrade. (rebeccablundell, 22:37:07)
    4. Ghada has started a discussion in the developer forum for any feedback or suggestions on removing triggers: (rebeccablundell, 22:37:10)
    5. https://mahara.org/interaction/forum/topic.php?id=8324 (rebeccablundell, 22:37:13)

  3. Gregor reports on issues upgrading from 17.04 to 18.04 (rebeccablundell, 22:37:17)
    1. When upgrading using the command line, the permissions on some folders, e.g. Dwoo, are changed, leading to the site being unavailable. (rebeccablundell, 22:37:19)
    2. When upgrading from the command line, the web user should be used, i.e. sudo -u www-data php admin/cli/upgrade.php (rebeccablundell, 22:37:22)
    3. Gregor also had some issues with the image blocks in which the images are not being sized correctly after the upgrade. It could be to do with css. He is using the generated cssfor theming rather than building his custom theme in SASS and then generating it. He is going to check his site in raw / default and see if the same issue occurs there to narrow down the potential area. (rebeccablundell, 22:37:25)
    4. ACTION: Kristina will follow up with Gregor later in the month to figure out why screen share wasn't working for him during the meeting. (rebeccablundell, 22:37:30)

  4. Next meeting and chair (rebeccablundell, 22:37:33)
    1. IDEA: Since changing to audio meetings, it is hard to be the chair and also take minutes. Should we have a chair and a minute taker? (rebeccablundell, 22:37:35)
    2. Next time we will have a separate chair and minute taker. (rebeccablundell, 22:37:38)
    3. The next meeting will take place on 26 September 2018 at 7:00 UTC. Robert has volunteered to be chair and Rebecca will take minutes. (rebeccablundell, 22:37:40)
    4. https://www.timeanddate.com/worldclock/fixedtime.html?iso=20180926T07&p1=1440 (rebeccablundell, 22:37:43)


Meeting ended at 22:37:47 UTC (full logs).

Action items

  1. Kristina will follow up with Gregor later in the month to figure out why screen share wasn't working for him during the meeting.


People present (lines said)

  1. rebeccablundell (38)
  2. mahara-meetbot (3)


Generated by MeetBot 0.1.4.