22:35:50 <rebeccablundell> #startmeeting 67th Mahara developer meeting
22:35:50 <mahara-meetbot> Meeting started Wed Aug  8 22:35:50 2018 UTC and is due to finish in 60 minutes.  The chair is rebeccablundell. Information about MeetBot at https://wiki.mahara.org/wiki/Developer_Area/Developer_Meetings/Chair_Duties#Meetbot_commands.
22:35:50 <mahara-meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
22:35:50 <mahara-meetbot> The meeting name has been set to '67th_mahara_developer_meeting'
22:36:05 <rebeccablundell> #info Rebecca Blundell @ Catalyst IT in Wellington
22:36:05 <rebeccablundell> #info Kristina Hoeppner, Catalyst NZ, Wellington, NZ
22:36:06 <rebeccablundell> #info Cecilia Vela Gurovic, Catalyst NZ, Wellington, NZ
22:36:06 <rebeccablundell> #info Robert Lyon, Catalyst in Wellington, NZ
22:36:06 <rebeccablundell> #info Gregor Pirker, Danube University Krems, Austria
22:36:06 <rebeccablundell> #info Ghada El-Zoghbi, Catalyst AU, Sydney, Australia
22:36:29 <rebeccablundell> #topic 18.10 release and feature freeze
22:36:30 <rebeccablundell> #info Rebecca's PHP7.2 changes are still in progress, with web services still to be upgraded.
22:36:30 <rebeccablundell> #info We already have a number of new features for Mahara 18.10.
22:36:30 <rebeccablundell> https://bugs.launchpad.net/mahara/+bugs?field.milestone%3Alist=85083&field.tag=nominatedfeature
22:36:30 <rebeccablundell> #info Some great new features are getting in for tags, for example institution tags to have official tags and being able to fill a portfolio page with content for a tag or more.
22:36:31 <rebeccablundell> #info We are still working on getting the assignment submission via LTI integrated, and Matt has been making good progress on it. We are planning on getting all of https://wiki.mahara.org/wiki/Developer_Area/Specifications_in_Development/MNet_replacement/LTI_implementation#Proposal_for_initial_implementation in for October 2018.
22:36:39 <rebeccablundell> #info There are a number of other features still in progress that we'll see over the next couple of weeks if we can get them ready for 18.10 or not.
22:36:39 <rebeccablundell> #info We will work on integrating LTI into the Moodle assignment plugin for a client at Catalyst NZ later this year (not for 18.10). That'll be a good proof of concept to see how that works.
22:36:41 <rebeccablundell> #info The plan is to be in design freeze / feature freeze by the end of August / early September.
22:36:43 <rebeccablundell> #info Cecilia's jquery upgrades are being merged into master. Kristina would like them to be included in the 18.10 release. It's been a major change that will be good to have in before Bootstrap 4.
22:36:50 <rebeccablundell> #info Liam is working on upgrading to Bootstrap 4 and has made significant progress, but is having issues with different themes that still need to be resolved.
22:36:53 <rebeccablundell> #idea Will there be a migration tool for existing custom themes to make the upgrade easier?
22:36:55 <rebeccablundell> #info Since we are still in the middle of the upgrade to Bootstrap 4, we do not yet know how difficult it will be to upgrade custom themes and will take a look at that later on to figure out if it were possible to write a script to do some of the migration work.
22:36:59 <rebeccablundell> #info Bootstrap 4 is planned to arrive in Mahara 19.04.
22:37:01 <rebeccablundell> #topic Remove triggers from Mahara - in particular Elasticsearch DB triggers
22:37:03 <rebeccablundell> #info Ghada would like to change away from using DB triggers in Mahara.
22:37:05 <rebeccablundell> #info Robert is in favour of it.
22:37:07 <rebeccablundell> #info Mahara events could be used instead of triggers. Events can be filtered depending on what is happening, e.g. to avoid doing certain things during an upgrade.
22:37:10 <rebeccablundell> #info Ghada has started a discussion in the developer forum for any feedback or suggestions on removing triggers:
22:37:13 <rebeccablundell> https://mahara.org/interaction/forum/topic.php?id=8324
22:37:17 <rebeccablundell> #topic Gregor reports on issues upgrading from 17.04 to 18.04
22:37:19 <rebeccablundell> #info When upgrading using the command line, the permissions on some folders, e.g. Dwoo, are changed, leading to the site being unavailable.
22:37:22 <rebeccablundell> #info When upgrading from the command line, the web user should be used, i.e. sudo -u www-data php admin/cli/upgrade.php
22:37:25 <rebeccablundell> #info Gregor also had some issues with the image blocks in which the images are  not being sized correctly after the upgrade. It could be to do with css. He is using the generated cssfor theming rather than building his custom theme in SASS and then generating it. He is going to check his site in raw / default and see if the same issue occurs there to narrow down the potential area.
22:37:30 <rebeccablundell> #action Kristina will follow up with Gregor later in the month  to figure out why screen share wasn't working for him during the meeting.
22:37:33 <rebeccablundell> #topic Next meeting and chair
22:37:35 <rebeccablundell> #idea Since changing to audio meetings, it is hard to be the chair and also take minutes. Should we have a chair and a minute taker?
22:37:38 <rebeccablundell> #info Next time we will have a separate chair and minute taker.
22:37:40 <rebeccablundell> #info The next meeting will take place on 26 September 2018 at 7:00 UTC. Robert has volunteered to be chair and Rebecca will take minutes.
22:37:43 <rebeccablundell> https://www.timeanddate.com/worldclock/fixedtime.html?iso=20180926T07&p1=1440
22:37:47 <rebeccablundell> #endmeeting