#mahara-dev: 62nd Mahara Developer Meeting

Meeting started by bob at 06:49:42 UTC (full logs).

Meeting summary

    1. robertl_ is Robert Lyon, Catalyst in Wellington, New Zealand (bob, 06:49:55)
    2. ghada is Ghada El-Zoghbi, Catalyst IT in Sydney, Australia (ghada, 06:50:10)
    3. cecilia is Cecilia Vela, Catalyst in Wellington, New Zealand (cecilia, 06:50:22)
    4. anitsirk is Kristina Hoeppner at Catalyst in Wellington, NZ (anitsirk, 06:50:28)
    5. anzeljg is Gregor Anželj, POVSOD, developer and translator, Ljubljana, Slovenia (anzeljg, 06:51:07)

  1. dajan to get in touch with Emily Lenel and Nicolas Thorel to explain the CAS issues that they are having (bob, 06:52:14)
    1. ACTION: kristina to follow up with emily about CAS (bob, 06:53:52)

  2. Approve Cecilia Vela Gurovic as a +2 reviewer (bob, 06:54:25)
    1. https://wiki.mahara.org/wiki/User:CeciliaVG (bob, 06:54:31)
    2. knowing that we don't every get all approved devs together, i sent a mail to all beforehand and received two replies that will count into the vote as well (one was from ghada though and she won't get a second vote for shoring up ;-) ). so we'll have 3 votes in total (anitsirk, 06:56:33)
    3. ACTION: make cecilia a +2 reviewer in gerrit (bob, 06:58:57)
    4. AGREED: cecilia is a +2 reviewer with 3 votes (bob, 06:59:35)

  3. Mahara and the GDPR: initial thoughts (bob, 07:00:53)
    1. On 25 May 2018 a new and stricter privacy regulation will go into effect in Europe, the General Data Protection Regulation (GDPR). (anitsirk, 07:01:08)
    2. https://www.eugdpr.org (anitsirk, 07:01:08)
    3. We started looking into it and identified a number of areas that need changes in Mahara or that we should alert institutions to. Disclaimer though: We aren't lawyers and thus the info and discussion on mahara.org should not be considered legal advice. (anitsirk, 07:01:08)
    4. The good thing: Mahara is already pretty good in many ways and a lot of things can be handled by updated terms and conditions. There are some areas though that will need some attention. (anitsirk, 07:01:08)
    5. You can find notes and ToDo items at https://wiki.mahara.org/wiki/Developer_Area/Specifications_in_Development/GDPR_compliance (anitsirk, 07:01:09)
    6. https://mahara.org/interaction/forum/topic.php?id=8097 - discussion forum thread for the topic (anitsirk, 07:01:09)
    7. IDEA: We are aiming to make necessary changes to Mahara for the 18.04 release, which comes out in April 2018 so institutions affected can upgrade by 25 May 2018. (anitsirk, 07:01:10)
    8. if you'd like to discuss anything more, please post in the forum thread and we'll then take things over into the wiki if needed. (anitsirk, 07:24:44)
    9. https://docs.moodle.org/dev/GDPR_For_Administrators some info regards to moodle (bob, 07:25:22)

  4. New features for 18.04: S3 storage, Memcached session handling (bob, 07:27:47)
    1. Catalyst in Australia have been doing great work in getting Mahara to work with cloud storage. (anitsirk, 07:28:02)
    2. And have been helping with code review to get memcached session handling available in core (anitsirk, 07:28:13)
    3. the current cloud implementation for 18.04 relies on core code and an external plugin. so far it works for aws. (anitsirk, 07:29:07)
    4. https://github.com/catalyst/mahara-module_objectfs/blob/master/README.md (anitsirk, 07:29:18)
    5. there is a wishlist item to get cloud storage working for images as well. as they are handled differently from other artefacts, they were excluded from that first implementation (anitsirk, 07:30:02)
    6. we are also looking at getting Mahara working with redis session handling also (anitsirk, 07:30:14)
    7. this means Mahara will be flexible with more modern underlying systems and fit better with using mahara with and/or on the cloud (anitsirk, 07:31:42)

  5. Need to promote LTI to get LTI related things built in Mahara (bob, 07:38:26)
    1. bob: I feel that to make Mahara more acceptable to clients it needs to be able to connect to more platforms other than Moodle. Currently we have LTI only as an SSO but would like to have more features available on an LTI level, like assignment submission - but that is a big costly piece of work. (anitsirk, 07:39:08)
    2. IDEA: when you have client work /and or are making a feature - spend a thought about can it be done in LTI way, have LTI api etc (anitsirk, 07:41:02)

  6. Assigment submission via LTI (bob, 07:41:12)
    1. https://wiki.mahara.org/wiki/Developer_Area/Specifications_in_Development/MNet_replacement/LTI_implementation#Proposal_for_initial_implementation - is the proposal (anitsirk, 07:41:19)

  7. Next meeting and chair (bob, 07:53:07)
    1. AGREED: Next meeting is 17th Jan 2018 at https://www.timeanddate.com/worldclock/fixedtime.html?iso=20180117T07&p1=136 (bob, 07:59:58)
    2. anitsirk to be chair (bob, 08:00:55)

  8. Any other business (bob, 08:01:18)
    1. Mahara compatibility: Lately Mahara has been running into problems where systems are too new for Mahara to function on correctly, eg PHP 7.1, Elasticsearch 6.0.0 (anitsirk, 08:02:23)
    2. it would be great if you could fill in our survey and promote it amongst your network for the "Timeline" feature: https://surveys.catalyst.net.nz/index.php/324185 (anitsirk, 08:10:41)
    3. https://surveys.catalyst.net.nz/index.php/324185 (anitsirk, 08:10:42)
    4. AGREED: need to also mention max version in README (bob, 08:12:53)


Meeting ended at 08:13:51 UTC (full logs).

Action items

  1. kristina to follow up with emily about CAS
  2. make cecilia a +2 reviewer in gerrit


Action items, by person

  1. cecilia
    1. make cecilia a +2 reviewer in gerrit


People present (lines said)

  1. anitsirk (150)
  2. bob (90)
  3. ghada (78)
  4. anzeljg (37)
  5. cecilia (10)
  6. mahara-meetbot (3)


Generated by MeetBot 0.1.4.