06:49:42 <bob> #startmeeting 62nd Mahara Developer Meeting
06:49:42 <mahara-meetbot> Meeting started Thu Nov 23 06:49:42 2017 UTC and is due to finish in 60 minutes.  The chair is bob. Information about MeetBot at https://wiki.mahara.org/wiki/Developer_Area/Developer_Meetings/Chair_Duties#Meetbot_commands.
06:49:42 <mahara-meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
06:49:42 <mahara-meetbot> The meeting name has been set to '62nd_mahara_developer_meeting'
06:49:49 <bob> Hello everyone and welcome
06:49:49 <bob> Please introduce yourself with #info
06:49:55 <bob> #info robertl_ is Robert Lyon, Catalyst in Wellington, New Zealand
06:50:10 <ghada> #info ghada is Ghada El-Zoghbi, Catalyst IT in Sydney, Australia
06:50:22 <cecilia> #info cecilia is Cecilia Vela, Catalyst in Wellington, New Zealand
06:50:28 <anitsirk> #info anitsirk is Kristina Hoeppner at Catalyst in Wellington, NZ
06:51:07 <anzeljg> #info anzeljg is Gregor Anželj, POVSOD, developer and translator, Ljubljana, Slovenia
06:51:45 <bob> ok, is that everyone?
06:52:02 <bob> looks so
06:52:04 <bob> OK, looking at the agenda we begin with the unresolved topic from last meeting
06:52:14 <bob> #topic dajan to get in touch with Emily Lenel and Nicolas Thorel to explain the CAS issues that they are having
06:52:15 <bob> But again, as dajan is not here yet we will have to skip that
06:52:24 <anitsirk> dajan is not here so he can't update us on it.
06:52:33 <bob> unless anyone else can speak to it?
06:52:38 <anitsirk> i think he's pretty busy finishing up his phd right now.
06:52:54 <anitsirk> sorry. hadn't follwed up. if you like, i can send a mail to emily
06:53:13 <bob> That would be handy
06:53:21 <anitsirk> bob: turn the action item over to me then please
06:53:52 <bob> #action kristina to follow up with emily about CAS
06:54:12 <bob> is that the right way to do it?
06:54:15 <anitsirk> yup
06:54:18 <bob> cool
06:54:20 <bob> OK, so that brings us straight into the first topic for this meeting
06:54:25 <bob> #topic Approve Cecilia Vela Gurovic as a +2 reviewer
06:54:31 <bob> You can read a bit about Cecilia and her contributions so far here
06:54:31 <bob> #link https://wiki.mahara.org/wiki/User:CeciliaVG
06:54:31 <bob> If you have any questions for her feel free to ask
06:55:01 <anitsirk> to remind everyone of the voting process: Only approved devs can participate but everyone can ask cecilia questions and discuss
06:55:17 <cecilia> I'm here to answer any questions :)
06:55:24 <anitsirk> approved devs are all with +2 permissions. in today's chat we have bob and ghada who qualify
06:55:36 <anitsirk> so the majority vote of them will suffice.
06:55:51 <ghada> hi cecilia , I hope you like working on Mahara
06:55:55 <bob> Having worked with her over the year and a bit I can am happy to vote yes to giving Cecilia +2 reviewer status
06:56:12 <ghada> me too. +2
06:56:33 <anitsirk> #info knowing that we don't every get all approved devs together, i sent a mail to all beforehand and received two replies that will count into the vote as well (one was from ghada though and she won't get a second vote for shoring up ;-) ). so we'll have 3 votes in total
06:56:35 <cecilia> hi ghada, yes I've been working in Mahara for a bit more than a year and I like it
06:57:20 <ghada> good to hear cecilia
06:57:35 <anitsirk> the third vote was from jono who's had a look at cecilia's code and also votes for her to become an approved dev.
06:57:36 <anitsirk> :-)
06:57:38 <ghada> i don't really have any questions...
06:58:24 <anitsirk> although i can't vote, i've seen cecilia's code results and her implementations of bug fixes, new features and client work and think it is time she become an approved dev.
06:58:37 <bob> so is that enough votes to approve cecilia ?
06:58:41 <anitsirk> bob: yes
06:58:57 <bob> #action make cecilia a +2 reviewer in gerrit
06:59:11 <bob> I'll sort that out after the meeting
06:59:13 <anitsirk> bob: can you please also make an #agreed to record the vote
06:59:16 <bob> congrats cecilia
06:59:18 <ghada> congratulations cecilia
06:59:21 <anzeljg> congrats
06:59:27 <cecilia> Thank you everyone!
06:59:28 <anitsirk> congratulations, cecilia!
06:59:31 <cecilia> :D
06:59:35 <bob> #agreed cecilia is a +2 reviewer with 3 votes
06:59:36 <ghada> i think that means more work for you!!
06:59:44 <anzeljg> probably :)
07:00:02 <cecilia> I guess so, but happy to do it
07:00:35 <anitsirk> cecilia: :-)
07:00:50 <bob> now onto next topic
07:00:53 <bob> #topic Mahara and the GDPR: initial thoughts
07:00:54 <bob> over to you kristina
07:00:58 <anitsirk> you've done a wonderful job already. now things will just get even more interesting
07:01:07 <anitsirk> right. brace yourself. a bit of text to read. ;-)
07:01:08 <anitsirk> #info On 25 May 2018 a new and stricter privacy regulation will go into effect in Europe, the General Data Protection Regulation (GDPR).
07:01:08 <anitsirk> https://www.eugdpr.org
07:01:08 <anitsirk> Since it's a regulation, countries and institutions will need to adhere to it.
07:01:08 <anitsirk> #info We started looking into it and identified a number of areas that need changes in Mahara or that we should alert institutions to. Disclaimer though: We aren't lawyers and thus the info and discussion on mahara.org should not be considered legal advice.
07:01:08 <anitsirk> #info The good thing: Mahara is already pretty good in many ways and a lot of things can be handled by updated terms and conditions. There are some areas though that will need some attention.
07:01:09 <anitsirk> #info You can find notes and ToDo items at https://wiki.mahara.org/wiki/Developer_Area/Specifications_in_Development/GDPR_compliance
07:01:09 <anitsirk> https://mahara.org/interaction/forum/topic.php?id=8097 - discussion forum thread for the topic
07:01:10 <anitsirk> #idea We are aiming to make necessary changes to Mahara for the 18.04 release, which comes out in April 2018 so institutions affected can upgrade by 25 May 2018.
07:01:10 <anitsirk> That also bears the question whether we need to look into having the stable release available earlier than the end of April. So far nobody's said anything either way.
07:01:11 <anitsirk> Is anyone already looking into making changes to Mahara so we can coordinate our efforts a bit?
07:03:00 <anitsirk> we'll also need to make changes to the mahara.org T&C since it serves Europeans as well. So lucky us we use Mahara for it and will upgrade before the deadline. ;-)
07:03:25 <anzeljg> what's T&C?
07:03:33 <anitsirk> sorry anzeljg: terms and conditions
07:03:42 <anzeljg> ohhh... right!
07:04:15 <ghada> anitsirk - you mention in the wiki that most of the items can be dealt with in the T&C
07:04:39 <ghada> is that ok to just say to the user - well, you signed up for it...
07:04:42 <anitsirk> what i haven't looked into yet, as I wanted to get mahara underway is our other infrastructure like the wiki, gitlab, jenkins and reviews. i hope that we'll be able to cover a lot in the first instance with the T&C and some of our tools make it easy to see who's written what. as the GDPR allows for manual deletions, we don't need to automate everything
07:04:43 <ghada> so, that's the way it is
07:05:23 <anitsirk> ghada: it's a bit more complicated than that i'm afraid. but yes, institutions will need to explain why they collect certain info and that it needs to be collected to provide a service.
07:05:40 <anitsirk> in the first instance, if someone doesn't give consent to all items that need consent, they wouldn't receive an account.
07:05:42 <ghada> that's what i thought
07:06:03 <anitsirk> time will show if we can / want / need to be a bit more discerning
07:06:04 <ghada> i was just wondering about that because that's what's in the wiki - https://wiki.mahara.org/wiki/Developer_Area/Specifications_in_Development/GDPR_compliance
07:06:38 <ghada> right ...
07:06:55 <anitsirk> the GDPR doesn't explicitely talk about learning environments and thus some is up to interpretation right now.
07:07:01 <ghada> i now i've made mistakes before while posting a bug - where I added too much information about a client website for example.
07:07:18 <bob> I guess launchpad would be something to consider as people paste all manner of sensitive data into bug reports
07:07:45 <anitsirk> what it is concerned a fair bit as far as i can see is services that mine data for other purposes than the intended and that they need to make that clear and offer users that info transparently and a way forward. we don't process data automatically to profile people and base decisions on that profile.
07:08:13 <anitsirk> bob: yes, but that's not personal data in many cases and we already say to obscure any indentifying information.
07:08:54 <anitsirk> i also learned the new word "pseudonymisation". fun to figure out what it was when the definition comes only half-way through the document ;-)
07:09:00 <ghada> what about analytics
07:09:20 <ghada> piwik and google for example
07:09:38 <anitsirk> ghada: that was my fear, but right now we would still collect it and the T&C will need to mention that to the students and that they can't opt out because the uni needs it for their service to the students
07:10:07 <anitsirk> with piwik you can say "do not track" but I haven't tested if this is adhered to in a mahara instance.
07:10:14 <ghada> right. I've seen the piwik data and it's pretty anonymous
07:10:28 <ghada> i haven't tried it either anitsirk
07:10:31 <bob> and saving things to elasticsearch as well - would need to make sure when deleting things they actually go away
07:10:33 <anitsirk> you do have the ip address, but that can be shorted though then you have not clue where people are coming from.
07:10:56 <anitsirk> bob: that's still the question i think as an institution will need that data though for some processing.
07:11:23 <anitsirk> right now i would just mention it in the T&C and once people are clearer about actual use cases make adjustments.
07:11:52 <ghada> anitsirk - i'm just wondering what the penalties will be
07:11:56 <anitsirk> but it'll be good to know what happens when a user is deleted whether elasticsearch still pulls up the info or excludes it
07:12:17 <ghada> that is, if we miss something ...
07:12:23 <anitsirk> ghada: they can be quite high. but since the regulation doesn't say that the software needs to do everything, it'll be up to an institution.
07:12:37 <anzeljg> all in all i think tihis will be similar "mess" as the "cookie directive"
07:12:38 <ghada> i see
07:12:49 <anitsirk> with the "right to be forgotten" studens can demand their info is scrubbed but that can be done manually.
07:13:01 <ghada> this actually has other implications for "hosting"
07:13:17 <ghada> i.e. backups that have to be kept for x number of months for example
07:13:26 <ghada> what do we do when the student wants their data deleted
07:13:56 <ghada> but, that's not really mahara's problem
07:14:10 <ghada> it's an interesting question
07:14:10 <anitsirk> anzeljg: though more fierce as it's a regulation and not just a directive. the thing is also that countries need to make decisions first on how to deal with infringements and there is still a lot of discussion. peter from our UK office has a good understanding and he helped me sort some things when i looked into it and the end result was the wiki page as it is.
07:14:39 <anitsirk> ghada: yeah. had that question as well and that's not been fully solved as not mentioned in the GDPR.
07:14:39 <bob> I guess  if T&C says we keep data for x months only it means user will be forgotten after that time period
07:14:56 <bob> does 'being forgotten' need to be instant?
07:15:00 <anitsirk> some of the logs are also on the server and completely ourside of mahara
07:15:22 <ghada> yes, that too.
07:15:26 <anitsirk> bob: no. it can be done with some manual intervention. that just needs to be timely and people can't be asked to wait for months for a reply
07:16:12 <anitsirk> while we as software producers should support institutions, we don't need to handle everything and also can't handle everything. there are quite a few things that need to be dealt with by institutions
07:17:17 <bob> so our T&C can explain what things Mahara 'forgets' and what things it doesn't to make things clear for end user
07:17:37 <anitsirk> people are still debating and interpreting and then countries have their own rules. it'll take a bit until everything is sorted i would say. what i want to do though is that we take steps to handle our part as best as we can with what we can change and have a way forward (nice to haves) that will make life easier for institutions.
07:17:50 <anitsirk> bob: and a whole host of other things
07:18:23 <anitsirk> we can only provide a template and institutions need to make decisions on what they want to reveal and what not as the T&C are up to them.
07:18:32 <ghada> once we implement this, I think we'll need to have a document or something that says what Mahara does and how compliant it is.
07:18:39 <ghada> you know we'll get asked about this non-stop
07:18:51 <anitsirk> ghada: yeah. i'm thinking of a page like the accessiblity one on the wiki.
07:19:05 <ghada> yes, I think that's a good
07:19:36 <anitsirk> it will give people a quick overview and the confidence that they can use mahara
07:19:47 <ghada> have we created bugs for this change yet ?
07:20:07 <anitsirk> before i read the GDPR i was more concerned, but there aren't too many must dos right now.
07:20:12 <anitsirk> ghada: haven't gotten around to that yet.
07:20:13 <bob> And allow them to do 'what about ...?' in case we've missed somthing
07:20:29 <anitsirk> and also mention that it's not legal advice :-)
07:21:15 <ghada> the under age issue is interesting
07:21:16 <anitsirk> we will need to come up with our own revised T&C though for mahara.org. so i guess i'll be sweating over that with our legal advisor at some point.
07:21:49 <ghada> for primary schools, this will be an issue
07:21:52 <anitsirk> yep. right now i would say that institutions can handle that by turning off self-registration
07:22:01 <ghada> right ...
07:22:17 <anitsirk> and then it'll be up to their policies if they require parents to sign a piece of paper in addition to the kids clicking a consent box.
07:22:22 <anitsirk> or something else
07:22:43 <anzeljg> anitsirk: any idea how moodle is resolving this issue?
07:22:54 <anitsirk> i think the isolated institutions feature will also help multitenanted instances keep different age groups apart
07:22:58 <anzeljg> since it is the similar context...
07:23:18 <anitsirk> anzeljg: not sure. i think it's still being debated
07:24:44 <anitsirk> #info if you'd like to discuss anything more, please post in the forum thread and we'll then take things over into the wiki if needed.
07:25:14 <anitsirk> i'll also see to create some wishlist items, in particular the ones that we need to deal with.
07:25:22 <bob> #link https://docs.moodle.org/dev/GDPR_For_Administrators some info regards to moodle
07:25:51 <bob> one of the things I note on that page is the sharing of info to external systems via LTI for example
07:26:22 <anitsirk> oh that's helpful
07:26:49 <anitsirk> bob: yes, integrations are an interesting topic as well in regard to consent.
07:27:26 <anitsirk> shall we move on?
07:27:34 <bob> yep
07:27:40 <ghada> yes
07:27:45 <anzeljg> ok
07:27:47 <bob> #topic New features for 18.04: S3 storage, Memcached session handling
07:27:47 <bob> Catalyst in Australia have been doing great work in getting Mahara to work with cloud storage.
07:28:02 <anitsirk> #info Catalyst in Australia have been doing great work in getting Mahara to work with cloud storage.
07:28:02 <bob> And have been helping with code review to get memcached session handling available in core
07:28:13 <anitsirk> #info And have been helping with code review to get memcached session handling available in core
07:28:46 <bob> Some core changes are merged already with more stuff to come
07:29:07 <anitsirk> #info the current cloud implementation for 18.04 relies on core code and an external plugin. so far it works for aws.
07:29:18 <anitsirk> https://github.com/catalyst/mahara-module_objectfs/blob/master/README.md
07:29:52 <bob> we are also looking at getting Mahara working with redis session handling also
07:30:02 <anitsirk> #info there is a wishlist item to get cloud storage working for images as well. as they are handled differently from other artefacts, they were excluded from that first implementation
07:30:14 <anitsirk> #info we are also looking at getting Mahara working with redis session handling also
07:30:34 <bob> this means Mahara will be flexible with more modern underlying systems
07:31:12 <bob> and fit better with using mahara with and/or on the cloud
07:31:42 <anitsirk> #info this means Mahara will be flexible with more modern underlying systems and fit better with using mahara with and/or on the cloud
07:32:27 <bob> if anyone has any thoughts ideas about how to make Mahara work better with the cloud feel free to mention now
07:32:42 * bob finishes his rant
07:33:04 <ghada> It would be good if it also worked with OpenStack
07:33:07 <anzeljg> bob: would that mean some kind of merge with my cloud plugin as well?
07:33:24 <anitsirk> ghada please correct me if i'm wrong, but i think to remember that the code for object storage is written so that an openstack plugin could be written
07:33:40 <anitsirk> anzeljg: i think that is quite different
07:33:41 <ghada> I think KC, one of the developers of the objectfs plugin, said it may be just a few minor tweaks to get it to work
07:34:03 <anitsirk> the object storage code doesn't allow users to decide where they can host their content but that it is hosted on s3.
07:34:35 <anitsirk> that sounds promising, ghada, as that would be awesome for our Catalyst Cloud in NZ and others using OpenStack elsewhere.
07:34:50 <ghada> yes, i agree
07:35:21 <anitsirk> anzeljg: have you had a lot of uptake of your plugin, i.e. know who's using it? i know we installed it for a client, but they haven't taken it live yet.
07:35:26 <ghada> anzeljg - it's really to save on cost of disk space when the site is in the cloud
07:36:05 <ghada> fast disk can be expensive - in the thousands of dollars a month - if you site has lots of uploads
07:36:21 <ghada> s3 is a lot cheaper
07:36:32 <anzeljg> not really. i know some people/institutions use it, but not exact numbers
07:38:07 <ghada> anything else ?
07:38:12 <bob> any more thoughts on this?
07:38:15 <ghada> shall we move on ?
07:38:18 <bob> lets
07:38:26 <bob> #topic Need to promote LTI to get LTI related things built in Mahara
07:38:27 <anitsirk> not from my end. some other new features will be for the GDPR and other long standing items
07:38:48 <bob> I feel that to make Mahara more acceptable to clients it needs to be able to connect to more platforms other than Moodle. Currently we have LTI only as an SSO but would like to have more features available on an LTI level, like assignment submission - but that is a big costly piece of work.
07:38:49 <bob> For that to happen we need to chip away at letting clients know the benefits of LTI and how it can help them.
07:39:08 <anitsirk> #info bob: I feel that to make Mahara more acceptable to clients it needs to be able to connect to more platforms other than Moodle. Currently we have LTI only as an SSO but would like to have more features available on an LTI level, like assignment submission - but that is a big costly piece of work.
07:39:27 <bob> and one way to do that is to make small LTI compatible things
07:40:03 <anzeljg> Assigment submission via LTI is something I wanted to discuss in AOB
07:40:15 <anitsirk> anzeljg: let's do it now then as that is the topic :-)
07:40:26 <bob> so when you have client work /and or are making a feature - spend a thought about can it be done in LTI way, have LTI api etc
07:40:50 <bob> ok, sounds good, way you go anzeljg
07:41:02 <anitsirk> #idea when you have client work /and or are making a feature - spend a thought about can it be done in LTI way, have LTI api etc
07:41:12 <bob> #topic Assigment submission via LTI
07:41:19 <anitsirk> https://wiki.mahara.org/wiki/Developer_Area/Specifications_in_Development/MNet_replacement/LTI_implementation#Proposal_for_initial_implementation - is the proposal
07:41:27 <bob> anzeljg, the floor's yours
07:41:33 <anzeljg> well i have a client that want to have assigment submission from mahara to moodle
07:41:48 <anzeljg> probably via LTI, but i really have no idea at this point
07:42:19 <anzeljg> basically they have moodle and mahara set up that way that users connect to both of them via IdP
07:42:43 <anzeljg> and want to connect moodel and mahara also by allowing assignment submissions
07:43:04 <anzeljg> i've heard that you (core team) are also thinking about building that
07:43:09 <anitsirk> anzeljg: that's doable via the current MNet feature. SSO via LTI and an IdP is possible as well, but not assignment submission.
07:43:24 <anzeljg> so i want to coordinate that with you...
07:43:29 <anitsirk> we have the proposal for the LTI assignment submisson that we'd like to get into core but it's a major piece of work.
07:44:00 <anzeljg> anitsirk: i know, but because of the fear that MNet will not be supported they do not want to go downt that route...
07:44:17 <anitsirk> so far, nobody wanted to finance the whole lot. so we were thinking of having multiple parties come together and contribute so we can then build it
07:44:40 <anzeljg> i know all of that
07:44:51 <bob> good choice by client - MNet is old and clunky
07:44:52 <anitsirk> and to be honest, we shouldn't make enhancements to the current moodle plugin as that would distract from the lti work and not be future proof
07:45:08 <anzeljg> my fear is also that it is too much for me - i mean coding all that by myself
07:45:59 <anitsirk> the current proposal is over a month's work and could easily be two months. we have the capacity to do that and also the expertise having built the intial LTI implementation.
07:46:06 <anzeljg> i keep hearing that it is a major piece of work, can somebody sketch that for me in few sentences?
07:46:13 <anitsirk> just did :-)
07:46:24 <anzeljg> right...
07:46:30 <anitsirk> i've also mentioned it in the partner forum.
07:47:16 <ghada> anzeljg - also, it needs to work with not just Moodle but other LMSs - like canvas and BB
07:47:41 <anitsirk> anzeljg: we might have a couple of other interested parties (not firmed up yet). if we get these three contributing to start things off, we could begin as it seems that some also wait for others to contribute so they can be assured that it will happen. but someone needs to make a start...
07:47:44 <ghada> we can target Moodle of course
07:48:10 <anzeljg> currently that is what my client wants
07:48:12 <ghada> as a start - and work from there for other LMSs
07:48:20 <anitsirk> ghada: the proposal is a generic one
07:48:22 <anzeljg> that sounds good
07:48:33 <ghada> yes, i know it needs to be generic.
07:48:46 <anitsirk> canvas can already do more than moodle and it might mean that we'll need to create some plugins to integrate with the actual assignment in moodle
07:49:15 <anitsirk> rather than using the lti one or we build more assessment things into mahara, e.g. rubric etc.
07:49:21 <ghada> anitsirk - you mean through the LTI interface ?
07:49:39 <ghada> for canbas that is ...
07:49:49 <anitsirk> i think right now we are a bit stifled because we don't have a base LTI integration and need to get that off the ground before thinking of easier / better ways.
07:50:08 <anitsirk> ghada: canvas has LTI directly in its assignments whereas moodle doesn't
07:50:18 <ghada> ah.. i see
07:50:36 <anitsirk> but it's a customization that we can't use for other systems.
07:50:57 <anitsirk> anzeljg: if you want to get me in touch with them, we can start the conversation. it would be fantastic to get this done for 18.04
07:51:27 <anitsirk> since europeans will need to upgrade to that version and then have the functionality available which might encourage some others to make enhancements to it.
07:52:01 <anitsirk> i've seen more interest in SmartEvidence, for example, now that people moved to an instance that has it included and suspect we'll get more development requests for it in the future.
07:52:27 <anzeljg> anitsirk: let us first have the conversation about it, but after this meeting.
07:52:36 <anitsirk> anzeljg: sounds good.
07:52:52 <bob> ok shall we move on?
07:52:59 <anitsirk> yup
07:53:05 <bob> sweet
07:53:07 <bob> #topic Next meeting and chair
07:53:25 <bob> right who wants to pop into the hot seat for next time?
07:53:38 <anitsirk> bob: can we talk about the date and time first? ;-)
07:53:48 <anitsirk> happy to, but would need to know if i'm available
07:54:09 <bob> well if you are the chair you get to pick :)
07:54:13 <anitsirk> lol
07:54:17 <anzeljg> lol
07:54:23 <bob> a bonus for taking up the role
07:54:25 <anitsirk> when were you thinking
07:54:30 <ghada> January ?
07:54:31 <anzeljg> anitsirk go for it
07:54:49 <bob> January would be best
07:54:57 <anitsirk> ghada: yep. i think the various xmas parties won't leave much time in december and it's already late november anyway
07:55:09 <bob> as poeple will be too busy before then
07:55:16 <anitsirk> or on vacation
07:55:27 <anitsirk> over the summer
07:55:48 <bob> how about 11th or 18th Jan?
07:55:52 <anitsirk> 3rd week of jan? that would be two weeks before feature freeze?
07:56:17 <cecilia> sounds good to me
07:56:29 <bob> sounds fine to me
07:56:30 <ghada> so 18th ?
07:56:49 <anitsirk> 18th sounds good to me
07:56:50 <ghada> that works for me
07:56:59 <anitsirk> same time?
07:57:12 <anitsirk> anzeljg: how's it with you and teaching?
07:57:20 <anzeljg> Thursdays morning don't work for me
07:57:29 <anzeljg> either wednesday of friday
07:57:42 <anitsirk> wednesday would be better for us i think
07:57:54 <bob> 17th is fine for me as well
07:57:56 <anzeljg> so 17th?
07:58:01 <ghada> 17th is fine
07:58:02 <anitsirk> wouldn't want to schedule a meeting after beer o'clock ;-)
07:58:05 <cecilia> me too
07:58:14 <anitsirk> or while AU has its
07:58:23 <anzeljg> ok :)
07:58:45 <ghada> same time works for me as well
07:58:52 <anitsirk> me too
07:59:02 <anzeljg> so https://www.timeanddate.com/worldclock/fixedtime.html?iso=20180117T07&p1=136
07:59:26 <anitsirk> looks good
07:59:58 <bob> #agreed Next meeting is 17th Jan 2018 at  https://www.timeanddate.com/worldclock/fixedtime.html?iso=20180117T07&p1=136
08:00:38 <bob> ok so anitsirk you ok to be chair?
08:00:44 <anitsirk> yep
08:00:55 <bob> #info anitsirk to be chair
08:01:10 <anitsirk> thanks for chairing today's meeting, bob.
08:01:17 <bob> umm
08:01:18 <bob> #topic Any other business
08:01:21 <ghada> yes, thanks bob
08:01:27 <anitsirk> oops. sorry.
08:01:32 <anitsirk> nothing from me
08:01:36 <ghada> me too
08:01:44 <anzeljg> no
08:01:45 <bob> I have a last minute one
08:01:46 <cecilia> nothing here
08:01:48 <bob> Mahara compatibility
08:01:59 <ghada> fire away !
08:02:05 <bob> Lately Mahara has been running into problems where systems are too new for Mahara to function on correctly, eg PHP 7.1, Elasticsearch 6.0.0
08:02:16 <bob> We have in our README file what min specs things need to be
08:02:23 <anitsirk> #info Mahara compatibility: Lately Mahara has been running into problems where systems are too new for Mahara to function on correctly, eg PHP 7.1, Elasticsearch 6.0.0
08:02:26 <bob> do we also need what max specs as well ?
08:02:39 <anitsirk> bob: in this case i would say yes since we don't yet support php 7.1
08:02:50 <ghada> do we support 7.0 ?
08:02:52 <anitsirk> if we only provide minimum, people will assume that they can go higher which won't work
08:02:54 <anitsirk> yes
08:02:55 <bob> or should we just try and fix things asap for newer versions?
08:03:12 <ghada> I'd love to have it work on 7.1
08:03:19 <ghada> but, do we have the time / resources ?
08:03:25 <anitsirk> bob: i think we'll need to fix but may not always be able to do so for supported versions as they have already been released.
08:03:37 <bob> PHP 7.0 should be supported - if you notice any problems file a bug report :)
08:03:41 <anitsirk> so supporting php 7.1 would be an 18.04 thing primarily
08:03:53 <ghada> right ..
08:03:54 <anitsirk> php 7 would have been supported since 16.10 iirc.
08:04:21 <bob> with PHP 7.1 it kinda works but there is some session problems
08:04:26 <anitsirk> bob: i thought we had excluded php 7.1 from the readme file for 17.10
08:04:27 <ghada> 16.10 ? really ... i didn't know
08:04:43 <anitsirk> oh no. it was 17.04
08:04:44 <anitsirk> sorry.
08:04:52 <ghada> ah .. ok, that makes more sense
08:05:00 <ghada> i was thinking elasticsearch would not work
08:05:06 <ghada> in 16.10
08:05:09 <ghada> with php 7
08:05:28 <bob> anitsirk, yep - I was using it as an example
08:05:34 <anitsirk> php 7 support in 16.10 was sparse, but bob and cecilia fixed heaps for 17.04
08:05:44 <ghada> bob - yes, i think we should include a max version for php
08:06:30 <bob> and now that we've got elasticsearch working version 5.x I see it fails for 6.x again
08:06:45 <ghada> oh no!!!!!!!!!!!!
08:07:07 <ghada> :-/
08:07:26 <anitsirk> that saves frustration on installer's side as they know that the shiny new server doesn't quite work yet rather than sending through error messages and failing. rather us noticing those messages and fixing them for next release.
08:07:40 <bob> so I'm working on making mahara compatible with both 5.x and 6.x
08:07:47 <anitsirk> that is too bad, bob. seems like they are making major changes again?
08:08:01 <ghada> that's so frustrating
08:08:21 <anitsirk> esp. with the fast release cycle
08:08:26 <bob> actually it's more to do with mahara code for indexing having legacy values in it that 5.x ignored
08:08:48 <bob> but 6.x says 'no, bad code'
08:09:10 <bob> it's bits and pieces left over from 1.7.x days
08:09:32 <anitsirk> ah right. code cleanup is good :-)
08:10:03 <ghada> ok... anything else ?
08:10:09 <anitsirk> yes, i actually do
08:10:20 <anitsirk> just a teeny tiny announcement.
08:10:25 <anzeljg> :)
08:10:41 <anitsirk> #info it would be great if you could fill in our survey and promote it amongst your network for the "Timeline" feature: https://surveys.catalyst.net.nz/index.php/324185
08:10:42 <anitsirk> https://surveys.catalyst.net.nz/index.php/324185
08:11:14 <anitsirk> we have a student intern who's going to do the research into this and getting some feedback from people for direction will be useful.
08:11:19 <anitsirk> that's all
08:11:54 <ghada> ok. thanks anitsirk
08:12:12 <ghada> bob - did we decide on your issue ?
08:12:29 <anitsirk> i think we did: yes to the maximum version
08:12:32 <ghada> the min / max supported versions ?
08:12:44 <ghada> it's not in the info / agreed ?
08:12:45 <anzeljg> yes to the max!
08:12:53 <bob> #agreed need to also mention max version in README
08:13:16 <bob> ok anything else from anyone?
08:13:20 <ghada> ok - excellent
08:13:25 <ghada> no, nothing from me
08:13:30 <anzeljg> no
08:13:36 <anitsirk> so if there isn't anything else, thanks again, bob, for chairing today's meeting.
08:13:39 <cecilia> no
08:13:51 <bob> #endmeeting