#mahara-dev: 60th Mahara Developer Meeting

Meeting started by anitsirk at 07:03:03 UTC (full logs).

Meeting summary

    1. anitsirk is Kristina Hoeppner, Catalyst in Wellington, NZ. (anitsirk, 07:03:18)
    2. robertl_ is Robert Lyon, Catalyst in Wellington, New Zealand (robertl_, 07:03:40)
    3. cecilia is Cecilia Vela , Catalyst in Wellington, New Zealand (cecilia, 07:03:52)
    4. ilya is Ilya Tregubov, Catalyst in Sydney, AU (ilya, 07:03:53)
    5. elazaness is Eden Lazaness, University of the Arts London, UK. (elazaness_, 07:04:16)
    6. Gregor Pirker Danube University Krems, Austria (Gregor_Pirker, 07:07:07)
    7. UAL is looking into creating plugins for Mahara to add some LMS functionality to it. (anitsirk, 07:12:29)

  1. Release of Mahara 17.04 (anitsirk, 07:15:54)
    1. We released Mahara 17.04 on 27 April 2017. (anitsirk, 07:15:59)
    2. You can find the release notes at https://mahara.org/interaction/forum/topic.php?id=7926 (anitsirk, 07:17:10)
    3. ghada is Ghada El-Zoghbi from Catalyst IT, Australia (ghada, 07:18:53)
    4. From a developer perspective, one of the biggest changes was getting rid of the old Mochikit JS. (anitsirk, 07:19:16)
    5. with the release of Mahara 17.04 we are stopping support for Mahara 15.10. it saw the last minor point release on the 26th of April. (anitsirk, 07:21:43)
    6. Mahara 15.04 will still be supported until October this year as we had extended the support. Then we are only supporting Bootstrapped releases. (anitsirk, 07:22:11)
    7. The Mahara 17.04 release has both 'new' and 'old' raw themes so one can choose which to base their theme off. For more info on what to do when you want to use drop-down menus, please see https://mahara.org/interaction/forum/topic.php?id=7925&post=31879 (I'll also add the info to the user manual). (anitsirk, 07:24:31)
    8. themes based on "old raw" would need templates changes cherry-picked (anitsirk, 07:26:52)
    9. we are not planning on supporting the old raw theme beyond 17.04 and the idea is to remove it for 17.10. we wanted to allow people to have a transition period though, hence why we kept it for 17.04 as option. (anitsirk, 07:27:46)

  2. Big projects for Mahara 17.10 (anitsirk, 07:28:01)
    1. At Catalyst, we are going to start extending the statistics area in May for the Advanced Analytics in Mahara project. (anitsirk, 07:28:10)
    2. http://aaimproject.com/ (anitsirk, 07:28:11)
    3. That'll see an increase in statistics - including over time - in the admin area. (anitsirk, 07:28:14)
    4. We are also taking on Antonella's / ETICEO's changes to have all edit screens combined into one to make the jumping between the individual areas more coherent. (anitsirk, 07:28:44)
    5. The beginnings are at https://reviews.mahara.org/7453 but Cecilia is currently working on expanding that. (anitsirk, 07:28:45)
    6. Another thing will be to look at the UX of the edit content screen in general and see how we can streamline things there and make them more intuitive. (anitsirk, 07:28:45)
    7. And not to forget, we are going to continue our work with Instructure on investigating the possibilities of extending the LTI functionality in Mahara to cover things beyond SSO. (anitsirk, 07:28:45)
    8. ACTION: dajan__ to get in touch with Emily Lenel and Nicolas Thorel to explain the CAS issues that they are having. (anitsirk, 07:46:11)

  3. Overview of the object storage functionality (anitsirk, 07:46:50)
    1. https://reviews.mahara.org/7676 (anitsirk, 07:46:57)
    2. Catalyst in Australia is developing a plugin for remote storage. it takes inspiration from the one it developed for Moodle https://github.com/catalyst/moodle-tool_objectfs (anitsirk, 07:48:04)
    3. proof of concept for remote storage is with AWS S3, but it can be expanded to be used with others, e.g. OpenStack's equivalent. (anitsirk, 07:50:27)
    4. the remote storage functionality is meant to replace parts of the internal storage and is meant for the entire mahara instance. it does not influence personal external storage like Google Drive etc. which can be added to Mahara via the cloud plugin. (anitsirk, 08:05:51)
    5. IDEA: we'd save the zip files to s3, when they need to be downloaded, they get saved to local disk - then sent to the client browser (anitsirk, 08:10:21)

  4. Next meeting and chair (anitsirk, 08:28:03)
    1. The 61st Mahara developer meeting will take place on 15 June 2017 at 7:00 UTC. Chair will be Robert Lyon. https://www.timeanddate.com/worldclock/fixedtime.html?iso=20170615T07&p1=1440 (anitsirk, 08:33:35)

  5. Any other business? (anitsirk, 08:33:43)


Meeting ended at 08:35:36 UTC (full logs).

Action items

  1. dajan__ to get in touch with Emily Lenel and Nicolas Thorel to explain the CAS issues that they are having.


Action items, by person

  1. dajan__
    1. dajan__ to get in touch with Emily Lenel and Nicolas Thorel to explain the CAS issues that they are having.


People present (lines said)

  1. anitsirk (131)
  2. robertl_ (56)
  3. ghada (49)
  4. ilya (36)
  5. dajan__ (13)
  6. elazaness_ (8)
  7. cecilia (6)
  8. Gregor_Pirker (5)
  9. mahara-meetbot (4)
  10. dajan (1)


Generated by MeetBot 0.1.4.