07:03:03 <anitsirk> #startmeeting 60th Mahara Developer Meeting
07:03:03 <mahara-meetbot> Meeting started Thu May  4 07:03:03 2017 UTC and is due to finish in 60 minutes.  The chair is anitsirk. Information about MeetBot at https://wiki.mahara.org/wiki/Developer_Area/Developer_Meetings/Chair_Duties#Meetbot_commands.
07:03:03 <mahara-meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
07:03:03 <mahara-meetbot> The meeting name has been set to '60th_mahara_developer_meeting'
07:03:13 <anitsirk> Hello everyone and welcome to the 60th Mahara developer meeting.
07:03:13 <anitsirk> Please introduce yourself with #info
07:03:18 <anitsirk> #info anitsirk is Kristina Hoeppner, Catalyst in Wellington, NZ.
07:03:40 <robertl_> #info robertl_ is Robert Lyon, Catalyst in Wellington, New Zealand
07:03:52 <cecilia> #info cecilia is Cecilia Vela , Catalyst in Wellington, New Zealand
07:03:53 <ilya> #info ilya is Ilya Tregubov, Catalyst in Sydney, AU
07:04:16 <elazaness_> #info elazaness is Eden Lazaness, University of the Arts London, UK.
07:05:02 <anitsirk> please give a big welcome to elazaness_. It's her first Mahara dev meeting (but hopefully not last :-) ).
07:05:19 <robertl_> hi elazaness_
07:05:32 <robertl_> welcome to the dev meeting
07:05:40 <elazaness_> Hi everyone :) Thank you :)
07:05:42 <ilya> hi elazaness! :)
07:05:44 <cecilia> Wellcome elazaness_ !
07:06:06 <anitsirk> elazaness_: do you want to share what your connecting is to Mahara at UAL?
07:06:34 <Gregor_Pirker> Good morning
07:06:40 <anitsirk> hi Gregor_Pirker. we are just at the introductions.
07:06:40 <Gregor_Pirker> sry for the delay
07:07:07 <Gregor_Pirker> #info Gregor Pirker Danube University Krems, Austria
07:07:27 <elazaness_> I work with the UAL Online Short Courses department and we are looking into developing plugins to add LMS functionality to Mahara
07:08:30 <robertl_> what sort of LMS functionality if I may ask?
07:09:35 <anitsirk> hello dajan. you made it. we are just at introductions. please introduce yourself with #info at the start.
07:10:36 <elazaness_> Adding variables to group settings to allow using groups as course websites. I can share pseudo code later on, but I guess it’s not that dat from what what suggested here: https://mahara.org/interaction/forum/topic.php?id=6242
07:11:36 <robertl_> ah cool
07:11:59 <robertl_> sounds like a fun thing to work on :(
07:12:03 <robertl_> sounds like a fun thing to work on :)
07:12:06 <robertl_> I meant
07:12:29 <anitsirk> #info UAL is looking into creating plugins for Mahara to add some LMS functionality to it.
07:12:50 <elazaness_> Hopefully :) we’re currently still in exploration stage
07:13:30 <anitsirk> yes. look forward to hearing more about what you are planning on doing. maybe our shiny new beginnings into LTI will help with some of that thinking so as to be able to integrate rather than having to reinvent everything.
07:14:31 <anitsirk> Since we are at the 60th developer meeting, a brief look back: We held the first dev meeting on the auspicious day of 10 November 2010 and have been at it for the past 6+ years.
07:14:54 <anitsirk> are there any questions for elazaness_?
07:15:25 <elazaness_> not yet - mostly here to listen today
07:15:53 <anitsirk> if not, let's get started with today's topics. since there was nothing left to do from last time, we'll head to:
07:15:54 <anitsirk> #topic Release of Mahara 17.04
07:15:59 <anitsirk> #info We released Mahara 17.04 on 27 April 2017.
07:16:00 <anitsirk> Thanks to everyone who had a part in this release. https://giphy.com/gifs/c1R3XcUXVWAFy
07:16:35 <anitsirk> i love what we could do for 17.04
07:17:10 <anitsirk> #info You can find the release notes at https://mahara.org/interaction/forum/topic.php?id=7926
07:17:48 <robertl_> it was great getting all the stuff in that we could - and it was nice to see new people getting commits in
07:17:51 <anitsirk> Gregor_Pirker and elazaness_: i hope you'll be able to take a closer look soon and maybe even upgrade your (test) sites to play with it.
07:18:23 <anitsirk> yes, new people like ilya. :-)
07:18:36 <anitsirk> you got your first commit in on 28 november.
07:18:51 <anitsirk> and now have a much bigger functionality proposal in review to which we'll get later on.
07:18:51 <ilya> Yeah :) thanks
07:18:53 <ghada> #info ghada is Ghada El-Zoghbi from Catalyst IT, Australia
07:19:16 <anitsirk> #info From a developer perspective, one of the biggest changes was getting rid of the old Mochikit JS.
07:19:17 <anitsirk> [insert big applause here]
07:19:23 <anitsirk> Alexey did the brunt of the work
07:19:51 <anitsirk> it was also cecilia's first full release and she got lots of contributions in.
07:19:56 <robertl_> yes, finally MochiKit is gone - all the devs rejoice
07:20:50 <anitsirk> #i made a short presentation and recording highlighting the bigger changes at https://slides.com/anitsirk/come-in-were-open-mahara-1704
07:21:43 <anitsirk> #info with the release of Mahara 17.04 we are stopping support for Mahara 15.10. it saw the last minor point release on the 26th of April.
07:22:11 <anitsirk> #info Mahara 15.04 will still be supported until October this year as we had extended the support. Then we are only supporting Bootstrapped releases.
07:22:52 <anitsirk> any questions or comments for this topic?
07:23:05 <robertl_> the current 17.04 release has both 'new' and 'old' raw themes so one can choose which to base their theme off
07:23:21 <robertl_> in case the want new or old style navigations
07:23:30 <dajan> 17.04 is fully translated into French (langpack and manual) :-)
07:23:44 <anitsirk> robertl_: good point.
07:23:49 <robertl_> but going forward we are looking to maintain the 'new' raw theme
07:24:31 <anitsirk> #info The Mahara 17.04 release has both 'new' and 'old' raw themes so one can choose which to base their theme off. For more info on what to do when you want to use drop-down menus, please see https://mahara.org/interaction/forum/topic.php?id=7925&post=31879 (I'll also add the info to the user manual).
07:24:43 <robertl_> so people sticking with 'old' raw as their theme or parent theme will need to pick across template changes from 'new' raw theme
07:24:56 <robertl_> come 17.10+
07:25:03 <anitsirk> Thank you very much for the excellent translation work, dajan, for Mahara, the manual and also Mahara Mobile (new version to come soon)
07:25:27 <anitsirk> and also many thanks to anzelgj and mits for the slovenian and japanese translations of mahara and mahara mobile
07:26:52 <anitsirk> #info themes based on "old raw" would need templates changes cherry-picked
07:27:46 <anitsirk> #info we are not planning on supporting the old raw theme beyond 17.04 and the idea is to remove it for 17.10. we wanted to allow people to have a transition period though, hence why we kept it for 17.04 as option.
07:28:00 <anitsirk> Speaking of 17.10, onto the next topic. :-)
07:28:01 <anitsirk> #topic Big projects for Mahara 17.10
07:28:10 <anitsirk> #info At Catalyst, we are going to start extending the statistics area in May for the Advanced Analytics in Mahara project.
07:28:11 <anitsirk> http://aaimproject.com/
07:28:14 <anitsirk> #info That'll see an increase in statistics - including over time - in the admin area.
07:28:44 <anitsirk> #info We are also taking on Antonella's / ETICEO's changes to have all edit screens combined into one to make the jumping between the individual areas more coherent.
07:28:45 <anitsirk> #info The beginnings are at https://reviews.mahara.org/7453 but Cecilia is currently working on expanding that.
07:28:45 <anitsirk> #info Another thing will be to look at the UX of the edit content screen in general and see how we can streamline things there and make them more intuitive.
07:28:45 <anitsirk> #info And not to forget, we are going to continue our work with Instructure on investigating the possibilities of extending the LTI functionality in Mahara to cover things beyond SSO.
07:29:36 <anitsirk> so lots of big things already in the pipeline just from our wellington team :-)
07:30:54 <anitsirk> do you have questions for any of these changes?
07:31:12 <dajan__> do you have time window to see LTI replacing totally what MNet is doing presently?
07:31:37 <anitsirk> dajan__ not yet as that depends on when we finish porting all the existing MNet functionality.
07:32:10 <anitsirk> we still need a replacement for: assignment submission and transfer of content from lms to mahara to reach basic feature parity.
07:32:36 <ghada> and the three big players we're testing with is: Moodle, Canvas, Blackboard
07:32:41 <ghada> any others?
07:32:42 <anitsirk> and then mnet would probably still need to stick around in the code base for a bit in case someone has customizations based on it
07:33:02 <anitsirk> ghada: blackboard is an ideal case but hard to get a hold of a test instance.
07:33:02 <ghada> good point anitsirk
07:33:48 <anitsirk> yes, those are the major lms. others would be great to test as well, but aren't feature much in the mahara community at the moment but are rather outliers.
07:34:17 <robertl_> if we can get moodle, canvas, blackboard doing functionality parity with Mnet that will be a huge improvement over what we've got now
07:34:30 <ghada> I wonder if we can get any willing BB clients to assist with the testing .
07:34:37 <anitsirk> canvas has some lti customizations that make assignment submission easier that aren't available in the other lms. so it'll be interesting to see how we can proceed.
07:34:40 <ghada> I keep trying but no one bites...
07:35:24 <dajan__> So about 1 to 2 years time I presume
07:35:37 <anitsirk> ghada: we've done initial testing with AUT at Mahara Hui and i'll approach them for screenshots as i haven't had any other bites either, but we'll also need to see that it's a recent version of BB
07:35:57 <ghada> good point
07:35:58 <anitsirk> dajan__ that really depends on momentum and funding.
07:36:03 <robertl_> Canvas is being proactive with getting more LTI stuff done
07:36:17 <anitsirk> moodle for example uses a differnet variable in 2.7 compared to 3.1
07:36:51 <anitsirk> i sweated a bit when my manual instructions suddenly didn't work until i realized that i was on an old moodle that will now be out of support shortly.
07:38:14 <anitsirk> and it would be nice to get as much lti work done quickly so we don't depend much on mnet anymore but can phase it out from our end and migrate people off to lti.
07:38:56 <anitsirk> there are also a couple of things that could still be improved for the SSO. for example having a parent auth and lti as child auth is not yet as smooth as with mnet.
07:40:12 <dajan__> But LTI auth overcomes problems they have in France with CAS in Moodle-Mahara integration. So it is a good think we go further with it.
07:40:13 <anitsirk> we do have a very good start though and can have any lti enabled lms connect to mahara now. robertl_ did need to allow more variables for blackboard, but that's a relatively easy change to make once we know what those variables are.
07:40:25 <anitsirk> dajan__ what are the CAS problems?
07:40:58 <robertl_> ooh, yes - what are the CAS issues
07:41:12 <robertl_> that LTI gets around
07:41:21 <dajan__> A bit too long to explain on the IRC now. But they are several posts in the forums from Emily Lenel (Rennes) and Nicolas Thorel (UIT Troyes)
07:41:42 <anitsirk> dajan__ could you briefly summarize?
07:42:04 <anitsirk> i can't see any forum post from nicolas
07:42:44 <anitsirk> and the only one from emily pertains to the cas auth plugin in general, i.e. SSO.
07:42:53 <dajan__> In short. When they have students SSO from the CASified Moodle jumping to Mahara it works well but not when external people connecting directly to Mahara. I remember the main problem was about sending messages.
07:43:21 <dajan__> But the best is being in touch with Emily and Nicolas for them to explain correctly what is their practical problems.
07:43:58 <anitsirk> dajan__ could you please ask them to state their issues in a forum post?
07:44:08 <anitsirk> you'll be seeing them in person soon. :-)
07:44:58 <dajan__> Yes at the moot/hui in June. With Martin Dougiamas as well.
07:45:04 <anitsirk> not sure if LTI would help much there as CAS is a different breed of SSO than SSO via LTI is. but it might make some other things easier
07:45:43 <anitsirk> thanks, dajan__
07:46:11 <anitsirk> #action dajan__ to get in touch with Emily Lenel and Nicolas Thorel to explain the CAS issues that they are having.
07:46:14 <dajan__> I will also see Emily Lemel later this month in Rennes
07:46:24 <dajan__> Wilco
07:46:46 <anitsirk> now I'd like to hand over to ilya for the next topic.
07:46:46 <anitsirk> Overview of the object storage functionality
07:46:50 <anitsirk> #topic Overview of the object storage functionality
07:46:55 <ilya> Hi
07:46:57 <anitsirk> https://reviews.mahara.org/7676
07:47:12 <ilya> So we are developing a plugin for remote storage for Mahara
07:47:32 <ilya> Its is based on similar for Moodle that can be found here https://github.com/catalyst/moodle-tool_objectfs
07:48:04 <anitsirk> #info Catalyst in Australia is developing a plugin for remote storage. it takes inspiration from the one it developed for Moodle https://github.com/catalyst/moodle-tool_objectfs
07:48:18 <anitsirk> and ilya is doing the dev work.
07:48:19 <ilya> I was faster !
07:48:50 <anitsirk> ilya: i'm just repeating things with #info so they make it into the minutes ;-)
07:49:06 <anitsirk> if you put #info at the beginning of your line, it'll go into the minutes directly without me repeating it
07:49:20 <robertl_> is the plugin designed for storage in certain clouds or can it be used with any?
07:49:50 * robertl_ assumes the remote storage is via a cloud
07:49:51 <ilya> Currently we only did  S3, but potentially for any
07:50:27 <anitsirk> #info proof of concept for remote storage is with AWS S3, but it can be expanded to be used with others, e.g. OpenStack's equivalent.
07:50:27 <ghada> so only aimed at AWS currently
07:51:21 <ghada> so how do you calculate quotas for users now? would an S3 file count in the quota ?
07:51:37 <ghada> or is it the same - no difference.
07:52:05 <anitsirk> and would you swap out internal storage completely for external or is it supposed to be possible to have both?
07:52:13 <ilya> both
07:52:30 <anitsirk> i assumed that it would be complete swap so we can take advantage of the cloud properties
07:52:34 <ilya> you can have different settings - i.e. if it is in remote and local, prefer remote
07:52:49 <ilya> or delete local completely and only have remote
07:53:14 <robertl_> so is the S3 storage owned by the user personally or the mahara institution?
07:53:15 <ghada> i think the local will always be required - that's where the files initially get saved before getting uploaded to s3, right?
07:54:07 <ilya> yes. But you can delete like old or big files,m you can always pull them back from remote
07:54:48 <ghada> robertl_ I think it's owned by the Mahara institution
07:54:50 <ilya> robert - it is owned by mahara, so not personally for user
07:55:21 <ghada> it's not like the other 'cloud' plugins
07:55:32 <anitsirk> ilya: could you please provide more information on your wishlist item then so we can understand it better? i thought that s3 would replace our current NFS where files are housed so we can use that storage rather than needing nfs when on a cloud server.
07:55:39 <ghada> it's another file storage area that Mahara the system can use.
07:56:11 <robertl_> ok so you'd want to make sure the user's quota is restricted in some way to make sure a user doens't fill it up with large files
07:56:29 <ilya> ok
07:57:04 <ghada> robertl_ S3 is very cheap. that was the motive behind this
07:57:16 <anitsirk> i guess it should be restricted like the current internal storage is restricted as it's just a different place / server that is used rather than - as ghada says - using your own personal google drive etc. space
07:58:16 * robertl_ thinks the danger might be people uploading gigabyte big pirated movies etc if they have too much space
07:58:21 <anitsirk> because s3 is cheaper, institutions might be willing to give much higher quotas than right now (or so high that it's not really a quota anymore)
07:58:29 <dajan__> Google Drive, DropBox: all what personal users are using to gather and store information before uploading them to Mahara.
07:58:39 <anitsirk> wouldn't we still have the restriction on the upload size maybe?
07:58:59 <robertl_> ah true - there would be that
07:59:03 <ghada> anitsirk - yes, there is still that restriction
07:59:29 <anitsirk> dajan__: that's not the type of storage for this functionality. it's more a complete replacement for internal storage so we can take advantage of cloud storage that has technical differences
07:59:38 <anitsirk> e.g. sizing and pricing
07:59:43 <ilya> Also I would like feedback what should be backed up. Like do we want resized images there at all etc
07:59:46 <ghada> dajan__ - yes. with s3, you're uploading from your hard drive to mahara. it then puts it in the cloud.
07:59:53 <anitsirk> gregor's cloud plugin would be for the google drives etc.
08:00:10 <ghada> but, the user won't know it's getting uploaded to the cloud. they won't know the difference
08:00:18 <dajan__> Is this plugin still working for Mahara 17.xx ?
08:00:36 <robertl_> ilya, I would avoid backing resized images
08:00:39 <anitsirk> ilya: what do you mean specifically? if we assume that s3 becomes the mahara storage then resized images should be kept so they don't have to be generated all the time, right?
08:00:41 <ilya> dajan - I use master branch
08:00:49 <ilya> so it works with latest Mahar
08:00:53 <anitsirk> dajan__: you mean the cloud plugin?
08:01:11 <robertl_> as things like clearing cache should remove them off the local dataroot
08:01:19 <dajan__> I mean the Gregor's Cloud plugin. Is it still working with 17.xx
08:01:28 <anitsirk> dajan__: the cloud plugin should work with 16.10. not sure if gregor already looked at it for 17.04. there shouldn't be any differences except for the navigation.
08:01:46 <ghada> good point rovertl_
08:01:53 <ghada> i mean robertl_
08:02:32 <ghada> so ilya - we wouldn't save the resized images since clearing the cache should remove them. I wouldn't want to be reaching out to the cloud every time we clear the cache
08:02:38 <dajan__> 10:00 am. Sorry I have to leave you. Will read the minutes later this afternoon. See you soon.
08:02:42 <ilya> ok
08:02:52 <anitsirk> bye dajan__
08:02:52 <robertl_> see ya dajan__
08:03:07 <cecilia> bye dajan
08:03:10 <robertl_> and resized images by their nature should be quite small
08:03:17 <ilya> true
08:03:20 <robertl_> as most of the resizing is for thumnails
08:03:28 <robertl_> thumbnails that is
08:04:07 <anitsirk> so am i understanding correctly (briefly scanning the moodle plugin's description), that s3 would only be used for certain files but not entirely replace the current mahara NFS storage?
08:04:57 * robertl_ suspecting it would be for the files in the dataroot artefact/ section - would that be right?
08:05:09 <ilya> Yes
08:05:10 <ghada> anitsirk - yes, that's correct
08:05:25 <ghada> robertl_ yes, that's right
08:05:31 <robertl_> and probably any leap2a exported files that get saved ?
08:05:47 <robertl_> as part of archiving submissions to groups
08:05:48 <ghada> not sure...
08:05:51 <anitsirk> #info the remote storage functionality is meant to replace parts of the internal storage and is meant for the entire mahara instance. it does not influence personal external storage like Google Drive etc. which can be added to Mahara via the cloud plugin.
08:05:56 <ghada> but i would think so.
08:06:09 <ghada> the archiving in particular would be very handy
08:06:18 <anitsirk> thanks for the clarification, ghada.
08:06:20 * robertl_ suspects they would be the biggest users of disk space
08:06:32 <ilya> cool - will keep inmind
08:07:07 <anitsirk> yeah, those archived submissions aren't accessed much. they could move to slower storage.
08:07:08 <robertl_> the archiving would be good as the files would be accessed rarely so fetching them slightly slower would be fine
08:07:09 <ilya> Also there certain operation only not working for S3 - like download content as zip
08:07:17 <ilya> So files need to be pulled first
08:07:58 <robertl_> that should be fine as people would expect a delay when download to zip
08:08:05 <ghada> so, what that means is we'd save the zip files to s3, when they need to be downloaded, they get saved to local disk - then sent to the client browser
08:08:12 <robertl_> ie, not an instant thing
08:08:17 <ghada> yes
08:08:17 <ilya> yes
08:09:04 <ghada> clear as mud?
08:09:09 <anitsirk> #idea When it comes to zipped files, S3 is not ideal. so we'd save the zip files to s3, when they need to be downloaded, they get saved to local disk - then sent to the client browser
08:09:11 <ghada> ;-)
08:09:47 <anitsirk> ghada: yes. if we can get more information on what we should expect that would be great to understand it better and test the correct things having the proper assumptions.
08:09:54 <ghada> Actually, it's grood for zipped files.
08:10:03 <anitsirk> #undo
08:10:03 <mahara-meetbot> Removing item from minutes: <ircmeeting.items.Idea object at 0x7f7a72a58350>
08:10:21 <anitsirk> #idea we'd save the zip files to s3, when they need to be downloaded, they get saved to local disk - then sent to the client browser
08:10:54 <anitsirk> i'll add a link to the log to the wishlist item for quick reference
08:11:25 <ghada> the pain points that we tried to alleviate with S3 is cost of traditional disk space.
08:11:40 <anitsirk> if the zipping takes longer and people can't do anything in the browser, we could offer to send a download link instead once the action is done like we do for exports when we use the export queue
08:12:22 <robertl_> and I assume S3 storage means replication of data as well
08:12:45 <ghada> well, the zipping of the data happens in a cron task. The download will be just a little bit slower but not significant.
08:13:05 <ghada> robertl_ replication - not really.
08:13:24 <ilya> its for file that are not needed urgently
08:13:26 <ghada> if they're saved to s3, they're then removed from the local mahara storage.
08:13:32 <anitsirk> currently the zipping is done automatically when you request an entire folder as the user needs to wait.
08:13:55 <ghada> anitsirk - sorry, i was talking about the archiving
08:14:11 <ghada> you are right about the leap2a
08:14:16 <anitsirk> ghada: right. yes. on cron and then availability of system resources.
08:14:42 * robertl_ was thinking in terms of cloud storage uses storage in the way that data is not lost if a physical disk gets corrupted
08:15:03 <robertl_> unlike local storage where it's all on one disk
08:16:08 <ghada> anything else?
08:16:18 <robertl_> a question, how does the system handle connection loss to S3
08:16:19 <robertl_> ?
08:16:35 <ghada> i'm not sure...
08:16:36 <robertl_> say S3 is temporarily not reachable?
08:16:45 <anitsirk> not from me. we'll probably need a bit of thinking around the edge cases and what is stored to s3 and what can't shouldn't to avoid delays.
08:16:54 <ghada> probably same as a mounted disk getting unmounted.
08:17:20 <robertl_> I'd imagine you'd still be allowed to upload things to local
08:17:22 <ilya> Umm
08:17:35 <robertl_> but not be able to see/retrieve things from S3
08:17:42 <ilya> So do you mean if file is only in remote?
08:18:17 <anitsirk> but then you have some files on local and some on s3. some you can access and others you can't. that's not transparent to the user though why that would be the case.
08:18:22 <robertl_> yep file existing only on remote would be an problem if connection went away
08:18:44 <anitsirk> robertl_ what happens right now when connection to NFs is lost?
08:19:30 * robertl_ thinking of AWS not being available due to storm a while back effecting a bunch of folks
08:19:32 <anitsirk> we'd still have the references to it in the database, but get the "access denied" message
08:19:58 <robertl_> would be better to have a placeholder image locally
08:20:06 <anitsirk> that then did affect all of the instances as mahara would then also sit on aws ;-)
08:20:12 <ilya> So you won't be acces that file, and will se exception
08:20:14 <anitsirk> not just the storage
08:20:25 <robertl_> saying 'real file temp unavailable'
08:20:32 <ghada> good point anitsirk
08:21:30 <anitsirk> would there be cases where people would have mahara on a non-cloud server but host remote files on s3? the trend seems to go to cloud for everything
08:21:47 <ghada> yes, they can do that.
08:22:00 <ilya> yep
08:22:06 <robertl_> I think as long as there some nice way to let users know that the storage is temporarily unavailable would be good
08:22:23 <ghada> i agree robertl_
08:22:35 <anitsirk> robertl_ might also want to chat with francis or matt. i know we had major problems with s3 for moodle (before the plugin that ilya mentioned) due to lots of inaccessibility. and we'll also need to take clustered environments into account
08:23:38 <ghada> i think clusters should be ok. it's the one s3 storage bucket that they all point to
08:23:39 <robertl_> ok
08:23:43 <anitsirk> not sure if it was files or more related to sessions though.
08:25:42 <anitsirk> it'll also be good to look at the test screnarios you had for moodle, ilya, so we can see which ones apply, would need changing or require adding on for mahara.
08:26:18 <ilya> ok. Sure
08:26:29 <anitsirk> thank you.
08:26:40 <anitsirk> shall we move to our most favorite topic? ;-)
08:27:02 <robertl_> I'll try and play with the patch in gerrit early next week and give a initial code review
08:27:14 <ilya> Thanks!
08:27:25 <ilya> ping me if you need info
08:27:37 <robertl_> righto
08:27:47 <anitsirk> ilya: would be great to have more info by then if you have time.
08:28:03 <anitsirk> #topic Next meeting and chair
08:28:33 <anitsirk> what about mid june, e.g. thursday 15th at the same time?
08:28:46 <anitsirk> that'll put us about 6 weeks out from feature freeze.
08:29:11 <robertl_> that time sounds ok for me
08:29:15 <cecilia> I will be back from holidays, so its good for me
08:29:26 <anitsirk> all refreshed, cecilia :-)
08:29:46 <cecilia> or really tired from the trip
08:29:50 <anitsirk> Gregor_Pirker and elazaness_: would that day and time work for you?
08:30:05 <Gregor_Pirker> that sounds also good for me :-)
08:30:13 <anitsirk> cecilia: hopefully you can relax during your trip.
08:30:13 <elazaness_> Yes, sounds good
08:30:22 <anitsirk> ilya and ghada?
08:30:39 <ghada> All of june is going to be a bit difficult for me.
08:30:48 <ghada> so, decide without me...
08:31:01 <ilya> Yes
08:31:07 <anitsirk> ok. we can always catch up some other time, ghada.
08:31:08 <ilya> sounds good
08:31:28 <anitsirk> alright then. that's one decision. now, who wants to chair?
08:31:49 <anitsirk> ghada is not available, so nobody suggest her please. ;-)
08:32:14 <ghada> oh, too bad! just my luck...
08:32:41 <ghada> :P
08:32:45 <robertl_> I'll do it
08:33:02 <anitsirk> thank you, robertl_
08:33:35 <anitsirk> #info The 61st Mahara developer meeting will take place on 15 June 2017 at 7:00 UTC. Chair will be Robert Lyon. https://www.timeanddate.com/worldclock/fixedtime.html?iso=20170615T07&p1=1440
08:33:43 <anitsirk> #topic Any other business?
08:34:23 <ghada> none from me.
08:34:28 <cecilia> no
08:34:30 <ilya> nope
08:34:44 <Gregor_Pirker> not from me
08:35:03 <elazaness_> No. Thank you everyone, see you next time
08:35:24 <ilya> see you
08:35:32 <anitsirk> Thank you very much for all the discussion today. See you in person, online and very latest at the next dev meeting.
08:35:36 <anitsirk> #endmeeting