#mahara-dev: 57th Mahara developer meeting

Meeting started by robertl_ at 07:54:19 UTC (full logs).

Meeting summary

    1. robertl_ is Robert Lyon, Catalyst in Wellington, New Zealand (robertl_, 07:54:35)
    2. anitsirk is Kristina Hoeppner, Catalyst in Wellington, NZ (anitsirk, 07:54:46)
    3. Gregor Pirker, Danube University Krems, Austria (Gregor_Pirker, 07:54:47)
    4. ghada_l is Ghada El-Zoghbi, Catalyst IT in Sydney, Australia (ghada, 07:54:53)
    5. cecilia is Cecilia Vela Gurovic, Catalyst in Wellington, New Zealand (cecilia, 07:55:34)
    6. cecilia is a new dev in the Mahara core team at Catalyst. (anitsirk, 07:56:54)

  1. Topics from previous meeting (robertl_, 07:58:46)
  2. From previous meeting: aaronw_ and robertl_ to discuss the details of how to get a build branch for Mahara releases going to support those who can't use composer. (robertl_, 07:59:04)
    1. The ssphp issue was sorted out when we realised we didn't need to install the dev/composer built version as part of the mahara infrastructure. (anitsirk, 08:00:07)
    2. We instead have the Makefile fetch, decompress, and install the stable version, which meant no need for composer. (anitsirk, 08:00:17)
    3. The 'make' command now does make css and make ssphp by default. (anitsirk, 08:00:30)
    4. The release system adds in the ssphp files before zipping up the release. (anitsirk, 08:01:07)

  3. aarow_ to update the Behat Testing setup page (robertl_, 08:02:47)
    1. progress is being made to run Behat tests in parallel in Jenkins to speed up the process esp. during crunch time. (anitsirk, 08:05:16)

  4. Mahara 16.10 release update (robertl_, 08:08:17)
    1. The Mahara 16.10 release is out. Congratulations to everyone involved!!! (anitsirk, 08:08:42)
    2. anitsirk made a short video introducing the new features. https://www.youtube.com/watch?v=d0J7RlYymQA Take a look and give us feedback about the new functionality. (anitsirk, 08:09:50)
    3. bugs 1637287, 1639096, 1636599, 1638733 were noticed and will be fixed in 16.10.1, which will be out later in the month. (anitsirk, 08:10:11)
    4. demo.mahara.org has the new features activated and will also be able to be used with mahara mobile soon. we'll need to figure out how to do the site reset safely though with a SSL cert without mixing everything up. (anitsirk, 08:11:22)
    5. so for the time being, you could use https://master.dev.mahara.org to check out Mahara Mobile on Android if you don't have your own testing site. (anitsirk, 08:12:07)

  5. Mahara Mobile update (robertl_, 08:14:48)
    1. Mahara Mobile, built using Cordova, is available in the Google Play store. (anitsirk, 08:15:11)
    2. we are working on getting it submitted to the Apple store as well. (anitsirk, 08:15:44)
    3. https://play.google.com/store/apps/details?id=org.mahara.mobile (anitsirk, 08:16:50)
    4. since Mahara Mobile is built on Cordova, we can take advantage of that framework and add features in some cases fairly easily by the looks of it. (anitsirk, 08:17:58)
    5. The cool thing about Mahara Mobile is that it works with internal auth, LDAP and SSO for logins. MNet users would have to set up the token. (anitsirk, 08:20:30)

  6. Focus for 17.04 (robertl_, 08:23:10)
    1. we already have a few new feature suggestions for 17.04. Please help test and review them. One of them is Gregor Anzelj's watchlist improvements, Gregor_Pirker (anitsirk, 08:25:53)

  7. Next meeting and chair (robertl_, 08:31:21)
    1. AGREED: Wed, 18 Jan, 0800 UTC for the next meeting: http://www.timeanddate.com/worldclock/fixedtime.html?iso=20170118T08 (robertl_, 08:36:39)
    2. AGREED: anitsirk volunteered to chair (robertl_, 08:37:30)

  8. Any other business (robertl_, 08:38:06)
    1. Mahara Hui NZ is happening in April 2017. https://maharahui.org.nz/ come along and also submit your proposals by the end of the month. (anitsirk, 08:38:48)
    2. the next Mahara newsletter will be published on 1 or 2 January 2017. Articles can be submitted until shortly before christmas. Get your thinking hats on and share what you are doing with portfolios in Mahara. (anitsirk, 08:40:57)


Meeting ended at 08:44:39 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. robertl_ (70)
  2. anitsirk (65)
  3. ghada (10)
  4. Gregor_Pirker (7)
  5. cecilia (3)
  6. mahara-meetbot (3)


Generated by MeetBot 0.1.4.