07:54:19 <robertl_> #startmeeting 57th Mahara developer meeting
07:54:19 <mahara-meetbot> Meeting started Wed Nov  9 07:54:19 2016 UTC and is due to finish in 60 minutes.  The chair is robertl_. Information about MeetBot at https://wiki.mahara.org/wiki/Developer_Area/Developer_Meetings/Chair_Duties#Meetbot_commands.
07:54:19 <mahara-meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
07:54:19 <mahara-meetbot> The meeting name has been set to '57th_mahara_developer_meeting'
07:54:26 <robertl_> Please introduce yourself
07:54:35 <robertl_> #info robertl_ is Robert Lyon, Catalyst in Wellington, New Zealand
07:54:46 <anitsirk> #info anitsirk is Kristina Hoeppner, Catalyst in Wellington, NZ
07:54:47 <Gregor_Pirker> #info Gregor Pirker, Danube University Krems, Austria
07:54:53 <ghada> #info ghada_l is Ghada El-Zoghbi, Catalyst IT in Sydney, Australia
07:55:34 <cecilia> #info cecilia is Cecilia Vela Gurovic, Catalyst in Wellington, New Zealand
07:56:01 <robertl_> That seems to be everyone
07:56:03 <anitsirk> i guess that's us
07:56:03 <robertl_> so
07:56:06 <robertl_> First, topics from previous meetings
07:56:08 <anitsirk> oh wait
07:56:21 <anitsirk> before we start, we should probably introduce cecilia :-)
07:56:22 * robertl_ waits
07:56:28 <robertl_> good point
07:56:51 <robertl_> cecilia, has joined the mahara team at catalyst
07:56:54 <anitsirk> #info cecilia is a new dev in the Mahara core team at Catalyst.
07:57:01 <anitsirk> who joined our ranks at the end of August.
07:57:25 <cecilia> Hi everybody :)
07:57:44 <anitsirk> and she already has a bunch of commits in Mahara 16.10 :-)
07:57:47 <ghada> hi cecilia! Welcome
07:57:58 <Gregor_Pirker> hi cecilia :-)
07:58:44 <robertl_> now for previous topics
07:58:46 <robertl_> #topic Topics from previous meeting
07:59:04 <robertl_> #topic From previous meeting: aaronw_ and robertl_ to discuss the details of how to get a build branch for Mahara releases going to support those who can't use composer.
07:59:22 <robertl_> This was a hold over question from earlier meetings
07:59:33 <robertl_> and the progress we have made is this
07:59:42 <robertl_> The ssphp issue was sorted out when we realised we didn't need to install the dev/composer built version as part of the mahara infrastructure.
07:59:48 <robertl_> We instead have the Makefile fetch, decompress, and install the stable version, which meant no need for composer.
07:59:54 <robertl_> The 'make' command now does make css and make ssphp by default.
08:00:07 <anitsirk> #info The ssphp issue was sorted out when we realised we didn't need to install the dev/composer built version as part of the mahara infrastructure.
08:00:08 <robertl_> So the release system the adds in the ssphp files before zipping up the release.
08:00:17 <anitsirk> #info We instead have the Makefile fetch, decompress, and install the stable version, which meant no need for composer.
08:00:30 <anitsirk> #info The 'make' command now does make css and make ssphp by default.
08:00:46 <robertl_> and so we don't need to worry about servers needing special thing
08:01:07 <anitsirk> #info The release system adds in the ssphp files before zipping up the release.
08:01:49 <anitsirk> that's great news, robertl_
08:02:00 <robertl_> Thanks to aaronw_ we can say that is all sorted now
08:02:37 <robertl_> The other topic from previous meeting was
08:02:44 <anitsirk> robertl_
08:02:47 <robertl_> #topic aarow_ to update the Behat Testing setup page
08:02:55 <anitsirk> so the makefile now has that for 16.10 already or just for 17.04?
08:03:14 <robertl_> it will be in the 16.10 and 17.04 branches
08:03:25 <anitsirk> thanks
08:04:04 <robertl_> As for the behat testing sutff - I'm not sure what aarow_ had in mind but
08:04:13 <robertl_> There is some progress being made on the Behat testing / Jenkins to parallel some of the testing to speed things up.
08:04:55 <ghada> oh that would be great.
08:05:12 <robertl_> Currently the problem with behat tests is the suite of tests takes hours to complete and so not very good when we need lots of things tested
08:05:16 <anitsirk> #info progress is being made to run Behat tests in parallel in Jenkins to speed up the process esp. during crunch time.
08:05:22 <robertl_> like when we are near a release
08:06:19 <robertl_> we've got a person in a different dept at catalyst having a look as they use gerrit/jenkins also
08:06:37 <robertl_> and have done similar things to what we need
08:06:41 <anitsirk> and he knows java :-)
08:06:54 <robertl_> so fingers crossed there will be improvements soon
08:08:11 <robertl_> So that brings us to the topics for this meeting
08:08:17 <robertl_> #topic Mahara 16.10 release update
08:08:41 <robertl_> so as you may know the 16.10 was released and generally it has gone ok
08:08:42 <anitsirk> #info The Mahara 16.10 release is out. Congratulations to everyone involved!!!
08:09:03 <robertl_> Already a few bugs were found and are being fixed for a 16.10.1 release which hopefully will be out soon
08:09:03 <robertl_> These bugs were noticed since the release: 1637287, 1639096, 1636599, 1638733
08:09:50 <anitsirk> #info anitsirk made a short video introducing the new features. https://www.youtube.com/watch?v=d0J7RlYymQA Take a look and give us feedback about the new functionality.
08:10:11 <anitsirk> #info bugs 1637287, 1639096, 1636599, 1638733 were noticed and will be fixed in 16.10.1, which will be out later in the month.
08:10:29 <robertl_> yes there is some exciting new features so please do play with them
08:10:58 <robertl_> and remember to report bugs when you find then
08:11:22 <anitsirk> #info demo.mahara.org has the new features activated and will also be able to be used with mahara mobile soon. we'll need to figure out how to do the site reset safely though with a SSL cert without mixing everything up.
08:12:07 <anitsirk> #info so for the time being, you could use https://master.dev.mahara.org to check out Mahara Mobile on Android if you don't have your own testing site.
08:12:53 <robertl_> Ah that is a good point - the mobile api stuff will need to be run under an https site
08:13:16 <anitsirk> or http if it's a dev site is fine.
08:13:16 <ghada> oh, ok. i wasn't aware of that.
08:13:26 <anitsirk> i don't think i'll ever forget that again. ;-)
08:13:33 <robertl_> which may cause issues for people who tend to run their prod sites under http
08:14:08 <anitsirk> if you are, https://letsencrypt.org/ is a good alternative to expensive certs
08:14:42 <robertl_> I guess part of this topic is
08:14:48 <robertl_> #topic  Mahara Mobile update
08:14:51 <anitsirk> yes :-)
08:15:11 <anitsirk> #info Mahara Mobile, built using Cordova, is available in the Google Play store.
08:15:44 <anitsirk> #info we are working on getting it submitted to the Apple store as well.
08:15:58 <anitsirk> there is a review process involved, so it'll take a bit longer.
08:16:30 <robertl_> so now it should be easier to get files from your phone into your mahara
08:16:32 <anitsirk> One of our front-end devs is conducting final initial tests and then I'll just need to fill in all the online paperwork,
08:16:50 <anitsirk> https://play.google.com/store/apps/details?id=org.mahara.mobile
08:17:26 <anitsirk> again, give it a go and let us know what you think.
08:17:58 <anitsirk> #info since Mahara Mobile is built on Cordova, we can take advantage of that framework and add features in some cases fairly easily by the looks of it.
08:18:10 <robertl_> part of that change was allowing users to generate their own tokens via their setting page
08:18:41 <robertl_> so they can get their app to talk to their mahara account easier
08:18:46 <robertl_> via webservices
08:18:46 <anitsirk> they are a bit harder to copy / type, but it's more like what other apps also offer: an overview page of all tokens and which device connects to them.
08:19:15 <anitsirk> and since it's using web services, the SSL cert is needed unless you are in non-production mode.
08:19:53 <anitsirk> Gregor_Pirker: do you know if your users have mobile devices and work with them for their portfolios?
08:20:30 <anitsirk> #info The cool thing about Mahara Mobile is that it works with internal auth, LDAP and SSO for logins. MNet users would have to set up the token.
08:21:46 <Gregor_Pirker> in some cases I have heard it but I will test the new mobile app and I will write in mahara.at news I hope will get some feedback about that
08:22:17 <anitsirk> Gregor_Pirker: fantastic that you'll be upgrading to 16.10. :-) Mahara Mobile needs the new mobile apis that are in it.
08:22:18 <robertl_> anything more about these topics?
08:22:45 <anitsirk> robertl_ not from me. just wanted to recap the great work you guys have done to get these things over the line and out for the release.
08:23:05 <robertl_> ok next topic
08:23:10 <robertl_> #topic Focus for 17.04
08:23:39 <robertl_> Now that we've got a big-ish release out with 16.10 the next one will be a bit smaller
08:24:32 <robertl_> partly because we've had two developers, aaron wells and son nguyen leave the team
08:24:54 <anitsirk> well, aaron not fully...
08:25:24 <robertl_> but as we always say if you want things in the next release please submit patches :)
08:25:51 <robertl_> true aaron is not fully gone but will be doing far less development
08:25:53 <anitsirk> #info we already have a few new feature suggestions for 17.04. Please help test and review them. One of them is Gregor Anzelj's watchlist improvements, Gregor_Pirker
08:26:19 <Gregor_Pirker> :-)
08:26:49 <anitsirk> And if you want to discuss your ideas, this is the place or we can have a chat in the forum or via audio / video.
08:27:07 <robertl_> I'm hoping to clean up, re-prioritise the reviews list a bit more in the coming days
08:27:38 <robertl_> so it more clearly reflects what we are trying to get in for 17.04
08:28:15 <anitsirk> sounds like a good plan.
08:28:25 <anitsirk> Gregor_Pirker: do you have any features planned?
08:29:49 <Gregor_Pirker> not at the moment but the Project students starts with the ats2020 Mahara in this mounth maybe I can tell you in dez more
08:30:38 <anitsirk> that would be fantastic.
08:31:09 <robertl_> now the fun bit
08:31:16 <anitsirk> what?
08:31:20 <anitsirk> it's not on the agenda :-D
08:31:21 <robertl_> #topic Next meeting and chair
08:31:50 <robertl_> no but it needs to be done
08:32:10 <robertl_> any volunteers  / preference for date?
08:32:22 <anitsirk> probably in january?
08:32:32 <anitsirk> happy to chair if nobody else wants to give it a go.
08:33:11 <robertl_> january sounds good - probably mid jan as people will be on holidays otherwise
08:33:28 <anitsirk> yep
08:33:49 <robertl_> how do 11th or 18th jan sound?
08:33:49 <cecilia> sounds good to me too
08:34:03 <Gregor_Pirker> this sounds good :-)
08:34:27 <anitsirk> robertl_ either is fine with me at this stage
08:34:54 <ghada> thank you anitsirk. and yes, probably mid/end of January
08:35:13 <robertl_> ok lets go with 18th Jan at the same time
08:35:49 <ghada> sure, that works for me.
08:35:58 <anitsirk> fine by me
08:36:15 <Gregor_Pirker> for me also fine too :-)
08:36:39 <robertl_> #agreed Wed, 18 Jan, 0800 UTC for the next meeting:  http://www.timeanddate.com/worldclock/fixedtime.html?iso=20170118T08
08:37:30 <robertl_> #agreed anitsirk volunteered to chair
08:37:40 <robertl_> lets lock that in
08:37:59 <robertl_> which brings us to
08:38:06 <robertl_> #topic Any other business
08:38:16 <anitsirk> i have a couple of brief announcements
08:38:23 <robertl_> go for it
08:38:48 <anitsirk> #info Mahara Hui NZ is happening in April 2017. https://maharahui.org.nz/ come along and also submit your proposals by the end of the month.
08:38:59 <anitsirk> it'll still be late summer at that time in NZ.
08:39:16 <anitsirk> so if you want to recharge your batteries and have some nice time, come on south.
08:39:32 <anitsirk> and ghada, wheather in auckland will probably definitely for sure be better than in sydney :-D
08:39:45 <robertl_> bound to be :)
08:40:52 <ghada> excellent!
08:40:57 <anitsirk> #info the next Mahara newsletter will be published on 1 or 2 January 2017. Articles can be submitted until shortly before christmas. Get your thinking hats on and share what you are doing with portfolios in Mahara.
08:41:28 <ghada> it's pretty rainy and miserable here right now...
08:41:29 <anitsirk> it can also be tips that make your life easier
08:41:43 <anitsirk> ghada: not so in Wellington. Beautiful day, the second in a row
08:42:01 <ghada> 2 in a row! Wow, that must be a record!
08:42:06 <ghada> ;-)
08:42:08 <anitsirk> lol
08:42:18 <anitsirk> anybody else have any other business?
08:43:21 <anitsirk> Tidbit from the Mahara part of the Catalyst office in Wellington: We found a weta. A small one and unfortunately without any food, it had not survived. http://www.adventurenewzealand.info/files/2012/12/Weta.jpg
08:43:30 <anitsirk> It must have really liked technology. forward thinking weta.
08:44:02 <anitsirk> that's all from me.
08:44:23 <robertl_> if there is no other business then I'll close the meeting
08:44:39 <robertl_> #endmeeting