#mahara-dev: 56th Mahara developer meeting

Meeting started by sonn at 08:01:19 UTC (full logs).

Meeting summary

    1. anitsirk is Kristina Hoeppner, Catalyst, Wellington, NZ (today from Sydney) (anitsirk, 08:01:36)
    2. sonn is Son Nguyen, Catalyst IT, Wellington, NZ (sonn, 08:01:44)
    3. robertl_ is Robert Lyon, Catalyst in Wellington, New Zealand (robertl_, 08:01:46)
    4. ghada is Ghada El-Zoghbi, Catalyst in Sydney, Australia (ghada, 08:02:16)
    5. sl-yairspi is Yair Spielmann, Synergy Learning in Belfast, NI (sl-yairspi, 08:02:34)

  1. From previous meeting: aaronw_ and robertl_ to discuss the details of how to get a build branch for Mahara releases going to support those who can't use composer. (sonn, 08:04:17)
    1. more progress on the build branch will be made in time for the 16.10 stable release (anitsirk, 08:06:11)
    2. simplesamlphp comes packages in Mahara and requires composer to fetch/install dependencies. if the server can't access the internet / fetch dependencies it gets a bit more complicated. (anitsirk, 08:11:39)
    3. IDEA: : prebuild the files needed somewhere so that they can be added to the stable build zip files etc so people can fetch them (anitsirk, 08:11:51)
    4. That is similar to how the building of the css files works. (anitsirk, 08:12:36)
    5. the new way of simplesamlphp replaces the old manual way. people using SAML SSO on their sites should be careful with an upgrade and test it on a test server first. (anitsirk, 08:16:42)
    6. ACTION: robertl_ will add an option in the Makefile in mahara to prebuild simplesamlphp packages for 16.10 release (sonn, 08:17:43)

  2. from previous meeting: aarow_ to update the Behat Testing setup page (sonn, 08:20:04)
    1. ACTION: aarow_laptop will update the Behat Testing setup page soon (sonn, 08:23:04)
    2. robertl_ updated the https://wiki.mahara.org/wiki/Testing/Behat_Testing/Error_%26_Solutions#Server_not_started and added the line 'First try the 'Shut down incorrectly' steps below - if you have had behat running successfully in the past ' (sonn, 08:25:09)
    3. sometime the selenium server does not stop when the tests failed in the middle (sonn, 08:26:24)

  3. From previous meeting: SmartEvidence has a bunch of patches in review (sonn, 08:27:00)
    1. All SmartEvidence patches have been merged and are available in 16.10RC1 (anitsirk, 08:27:20)
    2. a short demo video can be found at https://www.youtube.com/watch?v=hhA_MzUaLNc (anitsirk, 08:27:29)
    3. https://www.youtube.com/watch?v=hhA_MzUaLNc (anitsirk, 08:27:30)
    4. SmartEvidence will be a great new feature in Mahara enabling working with competency frameworks. (anitsirk, 08:29:17)
    5. anitsirk tested 16.10 RC on mobile today and it's already looking good (sonn, 08:29:23)

  4. Release Candidate (sonn, 08:32:18)
    1. As you may have seen, we released RC1 for 16.10 on Friday, 2 September (anitsirk, 08:32:47)
    2. it's available for testing now to make 16.10.0 a good stable release. (anitsirk, 08:33:01)
    3. Information about testing, where to get the code, what's new etc. is available in the forum post at https://mahara.org/interaction/forum/topic.php?id=7700 (anitsirk, 08:33:41)
    4. https://mahara.org/interaction/forum/topic.php?id=7700 (anitsirk, 08:33:41)
    5. IDEA: upgrade your *testing* / *development* sites and give feedback how it goes (anitsirk, 08:34:18)
    6. we are planning on putting out RC2 as we found a couple of big oopses that need fixing. (anitsirk, 08:35:00)
    7. If you find any issues please report them here https://launchpad.net/mahara/+milestone/16.10rc1 (anitsirk, 08:35:46)
    8. Please report bugs for 16.10 rc at https://launchpad.net/mahara/+milestone/16.10rc1 (sonn, 08:36:15)
    9. ACTION: sonn will make some VM images of mahara 16.10 rc for testing (sonn, 08:39:01)

  5. SmartEvidence (demo video at https://www.youtube.com/watch?v=hhA_MzUaLNc) (sonn, 08:41:38)
  6. PHP 7 (Progress is being made) (sonn, 08:42:40)
    1. Catlayst testers have been testing moe on PHP7 now that Ubuntu 16.04 has PHP7 as default. if anybody else can test as well and report issues that would be great. (anitsirk, 08:43:21)
    2. please do test the 16.10 release candidate on php7 as well as php 5 if you can (anitsirk, 08:46:39)

  7. Next meeting and chair (sonn, 08:51:34)
    1. http://www.timeanddate.com/worldclock/fixedtime.html?iso=20161109T08 (sonn, 08:57:52)
    2. AGREED: Wed, 9 Nov , 0800 UTC for the next meeting: http://www.timeanddate.com/worldclock/fixedtime.html?iso=20161109T08 (sonn, 08:59:09)
    3. AGREED: robertl_ volunteered to chair (sonn, 09:01:25)

  8. Any other business (sonn, 09:02:01)
    1. Mahara Hui UK 2016 will take place at the University of Sunderland on 17 and 18 November. The call for papers is open until 9 October and there is also still the possibility to be a sponsor. http://maharahuiuk.org/ (anitsirk, 09:02:57)
    2. http://maharahuiuk.org/ (anitsirk, 09:02:58)


Meeting ended at 09:07:04 UTC (full logs).

Action items

  1. robertl_ will add an option in the Makefile in mahara to prebuild simplesamlphp packages for 16.10 release
  2. aarow_laptop will update the Behat Testing setup page soon
  3. sonn will make some VM images of mahara 16.10 rc for testing


Action items, by person

  1. aarow_laptop
    1. aarow_laptop will update the Behat Testing setup page soon
  2. robertl_
    1. robertl_ will add an option in the Makefile in mahara to prebuild simplesamlphp packages for 16.10 release
  3. sonn
    1. sonn will make some VM images of mahara 16.10 rc for testing


People present (lines said)

  1. anitsirk (68)
  2. sonn (59)
  3. robertl_ (41)
  4. ghada (19)
  5. sl-yairspi (11)
  6. aarow_laptop (7)
  7. mahara-meetbot (4)


Generated by MeetBot 0.1.4.