08:01:19 <sonn> #startmeeting 56th Mahara developer meeting
08:01:19 <mahara-meetbot> Meeting started Wed Sep  7 08:01:19 2016 UTC and is due to finish in 60 minutes.  The chair is sonn. Information about MeetBot at https://wiki.mahara.org/wiki/Developer_Area/Developer_Meetings/Chair_Duties#Meetbot_commands.
08:01:19 <mahara-meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:01:19 <mahara-meetbot> The meeting name has been set to '56th_mahara_developer_meeting'
08:01:30 <sonn> Please introduce yourself
08:01:36 <anitsirk> #info anitsirk is Kristina Hoeppner, Catalyst, Wellington, NZ (today from Sydney)
08:01:44 <sonn> #info sonn is Son Nguyen, Catalyst IT, Wellington, NZ
08:01:46 <robertl_> #info robertl_ is Robert Lyon, Catalyst in Wellington, New Zealand
08:02:16 <aarow_laptop> #aarow_laptop is Aaron Wells, Catalyst IT, Wellington NZ
08:02:16 <ghada> #info ghada is Ghada El-Zoghbi, Catalyst in Sydney, Australia
08:02:34 <sl-yairspi> #info sl-yairspi is Yair Spielmann, Synergy Learning in Belfast, NI
08:03:01 <sonn> anyone else here?
08:03:29 <anitsirk> antonella, but maybe she stepped away
08:03:39 <sonn> ok
08:03:48 <sonn> First, topics from previous meetings
08:04:14 <anitsirk> #topic Topics from previous meeting
08:04:17 <sonn> #topic From previous meeting: aaronw_ and robertl_ to discuss the details of how to get a build branch for Mahara releases going to support those who can't use composer.
08:05:05 <robertl_> well , other than discuss it more since last time we not actually started any fix for this issue yet
08:05:21 <aarow_laptop> but we probably will soon :)
08:05:36 <robertl_> and as 16.10 release is in Oct - we have a fixed deadline
08:05:51 <aarow_laptop> robertl_: What did you do when you packaged the 16.10rc1?
08:06:11 <anitsirk> #info more progress on the build branch will be made in time for the 16.10 stable release
08:06:19 <robertl_> ignored the ssphp issue for now
08:06:51 <robertl_> those testing the rc I'd imagine would be able to install the required bits for make ssphp
08:07:16 <robertl_> as they (in theory) would be testing on a dev machine
08:07:20 <anitsirk> robertl_ you mean the one for the packages that are indirectly related to saml? I'm not sure if everyone here knows what these issues are as they are in a WR. ;-)
08:07:56 <robertl_> ok, the issue is we've adjusted how simplesamlphp works with mahara
08:08:12 <robertl_> in the past one had to set it up separate, which was a pain
08:08:32 <robertl_> now there is an option in the Makefile in mahara
08:08:55 <robertl_> that uses composer to fetch/install the bits needed
08:09:42 <robertl_> but a problem is that if the server your mahara is on doesn't have composer installed/can't fetch the dependencies
08:09:56 <robertl_> there will be pain
08:10:47 <robertl_> so the idea is we prebuild the files needed somewhere so that they can be added to the stable build zip files etc so people can fetch them
08:11:03 <robertl_> like we do with the building of the css files from sass
08:11:39 <anitsirk> #info simplesamlphp comes packages in Mahara and requires composer to fetch/install dependencies. if the server can't access the internet / fetch dependencies it gets a bit more complicated.
08:11:51 <anitsirk> #idea: prebuild the files needed somewhere so that they can be added to the stable build zip files etc so people can fetch them
08:12:36 <anitsirk> #info That is similar to how the building of the css files works.
08:12:53 <robertl_> so first thing to do will be to see if the simplesamlphp is os version/server type dependent
08:12:57 <ghada> robertl_ - do you download specific versions of the dependencies?
08:13:14 <ghada> just as i was typing...
08:14:38 <robertl_> that's what I need to look into
08:14:39 <sonn> robertl_ Are you going to do that for 16.10 release?
08:14:54 <robertl_> it would be best to get it done for 16.10
08:15:11 <robertl_> as the new way of simplesamlphp replaces the old way
08:15:35 <robertl_> so has the real potential to break sites
08:16:42 <anitsirk> #info the new way of simplesamlphp replaces the old manual way. people using SAML SSO on their sites should be careful with an upgrade and test it on a test server first.
08:17:43 <sonn> #action robertl_ will add an option in the Makefile in mahara to prebuild simplesamlphp packages for 16.10 release
08:18:51 <sonn> next topic?
08:19:21 <anitsirk> sure
08:20:04 <sonn> #topic from previous meeting: aarow_ to update the Behat Testing setup page
08:20:47 <aarow_laptop> Oh, shoot, I haven't really done much on that
08:20:56 <ghada> :-(
08:21:00 <aarow_laptop> sorry ghada
08:21:11 <ghada> that's ok.
08:21:13 <aarow_laptop> are you still having trouble with it?
08:21:21 <ghada> i haven't had a chance to get back to it
08:21:26 <ghada> lots of fires to put out
08:21:43 <anitsirk> aarow_laptop or sonn: do you know if cecilia could set behat up using the instructions?
08:22:14 <sonn> robertl_ helped her for that I reckon
08:22:35 <robertl_> she was able to set it up
08:22:58 <robertl_> but then later on she had a problem with selenium - what was the fix for that sonn?
08:23:04 <sonn> #action aarow_laptop will update the  Behat Testing setup page soon
08:23:23 <sonn> Yes, I am working on that
08:24:13 <sonn> now, all steps "I wait for" is not neccessary
08:24:39 <robertl_> I updated the https://wiki.mahara.org/wiki/Testing/Behat_Testing/Error_%26_Solutions#Server_not_started and added the line 'First try the 'Shut down incorrectly' steps below - if you have had behat running successfully in the past '
08:25:09 <sonn> #info robertl_ updated the https://wiki.mahara.org/wiki/Testing/Behat_Testing/Error_%26_Solutions#Server_not_started and added the line 'First try the 'Shut down incorrectly' steps below - if you have had behat running successfully in the past '
08:25:15 <robertl_> as the instructions there were not quite clear about when you need to bump selenium version
08:26:24 <sonn> #info sometime the selenium server does not stop when the tests failed in the middle
08:27:00 <sonn> #topic From previous meeting: SmartEvidence has a bunch of patches in review
08:27:20 <anitsirk> #info All SmartEvidence patches have been merged and are available in 16.10RC1
08:27:29 <anitsirk> #info a short demo video can be found at https://www.youtube.com/watch?v=hhA_MzUaLNc
08:27:30 <anitsirk> https://www.youtube.com/watch?v=hhA_MzUaLNc
08:27:39 <anitsirk> Now it just needs to be tested.
08:27:47 <robertl_> and there are a couple of fixes to be merged very soon
08:27:54 <robertl_> that are in gerrit
08:27:57 <sonn> #topic Release Candidate (please help test it)
08:28:04 <anitsirk> I tested it on mobile today and it's already looking good. the standards can be tapped and the descriptions show up :-)
08:28:13 <anitsirk> sonn: can you please undo the topic?
08:28:20 <anitsirk> i wasn't quite done yet with smartevidence ;-)
08:28:35 <sonn> #undo
08:28:35 <mahara-meetbot> Removing item from minutes: <ircmeeting.items.Topic object at 0x7f46dd89f810>
08:28:39 <anitsirk> thanks
08:29:17 <anitsirk> #info SmartEvidence will be a great new feature in Mahara enabling working with competency frameworks.
08:29:23 <sonn> #info  anitsirk tested 16.10 RC on mobile today and it's already looking good
08:29:33 <anitsirk> sl-yairspi: did you already have a play with it?
08:29:55 <anitsirk> sonn: i haven't done a full test. so that it still outstanding for anyone who wants to tackle that. :-)
08:30:41 <sonn> #info  But  anitsirk hasn't done a full test
08:31:24 <anitsirk> sonn: i think we can move to the RC now as any answer that sl-yairspi may give would most likely go for the RC as well. unless there are questions for SmartEvidence.
08:31:26 <sl-yairspi> I've not. Most of my Mahara work lately has been around upgrading customised sites from 1.4 to 16.04...
08:31:38 <anitsirk> oh wow. all the best with that.
08:31:46 <robertl_> woo, that is quite the jump
08:31:48 <anitsirk> 16.04 to 16.10 will go smoother :-)
08:31:49 <sl-yairspi> (thanks)
08:32:18 <sonn> #topic Release Candidate
08:32:18 <sl-yairspi> (and thanks for the tip)
08:32:47 <anitsirk> #info As you may have seen, we released RC1 for 16.10 on Friday, 2 September
08:33:01 <anitsirk> #info it's available for testing now to make 16.10.0 a good stable release.
08:33:41 <anitsirk> #info Information about testing, where to get the code, what's new etc. is available in the forum post at https://mahara.org/interaction/forum/topic.php?id=7700
08:33:41 <anitsirk> https://mahara.org/interaction/forum/topic.php?id=7700
08:34:18 <anitsirk> #idea upgrade your *testing* / *development* sites and give feedback how it goes
08:34:59 <sonn> I can create some docker and VM images with 16.10 RC for testing
08:35:00 <anitsirk> #info we are planning on putting out RC2 as we found a couple of big oopses that need fixing.
08:35:09 <ghada> do you think there's going to be a RC2?
08:35:19 <anitsirk> yep :-)
08:35:31 <ghada> that's what I thought...
08:35:37 <robertl_> If you find any issues please report them here https://launchpad.net/mahara/+milestone/16.10rc1
08:35:46 <anitsirk> #info If you find any issues please report them here https://launchpad.net/mahara/+milestone/16.10rc1
08:36:03 <anitsirk> sonn: good idea. what were you thinking of?
08:36:15 <sonn> #info Please report bugs for 16.10 rc at https://launchpad.net/mahara/+milestone/16.10rc1
08:36:28 <robertl_> I know there will be some adjustments for the .matrix files - so that will need to be tested again in rc2
08:36:50 <anitsirk> and the annotation issue when placing it on a map. ;-) that's already in review
08:37:06 <robertl_> yep, that too
08:37:07 <anitsirk> i wonder what will be better: Docker or VM. What will people have most experience with?
08:37:47 <ghada> well, for me it's a VM. I haven't had much luck with Docker.
08:37:53 <sonn> anitsirk: docker for Linux users, VM is best for Windows or Nac users
08:38:13 <sonn> I mean Mac users
08:38:21 <anitsirk> sonn: since most in the community are windows / mac, a couple of VMs might be best then
08:38:30 <sonn> ok
08:38:31 <anitsirk> that way they could test it also locally
08:38:58 <sl-yairspi> VM for me too. Docker seems promising, but still has quite a way to go to be easily compatible
08:39:01 <sonn> #action sonn will make some VM images of mahara 16.10 rc for testing
08:39:38 <anitsirk> sonn: let's look at that early next week when I'm back as we should also provide some content in it
08:39:45 <sonn> sure
08:40:11 <sonn> anything else about RC?
08:40:21 <anitsirk> not from me
08:41:23 <sonn> ok
08:41:38 <sonn> #topic SmartEvidence (demo video at https://www.youtube.com/watch?v=hhA_MzUaLNc)
08:41:57 <sonn> We did talk a bit
08:42:23 <anitsirk> yeah. we rolled that into the previous topic.
08:42:33 <anitsirk> was easier instead of waiting :-)
08:42:40 <sonn> #topic PHP 7 (Progress is being made)
08:43:17 <sonn> We did fix lots of PHP7 compatible issue in 16.10 rc
08:43:21 <anitsirk> #info Catlayst testers have been testing moe on PHP7 now that Ubuntu 16.04 has PHP7 as default. if anybody else can test as well and report issues that would be great.
08:43:28 <robertl_> we've got most of the php7 issues ironed out
08:43:34 <anitsirk> and that should have been "Catalyst" ;-)
08:43:47 <sonn> yes, they found a few warnings
08:43:53 <robertl_> and a couple of new ones have popped up and have patches for them
08:44:37 <ghada> oh that's really great news.
08:44:56 <ghada> it's something I get asked all the time about Mahara
08:45:19 <ghada> especially since Moodle (I think 3.0) works under php7
08:45:29 <anitsirk> sl-yairspi: that was one of your / Alex's questions as well
08:45:47 <anitsirk> yes, ghada. i think it was 3.0.2 or so
08:45:48 <sonn> Any load/performance test on PHP7 would be good
08:46:18 <robertl_> so yes, please do test rc1 on php7 as well as php 5 if you can
08:46:26 <sl-yairspi> that's fantastic
08:46:39 <anitsirk> #info please do test the 16.10 release candidate on php7 as well as php 5 if you can
08:47:06 <anitsirk> sl-yairspi: do you see any capacity in your team to do some load / performance testing under php7?
08:48:38 <sl-yairspi> I think it's unlikely at this point, but may be different closer to the actual upgrade.
08:48:55 <anitsirk> that would be great.
08:50:09 <sonn> anything else about PHP7?
08:50:27 <sonn> besides testing
08:50:32 <anitsirk> not from me.
08:50:52 <robertl_> nor me
08:51:34 <sonn> #topic Next meeting and chair
08:52:18 <robertl_> when will the next meeting be held?
08:52:33 <anitsirk> sonn?
08:52:41 <robertl_> will it be before or after the release of 16.10?
08:52:57 <sonn> I am thinking about that
08:53:15 <sonn> should be after the release I think
08:53:20 <anitsirk> if it's after 16.10 it's likely not happening before beginning of november unless we release early in october
08:54:14 <anitsirk> but there's not much to discuss and it's been like that in the past few months. so maybe a monthly meeting is not required at the moment?
08:54:32 <ghada> yes, i'm ok with that.
08:55:01 <robertl_> so push the next meeting out to nov? I'm fine with that
08:55:27 <sonn> I am fine with having next meeting in Nov
08:56:05 <anitsirk> any days of the week that don't work for people?
08:56:11 <sonn> 9 Nov is ok for you?
08:56:34 <robertl_> 9th sounds ok to me
08:56:34 <sonn> it is Wednesday
08:56:37 <ghada> 9 Nov is ok with me
08:56:42 <sl-yairspi> ok with me
08:56:47 <anitsirk> yep, does work atm
08:57:08 <sonn> Same time or 7 UTC?
08:57:12 <ghada> daylight savings will have started here
08:57:24 <ghada> so what does that make it....
08:57:26 <anitsirk> sonn: please provide a link so everyone can check easily
08:57:28 <sonn> It will be 9PM if we go for 8 UTC
08:57:52 <sonn> http://www.timeanddate.com/worldclock/fixedtime.html?iso=20161109T08
08:58:13 <ghada> yes, that works for me.
08:58:22 <anitsirk> works for me
08:58:23 <ghada> 8 UTC
08:58:40 <robertl_> 8 UTC sounds fine to me
08:58:49 <aarow_laptop> me too
08:59:04 <sl-yairspi> and earlier here. it will be harder, but don't go later just for me.
08:59:09 <sonn> #agreed Wed, 9 Nov , 0800 UTC for the next meeting: http://www.timeanddate.com/worldclock/fixedtime.html?iso=20161109T08
08:59:28 <anitsirk> thanks, sl-yairspi. it's only once every other month or so ;-)
09:00:15 <sonn> Anyone want to volunteer to chair?
09:00:59 <robertl_> Sure, I'll do it - haven't done it for a while
09:01:06 <anitsirk> thanks, robertl_
09:01:14 <anitsirk> i was saved by typing more slowly. :-D
09:01:25 <sonn> #agreed robertl_ volunteered to chair
09:01:40 <sonn> thanks robertl_
09:01:48 <robertl_> no worries
09:02:01 <sonn> #topic Any other business
09:02:04 <anitsirk> yes i have one
09:02:57 <anitsirk> #info Mahara Hui UK 2016 will take place at the University of Sunderland on 17 and 18 November. The call for papers is open until 9 October and there is also still the possibility to be a sponsor. http://maharahuiuk.org/
09:02:58 <anitsirk> http://maharahuiuk.org/
09:03:14 <anitsirk> sl-yairspi: hopefully, you'll be able to attend to upt the developer participation :-)
09:03:35 <anitsirk> and it would be great to get synergy as sponsor as well ;-)
09:04:14 <sl-yairspi> oh, good to know
09:04:44 <sonn> anyone else?
09:04:53 <sl-yairspi> if we can get the next version certified for php7 I might be able to persuade them ;)
09:05:12 <anitsirk> if you help with it ;-)
09:05:25 <sonn> yes, we can
09:05:42 <sonn> with your help
09:06:37 <anitsirk> thanks for chairing, sonn.
09:06:49 <anitsirk> have a nice evening everyone and happy RC testing :-)
09:06:53 <sonn> OK, I can close the meeting
09:06:55 <robertl_> yes, thanks sonn
09:07:04 <sonn> #endmeeting