#mahara-dev: 54th Mahara Developer Meeting

Meeting started by anitsirk at 08:01:35 UTC (full logs).

Meeting summary

    1. anitsirk is Kristina Hoeppner from Catalyst in Wellington (anitsirk, 08:01:57)
    2. I aaronw_ am Aaron Wells of Catalyst IT in Wellington, New Zealand (aaronw_, 08:02:00)
    3. Gregor Pirker, Danube University Krems, Austria (Gregor_P, 08:02:03)
    4. robertl_ is Robert Lyon, Catalyst in Wellington, New Zealand (robertl_, 08:02:14)
    5. ghada is Ghada El-Zoghbi from Catalyst IT in Sydney, Australia (ghada, 08:02:15)

  1. Topics from previous meeting (anitsirk, 08:02:40)
    1. anitsirk to bring up the composer issue for the SAML work and see if we want to proceed or make changes. (anitsirk, 08:02:46)
    2. IDEA: One possibility could be to create a build branch for those that can't install via composer. We already need composer for gulp. (anitsirk, 08:05:57)
    3. https://reviews.mahara.org/#/q/status:open+project:mahara+branch:master+topic:SimpleSAML (anitsirk, 08:06:51)
    4. the new SAML functionality would allow you to do "make ssphp" and install the SimpleSAMLPHP library via composer rather than you having to download SimpleSAML and install it manually. (anitsirk, 08:09:18)
    5. last time we discussed that some people aren't able to pull additional components from the internet if they don't come in the git branch. so instead of connecting to the regular core branch that requires the build process, they would connect to the branch that includes everything pre-built. (anitsirk, 08:12:16)
    6. and have that branch creation automated :-) (anitsirk, 08:13:24)
    7. ACTION: aaronw_ and robertl_ to discuss the details of how to get a build branch for Mahara releases going to support those who can't use composer. (anitsirk, 08:19:06)

  2. +2 for verification for new features (anitsirk, 08:19:29)
    1. IDEA: Should we have a +2 in Gerrit for new features for the verification part so it's more obvious when something can be merged from the front-end perspective? (anitsirk, 08:22:31)
    2. IDEA: Instead tag new features in the topic field with "(feature)" to distinguish them more easily (anitsirk, 08:23:48)
    3. ACTION: anitsirk to update the "How to contribute" wiki section that new features should have the topic set and include "(feature)" (anitsirk, 08:29:09)

  3. PHP dev needed at Mahara HQ (anitsirk, 08:31:22)
    1. We are looking for an experienced PHP dev in Wellington to work on mahara with us: https://www.catalyst.net.nz/jobs/php-developer-new-zealand-wellington (anitsirk, 08:33:19)
    2. Q&A: Can self-registration be turned off: Yes, for each institution in the institution settings. (anitsirk, 08:40:26)
    3. Q&A: Why is there a "Dwoo" folder in the maharadata directory? It holds the cached template files. Dwoo compiles the .tpl files into php files. (anitsirk, 08:41:22)
    4. There will be a new feature in 16.10 that clears the cache so that old template files don't hang around and potentially cause trouble when the site loads. (anitsirk, 08:42:21)
    5. the Dwoo directory can also be deleted manually. Mahara will recreate it automatically. (anitsirk, 08:44:52)

  4. Next meeting and chair (anitsirk, 08:45:25)
    1. The 55th Mahara Developer Meeting will take place on 3 August 2016 at 8:00 UTC with Aaron Wells as the chair. http://www.timeanddate.com/worldclock/fixedtime.html?iso=20160803T08 (anitsirk, 08:56:41)
    2. http://www.timeanddate.com/worldclock/fixedtime.html?iso=20160727T08 (anitsirk, 08:56:43)


Meeting ended at 08:57:16 UTC (full logs).

Action items

  1. aaronw_ and robertl_ to discuss the details of how to get a build branch for Mahara releases going to support those who can't use composer.
  2. anitsirk to update the "How to contribute" wiki section that new features should have the topic set and include "(feature)"


Action items, by person

  1. aaronw_
    1. aaronw_ and robertl_ to discuss the details of how to get a build branch for Mahara releases going to support those who can't use composer.
  2. anitsirk
    1. anitsirk to update the "How to contribute" wiki section that new features should have the topic set and include "(feature)"
  3. robertl_
    1. aaronw_ and robertl_ to discuss the details of how to get a build branch for Mahara releases going to support those who can't use composer.


People present (lines said)

  1. anitsirk (94)
  2. aaronw_ (34)
  3. ghada (28)
  4. robertl_ (17)
  5. Gregor_P (13)
  6. mahara-meetbot (3)


Generated by MeetBot 0.1.4.