08:01:35 <anitsirk> #startmeeting 54th Mahara Developer Meeting
08:01:35 <mahara-meetbot> Meeting started Wed Jun 29 08:01:35 2016 UTC and is due to finish in 60 minutes.  The chair is anitsirk. Information about MeetBot at https://wiki.mahara.org/wiki/Developer_Area/Developer_Meetings/Chair_Duties#Meetbot_commands.
08:01:35 <mahara-meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:01:35 <mahara-meetbot> The meeting name has been set to '54th_mahara_developer_meeting'
08:01:41 <anitsirk> Hello and welcome to our latest installment of the developer meeting. Please introduce yourself by putting a #info at the start of the line so we have you recorded in the minutes.
08:01:57 <anitsirk> #info anitsirk is Kristina Hoeppner from Catalyst in Wellington
08:02:00 <aaronw_> #info I aaronw_ am Aaron Wells of Catalyst IT in Wellington, New Zealand
08:02:03 <Gregor_P> #info Gregor Pirker, Danube University Krems, Austria
08:02:14 <robertl_> #info robertl_ is Robert Lyon, Catalyst in Wellington, New Zealand
08:02:15 <ghada> #info ghada is Ghada El-Zoghbi from Catalyst IT in Sydney, Australia
08:02:40 <anitsirk> #topic Topics from previous meeting
08:02:46 <anitsirk> #info anitsirk to bring up the composer issue for the SAML work and see if we want to proceed or make changes.
08:03:09 <anitsirk> We haven't really discussed it in Welington yet as there's been lots of other things to do.
08:03:26 <anitsirk> robertl_ and aaronw_ have been reviewing piers' patches though quite intensely
08:04:39 <robertl_> we have mentioned the possible need for a build branch so those that can't install via composer can get the files they need
08:04:59 <aaronw_> And we meant to do something like that when we added the gulp build step last year
08:05:11 <aaronw_> so this would just add a bit more to that same idea
08:05:57 <anitsirk> #idea One possibility could be to create a build branch for those that can't install via composer. We already need composer for gulp.
08:06:08 <ghada> I'm not on top of this. Is this for the compiled css files?
08:06:43 <anitsirk> ghada: it's for the SAML stuff that is going to be in core
08:06:51 <anitsirk> https://reviews.mahara.org/#/q/status:open+project:mahara+branch:master+topic:SimpleSAML
08:07:22 <aaronw_> So, currently the Mahara SAML auth plugin requires you to download SimpleSAML and install it somewhere on your computer outside of Mahara itself
08:07:38 <ghada> right.
08:07:51 <aaronw_> this series of patches changes it so that instead, you can do "make ssphp" and Mahara will download the SimpleSamlPHP library via composer
08:08:13 <aaronw_> So, this sorta adds a second "build" step to the Mahara codebase, with the first "build" step being the CSS
08:08:53 <aaronw_> So I was thinking, we should probably start doing something along the lines of a "nightly build" for people who want to experiment with the latest code but can't get gulp and/or composer up and running
08:09:06 <ghada> ok. so if the idea is to have a branch for the saml install, why not have one as well for the compiled css files?
08:09:18 <anitsirk> #info the new SAML functionality would allow you to do "make ssphp" and install the SimpleSAMLPHP library via composer rather than you having to download SimpleSAML and install it manually.
08:09:54 <anitsirk> i would think it would be all in one branch. just a build branch for core mahara.
08:10:02 <aaronw_> Yep
08:10:09 <ghada> ok.
08:10:15 <aaronw_> like "master-build" would be a branch to which we push a copy of the fully "built" source code with all the build steps
08:10:31 <aaronw_> We use something like that to do deployments in Catalyst NZ
08:10:53 <ghada> and the users would use this branch - instead of master - to get Mahara + simplesaml
08:11:04 <ghada> so they won't really need master
08:11:08 <aaronw_> Yep, if they didn't want to do the build process themselves
08:11:34 <ghada> so you'll need to create a build branch for each version / release of Mahara
08:11:45 <aaronw_> Yeah, and a script to update them
08:12:12 <ghada> i would think this can be automated, right?
08:12:16 <anitsirk> #info last time we discussed that some people aren't able to pull additional components from the internet if they don't come in the git branch. so instead of connecting to the regular core branch that requires the build process, they would connect to the branch that includes everything pre-built.
08:12:16 <aaronw_> yep
08:12:21 <ghada> i.e. the creation of this build branch
08:12:54 <ghada> that sounds good to me.
08:13:01 <ghada> were there other ideas thrown around?
08:13:24 <anitsirk> #info and have that branch creation automated :-)
08:13:25 <aaronw_> well, I guess another aspect of this, is that it kind of works as a test case for using composer to manage our dependencies
08:14:15 <robertl_> I belive the zip files on launchpad have the css in-built yes?
08:14:34 <robertl_> so for ssphp we could do the same
08:14:46 <anitsirk> robertl_: yes, they do.
08:15:31 <ghada> i think this is a great idea. it will solve a lot of people's issues that can't use composer
08:17:49 <anitsirk> aaronw_: shall we discuss the how-to in the office?
08:18:10 <robertl_> makes deploying to 3rd party machines easier also
08:18:20 <aaronw_> Sure, we can do that
08:18:37 <aaronw_> I've got a fairly clear picture of the implementation
08:19:06 <anitsirk> #action aaronw_ and robertl_ to discuss the details of how to get a build branch for Mahara releases going to support those who can't use composer.
08:19:12 <anitsirk> that sounds great, aaronw_
08:19:29 <anitsirk> #topic +2 for verification for new features
08:19:47 <anitsirk> Code reviews need to be approved by an approved code reviewer. Others can only give +1 but not +2.
08:19:47 <anitsirk> 
08:19:48 <anitsirk> While I don't think the same would be necessary for all front-end verifications, it would be good to have the option to give a +2 or something like that when new features are concerned. Right now there is just a +1. When new features are pushed to Gerrit, they should not only be approved by a tester who tests that there aren't any errors, but by someone who also looks at the interface and knows Mahara enough to make a decision whether it can go in l
08:20:46 <anitsirk> or is it working fine as is?
08:21:44 <aaronw_> I'm fine either way :)
08:22:29 <ghada> i hadn't realised there were changes being made until earlier today
08:22:31 <anitsirk> #idea Should we have a +2 in Gerrit for new features for the verification part so it's more obvious when something can be merged from the front-end perspective?
08:22:52 <anitsirk> ghada: we haven't made any changes to Gerrit
08:22:53 <robertl_> it might be worth just tagging it with (feature) in the topic field so we know to treat it differently
08:23:26 <anitsirk> robertl_ that's an idea and easier because I wouldn't think that we could have +2 for some but not all patches.
08:23:48 <anitsirk> #idea Instead tag new features in the topic field with "(feature)" to distinguish them more easily
08:24:49 <anitsirk> It hasn't been a problem yet. there were just some things that should have probably been done differently that we had to change then later on.
08:25:22 <anitsirk> and i don't want to make it a big deal or add huge processes as it's mainly a small group of people who do the majority of the reviews.
08:25:39 <anitsirk> would tagging be a good idea for you?
08:25:54 <ghada> i'm of the opinion to keep it simple
08:26:28 <ghada> i think that's a good idea and the people who review will know - as long as everyone is told in the future as well.
08:26:45 <anitsirk> We can put it in the guidelines on the wiki.
08:26:57 <anitsirk> and the topic can always be changed once the first person reviews it
08:27:12 <anitsirk> so it's not like it has to be done right from the start.
08:27:55 <robertl_> I wish gerrit could handle multiple topics for a patch
08:28:16 <anitsirk> :-)
08:28:32 <robertl_> but we will just have to go with 'My new thing (feature)'
08:29:09 <anitsirk> #action anitsirk to update the "How to contribute" wiki section that new features should have the topic set and include "(feature)"
08:29:28 <anitsirk> robertl_: It could even just be "master (feature)" if it's one patch.
08:29:50 <robertl_> yep
08:29:57 <anitsirk> i like how you work with the topics in gerrit. it makes it so much easier to see which ones belong to the connection manager and which ones to samlphp at the moment
08:30:40 <anitsirk> i think that was it for this topic.
08:31:01 <anitsirk> Here's a topic that is not on the list.
08:31:22 <anitsirk> #topic PHP dev needed at Mahara HQ
08:32:03 <anitsirk> We are looking for an experienced PHP dev in Welington to work on mahara with us: https://www.catalyst-au.net/jobs/php-developer-new-zealand-wellington
08:32:12 <anitsirk> If you know of anyone, please let us know.
08:32:24 <anitsirk> oops. i still had the AU site cashed. doesn't matter. it's the same page. :-0
08:32:26 <anitsirk> :-)
08:32:38 <anitsirk> they don't have to have done PHP before
08:33:19 <anitsirk> #info We are looking for an experienced PHP dev in Wellington to work on mahara with us: https://www.catalyst.net.nz/jobs/php-developer-new-zealand-wellington
08:33:26 <anitsirk> that was it for that at this moment.
08:33:45 <anitsirk> Do you have any other topics / business before we get to our favorite one?
08:34:16 <ghada> none from me.
08:34:30 <aaronw_> none here
08:34:35 <robertl_> none from me either
08:34:43 <anitsirk> Gregor_P?
08:34:57 <Gregor_P> i have a wish for Mahara 16.10. please can you make a button to deactivate the registration?
08:35:09 <anitsirk> Gregor_P: what do you mean?
08:35:16 <anitsirk> does the "Cancel" link not work for you?
08:35:27 <anitsirk> when you hit that you shouldn't be asked anymore
08:35:40 <anitsirk> though if you just navigate away from the page, you will (I think) ;-)
08:35:42 <robertl_> the cancel link should set a flag to not ask you on future upgrades
08:36:30 <Gregor_P> no no sometimes we don ´t need for some projekt the open registration
08:36:46 <anitsirk> Gregor_P: which registration are you talking about?
08:37:01 <anitsirk> robertl_ and I were talking about the registration with the mahara project.
08:37:05 <anitsirk> do you mean the self-registration?
08:37:12 <Gregor_P> yes
08:37:25 <anitsirk> you can deactivate that in the institution settings easily
08:38:02 <anitsirk> See  item 3 in the screenshot at http://manual.mahara.org/en/16.04/administration/institutions.html#add-an-institution
08:38:20 <Gregor_P> okay sry must be blind last week
08:38:28 <anitsirk> no problem. :-)
08:38:39 <anitsirk> anything else that you'd like to talk about?
08:39:19 <Gregor_P> yes i have a last question what is the Folder Dwoo?
08:39:38 <robertl_> in dataroot?
08:39:39 <aaronw_> You mean the one under the dataroot?
08:39:46 <Gregor_P> in maharadata
08:39:54 <robertl_> it holds the cached template files
08:39:58 <aaronw_> yep that
08:40:09 <aaronw_> The "Dwoo" templating engine compiles .tpl files into .php files
08:40:12 <robertl_> it changes the .tpl files into php files
08:40:26 <anitsirk> #info Q&A: Can self-registration be turned off: Yes, for each institution in the institution settings.
08:40:26 <ghada> there's an echo in here
08:40:42 <aaronw_> :)
08:40:56 <Gregor_P> ohh i understand
08:41:22 <anitsirk> #info Q&A: Why is there a "Dwoo" folder in the maharadata directory? It holds the cached template files. Dwoo compiles the .tpl files into php files.
08:41:23 <ghada> Gregor_P: there's a new feature that was added to clear the cache ...
08:41:26 <Gregor_P> have this folder a connection to the mahara cronjob
08:42:10 <aaronw_> Hm, I don't think it would, unless there's a cronjob that needs to use .tpl templates
08:42:21 <anitsirk> #info There will be a new feature in 16.10 that clears the cache so that old template files don't hang around and potentially cause trouble when the site loads.
08:43:15 <aaronw_> Are you having a problem where files under the dwoo directory don't have the right permissions for the web server to access them?
08:43:23 <Gregor_P> can i clear the cache manuel?
08:43:43 <Gregor_P> :-) okay
08:43:44 <ghada> yes you can. just delete the cache directory
08:43:57 <aaronw_> that's actually what the "clear cache" thing in 16.10 does
08:44:02 <aaronw_> just deletes the directory
08:44:04 <ghada> under the Dwoo directory
08:44:12 <aaronw_> Mahara will automatically recreate it as needed
08:44:52 <anitsirk> #info the Dwoo directory can also be deleted manually. Mahara will recreate it automatically.
08:44:57 <Gregor_P> ah thanks :-)
08:45:17 <anitsirk> Ok. And now to the last topic.
08:45:25 <anitsirk> #topic Next meeting and chair
08:45:41 <anitsirk> I propose Wednesday 27 July at 8 UTC http://www.timeanddate.com/worldclock/fixedtime.html?iso=20160727T08
08:46:12 <robertl_> I shall be away that week
08:46:26 <anitsirk> and that is correct. sorry, i forgot, robertl_
08:46:35 <robertl_> so the following week would be better for me
08:47:22 <ghada> that works for me
08:47:58 <anitsirk> I cannot attend any meetings in august at the 8 UTC time. if we switched it around and said 8:00 a.m. NZ, but that would be way too early for Ghada
08:48:14 <anitsirk> but you can also meet without me
08:48:19 <anitsirk> just have to find a meeting chair ;-)
08:48:24 <ghada> how about the 22nd?
08:48:38 <anitsirk> I don't think we'll have too much to discuss then.
08:48:47 <anitsirk> our last two meetings were pretty light.
08:49:04 <robertl_> ok lets go with 27th and I'll try to make it
08:49:17 <anitsirk> robertl_. no. enjoy your vacation.
08:49:27 <anitsirk> 3rd of august is fine. you don't need me.
08:49:36 <ghada> you don't need me.
08:49:39 <ghada> you can do it early
08:49:41 <anitsirk> i just don't think i'll be able to make a 4 a.m. meeting. ;-)
08:49:53 <ghada> no 4am....
08:49:57 <ghada> but 8am nz
08:50:20 <anitsirk> well, Gregor_P would 10 pm work for you or be too late?
08:50:29 <anitsirk> 10 pm austrian time that is
08:50:49 <Gregor_P> 10 pm is okay :-)
08:51:24 <anitsirk> aaronw_ 8 am? or rather meeting with me?
08:51:31 <anitsirk> but with ghada instead :-)
08:51:41 <ghada> what a choice!
08:51:50 <anitsirk> yeah. i like the second option :-)
08:52:36 <aaronw_> 8am NZ time, and what's the other option?
08:52:54 <anitsirk> have ghada in the meeting
08:53:07 <aaronw_> oh, but no specific time
08:53:11 <anitsirk> 6 am sydney is too early
08:53:16 <anitsirk> well, the typical 8 pm
08:53:19 <aaronw_> oh
08:53:31 <aaronw_> I guess 8pm is easier for me
08:53:53 <anitsirk> so: 8 am and kristina is chair (unless i have to be on a panel or give a presentation) or 8 pm and ghada can attend (but doesn't have to be chair ;-) )
08:54:14 <anitsirk> sold. 8 pm nz it is on 3 august 2016
08:54:22 <anitsirk> now. who wants to chair? :-d
08:55:32 <anitsirk> we could even do it this way to make it easier: Just meet and I'll put the commands in afterwards and aaronw_ can generate the log after the fact. that way you don't have to worry much about the meetbot commands
08:55:49 <aaronw_> I suppose I can chair
08:55:56 <aaronw_> I haven't done it in a while
08:55:58 <anitsirk> someone would only have to send me the log
08:56:03 <anitsirk> thanks aaronw_
08:56:41 <anitsirk> #info The 55th Mahara Developer Meeting will take place on 3 August 2016 at 8:00 UTC with Aaron Wells as the chair. http://www.timeanddate.com/worldclock/fixedtime.html?iso=20160803T08
08:56:43 <anitsirk> http://www.timeanddate.com/worldclock/fixedtime.html?iso=20160727T08
08:56:54 <aaronw_> sounds like a plan!
08:57:04 <anitsirk> thank you very much everyone for attending and have a nice evening and day.
08:57:16 <anitsirk> #endmeeting