#mahara-dev: 51st Mahara developer meeting

Meeting started by anzeljg at 08:02:59 UTC (full logs).

Meeting summary

    1. robertl_ is Robert Lyon, Catalyst in Wellington, New Zealand (robertl_, 08:03:17)
    2. anzeljg is Gregor Anželj, developer and translator from Povsod (Ljubljana, Slovenia) (anzeljg, 08:03:21)
    3. anitsirk is Kristina Hoeppner, Catalyst, Wellington in New Zealand (anitsirk, 08:03:28)
    4. aarowlaptop is Aaron Wells at Catalyst IT, Wellington NZ (aarowlaptop, 08:03:39)
    5. ghada_l is Ghada El-Zoghbi, Catalyst IT, Sydney, Australia (ghada, 08:03:44)

  1. Topics from previous meeting (anzeljg, 08:04:09)
    1. aarowlaptop to update the wiki and readme file to reflect the addition of the two mobile browsers in the supported software. (anzeljg, 08:04:20)
    2. I did that as part of my update to the readme file (anitsirk, 08:04:30)
    3. anitsirk to ask the front-end devs to write up instructions for building a theme under Windows. (anzeljg, 08:04:52)
    4. still need to do that. They are all very busy and didn't have time. (anitsirk, 08:05:09)
    5. anitsirk to update the readme for 15.04 and 15.10 and master in regards to supported versions of Internet Explorer. (anzeljg, 08:11:30)
    6. the readme files are updated and merged (anitsirk, 08:11:39)
    7. anitsirk to create a bug report for the password length. (anzeljg, 08:11:49)
    8. the bug report is at https://bugs.launchpad.net/mahara/+bug/1541171 (anitsirk, 08:12:06)
    9. anitsirk to start a discussion on mahara.org on whether to adopt the Contributor Covenant. (anzeljg, 08:12:19)
    10. I haven't started the covenant conversation yet. (anitsirk, 08:12:46)
    11. anitsirk to set up new bug report for disabling persona auth per default for 16.04 and add warning when about to enable it. (anzeljg, 08:13:14)
    12. that's done at https://bugs.launchpad.net/mahara/+bug/1541173 (anitsirk, 08:13:30)
    13. mingard will work on finding and documenting duplicated sections, and maybe do a bit of a proposal on how we should restructure the scripts generally (anzeljg, 08:13:57)
    14. ACTION: mingard will work on finding and documenting duplicated sections, and maybe do a bit of a proposal on how we should restructure the scripts generally (anzeljg, 08:14:30)

  2. User experience enhancement (anzeljg, 08:17:55)
    1. ACTION: anzeljg will try to create some plans/wireframes for simplifying Mahara create page procedure (anzeljg, 08:21:17)
    2. we still have plans to improve the pages / collection screens and unify them and then have more possibilities in how to deal with pages and collections / thumbnails etc (anitsirk, 08:24:12)
    3. IDEA: inline editing of the block titles would be great (anitsirk, 08:28:25)
    4. one issue will be the more things we stick on one page the more processing will need to be done to make sure all things are valid/current (anitsirk, 08:28:31)
    5. the other tricky thing is figuring out where the page title & description editor can fit in the on-screen real estate (anitsirk, 08:29:36)

  3. Mahara 16.04 (anzeljg, 08:33:40)
    1. calculating back from mid-april, our typical release time, we should try to bring out RC latest on 28 march (anitsirk, 08:35:14)

  4. Next meeting and chair (anzeljg, 08:37:29)
    1. http://www.timeanddate.com/worldclock/fixedtime.html?iso=20160428T07 then? (anzeljg, 08:40:58)
    2. the next, 52nd Mahara developer meeting will take place on 28 April 2016 at 7:00 UTC. anitsirk will chair it. (anzeljg, 08:47:11)
    3. http://www.timeanddate.com/worldclock/fixedtime.html?iso=20160428T07 (anzeljg, 08:47:17)

  5. Any other business (anzeljg, 08:47:26)
    1. the deadline for the next Mahara newsletter is 25 march 2016. Please submit your articles before then to be included in the April issue. (anitsirk, 08:48:51)
    2. Is there a problem connecting multiple Moodle instances to one Mahara? -> No. That is done easily. (anitsirk, 08:56:42)


Meeting ended at 09:01:37 UTC (full logs).

Action items

  1. mingard will work on finding and documenting duplicated sections, and maybe do a bit of a proposal on how we should restructure the scripts generally
  2. anzeljg will try to create some plans/wireframes for simplifying Mahara create page procedure


Action items, by person

  1. anzeljg
    1. anzeljg will try to create some plans/wireframes for simplifying Mahara create page procedure


People present (lines said)

  1. anzeljg (91)
  2. anitsirk (88)
  3. Gregor_Pirker (15)
  4. robertl_ (14)
  5. ghada (13)
  6. aarowlaptop (11)
  7. maharameet-nz (4)


Generated by MeetBot 0.1.4.