08:02:59 <anzeljg> #startmeeting 51st Mahara developer meeting
08:02:59 <maharameet-nz> Meeting started Thu Mar 10 08:02:59 2016 UTC and is due to finish in 60 minutes.  The chair is anzeljg. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:02:59 <maharameet-nz> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:02:59 <maharameet-nz> The meeting name has been set to '51st_mahara_developer_meeting'
08:03:05 <anzeljg> Welcome to the 51st Mahara developer meeting. Please say who you are and prefix that with "#info" so that the meeting minutes pick it up.
08:03:17 <robertl_> #info robertl_ is Robert Lyon, Catalyst in Wellington, New Zealand
08:03:19 <anitsirk> info anitsirk is Kristina Hoeppner, Catalyst, Wellington in New Zealand
08:03:21 <anzeljg> #info anzeljg is Gregor Anželj, developer and translator from Povsod (Ljubljana, Slovenia)
08:03:28 <anitsirk> #info anitsirk is Kristina Hoeppner, Catalyst, Wellington in New Zealand
08:03:39 <aarowlaptop> #info aarowlaptop is Aaron Wells at Catalyst IT, Wellington NZ
08:03:44 <ghada> #info ghada_l is Ghada El-Zoghbi, Catalyst IT, Sydney, Australia
08:04:09 <anzeljg> #topic Topics from previous meeting
08:04:20 <anzeljg> #info aarowlaptop to update the wiki and readme file to reflect the addition of the two mobile browsers in the supported software.
08:04:29 <anzeljg> aaron?
08:04:30 <anitsirk> #info I did that as part of my update to the readme file
08:04:35 <anzeljg> ok
08:04:38 <aarowlaptop> yep
08:04:48 <anzeljg> move on then
08:04:52 <anzeljg> #info anitsirk to ask the front-end devs to write up instructions for building a theme under Windows.
08:05:09 <anitsirk> #info still need to do that. They are all very busy and didn't have time.
08:05:23 <anzeljg> next one...
08:05:28 <anitsirk> However, today we had the problem on our a11y tester's computer. robertl
08:05:34 <anitsirk> did you figure the issue out?
08:05:45 <anitsirk> as that might help for writing the instructions :-)
08:05:57 <anitsirk> or rather robertl_
08:06:03 <robertl_> no he was busy and asked if I could catch up with him tomorrow morning
08:06:14 <robertl_> so hopefully will sort it out then
08:06:18 <anitsirk> sounds good. please take notes.
08:06:23 <robertl_> will do
08:07:02 <robertl_> I'm hoping it's an easy fix but who knows with wamp
08:07:15 <anzeljg> what was the issue?
08:07:25 <anitsirk> we couldn't get gulp to run
08:07:39 <robertl_> he was having problem getting sass/gulp/npm working
08:07:41 <anitsirk> nodejs was installed and gulp was installed but there were warning that i hadn't seen before
08:08:11 <robertl_> I think it was something to do with lib-sass if I remember right
08:08:16 <anitsirk> yep
08:08:25 <anzeljg> yeah, it might be tricky on windows
08:08:44 <anitsirk> anzeljg: are you on windows?
08:08:53 <anzeljg> yes
08:09:00 <anzeljg> xampp stack
08:09:24 <anitsirk> do you happen to have instructions written down for yourself on how to run gulp there? that might help with this problem and also with the overall instructions
08:09:38 <anzeljg> no
08:09:51 <anzeljg> i remember giving it a try, but gave up
08:10:00 <anitsirk> ah. so what do you do?
08:10:03 <anzeljg> will try to install everything again and take notes
08:10:33 <anzeljg> anitsirk: just fetched finished themes and played a bit from there (without sass etc.)
08:10:36 <robertl_> if you do that before 10am Nz tomorrow feel free to email through your findings :)
08:10:49 <anzeljg> ok
08:10:50 <anitsirk> ah right.
08:11:25 <anzeljg> shall we move on
08:11:28 <anitsirk> yep
08:11:30 <anzeljg> #info anitsirk to update the readme for 15.04 and 15.10 and master in regards to supported versions of Internet Explorer.
08:11:39 <anitsirk> #info the readme files are updated and merged
08:11:47 <anzeljg> ok
08:11:49 <anzeljg> #info anitsirk to create a bug report for the password length.
08:12:06 <anitsirk> #info the bug report is at https://bugs.launchpad.net/mahara/+bug/1541171
08:12:16 <anzeljg> we are quick today...
08:12:19 <anzeljg> #info anitsirk to start a discussion on mahara.org on whether to adopt the Contributor Covenant.
08:12:37 <anitsirk> ha. and i need to reply to aaron on it. will do so later
08:12:46 <anitsirk> #info I haven't started the covenant conversation yet.
08:12:51 <anitsirk> it's still on my ToDo list
08:13:12 <anzeljg> ok then.
08:13:14 <anzeljg> #info anitsirk to set up new bug report for disabling persona auth per default for 16.04 and add warning when about to enable it.
08:13:30 <anitsirk> #info that's done at https://bugs.launchpad.net/mahara/+bug/1541173
08:13:55 <anzeljg> almost through last meeting topics...
08:13:57 <anzeljg> #info mingard will work on finding and documenting duplicated sections, and maybe do a bit of a proposal on how we should restructure the scripts generally
08:14:05 <anzeljg> anyone have any information?
08:14:14 <anitsirk> i haven't heard from mingard and he's not here. so let's postpone
08:14:30 <anzeljg> #action mingard will work on finding and documenting duplicated sections, and maybe do a bit of a proposal on how we should restructure the scripts generally
08:14:36 <anitsirk> that was for the removal of mochikit anyway iirc and that's not urgent for 16.04
08:15:35 <anitsirk> Hello Gregor_Pirker. Greetings to Austria
08:15:44 <anzeljg> Gregor_Pirker hi
08:15:47 <Gregor_Pirker> Good morning :-) sry for the delay
08:16:09 <anzeljg> Please introduce yourself with #info
08:16:11 <anitsirk> Gregor_Pirker: we just finished the topics from last time. Been pretty quick this week :-)
08:17:42 <anzeljg> Shall we continue...
08:17:52 <anitsirk> let's
08:17:55 <anzeljg> #topic User experience enhancement
08:18:09 <anzeljg> User of listovnik.sio.si are teachers and students (approx. from 13 to 18 years old). There were reports that mostly students struggle with the use of Mahara and find it quite challenging. The reports say that they would like Mahara to be more modern, especially without menus. Logged-in user's dashboard should contain large buttons instead of menus, so the users have all available options (e.g. create new plan, create new page/coll
08:18:18 <anzeljg> Sharing and tagging should be more prominent and available everywhere througout the site. One way might be that the user's dashboard also contain all their content somehow gruped by the tags.
08:18:27 <anzeljg> When creating new page it would be nice that it would be somehow similar to e.g. GoogleDocs => There should be a page title "Untitled" by default in the same page where users create/design a page (where there are blocks for them to drag-and-drop). And users could change the page's title without leaving it (no use of tabs). Same would be true for description, display of page owner etc.
08:18:35 <anzeljg> I also have to add that we are still running Mahara 1.10 (I think) and that some of this has already been addressed in newer versions. But this should serve as a starting point for debate and/or rethinking the user experience.
08:18:37 <anzeljg> ..
08:19:10 <ghada> yeah, i think we should...
08:19:23 <aarowlaptop> yep, I think that's the right direction for us to head in
08:19:44 <anitsirk> anzeljg: have you done any wireframes or mock-ups around this?
08:20:14 <anzeljg> not yet, since I got the info two days ago and some updates yesterday.
08:20:30 <anitsirk> no worries then ;-)
08:20:43 <anzeljg> will try to investigate some more and create some wireframes and/or entriy in the wiki.
08:20:55 <anitsirk> would be really great if you / the group could get some wireframes done to discuss them with other users
08:21:17 <anzeljg> #action anzeljg will try to create some plans/wireframes for simplifying Mahara create page procedure
08:21:50 <anzeljg> anitsirk: ok
08:22:19 <anitsirk> we still have plans to improve the pages / collection screens and unify them and then have more possibilities in how to deal with pages and collections / thumbnails etc
08:22:41 <anzeljg> what are the plans?
08:22:57 <anzeljg> are they somewhere on the wiki?
08:23:14 <anitsirk> interesting about the buttons on the dashboard. a couple of our ux people didn't develop that idea of a mega menu as there weren't enough items to warrant it.
08:23:42 <anitsirk> anzeljg: don't think they are on the wiki yet. i'll dig up the early drafts and send them through.
08:23:51 <anzeljg> thanks
08:24:04 <anitsirk> there will need to be some changes and since we haven't had time to discuss it further, we didn't develop them further for the time being.
08:24:12 <anitsirk> #info we still have plans to improve the pages / collection screens and unify them and then have more possibilities in how to deal with pages and collections / thumbnails etc
08:24:28 <anitsirk> 16.04 seems to have come around faster than 15.10...
08:24:58 <anzeljg> there is still 16.10 or later version :)
08:25:16 <anitsirk> :-)
08:25:52 <anzeljg> anything else anyone? seems like me and anitsirk are the only ones typing...
08:25:54 <anzeljg> :)
08:26:05 <ghada> and doing a great job at it too!
08:26:10 <anitsirk> i'm good for now and look forward to the wireframes
08:26:42 <anitsirk> Gregor_Pirker: do you get feedback from your students / staff at times or are you planning on getting feedback from them?
08:26:49 <robertl_> yeah, would need to see the wireframes to work out how easy/hard it will be to change things
08:27:15 <anitsirk> and we already mulled over the idea of inline editing for block titles.
08:27:44 <ghada> inline editing of the block titles would be great
08:27:46 <anitsirk> page title might be similar to that.
08:27:58 <robertl_> one issue will be the more things we stick on one page the more processing will need to be done to make sure all things are valid/current
08:28:25 <anitsirk> #idea inline editing of the block titles would be great
08:28:31 <anitsirk> #info one issue will be the more things we stick on one page the more processing will need to be done to make sure all things are valid/current
08:28:31 <anzeljg> anitsirk: and adding page description probably too
08:28:38 <aarowlaptop> I think the other tricky thing is figuring out where the page title & description editor can fit in the on-screen real estate
08:28:44 <aarowlaptop> well, title's fairly easy
08:28:52 <aarowlaptop> you just display it where it currently is, and make that toggle-able into an editor
08:29:03 <anitsirk> anzeljg: not sure. those might be trickier as they could take up a lot of space and aren't visible when you currently edit a page.
08:29:13 <robertl_> expand/collapse an area to edit it maybe
08:29:30 <anzeljg> that would probably work?
08:29:32 <anitsirk> 3info the other tricky thing is figuring out where the page title & description editor can fit in the on-screen real estate
08:29:36 <anitsirk> #info the other tricky thing is figuring out where the page title & description editor can fit in the on-screen real estate
08:30:19 <Gregor_Pirker> my plan in next two month is to bring Mahara.at on the last stand and for the ats2020 project i will try the mahara version 16.10 I am very excited :-) after it i can give you a lot of feedback ;-)
08:30:42 <anitsirk> fantastic, Gregor_Pirker. look forward to the end of the year then :-)
08:30:46 <anzeljg> looking forward to that!
08:32:08 <anzeljg> anything else? anyone?
08:32:44 <anitsirk> not anymore
08:32:52 <anzeljg> we on to the dreaded topic then:
08:32:53 <anzeljg> #topic Next meeting and chair
08:32:58 <anitsirk> anzeljg: not quite
08:33:04 <anzeljg> ok
08:33:07 <anitsirk> i sneakily added a late topic ;-)
08:33:17 <anitsirk> can you do an undo please?
08:33:29 <anzeljg> #undo
08:33:29 <maharameet-nz> Removing item from minutes: <ircmeeting.items.Topic object at 0x7f1b94e11210>
08:33:37 <anzeljg> sorry anitsirk...
08:33:40 <anitsirk> np
08:33:40 <anzeljg> #topic Mahara 16.04
08:33:57 <anitsirk> this is more of a quick update of "the plan".
08:34:08 <anitsirk> we are already well into March and there are not that many weeks left.
08:34:35 <anitsirk> calculating back from mid-april, our typical release time, we should try to bring out RC latest on 28 march
08:34:57 <anitsirk> to give us about 3 weeks for rc and high importance bugs before the final release of
08:35:01 <anitsirk> drumroll
08:35:02 <anitsirk> 16.04
08:35:06 <anzeljg> yay
08:35:14 <anitsirk> #info calculating back from mid-april, our typical release time, we should try to bring out RC latest on 28 march
08:35:35 <anitsirk> so, if you know anybody who has some spare time on their hands and wants to review patches...
08:36:01 <anitsirk> that's it from me on this topic for the moment.
08:36:10 <anzeljg> call for reinforcements...
08:37:29 <anzeljg> #topic Next meeting and chair
08:37:39 <anzeljg> I was thinking about http://www.timeanddate.com/worldclock/fixedtime.html?iso=20160421T07 or is it too late?
08:38:12 <aarowlaptop> 7pm in Wellington
08:38:28 <aarowlaptop> so that's fine for us
08:38:30 <anitsirk> that date won't work for me. i'll not be back in wellington until about 7 if all goes well
08:38:59 <anzeljg> a week earlier?
08:39:15 <robertl_> what about the week later - we should have the next release out by then
08:39:25 <anzeljg> good idea...
08:39:32 <robertl_> and can celebrate!
08:39:41 <anitsirk> that looks better
08:39:48 <anitsirk> either is fine by me
08:40:03 <anitsirk> just not so much the week of the 17th
08:40:54 <anitsirk> 28th then?
08:40:58 <anzeljg> http://www.timeanddate.com/worldclock/fixedtime.html?iso=20160428T07 then?
08:41:09 <anzeljg> oh...
08:41:22 <anitsirk> yes. sounds good
08:42:11 <anzeljg> what about others?
08:42:19 <aarowlaptop> sounds good to me
08:42:34 <Gregor_Pirker> oh on my holiday :-) will try to stand up in the morning ;-)
08:42:49 <anitsirk> oh is it easter break?
08:43:12 <anzeljg> anitsirk: no, more 1st May thing...
08:43:12 <Gregor_Pirker> no this is in the end of march
08:43:40 <anitsirk> anzeljg: wow. we ever only got the 1st of may off but not more than that.
08:43:41 <Gregor_Pirker> anzeljg :-) correct^^
08:43:55 <anzeljg> easter break is a mont pripor
08:44:05 <anzeljg> sorry, my mistake
08:44:27 <anzeljg> i meant that easter break is about a month pripor to our next meeting
08:44:27 <anitsirk> that was a grand mistake, anzeljg. made my evening :-)
08:44:42 <ghada> the orthodox easter is in April
08:45:13 <Gregor_Pirker> but the 28.04 is for me ok
08:45:19 <anzeljg> so, who wants to be the chair of our next meeting?
08:45:20 <ghada> me too
08:46:20 <anitsirk> anzeljg: i doubt anybody will say anytime soon. i'm happy to chair
08:46:36 <anzeljg> you get to poen virtual champagne than...
08:46:38 <anzeljg> thanks.
08:46:41 <aarowlaptop> Thanks anitsirk
08:46:44 <anitsirk> :-)
08:46:46 <anzeljg> poen=open
08:47:11 <anzeljg> #info the next, 52nd Mahara developer meeting will take place on 28 April 2016 at 7:00 UTC. anitsirk will chair it.
08:47:17 <anzeljg> #link http://www.timeanddate.com/worldclock/fixedtime.html?iso=20160428T07
08:47:26 <anzeljg> #topic Any other business
08:47:30 <anitsirk> i have one
08:47:39 <anzeljg> anyone else?
08:47:50 <ghada> nope
08:48:01 <aarowlaptop> nope
08:48:25 <anzeljg> robertl_, Gregor_Pirker?
08:48:48 <anzeljg> anitsirk: it's your stage then...
08:48:51 <anitsirk> #info the deadline for the next Mahara newsletter is 25 march 2016. Please submit your articles before then to be included in the April issue.
08:49:00 <anitsirk> that was it
08:49:09 <anzeljg> short and sweet
08:49:16 <robertl_> nothing from me
08:49:35 <anzeljg> anyone wants to add something else, or shall we end the meeting?
08:49:52 <Gregor_Pirker> i have a little question
08:50:00 <anzeljg> go for it
08:50:55 <Gregor_Pirker> at the moment i will try to use mahoodle with one mahara and more moodle i have test and at the moment i didn´t find any problem
08:51:46 <Gregor_Pirker> do everybody know any problems with that
08:51:57 <Gregor_Pirker> ?
08:52:01 <Gregor_Pirker> :-)
08:52:05 <anitsirk> Gregor_Pirker: there shouldn't be a problem
08:52:08 <ghada> so you have more than one Moodle ?
08:52:26 <anitsirk> the only thing you can't do is connect one moodle to multiple institutions in your mahara instance. but connecting many moodles to 1 mahara is fine
08:52:51 <anitsirk> will the users be different in the moodle instances or will they all have accounts in each?
08:53:52 <Gregor_Pirker> yes for a projekt we will try to use one mahara in austria and some pilot school will use moodle an connect with our mahara
08:54:28 <anzeljg> so each pilot school will have it's own moodle, but they will all connect to one mahara?
08:54:30 <anitsirk> that's fine. not every user needs to have the same authentication method.
08:54:32 <Gregor_Pirker> they have each accounts in the moodle
08:54:49 <ghada> anitsirk: can you connect several moodles to one mahara institution - i.e. several xmlrpc's in the institution?
08:54:54 <anitsirk> Gregor_Pirker: so every user has an account in every moodle?
08:55:00 <anitsirk> ghada: yep
08:55:05 <ghada> ok
08:55:32 <anitsirk> but generally, you have one moodle auth instance in one mahara institution so you can manage your users by institution
08:55:56 <anitsirk> that way you can give them their institution theme, they can have different messages on the dashboard etc.
08:56:42 <anitsirk> #info Is there a problem connecting multiple Moodle instances to one Mahara? -> No. That is done easily.
08:57:25 <anzeljg> anitsirk: I would guess no. I guess that schools will have separate moodles, so a student from certain school will have an account only on that moodle and not on other ones. But they will all connect to one mahara. Gregor_Pirker: Am I right?
08:57:58 <ghada> are you worried that a users may have more than one user account in Mahara?
08:58:01 <Gregor_Pirker> yes this is right :-=
08:58:07 <anitsirk> anzeljg: i suspect that you are right. just confirming with Gregor_Pirker in german. :-)
08:58:08 <Gregor_Pirker> :-)
08:58:52 <anzeljg> anitsirk: alles klar
08:58:53 <anitsirk> ghada: yes. that would have been my worry. the usersuniquebyusername value can prevent that. but we don't have to worry about that in this case
08:59:33 <ghada> ok
09:00:29 <anzeljg> anything else? anyone?
09:01:00 <ghada> no, i'm good.
09:01:06 <anitsirk> nope
09:01:37 <anzeljg> #endmeeting