#mahara-dev Meeting

Meeting started by robertl_ at 08:05:28 UTC (full logs).

Meeting summary

    1. anitsirk is Kristina Hoeppner, Catalyst IT, Wellington, NZ (anitsirk, 08:05:44)
    2. robertl_ is Robert Lyon, Catalyst IT, Wellington, NZ (robertl_, 08:05:48)
    3. tobiasz is Tobias Zeuch, developer at KIT, Karlsruhe, Germany (tobiasz, 08:06:02)
    4. son is Son Nguyen, Catalyst IT, Wellington, NZ (son, 08:06:54)
    5. anzeljg is Gregor Anželj, developer and translator from Gimnazija Bežigrad, Ljubljana, Slovenia (anzeljg, 08:07:11)
    6. aarowlaptop is Aaron G. Wells from Catalyst IT in Wellington, NZ (aarowlaptop, 08:08:33)

  1. Items from last meeting (robertl_, 08:09:26)
    1. anitsirk to check if another catalyst dev can upgrade the mahara gerrit since we are upgrading our internal one as well. (robertl_, 08:09:35)
    2. anitsirk to adjust the help text to show the correct number of days that certain messages are deleted. (robertl_, 08:10:40)
    3. robertl to write up notes of how to deal with patches that one person started and another continued and then hands back (robertl_, 08:11:09)
    4. Nigel Cunningham from Catalyst - Melbourne (nigelc1, 08:21:51)
    5. ACTION: robert_ look into the reviews permissions to see if this problem can be avoided and/or update the wiki page with more info (robertl_, 08:27:42)
    6. tobiasz tries to implement an automatic conversion of all reusable text-boxes that aren't copied so far to plain ones. (robertl_, 08:28:23)

  2. Discuss the allowing of Ghada to the security review group (robertl_, 08:41:22)
    1. ACTION: robertl_ send email to +2 reviewers to vote on Ghada to security team (robertl_, 08:46:49)
    2. Vote for Ghada to become member of the security review as it’s beneficial to be able to talk to someone in a similar timezone. She also did a great job for the last security issue and also reviews in general. (anitsirk, 08:47:08)

  3. Discuss the Social profile addresses feature (robertl_, 08:47:27)
    1. IDEA: : robert was talking about removing messaging artefacts:icq, skype, etc. the big issue was how difficult it would be to remove the old types and still have things like import/export still work (anitsirk, 08:56:41)
    2. ACTION: anzeljg to report back on how much more work is needed to get the converting of old types to new socialprofile types and whether import/export will still work (robertl_, 08:58:48)

  4. Discuss the Question plugin (robertl_, 08:59:50)
    1. who can pick best answer? tobiasz says he considers a right for /edit the question/, that is provided to the author and admins, and I thought it consinstent to provide that same right also to "pick the best answer" (anitsirk, 09:07:57)
    2. questions will be implemented as personal artefacts initially and not as group artefacts. (anitsirk, 09:14:40)
    3. IDEA: keep things simple for the beginning and not worry about attachments. but just have questions, answers and comments. (anitsirk, 09:22:34)
    4. turning off attachments on comments would be more difficult as comments, i.e. feedback comes with attachments built-in and there is no switch to turn attachmens off there. (anitsirk, 09:23:45)
    5. IDEA: : turn off attachments on comments on answers in the question plugin but keep attachments on feedback (anitsirk, 09:27:56)

  5. Next meeting and chair (robertl_, 09:28:55)
    1. the 36th Developer Meeting will take place on 25th September at 8:00 UTC: http://www.timeanddate.com/worldclock/fixedtime.html?msg=Mahara+36th+Developer+Meeting&iso=20140925T08 (robertl_, 09:38:30)

  6. Any other business (robertl_, 09:39:01)
    1. IDEA: make it default for people who have a registered account to be able to verify things. (anitsirk, 10:05:00)
    2. the ui freeze is coming closer. thus, if you have time to review patches that have already been submitted, any help would be appreciated. (anitsirk, 10:09:15)


Meeting ended at 10:12:05 UTC (full logs).

Action items

  1. robert_ look into the reviews permissions to see if this problem can be avoided and/or update the wiki page with more info
  2. robertl_ send email to +2 reviewers to vote on Ghada to security team
  3. anzeljg to report back on how much more work is needed to get the converting of old types to new socialprofile types and whether import/export will still work


Action items, by person

  1. anzeljg
    1. anzeljg to report back on how much more work is needed to get the converting of old types to new socialprofile types and whether import/export will still work
  2. robertl_
    1. robertl_ send email to +2 reviewers to vote on Ghada to security team


People present (lines said)

  1. robertl_ (136)
  2. anitsirk (95)
  3. anzeljg (60)
  4. tobiasz (49)
  5. aarowlaptop (36)
  6. son (5)
  7. nigelc1 (5)
  8. maharameet (3)
  9. nigelc_ (3)


Generated by MeetBot 0.1.4.