08:05:28 <robertl_> #startmeeting
08:05:28 <maharameet> Meeting started Thu Aug 14 08:05:28 2014 UTC.  The chair is robertl_. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:05:28 <maharameet> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:05:35 <robertl_> Hello and welcome to the 35th Mahara Developer Meeting
08:05:41 <robertl_> Please let us know who you are with fronting your intro using #info
08:05:44 <anitsirk> #info anitsirk is Kristina Hoeppner, Catalyst IT, Wellington, NZ
08:05:48 <robertl_> #info robertl_ is Robert Lyon, Catalyst IT, Wellington, NZ
08:06:02 <tobiasz> #info tobiasz is Tobias Zeuch, developer at KIT, Karlsruhe, Germany
08:06:54 <son> #info son is Son Nguyen, Catalyst IT, Wellington, NZ
08:07:11 <anzeljg> #info anzeljg is Gregor Anželj, developer and translator from Gimnazija Bežigrad, Ljubljana, Slovenia
08:07:41 <robertl_> Just a note: If you have something long to say, please put .. on a line by itself once you are done to indicate the end of a long statement.
08:07:49 <robertl_> And please feel free to use meetbot commands yourself to put something into the minutes, e.g. by using #info or #idea where appropriate / wanted
08:07:56 <robertl_> hi aarowlaptop
08:08:01 <aarowlaptop> Hello!
08:08:03 <robertl_> the meeting just started
08:08:19 <robertl_> please do your info
08:08:33 <aarowlaptop> #info aarowlaptop is Aaron G. Wells from Catalyst IT in Wellington, NZ
08:09:01 <robertl_> is that everybody?
08:09:08 <anitsirk> looks like it for the moment
08:09:23 <robertl_> ok, on with the show
08:09:26 <robertl_> #topic Items from last meeting
08:09:35 <robertl_> #info anitsirk to check if another catalyst dev can upgrade the mahara gerrit since we are upgrading our internal one as well.
08:09:49 <robertl_> is anything happened with that?
08:10:01 <anitsirk> still needs to be done. awaiting a reply
08:10:22 <anitsirk> only just followed up on that due to travels.
08:10:32 <robertl_> ok then, onto next item
08:10:40 <robertl_> #info anitsirk to adjust the help text to show the correct number of days that certain messages are deleted.
08:10:50 <anitsirk> i’ll do that as part of the general lang string review for the next release
08:11:02 <robertl_> ok cool - this is going nice and fast
08:11:09 <robertl_> #info robertl to write up notes of how to deal with patches that one person started and another continued and then hands back
08:11:16 <robertl_> I added some notes here: https://wiki.mahara.org/index.php/Developer_Area/Pushing_Git_Commits#Problems_with_pushing_patches_to_gerrit
08:11:39 <robertl_> so feel free to expand on them if there are other use-cases
08:11:47 <robertl_> where pushing commits fails
08:12:30 <anitsirk> robertl_: but changing the author, doesn’t that mean that the author is cahnged for the entire patch? i.e. if someone did most of the work but the final corrector only did a small thing, is the second one then listed as author?
08:13:17 <son> Can we add multiple authors in one patch?
08:13:22 <anitsirk> or is that second person only added as additional author?
08:13:26 <aarowlaptop> no, git commits can only have one author
08:13:42 <robertl_> usually this occurs when one of us +2 people tweak a patch and then original writer can't push it
08:13:52 <robertl_> when they make changes
08:13:56 <aarowlaptop> In most projects the "Signed off by" represents additional people who've worked on the project
08:14:06 <aarowlaptop> I mean, commit
08:15:22 <anitsirk> robertl_: so when you +2 people tweak a patch, you aren’t changing the author line, right?
08:16:17 <robertl_> hmm, maybe it happens when a non +2 wants to tweak one of our patches
08:16:38 * robertl_ doesn't see this error as he has +2 permissions
08:16:57 <robertl_> but changing the author has worked for others
08:17:32 <robertl_> as I say - feel free to adjust the info there if it is not correct
08:17:41 <anitsirk> it just might not reflect the correct authorship properly.
08:17:55 <anitsirk> but i have no idea whether there is something that should be done differently.
08:18:02 <anitsirk> did someone ask the gerrit people?
08:19:18 <tobiasz> I think it happened to me, when I tried to submit to my own patch after one of the +2-authors had committed something, so it looks like the +2-authors change the author, otherwise the explicit author-tag wouldn't help, right?
08:19:23 <robertl_> I took the info from here: http://review.cyanogenmod.org/Documentation/error-invalid-author.html
08:19:49 <son> Hi nigelcl
08:20:36 <nigelc1> Hi all. What am I supposed to say for the bot?
08:21:13 <robertl_> which looks to be the manual pages of gerrit in web form
08:21:29 <robertl_> you need to go #info  and state who you are
08:21:40 <nigelc1> Ah. Thanks.
08:21:51 <nigelc1> #info Nigel Cunningham from Catalyst - Melbourne
08:22:36 <aarowlaptop> The advice on the wiki page looks correct to me
08:22:37 <anitsirk> robertl_: or would it rather have to be: “If pushing to Gerrit fails with the error message "invalid author" and somebody else is author of the commit for which the push fails, then you have no permissions to forge the author identity. In this case you may contact the project owner to request the access right +1 Forge Author Identity in the Forge Identity category or ask the maintainer to commit this change on the author’s behalf.”
08:23:43 <anitsirk> it seems to me that changing the author on a commit where the original author should have stayed the same wouldn’t be the best solution as we’d alter who’s done most of the work. maybe it’s rather a permissions thing that can be set in gerrit as the above info suggests if i’m reading it correctly.
08:24:59 <robertl_> it's worth looking into - if it's just a perms change then that would be good
08:25:33 <aarowlaptop> I guess we could add on an instruction telling people that they can request a core dev to change the author if need be
08:26:04 <robertl_> #action look into the reviews permissions to see if this problem can be avoided and/or update the wiki page with more info
08:26:35 <robertl_> I'll look some more into that
08:26:41 <anitsirk> thanks
08:26:52 <anitsirk> robertl_: can you please set that action for yourself?
08:26:56 <anitsirk> you may want to #undo
08:26:57 <tobiasz> tough it might be interesting to see, if a +2-committer automatically changes the author, for anitsirks concern
08:27:16 <anitsirk> the last item from the agenda and redo it with your name in it ;-)
08:27:27 <robertl_> #undo look into the reviews permissions to see if this problem can be avoided and/or update the wiki page with more info
08:27:27 <maharameet> Removing item from minutes: <MeetBot.items.Action object at 0x12bb7d0>
08:27:42 <robertl_> #action robert_ look into the reviews permissions to see if this problem can be avoided and/or update the wiki page with more info
08:27:51 <robertl_> like that you mean?
08:27:54 <anitsirk> yep
08:28:07 <robertl_> cool
08:28:21 <robertl_> ok next item
08:28:22 <anitsirk> that way the minutes know who is the person for the action :-)
08:28:23 <robertl_> #info tobiasz tries to implement an automatic conversion of all reusable text-boxes that aren't copied so far to plain ones.
08:28:37 <robertl_> tobiasz, how is this coming along?
08:29:12 <tobiasz> I've uploaded a patch that lets you convert all text boxes into simple text boxes from the configuration of the block type
08:29:43 <anitsirk> tobiasz: sorry, haven’t had time to look at it. does it convert all of them or just the ones that haven’t been used multiple times?
08:29:46 <tobiasz> That is, all that don't have any special features, like license, attachments or reuse
08:29:47 <robertl_> what types of restrictions are in place - o can you convert any
08:29:56 <anitsirk> thanks for the quick answer :-)
08:29:56 <robertl_> ah ok
08:30:29 <robertl_> is it  one time deal or can you go back an forth?
08:30:56 <robertl_> and is it per textbox block ? or site wide?
08:31:04 <tobiasz> it's a one time deal, so far
08:31:28 <tobiasz> and it's site wide, all text boxes, that match the criteria
08:31:59 <robertl_> cool - sounds easy enough to test
08:32:08 <robertl_> will try and get to that asap
08:32:34 <tobiasz> I thought about listing the text boxes and let the admin untick single blocks, but I can't imagine that being practical unless all the users stand behind the admin, when he's doing that
08:32:51 <anitsirk> tobiasz: i agree and wouldn’t think it would be practical.
08:33:26 <robertl_> anyone else have more questions on the items from last meeting?
08:33:30 <anitsirk> they’d have to look at every single scrap of word. even a small portfolio can easily have 50 text boxes esp. if you copy templates. just multiply that...
08:34:17 <tobiasz> do you think that is sufficient so far, or do the simple text boxes need an option to be converted (only that single one) into a reusable text box?
08:34:33 <robertl_> textbox would definitely be one of the most used blocks
08:35:06 <robertl_> ok we good to move on?
08:35:41 <tobiasz> also, the simple text box is now called "text" and robertl_ submitted a patch to rename the old text boxes to "note"
08:36:08 <robertl_> yep I felt just changing the text strings would be fine for that
08:36:14 <anitsirk> tobiasz: i think we said to keep it simple for the beginning.
08:36:20 <robertl_> like we did with blog to journal
08:36:29 <anitsirk> and thus not do any text to note conversion.
08:36:57 <anitsirk> yep. we talked about the strings on monday and thus “text” and “note” :-)
08:37:18 <robertl_> is the conversion bit part of the 'extensions' admin section?
08:37:21 <anitsirk> but for the plugin name: would there be any confusion?
08:37:28 <anitsirk> what does it currently say?
08:38:02 <tobiasz> anitsirk: I've had a look at the patch, every string that appears to the user, is changed into "text"
08:38:04 <robertl_> my patch changes the title of the plugin from textbox to note
08:38:14 <tobiasz> sorry, "note" of course
08:38:42 <robertl_> so even in the extensions -> plugin list in admin it says 'note'
08:38:55 <anitsirk> just had a look at the extensions page and i think the current textbox is just “html”. there is no mention of “textbox"
08:39:08 <anitsirk> robertl_: ah. that’s good
08:39:15 <tobiasz> robert: exactly, the option is /hidden/ in the configuration from the extension page
08:40:17 <robertl_> there is a file/html but that is different to internal/textbox
08:40:40 <robertl_> it will be the internal/textbox that becomes internal/note
08:41:10 <anitsirk> sorry. was looking under artefact and not blocktype. you are right, robertl_
08:41:20 <robertl_> ok moving forward
08:41:22 <robertl_> #topic Discuss the allowing of Ghada to the security review group
08:41:51 <robertl_> when I had to get out the recent update I found Ghada a big help
08:42:09 <robertl_> and so was wondering if she should be part of the security group
08:42:16 <robertl_> what do others think?
08:42:36 <anitsirk> +1
08:42:46 <anitsirk> (but I can’t really vote ;-) )
08:43:03 <tobiasz> I think she did a great reviewers job on the new user message system, +1
08:43:16 <robertl_> I found it useful having another member in a similar timezone when wgtn folks were on holiday/sick
08:43:33 <robertl_> son:  what do you think?
08:43:44 <robertl_> +1 form me also
08:44:36 <anzeljg> +1 (I also can't vote)
08:45:04 <son> +1
08:45:35 <robertl_> anitsirk, do you know how many counting votes do we need?
08:45:58 <anitsirk> robertl_: there are not enough voting members here to make a decision. i suggest we send an email to all +2 reviewers and vote via email
08:46:13 <robertl_> that sounds a plan
08:46:14 <anitsirk> there’s basically robertl_ and son only here who can vote.
08:46:40 <tobiasz> isn't anzeljg a +2 reviewer?
08:46:45 <anzeljg> nope
08:46:49 <robertl_> #action robertl_ send email to +2 reviewers to vote on Ghada to security team
08:47:08 <robertl_> ok next item
08:47:08 <anitsirk> #info Vote for Ghada to become member of the security review as it’s beneficial to be able to talk to someone in a similar timezone. She also did a great job for the last security issue and also reviews in general.
08:47:25 <robertl_> ta anitsirk
08:47:27 <robertl_> #topic Discuss the Social profile addresses feature
08:47:42 <anzeljg> I just wanted to discuss further Robert's comment on this feature at https://reviews.mahara.org/#/c/2936/
08:47:44 <robertl_> anzeljg, I believe that is your one
08:47:55 <anzeljg> The comment was: "It would be good to also transform the existing message types into the 'socialprofile' type - that way we could get rid of a bunch of obsolete options (and code associated with them)."
08:48:02 <anzeljg> What do others think?
08:48:05 <anzeljg> ..
08:48:41 <anzeljg> robert was talking about removing messaging artefacts:icq, skype, etc. Right?
08:49:03 <robertl_> it was discussed at mahara hq and if I remember right we were for converting the old style to new style
08:49:18 <anitsirk> agree. would be good to be more consistent esp. since many will probably not have used those “ancient” messaging types. we’d have to convert them though as some people might have repurposed them for other messaging types by just changing the lang strings.
08:49:18 <anzeljg> oh I see...
08:49:43 <robertl_> the big issue was how difficult it would be
08:49:57 <anzeljg> what do you mean?
08:50:15 <robertl_> to remove the old types and still have things like import/export still work
08:50:25 <tobiasz> robertl_: "new style" means, user defined field names? Or side-wide defined?
08:50:53 <tobiasz> *"site wide" instead of side-wide
08:50:54 <robertl_> fields defined as artefacttype socialprofile
08:51:35 <robertl_> the current patch, if i'm right, allows one to add label/value pairs
08:51:44 <anzeljg> tobiasz: they are user defined descriptions, but in the case of the upgrade I think the descriptions would (initially) have to be set from existing lang strings
08:51:48 <robertl_> and they are all stored as the same artefacttype
08:52:15 <tobiasz> ok, thanks. That sounds good to me
08:52:16 <robertl_> is that right anzeljg
08:52:18 <robertl_> ?
08:52:33 <anzeljg> what robert_?
08:52:44 <anzeljg> they are label/value
08:53:14 <anzeljg> and the labels in the upgrade process will be set from existing lang strings for icq, skype etc.
08:54:24 <robertl_> there was talk about the removal of a bunch of php code relating to the old types
08:55:02 <robertl_> that is part of the 'still to do' stuff
08:55:02 <anzeljg> yes as a result from converting the old artefacttypes to new ones right?
08:55:12 <robertl_> yep
08:55:59 <robertl_> anzeljg, any idea how much more work is needed to get that in and all merge ready?
08:56:16 <robertl_> a little, a lot?
08:56:31 <anzeljg> I thnik that import/export should work, but it has to be tested.
08:56:41 <anitsirk> #idea: robert was talking about removing messaging artefacts:icq, skype, etc. the big issue was how difficult it would be to remove the old types and still have things like import/export still work
08:57:13 <anzeljg> if it works, then I guess it is not a lot of work
08:57:37 <anzeljg> I can try that locally and report back
08:57:48 <robertl_> ok cool
08:58:33 <aarowlaptop> Whoops, I was disconnected for a while there
08:58:48 <robertl_> #action anzeljg to report back on how much more work is needed to get the converting of old types to new socialprofile types and whether import/export will still work
08:59:20 <anzeljg> will do :)
08:59:43 <robertl_> ok, moving on to the next one
08:59:50 <robertl_> #topic Discuss the Question plugin
09:00:01 <robertl_> tobiasz, this is your plugin
09:00:40 <tobiasz> well, it was based on the paper from the totara social plan
09:01:33 <tobiasz> I think, most of the basic functionality is there, I wanted to add a better search/filter for questions and a block type
09:01:40 <robertl_> I was a little confused about when questions should be editable and when they shouldn't
09:02:14 <robertl_> as I was worried one could change the question after people had answered
09:02:27 <tobiasz> yep, the way I thought it was, that "open" means "open for answers", but I noticed that this caused a little confusion
09:02:36 <robertl_> and so could totally change the relevance of their answers
09:03:05 <tobiasz> actually, I thought so initially, but I agree that this was a bad idea
09:03:25 <tobiasz> ... changing the question text after someone has already answered
09:03:35 <anitsirk> #info most of the basic functionality is there, tobiasz wanted to add a better search/filter for questions and a block type
09:04:42 <robertl_> also should all admins be allowed to pick best answer or should it only be the question creator?
09:05:25 <anitsirk> what about staff? wouldn’t they sometimes be better suited than admins?
09:05:53 <tobiasz> so far, I consider a right for /edit the question/, that is provided to the author and admins, and I thought it consinstent to provide that same right also to "pick the best answer"
09:06:33 <aarowlaptop> Makes sense that a question author should be able to pick which answer they think is best
09:07:13 <tobiasz> I think, on a code level, admin checks "admin for this user", so that might include staff, but I'm not sure
09:07:22 <tobiasz> I'll have a closer look on that
09:07:57 <anitsirk> #info who can pick best answer? tobiasz says he considers a right for /edit the question/, that is provided to the author and admins, and I thought it consinstent to provide that same right also to "pick the best answer"
09:08:41 <tobiasz> aarowlaptop: yep, the author should always have the right to pick the best answer. What we were unclear about was, if the admin also should have that right
09:09:11 <anitsirk> tobiasz: thanks. we need to keep in mind that admins are often that: admins and not really involved in the day to day content use of the application. thus, the next best thing would be staff if you want to give some people more privileges and not just anyone
09:09:55 <aarowlaptop> Ah, I see. Well usually, only artefact owners/authors are allowed to edit their artefacts. So it should probably be the same for questions
09:10:03 <aarowlaptop> if they are a type of artefact
09:10:37 <tobiasz> they are artefacts. Ok, makes sense to me
09:11:13 <robertl_> Another thing I noticed was questions can have comments added to them as well as answers , and that answers can also have comments - my query was should those comments be allowed to have attachements?
09:11:16 <tobiasz> so, maybe additional staff get's the right with an option?
09:11:44 <anitsirk> what do you mean “with an option"?
09:12:04 <anzeljg> that the author/owner has the option to allow staff the right
09:12:18 <aarowlaptop> I think the only situation where it would make sense for multiple people to be able to edit or administer a question, would be if questions can be created as group artefacts
09:12:55 <aarowlaptop> ... and/or maybe also if questions can be created as site-level or institution-level artefacts?
09:13:16 <anitsirk> i would normally only give the right to choose the best answer, but not to alter the question (unless it’s a question in a group and then the same rules could apply that apply to pages: decide who can edit)
09:13:24 <tobiasz> ok, they don't work as group artefacts so far, so I'll skip those additional rights for the moment
09:13:54 <anzeljg> that's what i thought: that the author/owner has the option to give staff the right to choose the best answer (not to edit the question)
09:14:20 <robertl_> we can alway get it working for the individual first before tackling groups/insititutions
09:14:40 <anitsirk> #info questions will be implemented as personal artefacts initially and not as group artefacts.
09:14:42 <aarowlaptop> Yes
09:14:47 <tobiasz> ok
09:15:57 <aarowlaptop> I'd rather avoid having the option, on a personal question artefact, to give partial control of it to other users. We don't have any other personal artefacts that act that way, and I think it could open up a lot of complexities.
09:17:13 <tobiasz> about the comments: in general I imagine it to be usefull to add files in comments, though it's not a must-have from my point of view
09:18:17 <robertl_> I just wonder that with questions/answers/likes/comments all being part of this that it could get a little messy/confusing
09:18:44 <robertl_> if one can do comment attachments also
09:18:59 <robertl_> but if others are fine with it I'll not fight it :)
09:19:00 <aarowlaptop> agreed
09:19:08 <aarowlaptop> hm
09:19:21 <aarowlaptop> Well, on the one hand it's nice to be consistent
09:19:28 <robertl_> true
09:19:57 <aarowlaptop> I can see how people might do a question like "Attach a word document with ... in it"
09:20:14 <aarowlaptop> Oh, but it's the comments that have attachments, not the answers, huh?
09:20:23 <robertl_> yep, the comments
09:20:32 <aarowlaptop> I guess I could go either way on this one. :-\
09:21:01 * robertl_ thinking of stackoverflow - where there are questions / answers / comments
09:21:04 <tobiasz> hmm, good point. Attachments on answers would make more sense
09:21:09 <robertl_> but no attachments
09:21:42 <aarowlaptop> right
09:22:04 <anzeljg> robertl_: agree, we can always complicate things later :)
09:22:34 <anitsirk> #idea keep things simple for the beginning and not worry about attachments. but just have questions, answers and comments.
09:22:49 <robertl_> the problem here is comments have attachments built in - so the complication would be to not have them :)
09:22:51 <tobiasz> about the complication: Does anybody know if there's a switch to turn off attachments for comments? I found the comment code in general rather difficult to adjust
09:23:07 <robertl_> I looked, there isn't
09:23:20 <robertl_> it's an all or nothing deal at the moment
09:23:39 <tobiasz> maybe I can just hide them on CSS?
09:23:45 <anitsirk> #info turning off attachments on comments would be more difficult as comments, i.e. feedback comes with attachments built-in and there is no switch to turn attachmens off there.
09:23:53 <robertl_> but that switch should be added - as a institution setting
09:24:07 <robertl_> or site setting
09:24:11 <robertl_> I believe
09:24:45 <robertl_> even if it's not for this change in particular
09:24:48 <anitsirk> i quite like the attachments as they allow for richer feedback than just text
09:25:08 <anitsirk> like audio commentary or even a video if you so wanted. we want to promote the use of multimedia in a portfolio and not just text...
09:25:31 <anitsirk> maybe it would be better to keep attachments on regular feedback, but not allow attachments on comments.
09:26:01 <robertl_> have some demarkation of where to have attachments and where not to
09:26:11 <robertl_> that sounds ok
09:26:57 <tobiasz> anitsirk: I don't think, robertl_ wanted to turn off attachments on feedback in general, just add a switch to deactivate them on comments on the answers in the question plugin (and other artefacts)
09:27:26 <robertl_> yeah - that's the idea I've come round to
09:27:56 <anitsirk> #idea: turn off attachments on comments on answers in the question plugin but keep attachments on feedback
09:28:35 <robertl_> ok any more questions about the Question plugin?
09:28:43 <anitsirk> nope. not at the moment.
09:28:53 <robertl_> right then
09:28:55 <robertl_> #topic Next meeting and chair
09:29:32 <robertl_> so who would like to volunteer to be the chair?
09:30:19 <anitsirk> i can do it
09:30:20 <robertl_> anyone?
09:30:24 <robertl_> thank anitsirk
09:30:25 <tobiasz> maybe fix the date first?
09:30:30 <anitsirk> ;-)
09:30:41 <robertl_> ah true that might help
09:31:00 <anzeljg> anitsirk was too fast for all of us ;)
09:31:10 <anitsirk> i waited a whole minute ;-)
09:31:17 <anzeljg> indeed... :)
09:31:28 <anitsirk> wanted to put robertl_ out of his misery
09:31:57 <anzeljg> wow, commendable :)
09:32:19 <robertl_> I haven't been that bad have I?
09:32:28 <anzeljg> not at all!
09:32:37 <anitsirk> nah. just meant the misery of having to find a volunteer
09:33:38 <anzeljg> what about the last week of September?
09:34:08 <nigelc1> Sorry guys - keep dropping out tonight. Not that I'd have much to say anyway :)
09:34:08 <anitsirk> week of 22nd?
09:34:37 <anzeljg> yep
09:34:38 <tobiasz> week of 22nd sounds good to me
09:34:42 <robertl_> that will just be before the release of 1.10
09:34:43 <anitsirk> that would work
09:34:52 <robertl_> so we'll have something to discus right there
09:35:08 <robertl_> week of 22nd sounds fine to me
09:35:23 <robertl_> which actual day/night though?
09:35:23 <anitsirk> shall we say thursday again to stay consistent?
09:35:37 <robertl_> that's ok with me
09:35:56 <aarowlaptop> me too
09:36:02 <tobiasz> me too
09:36:26 <anzeljg> ok
09:36:34 <nigelc1> Thursdays good here too.
09:36:36 <anitsirk> waht about http://www.timeanddate.com/worldclock/fixedtime.html?msg=Mahara+36th+Developer+Meeting&iso=20140925T08
09:36:42 <anitsirk> 25th of September at 8 UTC?
09:36:56 <anzeljg> that would work
09:37:23 <robertl_> cool by me
09:37:33 <son> good to me
09:37:49 <tobiasz> fine with me
09:38:30 <robertl_> #info the 36th Developer Meeting will take place on 25th September at 8:00 UTC: http://www.timeanddate.com/worldclock/fixedtime.html?msg=Mahara+36th+Developer+Meeting&iso=20140925T08
09:38:59 <robertl_> ok so that leaves
09:39:01 <robertl_> #topic Any other business
09:39:06 <anzeljg> i have one
09:39:09 <tobiasz> I have a small question
09:39:13 <tobiasz> after you, anzeljg
09:39:26 <anzeljg> waiting for others...
09:39:26 <anitsirk> i also have a small one
09:39:44 <anitsirk> go ahead, anzeljg
09:40:00 <anzeljg> I'm planning to rewrite Survey plugin in a way that it will be possible to generate surveys using forms inside Mahara (e.g. in Administration) instead of using XML. So also forms could be generated - this can maybe also be an answer to https://bugs.launchpad.net/mahara/+bug/1317447
09:40:07 <anzeljg> But I have some trouble how to calculate results from surveys or rather how can Mahara users "tell" or "instruct" Mahara to calculate results. I mean it is easy to e.g. find maximum/minimum/average value from all the numerical answers/options, but it is something completely different when you have more than one category of answers in the survey and when some answers count in a positive way/direction and the other answers in a nega
09:40:16 <anzeljg> I would be very greteful for any ideas how to achieve this. BTW: in current Survey plugin solution this (the results calculation) had to be hard-coded by a programer, so I'm looking for a "simple" (if possible) soultion to allow regular users to achieve/"code" this...
09:40:17 <anzeljg> ..
09:40:52 <anzeljg> "grateful" not greteful :)
09:41:14 <anitsirk> that’s the secret sauce of survey software :-)
09:41:20 <aarowlaptop> Does Moodle have a survey plugin?
09:41:28 <anzeljg> anitsirk: I know
09:41:32 <anitsirk> it has a feedback plugin that does some basic calculations
09:41:33 <aarowlaptop> You could look at how they do it
09:41:40 <anzeljg> aarowlaptop: it does, thanks!
09:41:42 <anitsirk> what sort of calculations were you thinking of, anzeljg ?
09:42:13 <anitsirk> if at all, i would only do the very basics because for anything complicated, people will want to export it to a more sophisticated program to do their analysis in.
09:42:43 <anzeljg> I have a survey which has three categories (since it measures three things), then it also has some control questions and results are calculated based on regular and control questions...
09:42:58 <robertl_> we could also take a look at how the current survey plugin does it's calculations to see if/how it could be made more generic/flexible
09:42:59 <aarowlaptop> What sort of answer fields does the survey plugin support?
09:43:12 <anzeljg> regular questions increase score, control questions decrease score
09:43:37 <aarowlaptop> It's real easy to get real complicated with these sorts of things. Take a look at the Mahara quiz question interface, for instance. ;)
09:44:03 <anzeljg> aarowtop: currently: text, textarea, dropdown, checkboxes, radiobuttons - standart set I guess
09:44:03 <anitsirk> aarowlaptop: mahara or moodle?
09:44:11 <aarowlaptop> Oh, Moodle
09:44:20 <aarowlaptop> Mm hm
09:44:42 <aarowlaptop> I mean, for things with a fixed number of answers (dropdown, checkbox, radio button) it seems like you could just have a bar graph
09:45:00 <aarowlaptop> but then I don't have much domain knowledge of surveys
09:45:26 <anzeljg> aarowtop: I know, but I also have to calculate the result either as a number or as a prcent
09:46:00 <anitsirk> anzeljg: what if you only went with the most basic analysis? calculations according to regular and control questions seems already pretty complicated.
09:46:06 <aarowlaptop> (I'm looking up what a control question is now...)
09:46:12 <anitsirk> moodle only does very simple analysis in the feedback module iirc
09:46:54 <anzeljg> I don't know exactly how they are called in English - they can be control questions or inverse questions or...
09:46:59 <anitsirk> the quiz module is of course a whole different kettle of fish
09:47:33 <anzeljg> thanks guys. I'll try to work something out... Please let me know if you have any idea, ok?
09:47:40 <aarowlaptop> Hm, so is a "control question" one that you include so you can tell if they're just answering the questions randomly?
09:48:00 <aarowlaptop> And if they give the "wrong" answer to the control question, you disregard their answers?
09:48:07 <anzeljg> aarowtop: As far as I know yes
09:48:46 <anzeljg> No it doesn't work like that - you don't completely disregard their answers
09:49:00 <anzeljg> it just shows in their results...
09:49:35 <tobiasz> but due to the different wording, the control-questions answer might differ slightly, if you use weights, for example. I think that gets difficult pretty fast
09:50:01 <anzeljg> agree
09:50:57 <anzeljg> that's why it's easier to create survey with XML (and optional logic programmed in the back), and not let users create their own... :(
09:51:25 <anitsirk> anzeljg: but what if you keep out the analysis and let other software take care of that? would that work?
09:52:10 <anzeljg> As I see it: user "solves" the survey and gets instant feedback
09:52:13 <anitsirk> haven’t used R, but I remember that we could import questionnaire data into SPSS and then assign weighting etc.
09:52:37 <anzeljg> even the simplest surveys I've came around (and are already implemented in XML) have control questions and stuff like that
09:54:21 <anzeljg> It's is also nice that users can graphically present the results of simple questionnaire/survey on their Mahara page (remember MyLearning plugin?)
09:55:21 <anitsirk> did you have different weightings in the mylearning plugin?
09:55:37 <anzeljg> no - meant the graphical presentation
09:56:37 <anzeljg> it just came to my mind - i might do something in between: allow users to create simple forms/surveys with forms and support complex ones (programmatically in the back)
09:58:06 <robertl_> so have some preset surveys as well as ability to create a survey
09:58:12 <robertl_> ?
09:58:20 <anzeljg> yep. like the hybrid approach
09:58:30 <anitsirk> mabye it’s two different plugins then just so that it’s easier to keep things apart esp if you use different infrastructure
09:58:50 <anzeljg> that's good too
09:59:34 <anitsirk> just so that things aren’t overcomplicated
09:59:58 <anzeljg> so like: survey plugin (like it is now, with XML and stuff) and forms plugin to allow users to create simple forms/surveys
10:01:12 <anzeljg> thanks guys!
10:01:16 <anzeljg> that's all from me
10:01:45 <tobiasz> ok, so here's my question: I remember aarowlaptop saying on the workshop in Brighton that from +1-reviewers, a Verified-note would be helpfull - but I can't see how to put that. Is that a permission-issue or did I just miss the box?
10:02:13 <anitsirk> tobiasz: do you only see the code reviewer column or also the verified column?
10:02:23 <anitsirk> i mean when you give your review?
10:02:33 <anitsirk> probably not really a column but radio buttons
10:02:48 <tobiasz> In the list of reviewers, I see the "Verified" and the "Code-Review" column
10:03:07 <anitsirk> i think you’d need to be in the “tester” group to be able to “Verify”
10:03:38 <anitsirk> and what do you see when you click the “Review” button? Do you only have one area, “code review” or also “verify” with the +1, no score, fail?
10:03:46 <tobiasz> But when I publish a review, I only see the "Code-Review" section
10:04:00 <anitsirk> yep. you aren’t in the proper group. i think it is the tester group.
10:04:18 <anitsirk> aarowlaptop: could you please add tobiasz into the group that i’m / cattester, i.e. stephen is in?
10:04:29 <anitsirk> i shouldn’t be in any other special group and i see both.
10:04:40 <aarowlaptop> sure
10:05:00 <anitsirk> #idea make it default for people who have a registered account to be able to verify things.
10:05:09 <anitsirk> usually, you probably start out with verification and not code review
10:05:10 <aarowlaptop> done
10:05:23 <anitsirk> aarowlaptop: ^
10:05:26 <tobiasz> ok, thanks. Just what I wanted to ask, anitsirk ^^
10:06:10 <anitsirk> as i see it, anyone can do the verification because we use that as front end QA / testing. whereas code review should really only be for those looking into the code.
10:06:33 <tobiasz> (and thanks for adding me to the group, the Verified-part appears now)
10:06:42 <anitsirk> easy fix :-)
10:08:03 <anitsirk> did you have anything else, tobiasz ?
10:08:29 <tobiasz> no, that's it, thanks
10:09:15 <anitsirk> #info the ui freeze is coming closer. thus, if you have time to review patches that have already been submitted, any help would be appreciated.
10:09:49 <anitsirk> that’s it from me.
10:09:52 <nigelc_> I'm working on a different project for a client at the mo, but will just focus on testing when I come back, if you want.
10:09:57 <robertl_> anyone else?
10:10:27 <anitsirk> thanks, nigelc. let us know when you’d have time again, and we can prioritize what to look at for you.
10:10:47 <nigelc_> Was going to focus on CSV import/exports, but that can wait till after I guess.
10:10:51 <nigelc_> That would be good.
10:11:52 <robertl_> ok, if no one else has anything I'l  call this meeting closed
10:11:55 <robertl_> Thank you all very much for attending and discussing in today's dev meeting.
10:12:03 <anitsirk> thank you for chairing, robertl_
10:12:05 <robertl_> #endmeeting