#mahara-dev Meeting

Meeting started by yuliyabozhko at 08:15:21 UTC (full logs).

Meeting summary

    1. ghada is Ghada El-Zoghbi, developer at Catalyst IT, Sydney, AU (ghada, 08:16:51)
    2. tobiasz is Tobias Zeuch, developer at the KIT, Karlsruhe, Germany (tobiasz, 08:16:53)
    3. anitsirk is Kristina Hoeppner, Catalyst IT, Wellington, NZ (anitsirk, 08:16:54)
    4. yuliya is Yuliya Bozhko, developer at TotaraLMS, Wellington, NZ (yuliyabozhko, 08:17:01)
    5. rkabalin is Ruslan Kabalin, Lancaster University, UK (rkabalin, 08:17:23)
    6. sonn_ is Son Nguyen, Catalyst IT, Wellington, NZ (sonn_, 08:17:26)
    7. robertl_ is Robert Lyon, Catalyst IT, Wellington, NZ (robertl_, 08:17:29)
    8. irc://irc.freenode.net:6667/#info simoncoggins1 is Simon Coggins, TotaraLMS, Wellington, NZ (simoncoggins1, 08:17:29)
    9. simoncoggins1 is Simon Coggins, TotaraLMS, Wellington, NZ (simoncoggins1, 08:17:55)
    10. aarowlaptop is Aaron G. Wells of Catalyst in Wellington NZ (anitsirk, 08:18:51)

  1. Items from last meeting (yuliyabozhko, 08:19:09)
    1. everyone to look at list of enhancement suggestions made by the Ljubljana group (yuliyabozhko, 08:19:14)
    2. AGREED: everyone need to comment on the individual items from enhancement list in the forums / bugs and then talk about them if needed (yuliyabozhko, 08:19:35)
    3. https://mahara.org/interaction/forum/topic.php?id=6283 (yuliyabozhko, 08:19:54)
    4. aarowlaptop look into gerrit update (yuliyabozhko, 08:20:12)
    5. ACTION: aarowlaptop look into gerrit update (yuliyabozhko, 08:22:40)

  2.  tobiasz on non-reusable textboxes: new block type or diversified interface for existing one (yuliyabozhko, 08:23:12)
    1. users complain about text boxes in copied pages where they don’t see the hint and accidentally overwrite the original text. (anitsirk, 08:24:29)
    2. https://bugs.launchpad.net/mahara/+bug/1296390 (aarowlaptop, 08:25:23)
    3. https://bugs.launchpad.net/mahara/+bug/1296390 (yuliyabozhko, 08:25:38)
    4. IDEA: 1) make it distinguishable in one block that you can have re-usable notes and those that can’t be re-used (anitsirk, 08:26:22)
    5. IDEA: 2) have two different blocktypes because then the non-reusable text snippets can have a simpler interface (anitsirk, 08:26:44)
    6. IDEA: have a confirm prompt when saving a textbox alerting user that it will change in other places - giving them options 'ok' 'no make copy' or 'cancel' (yuliyabozhko, 08:42:58)
    7. IDEA: there should be two different text blocktypes and that the re-usable one needs some more usability work to make it clear that text will be replaced elsewhere if not copied. (anitsirk, 08:46:07)
    8. ACTION: everyone have a look at discussion forum and bug listing https://bugs.launchpad.net/mahara/+bug/1296390 if anything can be added to the discussion (yuliyabozhko, 08:46:44)
    9. https://bugs.launchpad.net/mahara/+bug/1152441 (anitsirk, 08:47:30)
    10. IDEA: in order to hook it into elasticsearch it may well need to be an artefact on the backend... just not an artefact that is viewable and editable on its own (anitsirk, 08:54:27)

  3.  Yuliya on reviewing patches from Totara (yuliyabozhko, 08:58:40)
    1. https://reviews.mahara.org/#/c/3374/ (simoncoggins1, 09:06:28)

  4.  aarowlaptop on allowing anonymous-author portfolio pages (yuliyabozhko, 09:08:42)
    1. https://bugs.launchpad.net/mahara/+bug/548021 (yuliyabozhko, 09:08:51)
    2. ACTION: aarowlaptop contact Gregor to get more information/use cases on anonymous pages (yuliyabozhko, 09:21:02)

  5. Next meeting and chair (yuliyabozhko, 09:22:46)
    1. AGREED: 34th Mahara dev meeting on Thursday, 10th of July 2014 at 8 AM UTC (9 AM UK, 10 AM Europe, 8 PM NZ) (yuliyabozhko, 09:24:35)
    2. http://www.timeanddate.com/worldclock/fixedtime.html?iso=20140710T08 (yuliyabozhko, 09:24:45)
    3. robertl_ to chair the 34th Mahara dev meeting (yuliyabozhko, 09:28:55)

  6. Any other business (yuliyabozhko, 09:29:01)
    1. please fill in the questionnaire for Moodle Mahara integration and pass it on to anybody you know who has an interest: https://docs.google.com/forms/d/1vyECf8s8lyEX6YJuf9SGe7sUN5flaROcfBF7mPxY9fc/viewform (anitsirk, 09:29:56)
    2. The University of Canberra is funding major work for Mahara: archiving of pages and making the Mahara assignment submission plugin work over LTI. base specs are at https://wiki.mahara.org/index.php/Developer_Area/Specifications_in_Development/Moodle_LTI_integration (anitsirk, 09:33:43)


Meeting ended at 09:37:39 UTC (full logs).

Action items

  1. aarowlaptop look into gerrit update
  2. everyone have a look at discussion forum and bug listing https://bugs.launchpad.net/mahara/+bug/1296390 if anything can be added to the discussion
  3. aarowlaptop contact Gregor to get more information/use cases on anonymous pages


Action items, by person

  1. aarowlaptop
    1. aarowlaptop look into gerrit update
    2. aarowlaptop contact Gregor to get more information/use cases on anonymous pages


People present (lines said)

  1. yuliyabozhko (113)
  2. anitsirk (95)
  3. aarowlaptop (49)
  4. tobiasz (48)
  5. ghada (34)
  6. robertl_ (22)
  7. simoncoggins1 (11)
  8. rkabalin (7)
  9. maharameet (2)
  10. dobedobedoh (2)
  11. sonn_ (1)


Generated by MeetBot 0.1.4.