08:15:21 <yuliyabozhko> #startmeeting
08:15:21 <maharameet> Meeting started Thu Jun  5 08:15:21 2014 UTC.  The chair is yuliyabozhko. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:15:21 <maharameet> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:15:38 <yuliyabozhko> thanks dobedobedoh
08:15:43 <anitsirk> thank you dobedobedoh
08:15:47 <dobedobedoh> ghada: It's running on my personal VM
08:15:51 <yuliyabozhko> shall we carry on?
08:16:17 <yuliyabozhko> someone should write meetbot instructions
08:16:20 <ghada> intros again?
08:16:33 <anitsirk> might be easier than trying to combine things later
08:16:38 <yuliyabozhko> yeah, we just started anyway
08:16:51 <ghada> #info ghada is Ghada El-Zoghbi, developer at Catalyst IT, Sydney, AU
08:16:53 <tobiasz> #info tobiasz is Tobias Zeuch, developer at the KIT, Karlsruhe, Germany
08:16:54 <anitsirk> #info anitsirk is Kristina Hoeppner, Catalyst IT, Wellington, NZ
08:17:01 <yuliyabozhko> #info yuliya is Yuliya Bozhko, developer at TotaraLMS, Wellington, NZ
08:17:06 <rkabalin> May be we can intro, and then someone copy-paste previous discussion you had before meetbot woke up
08:17:10 <anitsirk> yuliyabozhko: you’d need to paste the agreed action. i think it only shows up from you as chair
08:17:23 <rkabalin> #info rkabalin is Ruslan Kabalin, Lancaster University, UK
08:17:26 <sonn_> #info sonn_ is Son Nguyen, Catalyst IT, Wellington, NZ
08:17:29 <robertl_> #info robertl_ is Robert Lyon, Catalyst IT, Wellington, NZ
08:17:29 <simoncoggins1> irc://irc.freenode.net:6667/#info simoncoggins1 is Simon Coggins, TotaraLMS, Wellington, NZ
08:17:33 <yuliyabozhko> anitsirk: will do
08:17:39 <simoncoggins1> oops
08:17:55 <simoncoggins1> #info simoncoggins1 is Simon Coggins, TotaraLMS, Wellington, NZ
08:18:04 <yuliyabozhko> dobedobedoh: can you please introduce yourself for the meeting minutes too?
08:18:49 <yuliyabozhko> if that's everyone, we can carry on then :)
08:18:51 <anitsirk> #info aarowlaptop is Aaron G. Wells of Catalyst in Wellington NZ
08:19:07 <anitsirk> yep, carry on
08:19:09 <yuliyabozhko> #topic Items from last meeting
08:19:14 <yuliyabozhko> #info everyone to look at list of enhancement suggestions made by the Ljubljana group
08:19:35 <yuliyabozhko> #agreed everyone need to comment on the individual items from enhancement list in the forums / bugs and then talk about them if needed
08:19:44 <yuliyabozhko> I am just adding what we agreed on
08:19:54 <yuliyabozhko> #link https://mahara.org/interaction/forum/topic.php?id=6283
08:19:55 <anitsirk> yep. that’s fine
08:20:12 <yuliyabozhko> #info aarowlaptop look into gerrit update
08:20:30 <yuliyabozhko> did you have a chance to look at it, aarowlaptop?
08:20:46 <aarowlaptop> No, I haven't looked into that yet
08:21:09 <yuliyabozhko> gerrit is currently on version 2.6.1 and can be updated to 2.8.5 which has quite useful features
08:21:29 <aarowlaptop> Yep, I'm definitely in favor of upgrading, just haven't gotten round to it yet.
08:21:38 <yuliyabozhko> would you like me to added to the next meeting agenda?
08:22:17 <yuliyabozhko> or would you prefer someone else looks into that?
08:22:17 <aarowlaptop> Sure
08:22:30 <aarowlaptop> We should still upgrade, so you can put it on the next meeting agenda
08:22:36 <yuliyabozhko> ok
08:22:40 <yuliyabozhko> #action aarowlaptop look into gerrit update
08:23:05 <dobedobedoh> dobedobedoh: is Andrew Nicols @ Moodle Pty Limited
08:23:12 <yuliyabozhko> #topic tobiasz on non-reusable textboxes: new block type or diversified interface for existing one
08:23:30 <tobiasz> We repeatedly had users complain about text boxes in copied pages, when they didn't notice the hint about the shared notes artefact and accidently overwrote the content of the original page. You find the discussion in the forum here: https://mahara.org/interaction/forum/topic.php?id=6257
08:23:39 <tobiasz> I'll give a quick summary
08:23:57 <tobiasz> I had found an old discussion touching that topic when the feature of reusable text boxes was announced (in 2011) and I think the idea back there was to add a switch to the text box between the reusable/artefact-related functionality and a plain version. Aaron, however, had the idea to split the functionality into two separate block types.
08:24:09 <tobiasz> I think the solution with two artefacts is cleaner, but it should be clear to users, which one is which. Aaron suggested the non-artefact-related block type to offer a simplified interface (e.g. no file attachments).
08:24:24 <tobiasz> My idea was to move the complete editing functionality for the notes to the content panel and on the portfolio level only select the note artefact - where Kristina objected that users want to create content on the portfolio view.
08:24:29 <anitsirk> #info users complain about text boxes in copied pages where they don’t see the hint and accidentally overwrite the original text.
08:24:30 <tobiasz> So I'd like to clarify, if we want two add a switch to the existing checkboxes or rather two separate block types - and if so, how to distinguish them so users don't get confused about which one to use.
08:24:47 <yuliyabozhko> did you mention that it was on enhancements suggestion from Gregor's list?
08:25:08 <aarowlaptop> This was item 2 on Gregor's list
08:25:09 <tobiasz> ah, sorry, forgot that. It's also on the list of the enhancements from the Ljubljana group
08:25:15 <aarowlaptop> "Copying of Textboxes should create real copies"
08:25:22 <anitsirk> it had already come u pbefore gregor’s list though
08:25:23 <aarowlaptop> https://bugs.launchpad.net/mahara/+bug/1296390
08:25:26 <aarowlaptop> yep
08:25:38 <yuliyabozhko> #link https://bugs.launchpad.net/mahara/+bug/1296390
08:26:05 <aarowlaptop> Yeah, my favored way of doing this is to create two separate block types -- one for one-off text, and another for reusable notes
08:26:22 <anitsirk> #idea 1) make it distinguishable in one block that you can have re-usable notes and those that can’t be re-used
08:26:44 <anitsirk> #idea 2) have two different blocktypes because then the non-reusable text snippets can have a simpler interface
08:27:17 <anitsirk> i think that would be the best. the re-usable interface is already quite complex. adding yet another layer may be too much.
08:27:23 <tobiasz> I also favor the second idea, I think it easier to explain that to the user
08:27:43 <yuliyabozhko> hmm, it should be made clear enough to users
08:28:10 <anitsirk> while i favor that re-usable text boxes should stil be able to be created on a page itself, i think it should also be possible to create them under content. it’s the only artefact that cannot be created there but only edited
08:28:13 <ghada> i think users will also want to 'convert' one to the other.
08:28:22 <anitsirk> ghada: good point
08:28:37 <aarowlaptop> maybe
08:28:44 <yuliyabozhko> yeah, might get complicated
08:28:56 <tobiasz> Aaron suggested rename the actual textbox blocktype to "note" and call the new, non-copiable block type one text
08:28:57 <yuliyabozhko> does anyone want to write down some ideas on bug listing?
08:28:59 <anitsirk> you might start out with a non-reusable one but then realize that it’s gotten so long / important that it would be good to keep. however, it might be easier to just copy and paste
08:29:00 <ghada> i agree but there will be voices out there
08:29:36 <anitsirk> ghada: it could be a future enhancement :-)
08:29:37 <ghada> yes, copy/paste is always available.
08:29:41 <ghada> exactly.
08:29:42 <aarowlaptop> yeah, future enhancement ;)
08:30:21 <anitsirk> i think fixing up the current functionality is more important. i also noticed that notes do not ever get deleted even when they don’t exist in pages anymore.
08:30:22 <tobiasz> We have very small communities on mahara here, but I don't know any of our users, that uses the copyable feature on purpose. Are there users out htere that use them frequently?
08:30:28 <robertl_> how would existing text blocks be migrated? would they be notes or new textboxes?
08:30:34 <anitsirk> tobiasz: i do
08:30:39 <tobiasz> ok :)
08:30:58 <anitsirk> i use it when i have similar text for templates for example or when creating a series of pages that are fairly similar
08:31:12 <ghada> yes, one client (a school) does hits here in Sydney
08:31:15 <anitsirk> sure. i could just copy and paste, but it’s quite handy that the title is available as well as all the formatting
08:31:35 <ghada> and, we've got an outstanding bug for months now.
08:31:41 <tobiasz> I wouldn't migrate any existing block types, though it doesn't help with huge list of notes that you can already choose from, from which most are not intended to be copied
08:31:41 <yuliyabozhko> I haven't used them much
08:31:53 <anitsirk> but in general, it would be better to not be connected to the original from the start i think but choose that only if you want to stay connected to it.
08:32:17 <aarowlaptop> Could be that when you delete a note, if it's used in any pages you have the option to "downgrade" those into standalone text blocks
08:32:20 <anitsirk> ghada: i think that bug is different and related to their portal / firewall
08:32:25 <aarowlaptop> that would be a relatively simple migration path
08:32:31 <anitsirk> the copying functionality itself works as intended.
08:32:32 <tobiasz> anitsirk: that would be one interface for both?
08:32:39 <ghada> funny, these clients want it connected to the original text and are complaining that it's not linked.
08:33:00 <anitsirk> tobiasz: that’s the tricky bit.
08:33:01 <ghada> anitsirk: this is a different one. I fixed the firewall/portal issue.
08:33:14 <anitsirk> ah ok, ghada. good to know that that works now :-)
08:33:27 <yuliyabozhko> :)
08:33:42 <anitsirk> tobiasz: starting out with not being connected i think is trickier than the current behavior because you’d do it retroactivtlye
08:33:57 <anitsirk> to best not open that can of worms.
08:33:57 <robertl_> good to hear the portal issue is fixed :)
08:34:14 <ghada> robertl_: "fudged"....
08:34:24 <ghada> :)
08:34:25 <robertl_> lol
08:34:29 <tobiasz> But many users don't notice that the content is connected, especially new users
08:35:10 <anitsirk> yes. we’ve pondered using a pop-up box but that can also be quite intrusive esp. once you’ve got it and still need to click them away all the time
08:35:11 <ghada> tobiasz: i agree. and the ones who do use this functionality, get it confused.
08:35:43 <ghada> can we actually have it "look" different?
08:35:57 <anitsirk> ghada: in what wa?
08:35:57 <yuliyabozhko> that could be one of the options
08:35:58 <anitsirk> way?
08:35:59 <robertl_> would it be worth having some indication on edit screen that the textbox is linked? like some header to the textbox in a bright colour letting them know
08:36:03 <ghada> different colour background, more rounded corners, i don't know...
08:36:13 <anitsirk> robertl_: it’s already there in red ;-)
08:36:20 <tobiasz> From a new user perspective I would imagine it more the other way round: you write a text and then notice, that this is a snippet/note, you would like to keep for another page
08:36:27 <robertl_> not in the config form but the edit page
08:37:33 <yuliyabozhko> if reusable items and non-reusable items are in different categories, they would be seen as different
08:37:36 <ghada> there's already a message at the top to inform the users that this if they make changes, it will change the original
08:37:55 <tobiasz> robertl: I like that idea, I think if we'd stick with one blocktype, the difference should be more notorious than just a little switch or a small red text
08:38:12 <anitsirk> having two blocktypes would make it clearer i think
08:38:24 <tobiasz> noticable, not notoriuous
08:38:25 <yuliyabozhko> I agree with anitsirk
08:38:25 <anitsirk> adding more to the edit screen might be overloading that one. it’s already very busy
08:38:54 <anitsirk> because then users would make a conscious choice between just having plain text vs. creating something they can re-use.
08:38:56 <aarowlaptop> yeah, that was my thought
08:39:03 <yuliyabozhko> it can be one block with two options
08:39:17 <ghada> anitsirk: agreed.
08:39:24 <anitsirk> and you probably only re-use in very specific cases. i re-use text boxes for similar content or for the same content, in particular instructions on templates
08:39:47 <yuliyabozhko> any other ideas?
08:39:50 <anitsirk> there i really only want to update one copy of the textbox and have it updated in 10 other pages without having to go into every single one and update the textobx manually
08:40:42 <anitsirk> i guess we’d need to figure out what to do with the current notes. what about having those that were re-used as re-usable blocktypes and the rest as simple text?
08:40:43 <robertl_> would having a confirm prompt when saving a textbox alerting user that it will change in other places - giving them options 'ok' 'no make copy' or 'cancel' be useful
08:40:52 <tobiasz> From a portfolio perspective, I think the usual case for reusable elements would be, create a note on the content-area and select it in the portfolio view
08:41:57 <anitsirk> tobiasz: there i’d still like to be able to create re-usable item directly in the portfolio. a number of people complain about the process of having to go into content first and then needing to put it onto a portfolio page instead of starting on the portfolio page.
08:42:16 <yuliyabozhko> tobiasz: I think we are trying to get away from this workflow as it is not very user friendly
08:42:32 <anitsirk> robertl_: hadn’t thought of that. sounds like the best idea so far for the re-usable ones to me
08:42:36 <tobiasz> ok, I agree with that
08:42:58 <yuliyabozhko> #idea have a confirm prompt when saving a textbox alerting user that it will change in other places - giving them options 'ok' 'no make copy' or 'cancel'
08:43:46 <anitsirk> what about just having three buttons then instead of a popup which would be an additional click?
08:43:46 <yuliyabozhko> so, any action on this topic?
08:44:30 <anitsirk> i guess it’s back to discussing a bit more on the forum / tracker to come up with the plan to untangle things.
08:44:45 <aarowlaptop> Yeah, let's work it out on the bug tracker, now that we've had some discussion about it here
08:44:58 <robertl_> sounds good
08:45:01 <tobiasz> ok
08:45:04 <ghada> yes.
08:45:09 <yuliyabozhko> should this be a task for everyone interested?
08:45:12 <anitsirk> i think we agree that there should be two different blocktypes and that the re-usable one needs some more usability work to make it clear that text will be replaced elsewhere if not copied.
08:45:42 <robertl_> that sums it up nicely I recon
08:45:59 <yuliyabozhko> ok
08:46:07 <anitsirk> #idea there should be two different text blocktypes and that the re-usable one needs some more usability work to make it clear that text will be replaced elsewhere if not copied.
08:46:44 <yuliyabozhko> #action everyone have a look at discussion forum and bug  listing https://bugs.launchpad.net/mahara/+bug/1296390 if anything can be added to the discussion
08:47:14 <tobiasz> can I start working on the new block type or is that also subject to discuss?
08:47:27 <anitsirk> it’s https://bugs.launchpad.net/mahara/+bug/1152441
08:47:30 <anitsirk> #link https://bugs.launchpad.net/mahara/+bug/1152441
08:47:43 <anitsirk> tobiasz: which blocktype? the simple text one?
08:47:54 <tobiasz> yep, the simple one
08:48:15 <yuliyabozhko> if we agreed, that we need two blocktypes, why nor
08:48:21 <aarowlaptop> tobiasz: Sure, I'd say go ahead
08:48:35 <anitsirk> my opinion for that in terms of functionality: Title, Description, Tags. And then a way of migrating existing single “notes” to that.
08:48:37 <tobiasz> ok, great
08:48:43 <yuliyabozhko> do I need to add this to actions?
08:48:45 <anitsirk> I don’t think we need comments on the simple text
08:48:56 <anitsirk> yuliyabozhko: i don’t think so.
08:49:06 <yuliyabozhko> ok, thanks
08:49:10 <tobiasz> agreed, no comments
08:49:12 <aarowlaptop> I don't think it really needs tags for that matter
08:49:14 <anitsirk> unless you want to make tobiasz to report back next time ;-)
08:49:22 <robertl_> it would be good to see something in action as that will help clarify what we want
08:49:24 <yuliyabozhko> very tempting :D
08:49:34 <aarowlaptop> Yeah, good idea
08:49:42 <tobiasz> fine with me ^^
08:49:46 <anitsirk> tags: mhh. probably not since it’s just a line of text or so
08:50:00 <tobiasz> also agreed, no need for tags
08:50:16 <ghada> so, it won't have any attached files, etc?
08:50:33 <yuliyabozhko> that's the point of being "simple" I guess :)
08:50:44 <ghada> ok, sounds good to me.
08:51:03 <tobiasz> my idea of simple was about not being connected to an artefact, but I'm fine without the files
08:51:27 <yuliyabozhko> :) ah, right
08:51:39 <ghada> any opinions?
08:51:59 <aarowlaptop> although from an implementation perspective... in order to hook it into elasticsearch it may well need to be an artefact on the backend... just not an artefact that is viewable and editable on its own
08:52:04 <anitsirk> tobiasz: so pretty much go back to what the textbox used to be back in the day.
08:52:11 <aarowlaptop> sort of like how commenst are technically artefacts
08:52:26 <tobiasz> aarow: are they?
08:52:31 <aarowlaptop> yeah :)
08:52:37 <yuliyabozhko> yep, they are
08:53:30 <tobiasz> that's for when you use the elasticsearch to search the pages?
08:53:34 <aarowlaptop> Hm, actually I'll take a look at it
08:54:11 <aarowlaptop> No, comments were written before the Elasticsearch stuff. I'm not sure why they're artefacts exactly, except that it's kind of a convenient way to store them
08:54:25 <tobiasz> I haven't worked with elastic search so far, but other block types also have titles and such. I'll have a look at that as well
08:54:27 <anitsirk> #idea in order to hook it into elasticsearch it may well need to be an artefact on the backend... just not an artefact that is viewable and editable on its own
08:54:41 <aarowlaptop> Okay, I'll check into that tomorrow
08:54:52 <tobiasz> ok, great
08:54:57 <ghada> will it also appear in the notes section?
08:55:01 <aarowlaptop> I think you're right, it would be easier and simpler to just store the text in the block
08:55:11 <aarowlaptop> artefacts are mainly meant for reuse, and this will not be reusable
08:55:13 <tobiasz> no, it won't appear in the notes section
08:56:07 <yuliyabozhko> anything else on this?
08:56:12 <tobiasz> I'm done
08:56:13 <anitsirk> but would you want to share them in some sort of stream maybe, yuliyabozhko?
08:56:13 <aarowlaptop> not from me
08:56:14 <ghada> ok. i think we're ok on this
08:56:53 <ghada> i think we keep it simple.
08:57:15 <aarowlaptop> what's next on the agenda, yuliya?
08:57:15 <tobiasz> and the watchlist event should be triggered anyways
08:57:20 <anitsirk> but if it’s simple to write, people will use it for longer things that they may want to share and not re-use.
08:57:24 <yuliyabozhko> anything we would like to check about this topic next meeting?
08:57:32 <yuliyabozhko> to add to actions
08:57:41 <yuliyabozhko> if not, moving on :)
08:58:25 <aarowlaptop> nope, I think we're good. We'll hammer out further details in the bug tracker
08:58:33 <yuliyabozhko> ok then
08:58:40 <yuliyabozhko> #topic Yuliya on reviewing patches from Totara
08:58:45 <yuliyabozhko> I will be quick :)
08:58:52 <yuliyabozhko> as some of you hopefully know, Totara team is currently doing lots of work in social features area
08:59:03 <yuliyabozhko> so, I put this item on meeting agenda earlier this week when I felt that our progress has stalled a bit due to lack of feedback on the patches in review, but it seems that we did quite a bit of work on reviewing and merging patches today
08:59:12 <yuliyabozhko> thanks a lot everyone who participated :D
08:59:29 <yuliyabozhko> I guess all I want to ask is to prioritise when possible reviewing/feedback of the new features from Totara team (Nathan Lewis, Valerii Kuznetsov, Moises Burgos, and myself) while we are quite early in Mahara release cycle
08:59:38 <yuliyabozhko> We still have a lot of work to do and it is quite hard to work with patches with so many dependencies
08:59:46 <yuliyabozhko> that's it from me :) thanks
09:00:48 <ghada> do you have a list of what's most important for you - while reviewing?
09:01:12 <rkabalin> good to know more new stuff is coming
09:01:27 <yuliyabozhko> ghada: no. it might be a good idea TO MAKE A LIST
09:01:48 <ghada> :)
09:02:30 <yuliyabozhko> I am not sure on how to communicate importance of some patches other than ask someone to review them directly
09:02:36 <simoncoggins1> often if there are patches with dependencies it is the ones that things depend on that we need in
09:02:39 <robertl_> it was good to see some of the bigger patches merged as it opens up the reviewing of smaller child patches which should go quicker
09:03:13 <robertl_> eg they shouldn't need 30+ revisions
09:03:37 <yuliyabozhko> yeah, definitely
09:03:37 <anitsirk> yuliyabozhko: i think in terms of priority: whether it’s activity stream or artefact level sharing etc. then within that it’s to look at all due to the dependencies.
09:04:07 <yuliyabozhko> anitsirk: yep, pretty much. that would be great
09:04:08 <simoncoggins1> the three big ones at the moment are activity stream, artefact sharing and chat
09:04:15 <yuliyabozhko> we also have chat in review already
09:04:32 <yuliyabozhko> Valerii is currently splitting it into smaller patches for easier review
09:04:37 <simoncoggins1> if I had to pick a priority it would probably be activity stream, then artefact level sharing
09:04:50 <simoncoggins1> but they are both important because they touch on so many areas of mahara
09:05:17 <simoncoggins1> some of the other features that are coming like questions and ideas are more independent
09:05:43 <yuliyabozhko> activitystream is separated into a topic
09:05:52 <yuliyabozhko> so, it's easier to find it in review
09:05:54 <tobiasz> besides the likeability, or is that already merged?
09:05:56 <simoncoggins1> we really appreciate all the effort and help so far!
09:06:23 <yuliyabozhko> tobiasz: only initial activity stream patch has been merged
09:06:27 <simoncoggins1> likes is in activitystream topic:
09:06:28 <simoncoggins1> https://reviews.mahara.org/#/c/3374/
09:06:35 <yuliyabozhko> all child patches are still there
09:06:50 <tobiasz> ok, thanks
09:07:35 <rkabalin> Will try to dedicate some time to reviewing, though it is a bit difficult at the moment.
09:07:40 <yuliyabozhko> cool. if you have any questions, don't hesitate contact any of us in Totara
09:08:24 <yuliyabozhko> ok, next topic then :)
09:08:42 <yuliyabozhko> #topic aarowlaptop on allowing anonymous-author portfolio pages
09:08:51 <yuliyabozhko> #link  https://bugs.launchpad.net/mahara/+bug/548021
09:09:22 <yuliyabozhko> to be honest, I haven't looked at this one
09:09:53 <yuliyabozhko> looks like a pretty old bug
09:10:09 <anitsirk> it’s a wishlist item. :-)
09:10:10 <tobiasz> connected to the Ljubljana ideas, though
09:10:17 <robertl_> ah yeah I merged that one before fully realising the problems with it
09:10:27 <yuliyabozhko> aarowlaptop: would you like to talk about it?
09:10:43 <robertl_> the danger of anonymous pages
09:10:56 <aarowlaptop> well, I was just wondering if anyone had any ideas on what the use case for this is
09:10:57 <tobiasz> my fault, should have marked it as in-discussion
09:11:06 <aarowlaptop> I see that the Ljubljana folks want it as well
09:11:12 <yuliyabozhko> oh, came across similar problem in bagdes
09:12:06 <aarowlaptop> hm, although I guess specifically what the Ljubljana group says is that *public* pages should not show the author
09:12:34 <yuliyabozhko> in this case you need a way of verifying the author which might not be easy
09:12:37 <aarowlaptop> whereas what the current patch does, is allow you to hide the page name from everyone?
09:12:40 <anitsirk> Currently, people can already choose what name to display. It does not have to be the fullname. everywhere else (blogs, social networks etc.) you always have your name displayed.
09:12:41 <aarowlaptop> I mean the author name
09:13:11 <tobiasz> the patch hides the author to anyone, who couldn't see the authors profile
09:13:18 <yuliyabozhko> what the point of hiding user name?
09:13:28 <ghada> what is the worry of having anonymous authoers
09:13:57 <aarowlaptop> It's an accountability thing
09:14:06 <robertl_> if I am anonymous I can make an official looking page saying give me your c/card info
09:14:11 <anitsirk> yuliyabozhko: that’s what we are trying to find out
09:14:15 <aarowlaptop> so that's one aspect, creating phishing pages
09:14:16 <tobiasz> the "report objectionable material" link is still shown i public pages, isn't it?
09:14:25 <yuliyabozhko> yes
09:14:34 <anitsirk> but not everyone will report a page.
09:14:50 <yuliyabozhko> wait, isn't it only displayed to logged in users?
09:14:55 <aarowlaptop> right, and admins may not check that frequently
09:15:05 <ghada> but i can also put some obscure name on that page as an auther.  I can be "Barack Obama"...
09:15:08 <anitsirk> or is the problem more around the fact that you can currently see the person’s name and profile pic even when they don’t have access to the full profile?
09:15:09 <aarowlaptop> hm, there's that too, only logged in users can report a page objectionable
09:15:40 <aarowlaptop> tobiasz: Did you implement this patch because you need it at your institution?
09:15:52 <anitsirk> ghada: yes, you can already have a display name if your institution / site allows for that. so you can be anonymous. however, that then goes for the entire site
09:16:09 <anitsirk> while you can choose which name to display as author, around a site your display name is your primary name
09:16:14 <tobiasz> no, I just looked at the proposals from the Ljubljana group and had the idea
09:16:48 <aarowlaptop> Oh, okay
09:16:56 <anitsirk> ok. so we need more input from gregor on what he actually means
09:16:59 <tobiasz> so for me, it's ok to revert the patch. We should ask Gregor why he needs the feature, though
09:17:04 <aarowlaptop> Yeah
09:17:16 <aarowlaptop> Okay, I'll ask Gregor about it
09:17:34 <aarowlaptop> I think it may be worth keeping, just as an optional feature
09:17:53 <anitsirk> is it configurable on the site / institution level?
09:17:55 <tobiasz> There's a fix for the institution link from robertl, though. Can we exclude that into a separate patch?
09:17:59 <anitsirk> sorry, haven’t had the chance to look at it yet.
09:18:09 <robertl_> would it be better to display the author as text rather than link for public users?
09:18:19 <robertl_> instead of hiding it altogether
09:18:33 <anitsirk> it would need to be a link when the profile is publicly viewable
09:18:34 <aarowlaptop> Well, we'll have to see what the use-case is to know whether that's better or not
09:18:36 <tobiasz> anitsirk: no, my attempt was that if you can't follow the link to the profile page, then the link is obsolete
09:19:09 <aarowlaptop> I suspect that, if you want your users to create pages with no "author" line, you probably don't want their name printed on the page
09:19:20 <ghada> so, if you're logged in and can view the user's info, the name appears?
09:19:26 <tobiasz> yep
09:19:50 <anitsirk> i still don’t like it because then it looks like the institution wrote the page
09:19:54 <anitsirk> or the mahara install
09:19:58 <yuliyabozhko> right, we definitely need more info on this one from Gregor
09:20:12 <yuliyabozhko> aarowlaptop: will you contact him?
09:20:16 <aarowlaptop> sure
09:20:28 <anitsirk> we are dealing with user generated content here and if we don’t have any indiciation of author it falls back to the wider site which would not be good
09:20:31 <yuliyabozhko> thanks
09:20:39 <anitsirk> yuliyabozhko: can you please make an action ite
09:20:41 <anitsirk> item
09:20:54 <ghada> anitsirk: yes, i see your point.
09:21:02 <yuliyabozhko> #action aarowlaptop contact Gregor to get more information/use cases on anonymous pages
09:21:18 <yuliyabozhko> done
09:21:46 <yuliyabozhko> anything else on this?
09:22:02 <yuliyabozhko> I guess we can't discuss much until we get more info
09:22:41 <yuliyabozhko> ok, then, moving on
09:22:46 <yuliyabozhko> #topic Next meeting and chair
09:22:59 <yuliyabozhko> what about Thursday, 10th of July 2014 at 8 AM UTC (9 AM UK, 10 AM Europe, 8 PM NZ)?
09:23:21 <ghada> ok with me.
09:23:32 <anitsirk> works for me
09:23:34 <tobiasz> fine with me
09:23:35 <aarowlaptop> okay
09:23:42 <robertl_> where do feature freeze etc happen?
09:23:50 <aarowlaptop> Last week of July I believe
09:23:50 <robertl_> when do feature freeze etc happen?
09:24:00 <anitsirk> last week of July
09:24:09 <aarowlaptop> So 10th July will be the last meeting before the feature freeze
09:24:16 <robertl_> cool then having a meeting then should be good
09:24:16 <anitsirk> yes. sounds good.
09:24:17 <yuliyabozhko> then technically yes
09:24:24 <yuliyabozhko> cool
09:24:26 <robertl_> fine for me
09:24:35 <yuliyabozhko> #agreed 34th Mahara dev meeting on Thursday, 10th of July 2014 at 8 AM UTC (9 AM UK, 10 AM Europe, 8 PM NZ)
09:24:45 <anitsirk> and 6 pm Sydney
09:24:45 <yuliyabozhko> #link http://www.timeanddate.com/worldclock/fixedtime.html?iso=20140710T08
09:25:10 <yuliyabozhko> who would like to chair?
09:26:20 <yuliyabozhko> I can volunteer someone :)
09:27:26 <yuliyabozhko> seems like a very scary question...
09:27:42 <rkabalin> I can if noone wants
09:27:48 <anitsirk> who has not yet chaireda meeting?
09:28:31 <robertl_> I have not yet chaired one - I'll do it
09:28:41 <yuliyabozhko> great. thanks!
09:28:42 <anitsirk> thank you, robertl_
09:28:48 <rkabalin> thanks robertl_
09:28:55 <yuliyabozhko> #info robertl_ to chair the 34th Mahara dev meeting
09:29:01 <yuliyabozhko> #topic Any other business
09:29:06 <anitsirk> I have two
09:29:08 <yuliyabozhko> anything else?
09:29:21 <yuliyabozhko> cool, go on :)
09:29:56 <anitsirk> #info please fill in the questionnaire for Moodle Mahara integration and pass it on to anybody you know who has an interest: https://docs.google.com/forms/d/1vyECf8s8lyEX6YJuf9SGe7sUN5flaROcfBF7mPxY9fc/viewform
09:30:10 <anitsirk> it is for the MNet “replacement”
09:30:38 <anitsirk> and use cases of what works well right now as well as what functionality you are missing would be great to have so that the solution that we are going to come up with keeps all those things in mind
09:30:47 <yuliyabozhko> is it aimed at developers or admins?
09:30:54 <anitsirk> both
09:30:57 <ghada> have you passed this onto the Sydney office?
09:31:08 <anitsirk> ghada: not yet
09:32:05 <anitsirk> the important thing is to get use cases and not i prefer oauth because… the technical side will be decided once we have all the use cases and know what the integration needs to cater to.
09:32:40 <anitsirk> if you have a strong preference for a specific technology do say so as it might reveal any potential problems, but we don’t want the tech side to get into the way of the user side. dream a little…
09:32:49 <anitsirk> number 2
09:33:34 <anitsirk> The University of Canberra is funding major work for Mahara: archiving of pages and making the Mahara assignment submission plugin work over LTI. base specs are at https://wiki.mahara.org/index.php/Developer_Area/Specifications_in_Development/Moodle_LTI_integration
09:33:43 <anitsirk> #info The University of Canberra is funding major work for Mahara: archiving of pages and making the Mahara assignment submission plugin work over LTI. base specs are at https://wiki.mahara.org/index.php/Developer_Area/Specifications_in_Development/Moodle_LTI_integration
09:34:11 <yuliyabozhko> that's great news
09:34:18 <anitsirk> that work will be awesome because pages / collections that were submitted (groups or in Moodle) will be archived on the server
09:34:37 <anitsirk> and it makes the plugin less moodle specific.
09:34:52 <anitsirk> so big thanks to U of Canberra and esp. Shane Nuessler
09:35:20 <anitsirk> and like usual, as much as possible will be put into core Mahara.
09:35:27 <anitsirk> that’s all from me
09:35:30 <yuliyabozhko> sounds great
09:35:31 <rkabalin> yep, big thanks from us as well
09:35:33 <yuliyabozhko> thanks, anitsirk
09:35:43 <yuliyabozhko> anyone else?
09:36:05 <yuliyabozhko> I have nothing :)
09:36:25 <ghada> that's it from me...
09:37:04 <yuliyabozhko> ok then. thanks everyone for joining today :)
09:37:11 <anitsirk> thanks for chairing, yuliyabozhko
09:37:26 <ghada> thanks  yuliyabozhko. Great job.
09:37:29 <tobiasz> thanks, yuliyabozhko
09:37:36 <yuliyabozhko> :)
09:37:39 <yuliyabozhko> #endmeeting