#mahara-dev Meeting

Meeting started by anitsirk at 08:01:48 UTC (full logs).

Meeting summary

    1. anitsirk is Kristina Hoeppner from Catalyst IT, Wellington, New Zealand (anitsirk, 08:01:56)
    2. anzeljg is Gregor Anzelj, developer and translator from Gimnazija Bežigrad, Ljubljana, Slovenia (anzeljg, 08:02:06)
    3. robertl_ is Robert Lyon, Catalyst IT, Wellington, NZ (robertl_, 08:02:13)
    4. tobiasz3 is Tobias Zeuch, developer at the KIT, Karlsruhe, Germany (tobiasz3, 08:02:13)
    5. sonn2 is Son Nguyen from Catalyst IT, Wellington, New Zealand (sonn2, 08:02:15)
    6. mingard is Jono Mingard, student at Victoria University of Wellington (NZ) and former intern at Catalyst IT (mingard, 08:02:23)
    7. rkabalin is Ruslan Kabalin, Lancaster University, UK (rkabalin_, 08:02:36)

  1. Items from last meeting (anitsirk, 08:03:00)
    1. aarow_ is Aaron Wells from Catalyst IT in Wellington, NZ (aarow_, 08:03:02)
    2. sonn2 updated the wiki with information about databases: https://wiki.mahara.org/index.php/System_Administrator%27s_Guide/Requirements#Database_Server (anitsirk, 08:04:22)
    3. Hi, I'm a Moodle and Mahara developer at Lancaster University in the UK, working with Ruslan Kabalin (tonyjbutler, 08:07:51)
    4. dajan - Mahara French Community facilitator and Mahara translator (dajan, 08:08:54)
    5. IDEA: : start testing with MariaDB? (anitsirk, 08:10:08)
    6. https://mariadb.com/kb/en/mariadb-vs-mysql-compatibility/ - list of differences between MariaDB and MySQL (anitsirk, 08:11:46)
    7. IDEA: aarow: it would make the most sense to just say we support MySQL. MariaDB users should understand from that statement, that it will also work in MariaDB (anitsirk, 08:16:36)
    8. AGREED: DB requirements state that we support MySQL. MariaDB users should understand from that statement, that it will also work in MariaDB (anitsirk, 08:17:47)
    9. IDEA: since at least CentOS still offers no more recent version than 5.1.71, I think we should continue to support MySQL 5.1 for one more release cycle (anitsirk, 08:18:39)
    10. AGREED: : Support MySQL 5.1 until Mahara 1.10 (anitsirk, 08:19:31)

  2. Usability (anitsirk, 08:20:35)
    1. An international Mahara workshop took place in Ljubljana on 4 March 2014 that included representatives from Slovenian schools participating in the EUfolio project http://eufolio.eu (anitsirk, 08:23:52)
    2. Choose internal image in TinyMCE without attaching it first. (anzeljg, 08:24:03)
    3. https://bugs.launchpad.net/mahara/+bug/1038580 (anzeljg, 08:24:11)
    4. https://bugs.launchpad.net/mahara/+bug/1235569 (anzeljg, 08:24:18)
    5. ACTION: everyone to look at list of enhancement suggestions made by the Ljubliana group (anitsirk, 08:40:04)
    6. ACTION: anzeljg to write forum post / forum posts letting community members know about the usability improvement suggestions made in Ljubljana (anitsirk, 08:41:01)
    7. Copying of Textboxes should create real copies. (anzeljg, 08:41:20)
    8. https://bugs.launchpad.net/mahara/+bug/1296390 (anzeljg, 08:41:25)

  3. Whitespace changes in patches (anitsirk, 08:42:18)
    1. IDEA: rkabalin_ suggests to make a requirement not to introduce whitespaces changes at the lines that are not modified by the patch. (anitsirk, 08:44:09)
    2. IDEA: arrow_: How about we just run a formatter, after 1.9 is out, and strip out the extraneous whitespace from all the old Mahara core files? (anitsirk, 08:45:05)
    3. the big exception to the whitespace rule is external libraries (anitsirk, 08:53:20)
    4. IDEA: rkabalin_: have git strip whitespace changes from users who work with eclipse. aarow_: an automated formatting script would be a great idea (anitsirk, 09:01:22)
    5. aarow_: the automated formatting script wouldn't break git blame, because there's "git blame -w". It might break Eclipse annotate, which is a graphical equivalent to git blame... (anitsirk, 09:02:06)
    6. ACTION: aarow_ to see how many files have a whitespace problem. (anitsirk, 09:02:49)
    7. AGREED: : reintroduce the requirement for avoiding trailing whitespaces (anitsirk, 09:03:49)
    8. ACTION: rkabalin_ to update the dev documentation to reintroduce the requirement for avoiding trailing whitespaces (anitsirk, 09:04:50)

  4. Mahara core developer applications (anitsirk, 09:05:19)
    1. https://wiki.mahara.org/index.php/User:Mingard mingard (anitsirk, 09:05:23)
    2. https://wiki.mahara.org/index.php/User:Ybozhko yuliyabozhko1 (anitsirk, 09:05:24)
    3. https://wiki.mahara.org/index.php/Developer_Area/Developer_Meetings/Core_Developer_Applications/Ghada_El-Zoghbi Ghada (anitsirk, 09:05:25)
    4. AGREED: jono mingard to become an approved mahara core developer. (anitsirk, 09:18:26)
    5. AGREED: yuliyabozhko1 is to be an approved mahara core developer. (anitsirk, 09:19:01)
    6. AGREED: ghada el-zoghbi is the 3rd new approved mahara core developer (anitsirk, 09:19:56)
    7. ACTION: aarow_ to update gerrit and launchpad settings to include the 3 new mahara core devs. (anitsirk, 09:20:53)

  5. Next meeting and chair (anitsirk, 09:22:36)
    1. AGREED: 32nd Mahara dev meeting on Thursday, 1 May 2014 at 8:00 UTC: http://www.timeanddate.com/worldclock/fixedtime.html?msg=32nd+Mahara+developer+meeting&iso=20140501T08 (anitsirk, 09:29:29)
    2. rkabalin_ to chair the 32nd Mahara dev meeting. (anitsirk, 09:30:59)

  6. Any other business (anitsirk, 09:31:12)
    1. anzeljg: I just wanted to ask why the reviews have stalled on https://reviews.mahara.org/#/c/2936/ (anitsirk, 09:32:05)
    2. Mahara 1.9RC1 is about to be released. (anitsirk, 09:35:33)
    3. the booklet plugin https://wiki.mahara.org/index.php/Plugins/Artefact/Booklet was presented at Mahara Hui in Wellington last week and found a lot of interest. (anitsirk, 09:39:07)
    4. https://wiki.mahara.org/index.php/Plugins/Artefact/Booklet (anitsirk, 09:39:09)
    5. Maharamoot and Moodlemoot FR 2014 in Paris - June the 4-6th (anitsirk, 09:39:58)
    6. http://moodlemoot2014.univ-paris3.fr/ (anitsirk, 09:41:37)
    7. http://moodlemoot2014.univ-paris3.fr/mahara/ (anitsirk, 09:41:44)
    8. Mahara 1.9RC1 (anitsirk, 09:41:55)
    9. Mahara Hui - conference and now what? (anitsirk, 09:45:37)
    10. Last week we had our first NZ mahara conference, Mahara Hui (hui = assembly, gathering in Te Reo Māori). It consisted of 2 days presentations and 1 day hackfest. (anitsirk, 09:46:13)
    11. In the mood of sharing, we are going to make our hui logo available to others to use and others are also welcome to use “Mahara Hui” as general conference name (anitsirk, 09:47:08)
    12. check out https://maharahui.org.nz to view the two logos (anitsirk, 09:48:34)
    13. https://maharahui.org.nz (anitsirk, 09:48:46)
    14. thank you very much for everyone who attended and congrats again for our newly appointed core devs, mingard, yuliyabozhko1 and ghada el-zoghbi. (anitsirk, 09:56:20)


Meeting ended at 09:56:23 UTC (full logs).

Action items

  1. everyone to look at list of enhancement suggestions made by the Ljubliana group
  2. anzeljg to write forum post / forum posts letting community members know about the usability improvement suggestions made in Ljubljana
  3. aarow_ to see how many files have a whitespace problem.
  4. rkabalin_ to update the dev documentation to reintroduce the requirement for avoiding trailing whitespaces
  5. aarow_ to update gerrit and launchpad settings to include the 3 new mahara core devs.


Action items, by person

  1. aarow_
    1. aarow_ to see how many files have a whitespace problem.
    2. aarow_ to update gerrit and launchpad settings to include the 3 new mahara core devs.
  2. anzeljg
    1. anzeljg to write forum post / forum posts letting community members know about the usability improvement suggestions made in Ljubljana
  3. rkabalin_
    1. rkabalin_ to update the dev documentation to reintroduce the requirement for avoiding trailing whitespaces


People present (lines said)

  1. anitsirk (215)
  2. aarow_ (82)
  3. anzeljg (64)
  4. mingard (64)
  5. rkabalin_ (58)
  6. robertl_ (46)
  7. yuliyabozhko1 (34)
  8. sonn2 (26)
  9. dajan (21)
  10. tobiasz3 (10)
  11. tonyjbutler (7)
  12. _mingard (5)
  13. maharameet` (2)


Generated by MeetBot 0.1.4.