08:01:48 <anitsirk> #startmeeting
08:01:48 <maharameet`> Meeting started Thu Mar 27 08:01:48 2014 UTC.  The chair is anitsirk. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:01:48 <maharameet`> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:01:55 <anitsirk> Hello and welcome to the 31st Mahara developer meeting.
08:01:56 <anitsirk> Please introduce yourself by prefacing your introduction with the #info tag.
08:01:56 <anitsirk> #info anitsirk is Kristina Hoeppner from Catalyst IT, Wellington, New Zealand
08:02:06 <anzeljg> #info anzeljg is Gregor Anzelj, developer and translator from Gimnazija Bežigrad, Ljubljana, Slovenia
08:02:13 <robertl_> #info robertl_ is Robert Lyon, Catalyst IT, Wellington, NZ
08:02:13 <tobiasz3> #info tobiasz3 is Tobias Zeuch, developer at the KIT, Karlsruhe, Germany
08:02:15 <anitsirk> If you have a long statement, please use .. in a line by itself to indicate that you are finished.
08:02:15 <sonn2> #info sonn2 is Son Nguyen from Catalyst IT, Wellington, New Zealand
08:02:23 <mingard> #info mingard is Jono Mingard, student at Victoria University of Wellington (NZ) and former intern at Catalyst IT
08:02:36 <rkabalin_> #info rkabalin is Ruslan Kabalin, Lancaster University, UK
08:02:45 <yuliyabozhko1> #yuliya is Yuliya Bozhko from Totara Learning Solutions, Wellington NZ
08:02:59 <anitsirk> i think that’s all.
08:03:00 <anitsirk> #topic Items from last meeting
08:03:01 <anitsirk> sonn2 will look at which OS's & versions we'll be cutting off if we drop support for MySQL 5.1
08:03:02 <aarow_> #info aarow_ is Aaron Wells from Catalyst IT in Wellington, NZ
08:03:22 <anitsirk> sonn2. over to you
08:03:27 <sonn2> I've just update the wiki page https://wiki.mahara.org/index.php/System_Administrator%27s_Guide/Requirements#Database_Server
08:03:56 <sonn2> There are 2 major distribution currently support Mysql 5.1
08:04:08 <sonn2> RedHat and CentOS
08:04:22 <anitsirk> #info sonn2 updated the wiki with information about databases: https://wiki.mahara.org/index.php/System_Administrator%27s_Guide/Requirements#Database_Server
08:04:59 <aarow_> I'm confused, from that table it looks like they are all 5.1.x
08:05:09 <mingard> those are the versions with 5.1.x
08:05:12 <anzeljg> aarow_: +1
08:05:14 <anitsirk> sonn2: it would be great if you added whether any of the distribution versions that you list in the first table are still supported by the projects
08:05:19 <aarow_> oh, I see, it's a range for most of them
08:05:20 <sonn2> There are old distribution
08:05:22 <mingard> for example ubuntu has 5.3.x (I think) as of 12.04
08:05:40 <aarow_> hm, but that range is still mostly 5.1.x
08:05:51 <anitsirk> we really need to know distros are still supported. it’s not clear from the table
08:06:14 <anitsirk> * know which distros *
08:06:35 <anitsirk> hello tonyjbutler. could you please introduce yourself starting your line with #info ?
08:07:04 <sonn2> Currently only RedHat and CentOS still support 5.5
08:07:06 <sonn2> 5.1
08:07:08 <rkabalin_> I think there should be a section about databases in general and subsection about 5.1
08:07:50 <anitsirk> hello dajan. can you please introduce yourself starting your line with #info ?
08:07:51 <tonyjbutler> #info Hi, I'm a Moodle and Mahara developer at Lancaster University in the UK, working with Ruslan Kabalin
08:07:51 <aarow_> sonn2: So basically, RedHat and CentOS are the only 2 distros where the highest MySQL version available, is 5.1?
08:08:21 <aarow_> in the current release of that distro
08:08:29 <robertl_> when is the MariaDB stuff kicking in?
08:08:32 <sonn2> they support lowest MySQL version
08:08:54 <dajan> #info dajan - Mahara French Community facilitator and Mahara translator
08:09:04 <aarow_> right, I think I understand the table now
08:09:28 <mingard> is it worth testing with MariaDB? they claim to be a drop-in replacement so I guess incompatibility is their problem, but still ...
08:10:03 <sonn2> Yes, IMO, we should support for MariaDB 5.5 +
08:10:08 <anitsirk> #idea: start testing with MariaDB?
08:10:44 <robertl_> +1 to testing with MariaDB
08:11:22 <aarow_> there's a list of differences: https://mariadb.com/kb/en/mariadb-vs-mysql-compatibility/
08:11:46 <anitsirk> #link https://mariadb.com/kb/en/mariadb-vs-mysql-compatibility/ - list of differences between MariaDB and MySQL
08:12:15 <aarow_> skimming through, it doesn't look like anything that will affect us, but it wouldn't hurt to test
08:12:35 <anitsirk> should we start looking into MariaDB then right after the 1.9 release?
08:12:42 <mingard> note ubuntu 14.04 will still package mysql and has no plans to switch
08:14:10 <sonn2> note: Debian don't have MariaDB package
08:14:27 <aarow_> I think just, if someone wants to try Mahara in MariaDB, that should be enough. Since it is 99.9% compatible and aims to be 100% compatible with standard MySQL we don't really need to go out of our way to test against it regularly
08:14:29 <rkabalin_> I think MySQL or MariaDB could both stay as requirement, assuming they are really identical in a sense that no changes are required on Mahara side for one of them.
08:15:08 <robertl_> so it should be ok to say we support it
08:15:09 <anitsirk> but would we list mariadb as supported db or just say: it should work?
08:15:27 <anitsirk> if we aren’t testing for anything on it, i’d hesitate to say we support it.
08:15:31 <rkabalin_> Debian Jessie (testing) has it
08:15:32 <aarow_> yep
08:15:40 <aarow_> it would make the most sense to just say we support MySQL
08:16:09 <aarow_> MariaDB users should understand from that statement, that it will also work in MariaDB
08:16:18 <robertl_> fair enough
08:16:36 <anitsirk> #idea aarow: it would make the most sense to just say we support MySQL. MariaDB users should understand from that statement, that it will also work in MariaDB
08:16:43 <anitsirk> do others agree?
08:16:50 <rkabalin_> #agree
08:16:50 <mingard> I would go with that until it's the default in more distros
08:16:55 <sonn2> #agree
08:16:55 <mingard> #agree
08:16:57 <tobiasz3> #agree
08:16:59 <yuliyabozhko1> #agree
08:17:01 <robertl_> #agree
08:17:01 <tonyjbutler> Sound good
08:17:38 <anzeljg> #agree
08:17:47 <anitsirk> #agreed DB requirements state that we support MySQL. MariaDB users should understand from that statement, that it will also work in MariaDB
08:17:59 <anitsirk> do we still need to talk about which versions of mysql to support?
08:18:10 <aarow_> Going back to the original topic of MySQL 5.1, since at least CentOS still offers no more recent version than 5.1.71, I think we should continue to support MySQL 5.1 for one more release cycle
08:18:32 <robertl_> I agree with aarow_
08:18:39 <anitsirk> #idea since at least CentOS still offers no more recent version than 5.1.71, I think we should continue to support MySQL 5.1 for one more release cycle
08:18:53 <anitsirk> do others agree as well?
08:19:02 <anzeljg> +1
08:19:04 <rkabalin_> #agree
08:19:06 <tonyjbutler> #agree
08:19:09 <mingard> #agree
08:19:09 <tobiasz3> #agree
08:19:13 <yuliyabozhko1> #agree
08:19:14 <anzeljg> #agree
08:19:28 <sonn2> #agree
08:19:31 <anitsirk> #agreed: Support MySQL 5.1 until Mahara 1.10
08:19:41 <anitsirk> does that cover it for this topic?
08:19:52 <aarow_> I think so
08:20:18 <anitsirk> rkabalin_: i’ll move anzeljg’s topic up (haven’t forgotten about you), but he needs to leave in 10 min.
08:20:30 <rkabalin_> that is fine
08:20:35 <anitsirk> #topic Usability
08:20:36 <anitsirk> I've discussed with anzeljg via email that this will be a more general topic around usability and not look at each individual item as further discussions around them are needed.
08:20:36 <anitsirk> anzeljg: Thank you for adding links to existing bug reports and for creating new ones. Did you already start looking into some of them specifically? Or do you have a priority list?
08:21:01 <anitsirk> now also since he only has 10 min. to discuss with us, we should keep it to that time to get the discussion started.
08:21:08 <anzeljg> no priority list, but some introduction is needed, so...
08:21:25 <anzeljg> and anitsirk it's 70 minutes (the times were in UTC)
08:21:36 <anitsirk> oh sorry.
08:21:48 <anitsirk> mixed up my time zones
08:21:54 <anzeljg> Should I continue anyway?
08:21:57 <rkabalin_> yep
08:21:57 <anitsirk> yes, please
08:22:01 <anzeljg> On March 4th the Mahara international workshop took place in Ljubljana.
08:22:28 <anzeljg> This was a workshop for Slovenian schools taking part in EUfolio project (#link http://eufolio.eu/).
08:22:36 <anzeljg> In the project of collaboration between several school from several countries.
08:22:43 <anzeljg> After this short info I must also add that a part of that workshop there was aslo a developer meeting.
08:22:51 <anzeljg> At this meeting both sides, Austrian (represented by Klaus Himpsl-Gutermann, Thomas Strasser, Christian Fertl)
08:22:58 <anzeljg> and Slovenian (represented mainly by myself) exchanged our views on Mahara usability and the troubles faced
08:23:05 <anzeljg> when using Mahara.
08:23:12 <anzeljg> A lot of usability issues were already reported by other users and so wishlist items already exist, some
08:23:19 <anzeljg> issues I couldn't find so I've added new wishlist items.
08:23:26 <anzeljg> I propose that we go through these items one by one. The issues are described in bug tracker and I'll
08:23:35 <anzeljg> also post links here. If more explanaion is needed I'll try and explain those issues in more detail.
08:23:43 <anzeljg> The issues are in no particualr order...
08:23:44 <anzeljg> ..
08:23:52 <anitsirk> #info An international Mahara workshop took place in Ljubljana on 4 March 2014 that included representatives from Slovenian schools participating in the EUfolio project http://eufolio.eu
08:24:03 <anzeljg> #info Choose internal image in TinyMCE without attaching it first.
08:24:11 <anzeljg> #link https://bugs.launchpad.net/mahara/+bug/1038580
08:24:18 <anzeljg> #link https://bugs.launchpad.net/mahara/+bug/1235569
08:24:26 <anzeljg> Maybe should start with this...
08:25:02 <mingard> definitely something I've come across and want to see fixed
08:25:19 <anzeljg> We have also noticed if a user adds an image in textbox and wants to embed that image into a textbox content he/she is unable to do so.
08:26:12 <anitsirk> anzeljg: can you please file a report for that with the steps that you took? Normally that should work.
08:26:25 <anzeljg> Ok I'll do that...
08:26:36 <mingard> for the record, I have a patch to upgrade to tinymce 4.x in gerrit and it seems like in theory the image dialog plugin would be easy to extend to include a mahara file browser
08:26:45 <mingard> which is what I would like to see as a long-term solution
08:26:49 <rkabalin_> We came across that one in the past as well, people reported it.
08:27:02 <aarow_> +1 to what mingard said
08:27:04 <anzeljg> mingard: great
08:27:17 <anitsirk> i propose we take a look at the reports until the next meeting as there is quite a bit to read and think about
08:28:06 <robertl_> with the embedding of the image in the tinymce - what happens when the image is deleted?
08:28:17 <anitsirk> it would also be good to get some non-devs involved in the discussion. i know that shane from U of Canberra is interested in making usability improvements.
08:28:46 <mingard> robertl: would be nice if we could replace it with an 'image deleted' placeholder ...
08:29:07 <aarow_> Well, the browser will do that for you sort of, by showing that "missing or broken image" icon ;)
08:29:23 <robertl_> indeed :)
08:29:43 <anitsirk> or there could be a dialogue before deleting the image for good like we have elsewhere.
08:30:12 <mingard> yeah, but it might be hard to go through the db and delete it in all the places it appears
08:30:15 <yuliyabozhko1> then you'll need to check if it's used anywhere which might not be easy
08:30:38 <robertl_> it's just once the link is hardcoded in the html content of a box it is 'lost' to the mahara system
08:30:41 <anitsirk> mingard: the dialogue only tells you that the image is being used.
08:31:06 <anitsirk> right. so not like the other artefacts.
08:31:10 <mingard> so would the user just need to find all the places it's used and delete it from them?
08:31:16 <aarow_> yeah, if you wanted smarter behavior you'd need to store a record of that image link in addition to just putting an <img> tag in the html
08:31:49 <yuliyabozhko1> I think moodle does smth like that
08:32:00 <mingard> could you just grep for the image URL in the text box content? would that be too slow/hard?
08:33:07 <robertl_> could end up with problems if people manually alter the html code slightly so the grep doesn't pick them up
08:33:24 <mingard> true. but then it's their fault if the image isn't deleted :P
08:33:27 <aarow_> my instinct is you'd have reliability and performance issues if you just regexed the stored HTML in the DB
08:33:38 <robertl_> but it is to us they complain :)
08:33:53 <anitsirk> does someone want to look into this specifically after we’ve upgraded to tinymce for 1.10?
08:34:27 <aarow_> well, first things first, would be to just add that tinyMCE button for easier embedding of Mahara images
08:34:48 <aarow_> once that's in we could look at enhancing it to warn you when you're going to delete an image that's used in pages
08:35:01 <anzeljg> Maybe it would be also nice to revert the process by not needing to add image as attachement first, but that all images uploaded to user files would be instantly available for content inclusion in tinymce?
08:35:10 <rkabalin_> sounds like a good plan aarow_
08:35:12 <aarow_> Yes, that would be better
08:35:27 <aarow_> same for blogs, actually
08:36:05 <_mingard> sorry, uni internet >_<
08:36:12 <anzeljg> Blog entries and textboxes were both mentioned, yes :)
08:37:03 <robertl_> would you want tinymce to list all image files you've uploaded or just a subsection under say 'images' subdir?
08:37:26 <_mingard> I would say all image files
08:37:31 <anitsirk> robertl_: that wouldn’t be good because you may have your images all over your place due to your own organization
08:37:40 <_mingard> exactly
08:37:51 <robertl_> fair enough
08:38:39 <_mingard> it would be cool if there was a generic 'insert' button which could insert images, videos, or other types of files ...
08:38:57 <anitsirk> shall we say to look into the other things until the next dev meeting and update the enhancement reports with comments and questions?
08:39:11 <aarow_> sure
08:39:15 <rkabalin_> anitsirk +1
08:39:21 <_mingard> +1
08:39:43 <anitsirk> anzeljg: it would also be good if you wrote a forum post / forum posts if you haven’t already done so. Sorry, haven’t had time to check. people who only read the forums might want to know. some of these also mirror what christian kleinhanss had suggested
08:40:04 <anitsirk> #action everyone to look at list of enhancement suggestions made by the Ljubliana group
08:40:13 <anzeljg> I haven't. I was planning to do tat after this meeting.
08:40:21 <anitsirk> sounds great, anzeljg
08:40:24 <anitsirk> thank you
08:41:01 <anitsirk> #action anzeljg to write forum post / forum posts letting community members know about the usability improvement suggestions made in Ljubljana
08:41:07 <anitsirk> shall we move on?
08:41:20 <anzeljg> #info Copying of Textboxes should create real copies.
08:41:25 <yuliyabozhko1> yep
08:41:25 <anzeljg> #link https://bugs.launchpad.net/mahara/+bug/1296390
08:41:44 <anitsirk> anzeljg: i wouldn’t discuss every topic now. we just agreed to look at all of them until next meeting ;-)
08:41:51 <anzeljg> ok.
08:41:53 <anzeljg> sorry
08:42:18 <anitsirk> #topic Whitespace changes in patches
08:42:19 <anitsirk> The floor is yours, rkabalin_.
08:42:24 <rkabalin_> thanks
08:42:28 <anzeljg> I that case I'm done. I think they are quite well documented...
08:42:46 <rkabalin_> OK, trailing whitespaces. This has been discussed in the past http://meetbot.mahara.org/mahara-dev/2013/mahara-dev.2013-09-05-08.01.log.html
08:42:49 <rkabalin_> Basically, they add too much noise in the diffs, make revision difficult, make history navigation more difficult (e.g. if I use gitk, not diff), create first impression of low coding quality for someone who did not come accross mahara before.
08:42:53 <rkabalin_> I know, there is a way to run "git diff -w" and also an option in revision interface not to show whitespace changes.
08:42:56 <rkabalin_> But in my opinion, we basically allow to ignore something that can be easily avoided, and it is not even an obstracle that would stop people contributing.
08:42:59 <rkabalin_> I suggest to make a requirement not to introduce whitespaces changes at the lines that are not modified by the patch.
08:43:08 <anitsirk> #trailing white spaces have been discussed in http://meetbot.mahara.org/mahara-dev/2013/mahara-dev.2013-09-05-08.01.log.html
08:44:07 <aarow_> With the tools that I'm using (eclipse and git) it's actually harder to trim out all the extraneous whitespace changes from my change when committing, than to ignore them when diffing
08:44:08 <tobiasz3> would that requirement be checked by the script when running make push?
08:44:09 <anitsirk> #idea rkabalin_ suggests to make a requirement not to introduce whitespaces changes at the lines that are not modified by the patch.
08:44:11 <mingard> mahara does have issues with inconsistent whitespace though ... should these be addressed or just ignored until a patch happens to modify those lines?
08:44:31 <anitsirk> what about whitespace in third-party plugins?
08:44:35 <aarow_> How about we just run a formatter, after 1.9 is out, and strip out the extraneous whitespace from all the old Mahara core files?
08:44:44 <mingard> yes please :)
08:44:50 <rkabalin_> aarow_ are you sure there is no such setting in Eclipse? Netbeans for instance has it.
08:44:54 <aarow_> there are some really lengthy, old ones that have whitespace on the end of every line
08:45:05 <anitsirk> #idea arrow_: How about we just run a formatter, after 1.9 is out, and strip out the extraneous whitespace from all the old Mahara core files?
08:45:14 <rkabalin_> tobiasz3 It is more like for reviewers to check rather than script I think.
08:45:17 <aarow_> the problem in Eclipse is that the "Strip whitespace from end of lines" setting strips it from the end of *every* line in the file
08:46:11 <aarow_> so if I'm editing something like lib/activity.php, and I change one line, Eclipse strips the whitespace from every line, and then it's a hassle for me to do "git add -p", the one git command that *doesn't* have an "ignore whitespace" option, and pick out my one real change
08:46:25 <rkabalin_> Old lines could remain unchanged until someone touched them.
08:47:00 <aarow_> if we just ran a scrubbing script one time and cleared out the extraneous whitespace from the old lib files it would make my life a lot easier
08:47:09 <mingard> seconded - assuming a good enough one exists?
08:47:10 <rkabalin_> the problem with existing pataches, not old ones, anf if requirement will be enforced, we will gradually eleimiate whitespaces instances in the code.
08:47:32 <yuliyabozhko1> I thought there was a requirement already :)
08:47:43 <aarow_> we softened it to a recommendation
08:47:44 <mingard> there is
08:47:48 <mingard> (or not)
08:47:53 <robertl_> there is also the tabs instead of 4 space chars issue too
08:48:08 <anzeljg> especially in css files
08:48:16 <aarow_> I agree with enforcing the tab rule ;)
08:48:18 <tobiasz3> i think it only checks the changed lines, so you cannot introduce new whitespaces
08:48:19 <mingard> yeah, what if we are editing a file which uses tabs for indenting?
08:48:21 <yuliyabozhko1> stripping all existing ones will add quite a bit of noise
08:48:23 <mingard> my tabs are two spaces wide
08:48:29 <yuliyabozhko1> and will make git blame hard to you
08:48:31 <yuliyabozhko1> *use
08:48:37 <mingard> true that
08:48:37 <rkabalin_> aarow_ stubbing script could be an option, e.g. to run it once after release, but if there is no requirements new instances will be introduced again.
08:49:05 <mingard> I would be fine with scrubbing and adding more strict whitespace requirements
08:49:24 <yuliyabozhko1> why can't make push check for that in the lines changed?
08:50:05 <robertl_> sometimes make push is too picky and one needs to git push to gerrit
08:50:27 <mingard> I was wondering if there should be a force-push task in make which skips the checks (eg. too strict sql injection ones)
08:50:34 <robertl_> like when it complains on sql statements with from or join
08:50:39 <yuliyabozhko1> we have custom codechecker in Totara that does these kind of checks
08:50:48 <aarow_> that might be a good idea, mingard
08:51:01 <rkabalin_> mingard force puch is laready there ))
08:51:06 <aarow_> I just do "git push gerrit HEAD:refs/publish/master", but the syntax is easy to forget
08:51:10 <rkabalin_> s/puch/push
08:51:16 <tonyjbutler> I think a one-time scrubbing script followed by a requirement for future commits is the best solution
08:51:34 <rkabalin_> just do not use make ;)
08:52:26 <anitsirk> rkabalin_: just make sure to change the instructions on the wiki and it should be fine. then people like me won’t make any mistakes with the new rule ;-)
08:52:47 <robertl_> I agree with one time scrub script
08:52:48 <rkabalin_> one-time scrubbing script is not required even really. Requirement is more important.
08:52:51 <aarow_> It should also be noted, the big exception to the whitespace rule is external libraries
08:52:58 <mingard> for me having clean code outweighs the downside of hard-to-use git blame as yuliya pointed out
08:53:14 <aarow_> you can always do "git blame -w" ;)
08:53:20 <anitsirk> #info the big exception to the whitespace rule is external libraries
08:53:22 <mingard> so the scrubber would need to skip everything in lib/...?
08:53:40 <anzeljg> A question about comment in the beginning of each file. Which is valid? please see the difference between e.g. "htdocs/import.lib.php" and e.g. "htdocs/artefact/comment/version.php" (Mahara 1.8 code)
08:53:41 <aarow_> maybe every subdirectory that has a README.Mahara file in it
08:53:41 <rkabalin_> I agree re external libs, we do not need changing whitespace there.
08:54:28 <anzeljg> sorry: "htdocs/import/lib.php"
08:54:46 <mingard> anzeljg: the comment format was changed but I can't remember which is the new one
08:54:53 <mingard> IMO that should also be cleaned up
08:55:19 <anzeljg> Does it also apply for 3rd party plugins? It should IMO
08:55:40 <aarow_> anzeljg: Does what apply for 3rd party plugins?
08:56:00 <anzeljg> the comment format on the beginning of each file
08:56:28 <anzeljg> so the comment is the same as it is in core files
08:56:37 <anzeljg> well: same structure
08:56:40 <mingard> I would have it as a guideline for 3rd party plugins but not a requirement unless they are merged into core
08:56:57 <sonn2> I think these rules only apply for the core
08:57:08 <anzeljg> guideline sounds fine...
08:57:09 <anitsirk> mingard: do you mean mahara things or also 3rd party like tinymce?
08:57:11 <rkabalin_> If everyone agree, I will update documentation to make avoiding trailing whitespace changes as requirement.
08:57:25 <anitsirk> rkabalin_: and what about the scrubber?
08:57:27 <mingard> anitsirk: I just mean mahara things
08:57:28 <aarow_> Well, we don't code review 3rd party plugins, so we can't really enforce guidelines on them ;)
08:57:30 <robertl_> rkabalin_, I'm fine with that
08:57:57 <aarow_> I still vote against having whitespace as a requirement, but if everyone else wants it, so be it
08:57:59 <robertl_> well we only review them if we want to get them into core
08:58:07 <tonyjbutler> Without the scrubber first, life would be hard for Eclipse users wouldn't it?
08:58:23 <mingard> aarow_, I guess conscientious plugin devs can just look up the core guidelines
08:58:24 <aarow_> well, no harder than it currently is
08:58:36 <aarow_> the scrubber would just make my life easier
08:58:46 <mingard> and probably the lives of other potential devs
08:58:51 <aarow_> yes
08:58:58 <aarow_> as well as making the whitespace rule clearer
08:59:15 <rkabalin_> regarding stripping script, it is optional (I think not needed), inddeed, as yuliyabozhko1 stated, it will break git blame
08:59:22 <rkabalin_> re Eclipse users
08:59:50 <rkabalin_> what about not to inforce whitespace changes in eclipse
09:00:12 <rkabalin_> but making git stripping them
09:00:23 <rkabalin_> there is an option
09:00:27 <aarow_> an automated formatting script would be a great idea
09:01:07 <rkabalin_> in which case only whitespaces in the patch will be stripped only
09:01:19 <aarow_> it wouldn't break git blame, because there's "git blame -w". It might break Eclipse annotate, which is a graphical equivalent to git blame...
09:01:22 <anitsirk> #idea rkabalin_: have git strip whitespace changes from users who work with eclipse. aarow_: an automated formatting script would be a great idea
09:01:52 <aarow_> tell you what, I'll take a look at how many files have a whitespace problem
09:02:06 <anitsirk> #info aarow_: the automated formatting script wouldn't break git blame, because there's "git blame -w". It might break Eclipse annotate, which is a graphical equivalent to git blame...
09:02:10 <mingard> I would say automated formatting and stripping script if git blame -w is a viable option for people who need git blame
09:02:14 <aarow_> if we could just strip whitespace from a few crucial 10,000-line files that I as a core dev edit frequently, it would make my life a lot happier
09:02:49 <anitsirk> #action aarow_ to see how many files have a whitespace problem.
09:03:07 <anitsirk> should rkabalin_ still update the documentation to reintroduce the whitespace requirement?
09:03:18 <aarow_> sure, everyone but me seems to be in agreement about that
09:03:28 <mingard> +1
09:03:32 <robertl_> +1
09:03:34 <sonn2> +1
09:03:40 <tonyjbutler> +1
09:03:49 <anitsirk> #agreed: reintroduce the requirement for avoiding trailing whitespaces
09:04:00 <anitsirk> alright. anything else on this topic for now?
09:04:15 <rkabalin_> anitsirk, action for me please ;)
09:04:25 <anitsirk> action coming up.
09:04:36 <rkabalin_> cool
09:04:50 <anitsirk> #action rkabalin_ to update the dev documentation to reintroduce the requirement for avoiding trailing whitespaces
09:05:07 <rkabalin_> that is it on this topic I think
09:05:16 <anitsirk> moving on to some happy news.
09:05:19 <anitsirk> #topic Mahara core developer applications
09:05:20 <anitsirk> We are very happy to have received 3 applications from developers who have been very active in the community over the last months. They are: Jono Mingard, Yuliya Bozhko and Ghada El-Zoghbi.
09:05:21 <anitsirk> You can find their applications at:
09:05:23 <anitsirk> #link https://wiki.mahara.org/index.php/User:Mingard mingard
09:05:24 <anitsirk> #link https://wiki.mahara.org/index.php/User:Ybozhko yuliyabozhko1
09:05:25 <anitsirk> #link https://wiki.mahara.org/index.php/Developer_Area/Developer_Meetings/Core_Developer_Applications/Ghada_El-Zoghbi Ghada
09:05:26 <anitsirk> I hope all present approved core developers have had time to review the applications.
09:05:27 <anitsirk> Unfortunately, Ghada is not able to attend today's meeting due to a time zone conflict. However, if you have general questions, I may be able to answer them as I've worked with her on some Mahara projects.
09:05:32 <anitsirk> As for the voting, the approved core developers listed at https://reviews.mahara.org/#/admin/groups/6,members are allowed to vote on the applications. As far as I can see, we have the following approved core developers present:
09:05:52 <anitsirk> aarow_, rkabalin_, robertl_  and sonn2
09:06:03 <anitsirk> so these can vote
09:06:22 <anitsirk> the rest of us can’t cast votes, but can still ask questions :-)
09:06:44 <anitsirk> please let me know if i missed any core dev who has snuck in.
09:07:06 <yuliyabozhko1> might need 5 voters to decide :)
09:07:12 <anitsirk> why?
09:07:19 <yuliyabozhko1> 4 can be 2/2 :)
09:07:26 <anitsirk> we’ll see, yuliyabozhko1
09:07:26 <yuliyabozhko1> kidding
09:07:56 <aarow_> In Nevada, if an electoral vote results in a tie, it is settled by drawing a card
09:08:04 <robertl_> heh
09:08:21 <aarow_> just sayin' ;)
09:08:23 <anitsirk> makes sense… in nevada
09:08:36 <robertl_> I'd thought you were going to say drawing a gun
09:08:37 <tobiasz3> you could vote on one that all agree upon and then he can vote as the fifth :)
09:08:40 <anitsirk> any questions for the applicants? don’t let them sweat
09:08:57 <aarow_> robertl_: That's how they do it in Texas
09:09:12 <robertl_> lol
09:09:12 <yuliyabozhko1> :D
09:09:49 <anitsirk> going once
09:10:01 <anitsirk> going twice
09:10:09 <rkabalin_> What you guys think is the most important feature in mahara
09:10:09 <anitsirk> (i’m auctioning off question time)
09:10:30 <rkabalin_> (question for all applicants)
09:10:32 <mingard> most important feature currently?
09:10:43 <rkabalin_> in your understanding
09:10:59 <yuliyabozhko1> for me personally: privacy
09:11:02 <rkabalin_> might be not a feature per se, but a philosophy you know
09:11:19 <anitsirk> privacy in what sense?
09:11:23 <yuliyabozhko1> being able to show only what I need to/ want to
09:11:51 <anitsirk> BTW: i can’t answer that question on behalf of ghada
09:12:11 <robertl_> is there any part of mahara you would like to champion/promote?
09:12:16 <mingard> for me it's groups - seems like the thing that separates mahara from traditional portfolios/websites; collaboratively working on pages and stuff
09:12:22 <mingard> (in answer to rkbalin_)
09:12:39 <rkabalin_> yep, thanks guys
09:13:32 <anitsirk> robertl_: seems like you asked a tough question
09:13:42 <robertl_> indeed
09:13:56 <mingard> robertl_: I would champion the social side of things for much the same reasons - I can see how it would have been useful in high school
09:14:03 <mingard> to have feedback on various pieces of work
09:14:14 <yuliyabozhko1> robertl_: easier sharing of things, not only via pages :) and social networking
09:14:17 <mingard> and more individual student/teacher collaboration
09:14:32 <robertl_> good answers
09:14:42 <anitsirk> any more questions?
09:14:48 <anitsirk> or comments on the applications?
09:15:52 <anitsirk> alright. shall we move to the voting then?
09:15:53 <yuliyabozhko1> now anitsirk is asking tough questions :)
09:16:01 <anitsirk> :-)
09:16:03 <aarow_> +1 for voting ;)
09:16:06 <robertl_> lets vote!
09:16:30 <anitsirk> good. so only the 4 aforementioned can vote: aarow_, rkabalin_, robertl_ and sonn2
09:16:45 <anitsirk> it’s an open voting (the chat is logged and everyone can see the results)
09:16:46 <rkabalin_> others are observers )
09:16:54 <anitsirk> yes. thank you.
09:17:02 <anitsirk> and the applications don’t need to leave the chat. ;-)
09:17:03 <yuliyabozhko1> lol, and no cheating!
09:17:20 <anitsirk> so. ready. let’s start with jono
09:17:35 <sonn2> +2
09:17:40 <aarow_> lol
09:17:43 <robertl_> I vote yes
09:17:44 <anitsirk> the 4: please give us a +1 if you approve of jono becoming an approved core dev
09:17:47 <aarow_> +1-verified, +2-code-reviewed
09:17:56 <robertl_> +1
09:17:56 <aarow_> er... +1
09:17:57 <rkabalin_> +1
09:18:00 <sonn2> +1
09:18:10 <anitsirk> thank you. congratulations, mingard
09:18:15 <mingard> thanks :)
09:18:17 <yuliyabozhko1> merge it, quickly! :P until they changed their mind
09:18:21 <mingard> haha
09:18:25 <rkabalin_> :D
09:18:26 <anitsirk> #agreed jono mingard to become an approved mahara core developer.
09:18:40 <anitsirk> and now on to yuliyabozhko1. same procedure as above.
09:18:41 <sonn2> congrat
09:18:46 <aarow_> +1
09:18:47 <anzeljg> congrats
09:18:47 <robertl_> +1
09:18:47 <rkabalin_> +1
09:18:52 <sonn2> +1
09:19:01 <anitsirk> #agreed yuliyabozhko1 is to be an approved mahara core developer.
09:19:06 <anzeljg> congrats
09:19:07 <anitsirk> congratulations, yuliyabozhko1!
09:19:07 <yuliyabozhko1> yay! thanks :)
09:19:16 <mingard> congratulations :)
09:19:27 <anitsirk> and last not least, ghada el-zoghbi. let’s hear it for her in abscence.
09:19:33 <aarow_> +1
09:19:34 <robertl_> +1
09:19:36 <rkabalin_> +1
09:19:37 <sonn2> +1
09:19:56 <anitsirk> #agreed ghada el-zoghbi is the 3rd new approved mahara core developer
09:20:04 <anitsirk> congratulations, ghada!
09:20:11 <anzeljg> congrats to her also...
09:20:12 <aarow_> excellent, we're unanimous
09:20:15 <sonn2> congrats all aplicants
09:20:17 <mingard> congratulations if you're reading this chat log ;)
09:20:18 <yuliyabozhko1> :) awesome
09:20:19 <robertl_> congrats to all the new core developers, woo hoo!
09:20:25 <aarow_> I'll go ahead and update their settings in gerrit & launchpad
09:20:26 <mingard> yay, thanks everyone :)
09:20:28 <anitsirk> so now we have lots more core devs who can give a +2 on reviews :-)
09:20:31 <tobiasz3> congrats to all three of you
09:20:35 <anitsirk> thank you, aarow_
09:20:53 <anitsirk> #action aarow_ to update gerrit and launchpad settings to include the 3 new mahara core devs.
09:20:55 <rkabalin_> Congratulations
09:21:48 <anitsirk> tweet has been sent.
09:21:49 <robertl_> and when we get the openbadges stuff going we should have a mahara core developer badge :)
09:21:57 <anitsirk> :-)
09:21:58 <mingard> haha yes please
09:22:01 <sonn2> :)
09:22:21 <anitsirk> ok. i think this concludes this topic.
09:22:36 <anitsirk> #topic Next meeting and chair
09:22:36 <anitsirk> Shall we continue with the morning for Europe and evening for NZ / afternoon for Perth?
09:22:50 <anitsirk> (in case andrew will be able to join in)
09:23:08 <mingard> it'll be the middle of the night for me in japan (I think(
09:23:10 <anzeljg> robertl_: Already created one... :)
09:23:26 <anitsirk> oh. sorry, mingard. forgot about that. :-(
09:23:31 <yuliyabozhko1> any time fine with me
09:23:37 <robertl_> I'm fine with NZ in the evenings
09:23:48 <anitsirk> mingard: actually, it would be afternoon
09:23:52 <rkabalin_> I'm fine with UK morning
09:23:54 <sonn2> evening in NZ is fine for me
09:24:06 <mingard> oh yes, it would be the other way. never mind anitsirk :)
09:24:17 <anitsirk> what about Thursday, 24 April 2014 at 8 a.m. UTC (9 a.m. UK, 10 a.m. Europe, 8 p.m. NZ, 4 p.m. Perth / Tokyo?
09:24:24 <aarow_> the current meeting time just screws over North & South America, but we don't have anyone reporting from there just now
09:24:31 <anitsirk> so morning for europe would then definitely make more sense
09:24:44 <anitsirk> no, we don’t and i haven’t heard any complaints.
09:24:44 <aarow_> so sure, this time is fine by me
09:25:01 <aarow_> when those lazy Americans start contributing, we'll start rotating the meeting times again ;)
09:25:03 <yuliyabozhko1> it is Thursday before Easter Friday
09:25:09 <anitsirk> we should be able to have a virtual celebration on having released mahara 1.9 at that time
09:25:34 <anitsirk> yuliyabozhko1: no. it’s thursday before anzac day
09:25:39 <robertl_> thurs after easter
09:25:40 <anitsirk> easter is the week before
09:25:59 <anitsirk> would one hour earlier be better?
09:26:03 <anitsirk> or one week later?
09:26:08 <tobiasz3> I'm fine with Thursday, 24 April 2014 at 8 a.m. UTC
09:26:15 <yuliyabozhko1> right :) yep, fine for me then :)
09:26:20 <anzeljg> works for me also
09:26:21 <mingard> no idea what I'll be doing then, so any time is fine
09:26:26 <rkabalin_> I will not be able to join 24 April 2014
09:26:36 <anitsirk> rkabalin_: one week later?
09:26:37 <robertl_> 24th sounds fine to me
09:26:42 <anitsirk> may day?
09:26:53 <anitsirk> we don’t have the day off in nz ;-)
09:26:58 <anitsirk> can’t remember if the uk does
09:27:04 <anitsirk> what about japan?
09:27:07 <rkabalin_> up to you I can skip one
09:27:23 <rkabalin_> one week later is fine in fact
09:27:26 <anitsirk> rkabalin_: give us a date that would work for you
09:27:26 <dajan> 24th is fine to me
09:27:40 <anitsirk> so what about 1 may same time? would that suit everyone?
09:27:58 <robertl_> may 1st is ok for me
09:28:01 <mingard> yep. not a holiday in japan but I should still be able to make it
09:28:06 <rkabalin_> fine with me
09:28:10 <dajan> I have just missed the previous votes. All were ok to me
09:28:15 <tonyjbutler> ok with me
09:28:29 <anzeljg> ok with me
09:28:31 <yuliyabozhko1> yep, for me too
09:28:45 <anitsirk> dajan: you were not allowed to vote anyway. just an observer. ;-)
09:28:58 <anitsirk> alright. then let’s lock it in.
09:29:21 <anzeljg> For future reference: http://www.timeanddate.com/holidays/ ;)
09:29:29 <anitsirk> #agreed 32nd Mahara dev meeting on Thursday, 1 May 2014 at 8:00 UTC: http://www.timeanddate.com/worldclock/fixedtime.html?msg=32nd+Mahara+developer+meeting&iso=20140501T08
09:29:30 <anitsirk> and who wants to chair?
09:29:44 <rkabalin_> I can
09:29:46 <anzeljg> maybe one of the new core devs?
09:29:52 <anzeljg> too late
09:29:54 <rkabalin_> or, may be actually
09:29:58 <anitsirk> give them some time, anzeljg ;-)
09:30:02 <anzeljg> ok
09:30:12 <anitsirk> don’t want to scare them away ;-)
09:30:17 <rkabalin_> then me
09:30:18 <yuliyabozhko1> phew, got scared for a sec :P
09:30:29 <mingard> yeah, you're really very scary people
09:30:34 <anitsirk> yuliyabozhko1: but then for the 33rd :-D
09:30:46 <anitsirk> thank you for volunteering, rkabalin_
09:30:51 <yuliyabozhko1> deal
09:30:59 <anitsirk> #info rkabalin_ to chair the 32nd Mahara dev meeting.
09:31:12 <anitsirk> #topic Any other business
09:31:18 <anzeljg> I have one
09:31:26 <anitsirk> i have two
09:31:41 <anitsirk> anzeljg: please start
09:31:52 <anzeljg> I just wanted to ask why the reviews have stalled on https://reviews.mahara.org/#/c/2936/?
09:32:03 <anzeljg> not pushing or something...
09:32:05 <anitsirk> #info anzeljg: I just wanted to ask why the reviews have stalled on https://reviews.mahara.org/#/c/2936/
09:32:28 <anitsirk> we decided to keep this for mahara 1.10 as it would not get into 1.9 in time.
09:32:37 <sonn2> I can't see the patch
09:32:39 <aarow_> sorry, we just didn't have time to get around to it
09:32:48 <anzeljg> ok :(
09:32:48 <aarow_> sonn2: drop the ? from the end of the URL
09:33:10 <anitsirk> on the up side: it should get into 1.10 early on :-)
09:33:10 <sonn2> have not signed in yet
09:33:12 <sonn2> :)
09:33:22 <anitsirk> and the profile completion stuff is going into 1.9 as far as i know
09:33:32 <aarow_> yes
09:33:37 <anitsirk> sonn2: you can view the page without signing in
09:33:43 <robertl_> progress bar is merged
09:33:49 <tobiasz3> I guess it's the same for https://reviews.mahara.org/#/c/2686/ ?
09:33:50 <anitsirk> and your cookie consent is in as well
09:34:00 <anitsirk> yes, tobiasz3
09:34:14 <anitsirk> there are still a number of things that will need to be looked into
09:34:16 <aarow_> yes, sorry about that as well
09:34:33 <tobiasz3> ok, never mind
09:34:48 <anzeljg> anitsirk: i know and i'm gretful... just checking...
09:34:57 <anitsirk> and again: we should be getting this in early on for 1.10.
09:34:58 <anzeljg> I know that you guys have a lot of work :)
09:35:14 <anitsirk> it’s fantastic to have all these new features.
09:35:15 <anzeljg> getful = grateful
09:35:24 <anitsirk> which takes me to my topic.
09:35:33 <anitsirk> #info Mahara 1.9RC1 is about to be released.
09:35:39 <aarow_> on the note of profiles, actually, I was intrigued by the "booklet" plugin, which I saw at the NZ Mahara Hui last week: https://wiki.mahara.org/index.php/Plugins/Artefact/Booklet
09:35:57 <aarow_> it's basically custom fields for Mahara
09:36:00 <anitsirk> we are going through the last bits and pieces, i.e. lang string fixes and last changes.
09:36:13 <mingard> yes, I'd like to get the booklet plugin into 1.10 if possible
09:36:37 <yuliyabozhko1> instead of current profile?
09:36:46 <aarow_> I was thinking it might actually be something we could incorporate in as a replacement for the current profile & resume plugin sets, to make them fully customizable.
09:37:01 <mingard> yuliyabozkho1: instead of resume
09:37:01 <robertl_> the booklet plugin would deal with 'Multilinguality of Mahara artefacts' in resume section
09:37:05 <anitsirk> which might also resolve some multi-language requirements
09:37:15 <aarow_> though resume attachments might be hard to convert to the booklet format
09:37:22 <dajan> I showed your the booklet last year when i was in NZ but it was not working very well. Is it now any better?
09:37:39 <anitsirk> dajan: it’s in gerrit :-)
09:37:40 <yuliyabozhko1> looked pretty good last time we saw it
09:37:40 <mingard> true. and there might be issues with displaying stuff on small screens
09:37:42 <aarow_> Well admittedly I haven't tried it firsthand ;)
09:37:47 <aarow_> just saw the presentation
09:37:57 <aarow_> and I haven't looked at the code yet
09:38:12 <dajan> It was one of the interesting presentation in Mahoodle FR last year.
09:38:22 <anitsirk> it will need to be looked at from a number of angles and christophe had a list of todos that should be taken into consideration when reviewing it for core
09:38:23 <robertl_> the presentation was good
09:38:44 <mingard> it was, and the main features look basically finished
09:38:56 <mingard> did christophe say if it's in production at his uni?
09:39:04 <dajan> Don’t forget to talk about Maharamoot and Moodlemoot FR 2014 in Paris - June the 4-6th !
09:39:04 <sonn2> no
09:39:07 <anitsirk> #info the booklet plugin https://wiki.mahara.org/index.php/Plugins/Artefact/Booklet was presented at Mahara Hui in Wellington last week and found a lot of interest.
09:39:09 <anitsirk> #link https://wiki.mahara.org/index.php/Plugins/Artefact/Booklet
09:39:13 <aarow_> yes, I think he said it was
09:39:30 <anitsirk> mingard: yes. i think he mentioned it’s being used by a number of universities
09:39:48 <anitsirk> dajan. ok. you just got some other business :-)
09:39:58 <anitsirk> #info Maharamoot and Moodlemoot FR 2014 in Paris - June the 4-6th
09:40:03 <anitsirk> any more info, dajan?
09:40:22 <dajan> No. comming back gently but surely.
09:40:23 <anitsirk> would be good if you gave me a short blurb for the newsletter by tomorrow. there won’t be another one before 1 july.
09:40:36 <dajan> Right will do this later today.
09:40:41 <anitsirk> or is there already a website where i could steal some info, e.g. on cfp?
09:41:04 <anitsirk> i need to get the newsletter done latest on saturday NZ time.
09:41:23 <anitsirk> thank you, dajan. much appreciated.
09:41:24 <dajan> Yes here : http://moodlemoot2014.univ-paris3.fr/ and here http://moodlemoot2014.univ-paris3.fr/mahara/
09:41:37 <anitsirk> #link http://moodlemoot2014.univ-paris3.fr/
09:41:37 <dajan> Wilco
09:41:44 <anitsirk> #link http://moodlemoot2014.univ-paris3.fr/mahara/
09:41:50 <anitsirk> alright. back to my business.
09:41:55 <anitsirk> #info Mahara 1.9RC1
09:42:29 <anitsirk> so as I said, we are dealing with the last bits and pieces. my lang string fixes are all in gerrit but one where i need some help tomorrow as it would be HTML code in an error message.
09:42:54 <anitsirk> drumroll
09:42:57 <anitsirk> then we are looking at releasing RC1 either tomorrow or on monday.
09:43:12 <dajan> cool
09:43:26 <anitsirk> we invite everyone to test and test and test and give us feedback quickly so we can still meet our targeted release time of mid-april
09:43:55 <anzeljg> cool. really cool...
09:44:18 <anitsirk> any questions / comments?
09:44:19 <dajan> it is already pretty stable by me
09:44:51 <anitsirk> there were lots of changes but not as many design and javascript changes as for 1.8
09:45:01 <anitsirk> so that helped in not breaking things so much ;-)
09:45:10 <robertl_> true
09:45:12 <rkabalin_> will defeintely test
09:45:18 <anitsirk> thank you very much!
09:45:35 <anitsirk> ok. my second business is not dev related, but hopefully still of interest.
09:45:37 <anitsirk> #info Mahara Hui - conference and now what?
09:46:12 <robertl_> ... the world!
09:46:13 <anitsirk> #info Last week we had our first NZ mahara conference, Mahara Hui (hui = assembly, gathering in Te Reo Māori). It consisted of 2 days presentations and 1 day hackfest.
09:46:18 <anitsirk> That worked really well.
09:46:39 <dajan> Would you like we name the Maharamoots Mahara Hui. Or do you want to keep this for NZ?
09:47:08 <robertl_> it was good to meet up with users and get their feedback
09:47:08 <anitsirk> #info In the mood of sharing, we are going to make our hui logo available to others to use and others are also welcome to use “Mahara Hui” as general conference name
09:47:36 <anitsirk> we don’t want to hog “Mahara Hui” and thus, everyone is welcome to use it for their own mahara conference
09:47:38 <dajan> Ok in the FR world from 2015 then.
09:47:53 <aarow_> unless Hui is a swear word in French ;)
09:47:53 <anitsirk> and a cool logo would already be there: the campfire with marshmallow roasting.
09:48:11 <anitsirk> evonne found a perfect logo for expressing community, gathering
09:48:14 <dajan> Mmm don’t think so…
09:48:20 <anitsirk> we also have a more formal logo which can also be adapted.
09:48:33 <mingard> love the campfire logo :)
09:48:34 <aarow_> translate.google.com tells me Hui in French means "today"!
09:48:34 <anitsirk> #info check out https://maharahui.org.nz to view the two logos
09:48:46 <anitsirk> #link https://maharahui.org.nz
09:49:04 <anitsirk> that would be aujourd’hui. you are missing part of the wor,d aarow_  ;-)
09:49:28 <mingard> does the 'hui part not have meaning on its own?
09:49:46 <dajan> Aujourd’hui means today. Hui means nothing. Hui maybe ment « now » in very very very old French
09:49:47 <anitsirk> Moodle conferences are called moodlemoots. so why not have Mahara Hui around the world?
09:50:04 <aarow_> I think it's etymologically related to the Spanish "hoy"
09:50:23 <dajan> My Spanish is rotten. Sorry
09:50:26 <mingard> have we given up on mahara ham then aarow_?
09:50:27 <yuliyabozhko1> arrow_: don't try translating it into Russian >.<
09:50:32 <aarow_> that's Spanish for "today" :)
09:50:34 <rkabalin_> :D
09:50:37 <anitsirk> that’s it from me.
09:50:53 <anitsirk> anybody with any other business?
09:51:09 <aarow_> nope
09:51:18 <mingard> not from me
09:51:22 <dajan> I think we could fix the name and « impose » it as a decision. No? Do we vote?
09:51:36 <yuliyabozhko1> only 6 hours of sleep left *sigh*
09:51:39 <anitsirk> i don’t want to impose the name.
09:51:58 <anitsirk> “Mahara UK” is pretty established
09:52:11 <anitsirk> i just want to make a suggestion :-)
09:52:15 <aarow_> yes, we're just making it available as an option :)
09:52:19 <anzeljg> Mahara UK Hui?
09:52:33 <anitsirk> I think it would be Mahara Hui UK then.
09:52:37 <dajan> Mahara Hui UK, Mahara Hui FR, etc.
09:53:12 <dajan> And the organisers have to make a Haka at the beginning of the session.
09:53:28 <aarow_> I think it's okay for it to be up to the conference organizers, since they're the ones doing all the work
09:53:29 <anzeljg> Love that one... LOL
09:53:30 <anitsirk> it should start with a mihi. aarow_ is a good speaker :-)
09:53:59 <robertl_> and possibly a waiata (song)
09:54:19 <anitsirk> we just wanted to put it out there, in case people are looking for a suggestion and may want to use the artwork that we created.
09:54:32 <dajan> Moodlemoot FR has its traiditional Mojito drink. Mahara Hui FR will have the Aka. I love that.
09:54:44 <anitsirk> it was really great how everyone stood up and sang along. long live youtube practice
09:54:59 <mingard> or not practicing then mumbling the words
09:55:11 <anitsirk> oh so that was you, mingard? ;-)
09:55:12 <robertl_> true that!
09:55:43 <anitsirk> ok. seems like we reached the end of our meeting.
09:55:49 <mingard> pretty sure I was next to robertl_ at the time, we must have joined forces
09:56:20 <anitsirk> #info thank you very much for everyone who attended and congrats again for our newly appointed core devs, mingard, yuliyabozhko1 and ghada el-zoghbi.
09:56:23 <anitsirk> #endmeeting