#mahara-dev Meeting

Meeting started by dan_p at 07:34:43 UTC (full logs).

Meeting summary

  1. Meeting attendees (dan_p, 07:34:49)
    1. dan_p is Dan Poltawski - LUNS Ltd, UK (dan_p, 07:35:02)
    2. dobedobedoh is Andrew Nicols - LUNS Ltd, UK (dobedobedoh, 07:35:11)
    3. hughdavenport is Hugh Davenport, Catalyst IT (hughdavenport, 07:35:17)
    4. anitsirk: Kristina Hoeppner - Catalyst IT, Wellington, NZ (anitsirk, 07:35:18)
    5. richardm is Richard Mansfield - Catalyst IT Wgtn (richardm, 07:35:21)
    6. iarenaza is IƱaki Arenaza - Mondragon Unibertsitatea (iarenaza, 07:36:51)

  2. Items from previous meeting (dan_p, 07:37:58)
    1. fmarier_ to update the bug status page with new "milestone" usage guideline (dan_p, 07:38:03)
    2. ACTION: fmarier_ to update the bug status page with new "milestone" usage guidelines (dan_p, 07:39:08)
    3. thomaswbell88 to come up with ideas for mahara.org badges and post on the wiki under Specifications in Development (dan_p, 07:39:24)
    4. https://wiki.mahara.org/index.php/Developer_Area/Specifications_in_Development/Forum_Badges (dan_p, 07:39:36)
    5. Like the work in progress in wiki, but needs more technical detail to implement (dan_p, 07:42:36)
    6. ACTION: thomaswbell88 to come up with ideas for mahara.org badges and post on the wiki under Specifications in Development (dan_p, 07:43:40)

  3. Unit testing (dobedobedoh) (dan_p, 07:43:52)
    1. dobedobedoh has updated Mjollnir`'s phpunit branch with the intention of merging into 1.5 (dan_p, 07:45:50)
    2. dobedobedoh to update the code into reviewable chunks (dan_p, 07:53:24)
    3. Ruslan Kabalin - LUNS ltd., Lancaster, UK (rkabalin, 07:53:26)
    4. Selenium/Unit tests with commits (dan_p, 07:56:03)

  4. Selenium/Unit tests with commits (dan_p, 07:56:33)
    1. AGREED: (dan_p, 07:57:29)
    2. Push a unit/selenium test with a new feature (dan_p, 07:57:47)
    3. IDEA: hughdavenport proposes that developers push a selenium/unit test with a new feature (dan_p, 07:58:56)
    4. richardm suggests intergating selenium with jenkins, but seperate from gerrit (dan_p, 08:09:55)
    5. ACTION: LUNS to investigate adding a new mahara integration project to run selenium tests (dan_p, 08:11:17)

  5. Next meeting (dan_p, 08:13:06)
    1. Next meeting agreed for 06/09/11 - 19:30 UTC (dan_p, 08:16:38)

  6. Any other business (dan_p, 08:17:09)


Meeting ended at 08:18:59 UTC (full logs).

Action items

  1. fmarier_ to update the bug status page with new "milestone" usage guidelines
  2. thomaswbell88 to come up with ideas for mahara.org badges and post on the wiki under Specifications in Development
  3. LUNS to investigate adding a new mahara integration project to run selenium tests


People present (lines said)

  1. dan_p (69)
  2. hughdavenport (56)
  3. dobedobedoh (54)
  4. richardm (16)
  5. iarenaza (6)
  6. rkabalin (6)
  7. anitsirk (5)
  8. maharameet (5)


Generated by MeetBot 0.1.4.