07:34:43 <dan_p> #startmeeting
07:34:43 <maharameet> Meeting started Wed Aug  3 07:34:43 2011 UTC.  The chair is dan_p. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:34:43 <maharameet> Useful Commands: #action #agreed #help #info #idea #link #topic.
07:34:49 <dan_p> #topic Meeting attendees
07:34:57 <dan_p> Please put #info in from of your name
07:35:02 <dan_p> #info dan_p is Dan Poltawski - LUNS Ltd, UK
07:35:11 <dobedobedoh> #info dobedobedoh is Andrew Nicols - LUNS Ltd, UK
07:35:17 <hughdavenport> #info hughdavenport is Hugh Davenport, Catalyst IT
07:35:18 <anitsirk> #info anitsirk: Kristina Hoeppner - Catalyst IT, Wellington, NZ
07:35:21 <richardm> #info richardm is Richard Mansfield - Catalyst IT Wgtn
07:36:25 <dan_p> Some housekeeping whilst waiting for any other latecomers..
07:36:41 <dan_p> please say ".." on a line by itself if you are typing a long multi-line piece to indicate you've finished
07:36:47 <dan_p> ..
07:36:51 <iarenaza> #info iarenaza is IƱaki Arenaza - Mondragon Unibertsitatea
07:37:48 <dan_p> Ok, I think we are in for a short and sweet meeting today, so i'll move on ;)
07:37:58 <dan_p> #topic Items from previous meeting
07:38:03 <dan_p> #info fmarier_ to update the bug status page with new "milestone" usage guideline
07:38:12 <dan_p> In the absenece of fmarier I checked -  and don't believe this has been completed https://wiki.mahara.org/index.php/Developer_Area/Bug_Status
07:38:31 <dan_p> So I propose to carry this action forward to the next meeting
07:38:54 <iarenaza> #agree
07:38:58 <dobedobedoh> #agree
07:39:01 <hughdavenport> #agree
07:39:04 <richardm> #agree
07:39:08 <dan_p> #action  fmarier_ to update the bug status page with new "milestone" usage guidelines
07:39:24 <dan_p> #info thomaswbell88 to come up with ideas for mahara.org badges and post on the wiki under Specifications in Development
07:39:32 <dan_p> In the absence of thomaswbell88 I checked and found the wiki page WIP:
07:39:36 <dan_p> https://wiki.mahara.org/index.php/Developer_Area/Specifications_in_Development/Forum_Badges
07:40:29 <dan_p> Any comments on this without thomaswbell88 present?
07:40:46 <dan_p> (Otherwise I propose to carry it forward to the next meeting..)
07:41:03 * iarenaza having a look at it right now
07:41:26 <richardm> sounds good, probably needs a bit more technical detail before we go and implement it
07:41:49 <hughdavenport> yeh page looks good, but will need filling out a bit
07:42:00 <hughdavenport> and as richardm says a bit of tech detail
07:42:36 <dan_p> #info Like the work in progress in wiki, but needs more technical detail to implement
07:42:44 <dobedobedoh> Yup
07:43:34 <dan_p> Ok, well i'll carry that action forward
07:43:40 <dan_p> #action thomaswbell88 to come up with ideas for mahara.org badges and post on the wiki under Specifications in Development
07:43:52 <dan_p> #topic Unit testing (dobedobedoh)
07:44:27 <dobedobedoh> As the agenda page says, I've updated Mjollnir`'s phpunit branch from way back
07:44:48 <dobedobedoh> I've put it up git.luns.net.uk (https://git.luns.net.uk/?p=mahara.git;a=shortlog;h=refs/heads/phpunit)
07:44:52 <dobedobedoh> if anyone wants to see
07:45:02 <dobedobedoh> I'd like to propose that we try and get it in to Mahara 1.5
07:45:20 <dobedobedoh> and I was hoping for some guidance on the most appropriate way of merging it
07:45:38 <dobedobedoh> There are about 8 commits off master which are a mixture of Mjollnir`'s and mine
07:45:49 <dobedobedoh> and several are missing Signed-off-by etc
07:45:50 <dan_p> #info dobedobedoh has updated Mjollnir`'s phpunit branch with the intention of merging into 1.5
07:46:49 <dobedobedoh> So I also wanted to raise the question as to the best way of merging works which don't meet our current guidelines
07:47:08 <richardm> dobedobedoh: i think it's not a problem to retain authorship, i pushed a couple of patches that weren't mine to gerrit recently
07:47:14 <dobedobedoh> And to ask whether we should squash all of the commits down into one etc
07:47:52 <hughdavenport> depends on whether it is one big change or not
07:47:57 <richardm> dobedobedoh: whatever you think will make them easiest to review i suppose
07:48:01 <dobedobedoh> Okay dokay
07:48:02 <hughdavenport> it is easier to review if it is smaller chunks
07:48:10 <hughdavenport> but not too small :)
07:48:24 <hughdavenport> you could just push what you have and we can work from there
07:48:39 <dobedobedoh> Okay. I'll tidy it up a bit first as there are a few I'd like to squash
07:48:48 <iarenaza> dobedobedoh: Can we ask Mjollnir` to add the signed-off lines? (if that's a real problem)
07:49:14 <hughdavenport> gerrit will complain if you push stuff that has signedoffby someone else
07:49:22 <hughdavenport> you can change the author on the commit
07:49:39 <hughdavenport> the signedoffby is basically saying the person that pushed it is alright with it
07:49:48 <iarenaza> hughdavenport: and if it has multiple signed-off lines, does it also complain?
07:49:49 <hughdavenport> but they may not be the original author
07:49:54 <richardm> dobedobedoh can push them with his own signed-off, and Mjollnir` as author
07:50:16 <hughdavenport> iarenaza: not sure, but iirc it did it for me
07:50:26 <richardm> iarenaza: it's happy with multiple signed-off lines i think
07:50:40 <hughdavenport> yeh could be that
07:50:40 <dobedobedoh> That was all really -- I just wanted to raise the profile of the unit testing, and ask you to review the patches when they hit gerrit ;)
07:50:43 <dobedobedoh> ..
07:50:44 <dan_p> dobedobedoh: are you  proposing to acompany the code with some developer documentation? ;-)
07:50:46 <hughdavenport> just had to have you in it somewhere
07:50:48 <dobedobedoh> It is happy with multiple signed off lines
07:51:11 <dobedobedoh> dan_p: There's already a WIP at https://wiki.mahara.org/index.php/Developer_Area/Unit_Testing
07:51:31 <dobedobedoh> But it's very much a WIP ;)
07:52:30 <dobedobedoh> That's all I have
07:52:48 <dobedobedoh> Please consider what tests you may want to write...
07:52:49 <dobedobedoh> ..
07:53:24 <dan_p> #info dobedobedoh to update the code into reviewable chunks
07:53:26 <rkabalin> #info Ruslan Kabalin - LUNS ltd., Lancaster, UK
07:54:31 <dan_p> dobedobedoh: I don't think there are any actions out of that, agree?
07:54:38 <dobedobedoh> agree
07:54:45 <dobedobedoh> except on me to push
07:55:01 <dan_p> ok will move on..
07:55:02 <dan_p> #topic Next meeting
07:55:10 <dobedobedoh> I think hugh had something
07:55:17 <hughdavenport> yep, i added it last minute
07:55:19 <dobedobedoh> in the agenda
07:55:24 <hughdavenport> well last day/minute :P
07:55:27 <dan_p> doh
07:55:42 <hughdavenport> won't take long :)
07:55:43 <dan_p> #undo
07:55:43 <maharameet> Removing item from minutes: <MeetBot.items.Topic object at 0xb6e75eac>
07:56:03 <dan_p> #info Selenium/Unit tests with commits
07:56:24 <hughdavenport> right with this, I was thinking that it could be an idea for when we push a commit with a new feature
07:56:33 <dan_p> #topic Selenium/Unit tests with commits
07:56:45 <hughdavenport> that we also push along side it a unit test or a selenium test
07:56:57 <hughdavenport> that way we can test when something breaks later on
07:57:03 <hughdavenport> and we keep the tests up to date
07:57:21 <hughdavenport> and another thing is that we could possibly integrate one or both into jenkins
07:57:25 <hughdavenport> thoughts?
07:57:26 <hughdavenport> ..
07:57:29 <dan_p> #agree
07:57:31 <richardm> #agree
07:57:47 <dan_p> #info Push a unit/selenium test with a new feature
07:57:52 <dobedobedoh> I've tried this in the past... getting the selenium tests up to date
07:57:55 <hughdavenport> it will take a bit to get into the habit of doing, but I think it will be good in the long run
07:58:21 <dobedobedoh> The difficulty I found was in getting them detailed enough to test the functionality I'd written
07:58:33 <dobedobedoh> BUt I think that combined with phpunit tests, it shouldn't be a problem
07:58:33 <dobedobedoh> ..
07:58:41 <hughdavenport> yeh that is the problem with any test suite really
07:58:45 <hughdavenport> combining does help
07:58:56 <dan_p> #idea hughdavenport proposes that developers push a selenium/unit test with a new feature
07:59:11 <dobedobedoh> Selenium is a particular pain as it doesn't support state between tests or dependencies
07:59:21 <hughdavenport> yeh...
07:59:27 <dan_p> I have got this impression of Selenium being particularly 'fragile'
07:59:31 <hughdavenport> but with your new phpunit that will be good
07:59:54 <hughdavenport> dan_p: well it's basically a simulation of users clicking around, easily broken :)
07:59:57 <dobedobedoh> There's also that... some things you end up testing with xpath, and then something changes in teh UI and it's a right pain to calculate the new xpath
08:00:02 <hughdavenport> basically any change could break it
08:00:28 <richardm> they also take forever to run
08:00:40 <dobedobedoh> And automating them with jenkins is potentially tricky
08:00:47 <dobedobedoh> though not impossible
08:00:49 <hughdavenport> they do, which may mean that jenkins may not be the best
08:01:03 <hughdavenport> is it possible to have two jenkins runs, a quick and a slow?
08:01:06 <dan_p> I definitely agree they should be tested with jenkins though
08:01:21 <dan_p> hughdavenport: yes I think so
08:01:27 <hughdavenport> so we can get feedback on when it fails straightaway, and then later whether the tests pass
08:01:32 <dobedobedoh> Some things can only be tested with UI tests such as selenium so we definately need them
08:01:58 <dan_p> hughdavenport: though, does that not sort of break the workflow of trying not to 'break the build', if you submit and carry on?
08:02:27 <richardm> phpunit every commit, & selenium once or twice a day?
08:02:36 <dobedobedoh> We already have a requirement to split out minaccept and jenkinsaccept in the Makefile
08:02:47 <dobedobedoh> Ah I see
08:03:14 <dan_p> dobedobedoh: Are selenium tests less maintaince than detailed human instructons/testers..
08:04:05 <dobedobedoh> Debateable... they're more repeatable, but because of things like sometimes having to locate elements by xpath
08:04:15 <dobedobedoh> they can take a lot of setting up
08:04:17 <hughdavenport> all this said, the tests shouldn't be taken as gospel, they are just useful for finding stuff that may break old stuff accidentaly
08:04:21 <dobedobedoh> and then be broken very quickly
08:04:22 <dobedobedoh> ..
08:04:41 <dobedobedoh> I think they're worthwhile, but only when combined with phpunit
08:04:54 <hughdavenport> i would agree with that
08:04:59 <dobedobedoh> and I think it's probably worth looking at some of the user contributed comonents
08:05:06 <hughdavenport> i like richardm's comment saying maybe phpunit every commit
08:05:12 <dobedobedoh> e.g. I came across one which allowed you to store state between tests
08:05:15 <hughdavenport> then selenium less regularily
08:05:39 <dan_p> I think this is proably worth revisiing after phpunit is integrated?
08:05:51 <hughdavenport> yep, that sounds good
08:05:54 <dan_p> Or do we need to look at selenium integration now?
08:05:55 <dobedobedoh> Yeah
08:06:02 <dobedobedoh> Selenium is already integrated
08:06:09 <dobedobedoh> or you mean with jenkins?
08:06:10 <dan_p> integration to jenkins
08:06:23 <hughdavenport> i think integration with jenkins can come later
08:06:43 <hughdavenport> we can integrate phpunit first as it is more useful for jenkins on a per commit as its faster
08:06:56 <dobedobedoh> Are we bothered about things taking a while to test at present? There doesn't seem to be a /massive/ queue
08:07:07 <hughdavenport> but the whole point of my topic was just to get the mindset of thinking about writing tests as we go
08:07:24 <dobedobedoh> hughdavenport: I like it :)
08:07:33 <hughdavenport> dobedobedoh: when we submit a large series of patches it would have to test them all
08:07:37 <dobedobedoh> true
08:07:39 <dobedobedoh> that woudl suck
08:07:40 <hughdavenport> when it would be better to test at the end
08:07:54 <richardm> i think we do need integration with jenkins, but it should be pulled straight from the main repo, not gerrit
08:08:07 <richardm> (for selenium i mean)
08:08:10 <hughdavenport> especially if there are multiple patchsets
08:08:17 <dan_p> ah, agreed
08:08:33 <hughdavenport> like richardm said, it would be better to test after merge, we can always revert (although ugly)
08:08:37 <dan_p> richardm: would you see that then generating a bug or alerting some other way?
08:08:39 <hughdavenport> but it's only a whatif case
08:09:05 <richardm> dan_p: spamming the committer i guess
08:09:18 <dobedobedoh> It'd ahve to track down /which/ commit broke things
08:09:18 <dan_p> #info richardm suggests intergating selenium with jenkins, but seperate from jenkins
08:09:36 <richardm> separate from gerrit i meant
08:09:39 <dan_p> doh
08:09:42 <hughdavenport> hehe, integrate with jenkins but not with jenkins :P
08:09:46 <dan_p> #unfo
08:09:48 <dan_p> #undo
08:09:48 <maharameet> Removing item from minutes: <MeetBot.items.Info object at 0x9a8498c>
08:09:51 <hughdavenport> hehe
08:09:55 <dan_p> #info richardm suggests intergating selenium with jenkins, but seperate from gerrit
08:10:00 <dan_p> more coffee required
08:10:01 <hughdavenport> early morning dan_p?
08:10:06 <rkabalin> We could have just two projects on jenkins
08:10:26 <rkabalin> one for gerrit another for selenioum from master
08:10:33 * iarenaza is sorry, but has to leave (will read the chat logs later)
08:11:17 <dan_p> #action LUNS to investigate adding a new mahara integration project to run selenium tests
08:11:41 <richardm> :)
08:12:47 <dan_p> Ok, shall we leave it at that?
08:12:56 <hughdavenport> sounds good
08:13:06 <dan_p> #topic Next meeting
08:13:23 <dan_p> I proposed on the wiki 01/09/11 - 17:30 UTC
08:13:36 <dan_p> Thursday evening UK time, Friday morning NZ
08:14:19 <hughdavenport> sounds good
08:14:21 <rkabalin> I agree
08:14:22 <anitsirk> i can make it earliest on sept. 5
08:14:50 <anitsirk> but if there is only tech stuff as today, i can read the log ;-)
08:15:12 <dan_p> anitsirk: would be good to have you there
08:15:20 <dan_p> I can't make 5th, so new proposal
08:15:31 <dan_p> 06/09/11 - 19:30 UTC
08:15:43 <dan_p> (sorry that previous time was supposed to be 19:30!)
08:16:02 <richardm> fine by me
08:16:03 <anitsirk> the 7th should work for me
08:16:03 <dobedobedoh> I was gonna say!
08:16:06 <hughdavenport> lol, just saw that
08:16:08 <dobedobedoh> WFM
08:16:19 <rkabalin> :)
08:16:29 <rkabalin> 6th sounds fine
08:16:38 <dan_p> #info Next meeting agreed for 06/09/11 - 19:30 UTC
08:16:53 <dan_p> #idea dan_p to drink more coffee before future meetings
08:16:59 <hughdavenport> hehe
08:17:07 <dan_p> #undo
08:17:07 <maharameet> Removing item from minutes: <MeetBot.items.Idea object at 0x9a8c7ac>
08:17:09 <dan_p> #topic Any other business
08:17:53 <dan_p> Going once..
08:17:59 <hughdavenport> nothing from me
08:18:17 <dan_p> twice..
08:18:20 <anitsirk> nope. all good
08:18:47 <dan_p> Ok, lets wrap it up
08:18:58 <dan_p> thanks everyone
08:18:59 <dan_p> #endmeeting