#mahara-dev Meeting

Meeting started by anitsirk at 19:30:47 UTC (full logs).

Meeting summary

  1. Meeting attendees. (anitsirk, 19:30:57)
    1. Kristina Hoeppner from Catalyst IT in Wellington, NZ (anitsirk, 19:31:17)
    2. Andrew Nicols from LUNS Ltd in Lancaster, UK (dobedobedoh, 19:31:31)
    3. Ruslan Kabalin, LUNS Ltd, UK (rkabalin, 19:31:39)
    4. Heinz Krettek, Germany German language pack maintainer ;-) (H31nz, 19:32:28)
    5. Stacey Walker, Catalyst IT Europe, UK (lamiette, 19:32:42)
    6. Francois Marier, Catalyst (fmarier, 19:33:22)
    7. Dan Poltawski, LUNS Ltd, UK (danp_, 19:33:37)

  2. Items from previous meetings (anitsirk, 19:34:01)
    1. dobedobedoh to check the ubuntu code of conduct which is CC licensed for the mahara code of conduct (anitsirk, 19:34:09)
    2. ACTION: dobedobedoh to check the ubuntu code of conduct which is CC licensed for the mahara code of conduct (anitsirk, 19:35:26)
    3. dobedobedoh and azeljg to go over skins patches to try and get them into 1.4 (anitsirk, 19:35:36)
    4. ACTION: dobedobedoh and azeljg to go over skins patches to try and get them into 1.4, richardm will also take a look at them (anitsirk, 19:37:52)
    5. everybody should try to tag bugs to group them together (anitsirk, 19:39:19)
    6. iarenaza joined the chat room for the meeting (anitsirk, 19:40:14)
    7. iarenaza to draft language pack release policy (anitsirk, 19:43:30)
    8. richardm joined the chat room for the meeting (anitsirk, 19:43:50)
    9. ACTION: iarenaza to draft language pack release policy (anitsirk, 19:47:50)
    10. richardm to post on the wiki how we use status / priority / milestone in mahara (anitsirk, 19:48:10)
    11. http://wiki.mahara.org/Developer_Area/Bug_Status (richardm, 19:48:56)
    12. http://wiki.mahara.org/Developer_Area/Bug_Status (anitsirk, 19:49:21)
    13. Graphs in Mahara Statistics proposal (anzeljg) (anitsirk, 19:50:10)
    14. ACTION: Graphs in Mahara Statistics proposal (anzeljg) (anitsirk, 19:51:40)
    15. dobedobedoh to beg/borrow/steal/invent a forum code of conduct and place on the wiki (anitsirk, 19:52:26)

  3. Safety issues (rkabalin) (anitsirk, 19:53:17)
    1. ACTION: rkabalin to summarize his ideas of notifications of objectionable content on a subpage of http://wiki.mahara.org/Developer_Area/Specifications_in_Development (anitsirk, 20:04:37)
    2. ACTION: richardm checks if objectionable content notifications already go to institution admins besides site admins (anitsirk, 20:06:10)
    3. ACTION: H31nz supports iarenaza with drafting a language pack release policy (anitsirk, 20:07:34)
    4. anzeljg joined the chat fro the developer meeting (anitsirk, 20:08:45)
    5. Graphs in Mahara Statistics proposal (anzeljg) (anitsirk, 20:09:53)
    6. rangi joined the chat room for the meeting (anitsirk, 20:12:44)
    7. anzeljg thinks that pChart may be a suitable framework for rendering graphs in mahara, e.g. in the admin section (anitsirk, 20:14:58)
    8. ACTION: anzeljg will put more details about using pChart as framework for rendering graphs in Mahara on the bug tracker (anitsirk, 20:19:02)
    9. anzeljg is working on a blocktype to include Picasa and Flickr photos (anitsirk, 20:21:59)
    10. ACTION: anzeljg to further look into flickr and picasa photo block (anitsirk, 20:24:23)
    11. http://www.janrain.com/products/engage/social-sharing (rkabalin_, 20:34:58)
    12. by rkabalin_ : if you need backward integration (reposting Mahara elements in facebook or twitter) then janrain family could do that (anitsirk, 20:34:59)

  4. Picking a release date (francois) (anitsirk, 20:37:47)
    1. AGREED: (anitsirk, 20:39:07)
    2. : shall we put the release date at end of April / early May so that schools in the northern hemisphere have time for testing etc. before a final install for the new school year? (anitsirk, 20:40:12)
    3. Need help reviewing: skins, Google Apps and Live@Edu (anitsirk, 20:41:06)
    4. windows live (the google apps equivalent) was not yet tested with live@edu accounts (anitsirk, 20:44:33)
    5. ACTION: if somebody has a live@edu account, testing the windows live plugin by anzeljg would be fantastic (anitsirk, 20:44:51)
    6. ACTION: iarenaza to provide anzeljg with google apps for education account(s) for further testing of the google apps plugin (anitsirk, 20:48:59)

  5. quality improvements (anitsirk, 20:49:32)
    1. unit tests (anitsirk, 20:49:38)
    2. code reviews (anitsirk, 20:49:41)
    3. everybody to run minimum acceptance tests before commiting (was also action item from last time) (anitsirk, 20:50:03)
    4. ACTION: everybody and esp. iarenaza and anitsirk to find live@edu account for anzeljg's testing (anitsirk, 20:51:15)
    5. AGREED: (anitsirk, 20:52:10)
    6. AGREED: release date for 1.4 set to end of April-ish (anitsirk, 20:52:41)
    7. ACTION: anitsirk to find out how to obtain free google apps (for education) and live@edu accounts (consulting with iarenaza who says that they are free in ES) (anitsirk, 20:58:00)
    8. AGREED: as a first step, these plugins could be added to a git repo and that core changes (if any) be extracted from them to be considered first (anitsirk, 21:01:55)
    9. fmarier can provide you with git help (anitsirk, 21:02:53)
    10. AGREED: if a plugin starts in contrib and then lots of people use it, then it's probably a good candidate for inclusion in core (assuming it's not too hard to maintain and the quality is good) (anitsirk, 21:08:53)
    11. there is not yet a list of plugins-in-use from the weekly stats push, but it could be added according to richardm though most sites don't register with mahara.org and thus the statistics don't show an accurate picture across all mahara installations. they can just be an indicator. (anitsirk, 21:11:41)
    12. ACTION: richardm to add a list of plugins-in-use for the weekly stats push (anitsirk, 21:12:57)
    13. unit tests and code reviews (anitsirk, 21:13:26)
    14. everybody to run minimum acceptance tests before commiting (from the last meeting) (anitsirk, 21:13:47)
    15. ACTION: fmarier is going to try to get in touch with Mjollnir` and get the unit test work she did merge into master (anitsirk, 21:15:02)
    16. once unit tests are running as part of our continuous integration tests, we can start looking at writing tests and increasing our coverage (anitsirk, 21:15:28)
    17. fmarier runs selenium tests on all DBs before he does a release (anitsirk, 21:17:04)
    18. waawaamilk joined the dev meeting (anitsirk, 21:17:29)
    19. code reviews (anitsirk, 21:19:02)
    20. reasons for code review: 1) improve the quality of the code, 2) learn / mentor each other, 3) security review, 4) remove old code (anitsirk, 21:21:09)
    21. Gerrit is tool that falilitates doing that before commit goes to master (anitsirk, 21:21:51)
    22. http://code.google.com/p/gerrit/ (dobedobedoh, 21:22:37)
    23. AGREED: using gerrit to try to change our process of signing of code http://code.google.com/p/gerrit/ (anitsirk, 21:25:02)
    24. 2 people signing off does include the author of the commit (anitsirk, 21:25:21)
    25. when you're unsure about something, you can always invite specific people to review your code, but otherwise anybody with commit access to the main repo will be a reviewer in gerrit (anitsirk, 21:26:55)
    26. once that's in place then gerrit will be the only committer to master and the stable branches (anitsirk, 21:27:31)
    27. approvals are done by all existing committers and not just @catalyst users (anitsirk, 21:27:50)
    28. review example: member:rkabalin_ (LUNS) can review member:dobedobedoh's (LUNS) code and member:richardm (Catalyst) can review fmarier's (Catalyst) code, but of course when it's not time critical, it might be worth mixing that up to get more out of it, e.g. rkabalin_ reviewing fmarier's code. (anitsirk, 21:30:10)
    29. review role can change with time as community grows / # of people signing off increases, e.g. from 1 additional signoff to 1 additional signoff from outside your organisation (anitsirk, 21:32:03)
    30. you'll be able to log into gerrit using an OpenID account. fmarier suggests using your launchpad one (since it's also used for filing Mahara bugs) but any openID account should work (anitsirk, 21:32:33)
    31. ACTION: fmarier will setup gerrit and let people know once it's up (fmarier, 21:32:34)

  6. Next meeting (anitsirk, 21:33:48)
    1. if you have any other ideas (after this meeting) about how we can remove barriers to contribution and further empower developers, please feel free to email fmarier (mailto:francois@mahara.org), we are serious about wanting to share responsibilities for the project (anitsirk, 21:34:40)
    2. http://tinyurl.com/6hn9z78 (dobedobedoh, 21:39:50)
    3. AGREED: for the 23rd at 7:30a.m. UTC/GMT and 8:30 p.m. NZDT (anitsirk, 21:42:30)

  7. Any other business (anitsirk, 21:42:40)
    1. initial brain dump at http://wiki.mahara.org/Language_Packs/Language_Pack_Release_Policy by iarenaza (anitsirk, 21:43:56)
    2. AGREED: (anitsirk, 21:44:35)
    3. AGREED: either dobedobedoh or rkabalin_ will chair the next developer meeting -> LUNS to decide internally (anitsirk, 21:47:19)
    4. AGREED: we will try to rotate meeting chairs because it will also help us to learn the chat commands for structuring meeting minutes (anitsirk, 21:49:51)
    5. ACTION: item for everybody: think about how to improve getting user feedback - not just written feedback, but watching users to study their behavior and get first-hand insight into how they use mahara (anitsirk, 22:02:54)


Meeting ended at 22:10:27 UTC (full logs).

Action items

  1. dobedobedoh to check the ubuntu code of conduct which is CC licensed for the mahara code of conduct
  2. dobedobedoh and azeljg to go over skins patches to try and get them into 1.4, richardm will also take a look at them
  3. iarenaza to draft language pack release policy
  4. Graphs in Mahara Statistics proposal (anzeljg)
  5. rkabalin to summarize his ideas of notifications of objectionable content on a subpage of http://wiki.mahara.org/Developer_Area/Specifications_in_Development
  6. richardm checks if objectionable content notifications already go to institution admins besides site admins
  7. H31nz supports iarenaza with drafting a language pack release policy
  8. anzeljg will put more details about using pChart as framework for rendering graphs in Mahara on the bug tracker
  9. anzeljg to further look into flickr and picasa photo block
  10. if somebody has a live@edu account, testing the windows live plugin by anzeljg would be fantastic
  11. iarenaza to provide anzeljg with google apps for education account(s) for further testing of the google apps plugin
  12. everybody and esp. iarenaza and anitsirk to find live@edu account for anzeljg's testing
  13. anitsirk to find out how to obtain free google apps (for education) and live@edu accounts (consulting with iarenaza who says that they are free in ES)
  14. richardm to add a list of plugins-in-use for the weekly stats push
  15. fmarier is going to try to get in touch with Mjollnir` and get the unit test work she did merge into master
  16. fmarier will setup gerrit and let people know once it's up
  17. item for everybody: think about how to improve getting user feedback - not just written feedback, but watching users to study their behavior and get first-hand insight into how they use mahara


Action items, by person

  1. anitsirk
    1. everybody and esp. iarenaza and anitsirk to find live@edu account for anzeljg's testing
    2. anitsirk to find out how to obtain free google apps (for education) and live@edu accounts (consulting with iarenaza who says that they are free in ES)
  2. anzeljg
    1. Graphs in Mahara Statistics proposal (anzeljg)
    2. anzeljg will put more details about using pChart as framework for rendering graphs in Mahara on the bug tracker
    3. anzeljg to further look into flickr and picasa photo block
    4. if somebody has a live@edu account, testing the windows live plugin by anzeljg would be fantastic
    5. iarenaza to provide anzeljg with google apps for education account(s) for further testing of the google apps plugin
    6. everybody and esp. iarenaza and anitsirk to find live@edu account for anzeljg's testing
  3. dobedobedoh
    1. dobedobedoh to check the ubuntu code of conduct which is CC licensed for the mahara code of conduct
    2. dobedobedoh and azeljg to go over skins patches to try and get them into 1.4, richardm will also take a look at them
  4. fmarier
    1. fmarier is going to try to get in touch with Mjollnir` and get the unit test work she did merge into master
    2. fmarier will setup gerrit and let people know once it's up
  5. H31nz
    1. H31nz supports iarenaza with drafting a language pack release policy
  6. iarenaza
    1. iarenaza to draft language pack release policy
    2. H31nz supports iarenaza with drafting a language pack release policy
    3. iarenaza to provide anzeljg with google apps for education account(s) for further testing of the google apps plugin
    4. everybody and esp. iarenaza and anitsirk to find live@edu account for anzeljg's testing
    5. anitsirk to find out how to obtain free google apps (for education) and live@edu accounts (consulting with iarenaza who says that they are free in ES)
  7. richardm
    1. dobedobedoh and azeljg to go over skins patches to try and get them into 1.4, richardm will also take a look at them
    2. richardm checks if objectionable content notifications already go to institution admins besides site admins
    3. richardm to add a list of plugins-in-use for the weekly stats push
  8. rkabalin
    1. rkabalin to summarize his ideas of notifications of objectionable content on a subpage of http://wiki.mahara.org/Developer_Area/Specifications_in_Development


People present (lines said)

  1. anitsirk (252)
  2. fmarier (131)
  3. dobedobedoh (80)
  4. anzeljg (54)
  5. iarenaza (48)
  6. danp_ (35)
  7. waawaamilk (32)
  8. rkabalin_ (29)
  9. richardm (28)
  10. H31nz (19)
  11. rkabalin (12)
  12. lamiette (4)
  13. rangi (3)
  14. maharameet (2)


Generated by MeetBot 0.1.4.