19:30:47 <anitsirk> #startmeeting
19:30:47 <maharameet> Meeting started Thu Feb 17 19:30:47 2011 UTC.  The chair is anitsirk. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:30:47 <maharameet> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:30:56 <H31nz> Hello Kristina!
19:30:57 <anitsirk> #topic Meeting attendees.
19:30:58 <anitsirk> Please put #info at the beginning of your reply with your name so that it appears in the minutes and we don't have to hunt it down in the chat log.
19:31:17 <anitsirk> #info Kristina Hoeppner from Catalyst IT in Wellington, NZ
19:31:31 <dobedobedoh> #info Andrew Nicols from LUNS Ltd in Lancaster, UK
19:31:39 <rkabalin> #info Ruslan Kabalin, LUNS Ltd, UK
19:31:59 <anitsirk> oops. should have waited for Francois. he'll be back in 2 minutes
19:32:28 <H31nz> #info Heinz Krettek, Germany German language pack maintainer ;-)
19:32:42 <lamiette> #info Stacey Walker, Catalyst IT Europe, UK
19:32:51 <anitsirk> hi lamiette :-)
19:32:56 <fmarier> hi everyone
19:33:22 <fmarier> #info Francois Marier, Catalyst
19:33:37 <danp_> #info Dan Poltawski, LUNS Ltd, UK
19:33:59 <anitsirk> great. it looks like we can start with the topics. some may still wander in.
19:34:00 <lamiette> hi anitsirk, fmarier :)
19:34:01 <anitsirk> #topic Items from previous meetings
19:34:09 <anitsirk> #info dobedobedoh to check the ubuntu code of conduct which is CC licensed for the mahara code of conduct
19:34:33 <anitsirk> any news on that dobedobedoh?
19:34:34 <dobedobedoh> Ahem.. Sorry - I  haven't had a chance to do so yet
19:34:49 <dobedobedoh> We've had a busy couple of months
19:35:12 * rkabalin ^ agrees
19:35:17 <anitsirk> shall i keep it for the next meeting then?
19:35:22 <dobedobedoh> Please :)
19:35:26 <anitsirk> #action dobedobedoh to check the ubuntu code of conduct which is CC licensed for the mahara code of conduct
19:35:26 <fmarier> no worries, let's keep it on the list so it doesn't get lost
19:35:36 <anitsirk> #info dobedobedoh and azeljg to go over skins patches to try and get them into 1.4
19:35:48 <anitsirk> not to pester you again, dobedobedoh, ;-) just going down the list ;-)
19:35:58 <dobedobedoh> I've still not had a chance to go over the patches with more than just a skim. Richardm is also trying to make time to do this
19:36:09 <anitsirk> azeljg is not here today.
19:36:26 <anitsirk> then let's postpone this as well.
19:36:30 <dobedobedoh> There was a netsplit last time too which meant that several people (including anzeljg) didn't get in
19:36:35 <fmarier> where is azeljg based? europe somewhere?
19:36:44 <dobedobedoh> Spain
19:36:49 <anitsirk> users that have seen the skins / heard about them are very interested in that development
19:36:54 <anitsirk> nope. that was inaki
19:37:02 <fmarier> ok cool, so the timezones should be fine for him too
19:37:04 <anitsirk> he is somewhere on the balkan (anzeljg)
19:37:07 <dobedobedoh> ah okay
19:37:09 <dobedobedoh> my mistake
19:37:29 <dobedobedoh> Richard e-mailed on 1st Feb to say that he was hoping to look at the patches soon
19:37:52 <anitsirk> #action dobedobedoh and azeljg to go over skins patches to try and get them into 1.4, richardm will also take a look at them
19:38:16 <anitsirk> fmarier: do you know if richardm was going to be here this morning?
19:38:26 <fmarier> he said he might be 15 minutes late
19:38:38 <fmarier> but he will be here
19:38:42 <anitsirk> ah ok. then we will postpone his action point till later
19:39:03 <anitsirk> Mjollnir`: is not here either. maybe she will come as well?
19:39:19 <anitsirk> #info everybody should try to tag bugs to group them together
19:39:24 <anitsirk> how has that been going?
19:39:36 <fmarier> what was his action point?
19:39:39 <anitsirk> i know that I made a stupid mistake. ;-) thanks for correcting it, fmarier
19:39:43 <anitsirk> fm
19:39:46 <anitsirk> fmarier: yes
19:39:56 <anitsirk> hi iarenaza
19:40:02 <iarenaza> hi
19:40:14 <anitsirk> #info iarenaza joined the chat room for the meeting
19:40:31 * H31nz bbs
19:40:39 <fmarier> there are more tags on the bug tracker now, so i'd say we're doing well :)
19:41:28 <anitsirk> shall we then just proceed as started and check back some time later to see if the tags need revisions / rules?
19:42:39 <dobedobedoh> That seems sensible to me
19:42:50 <fmarier> yeah i think we should keep going and someone will bring it up later if it needs to be changed
19:43:03 <fmarier> we probably don't need to keep it on the agenda
19:43:14 <anitsirk> nope.
19:43:17 <richardm> I'm here, and no I still haven't looked at anzeljg's branch
19:43:25 <anitsirk> iarenaza: are you up for your action item?
19:43:30 <anitsirk> #info iarenaza to draft language pack release policy
19:43:45 <iarenaza> I'm afraid I haven't done my homework yet :-(
19:43:50 <anitsirk> #info richardm joined the chat room for the meeting
19:44:09 <anitsirk> iarenaza: do you need any help with that?
19:44:40 <iarenaza> It should be really simple, but I've been distracted by a million work-related things
19:44:44 <anitsirk> or input from other translators?
19:44:58 <iarenaza> input from translations would be great, sure
19:45:33 <anitsirk> H31nz: would you be able to liase with iarenaza?
19:47:14 <danp_> I think he went away
19:47:23 <anitsirk> mhh. i think so, too.
19:47:24 <iarenaza> I'll do a brain dump in 3-4 paragraphs tonight, before I got stuck agin
19:47:42 <iarenaza> s/got/get/
19:47:49 <anitsirk> sounds great.
19:47:50 <anitsirk> #action iarenaza to draft language pack release policy
19:48:07 <anitsirk> next item from last time:
19:48:10 <anitsirk> #info richardm to post on the wiki how we use status / priority / milestone in mahara
19:48:25 <richardm> i did it
19:48:40 <anitsirk> sorry. hadn't checked the wiki if you had done so. if so, could you please post the URL for posterity and for people to find easily, please?
19:48:56 <richardm> http://wiki.mahara.org/Developer_Area/Bug_Status
19:49:16 * rkabalin is 3G-connected, so he may disappear or stay silent for a while.
19:49:21 <anitsirk> #info http://wiki.mahara.org/Developer_Area/Bug_Status
19:49:25 <anitsirk> thanks, richardm
19:50:06 <anitsirk> ok. almost the last item from the last meeting is
19:50:10 <anitsirk> #info Graphs in Mahara Statistics proposal (anzeljg)
19:50:21 <anitsirk> has anybody heard from anzeljg about that in the meantime?
19:51:05 <richardm> I haven't
19:51:39 <anitsirk> then let's put that as action item as well.
19:51:40 <anitsirk> #action Graphs in Mahara Statistics proposal (anzeljg)
19:52:04 <anitsirk> fmarier: i put the last item from the meeting which is concerned with testing under your topic
19:52:25 <anitsirk> oops. forgot one action item from last meeting:
19:52:26 <anitsirk> #info dobedobedoh to beg/borrow/steal/invent a forum code of conduct and place on the wiki
19:52:46 <fmarier> anitsirk: on the agenda or somewhere else?
19:52:47 <dobedobedoh> That's the ubuntu code we discussed earlier
19:53:00 <anitsirk> sorry
19:53:02 <dobedobedoh> ;)
19:53:08 <anitsirk> fmarier: no just later on the agenda
19:53:14 <anitsirk> ok. topics for this week then :-)
19:53:17 <anitsirk> #topic Safety issues (rkabalin)
19:53:21 <rkabalin> right
19:53:54 <rkabalin> well, it is just a suggestion we should consider for implementation
19:53:56 <anitsirk> let's see how 3G is holding up...
19:54:30 <rkabalin> there is a possibility to report objectionable view only at the moment
19:55:03 <rkabalin> but it would be great to extend to forum posts, blog comments, wall posts, etc.
19:55:57 <fmarier> i think it's a good idea for forum posts, i'm not sure about blog comments and wall posts
19:56:13 <fmarier> i mean these two things are typically owned and controlled by individual users
19:56:18 <fmarier> who can delete stuff they don't want
19:56:43 <anitsirk> didn't know that you could delete a blog comment.
19:56:45 <rkabalin> say if there is spam pops up on the wall, there is no way to inform someone about it unless writing to the owner
19:57:09 <fmarier> oh i see, so it wouldn't go to the admin, it would go to the user
19:57:11 <anitsirk> because there are no notifications
19:57:15 <dobedobedoh> So more of an inform for those
19:57:31 <lamiette> what about banned language like how Moodle does it? word censorship etc
19:58:12 <danp_> I think word censors are too blunt an instrument
19:58:18 <iarenaza> fmarier: and in the case of forums, to the group managers or the admin?
19:58:31 <dobedobedoh> in the case of forums, surely the forum moderators
19:58:33 <danp_> substitutions just used instead, and it causes problems for a lot of places
19:58:48 <lamiette> danp_: I've never seen one in use, I just know it's there
19:58:49 <fmarier> iarenaza: yeah probably to the forum facilitators. admins already receive enough emails i'd say :)
19:59:08 <anitsirk> and it should be the moderators' role.
19:59:23 <anitsirk> however, if there is no specific moderator it still has to go to the admin, i think
19:59:38 <dobedobedoh> the group admin, not site admin though
19:59:53 <anitsirk> dobedobedoh: yes. preferably. esp. on a big mahara install
20:00:11 <anitsirk> site admin doesn't know the people. the group admin does most likely
20:00:22 <richardm> sounds like a good idea & it would be quite easy right? maybe just messages to the owner/moderators?
20:00:22 <dobedobedoh> I do like the idea of an 'inform user of bad content' button - especially for users with messaging disabled
20:00:32 <anitsirk> i think the site admin should only handle things that neither group or institution admins can
20:00:33 <richardm> the nice thing is we don't have to provide any special access
20:00:33 <rkabalin> for blog comments/wall - the notification shoudl probably goes to the owner
20:01:37 <anitsirk> rkabalin: yes, i think so, too.
20:02:28 <anitsirk> objectionable content for a view / page can't go to the owner who put that up (unless we want to inform him in addition to the admin that sb else thinks his stuff is objectionable).
20:03:10 <fmarier> rkabalin: would you like to summarize your idea on a subpage of http://wiki.mahara.org/Developer_Area/Specifications_in_Development ?
20:03:20 <rkabalin> I will do
20:03:28 <fmarier> thanks
20:03:44 <anitsirk> thinking of big mahara installs: should the notifications of objectionable views go to the institution admins instead of the site admins? if sb finds a view with bad content on a view of a student belonging to a school, i think the institution / school admin should be informed because it's easier for them to take measures also off Mahara than the site admin.
20:04:09 <fmarier> anitsirk: sounds like a good idea
20:04:15 <dobedobedoh> anitsirk: Sounds like a good iea
20:04:37 <anitsirk> #action rkabalin to summarize his ideas of notifications of objectionable content on a subpage of http://wiki.mahara.org/Developer_Area/Specifications_in_Development
20:04:46 <fmarier> anitsirk is the admin extraordinaire who has to deal with all of the objectionable notifications on mahara.org :)
20:04:56 <dobedobedoh> heh
20:05:03 <anitsirk> ;-) and on MyPortfolio as well besides craig
20:05:04 * H31nz is back from doggi walk
20:05:13 <richardm> anitsirk: i think they already do go to institutional admins
20:05:37 <anitsirk> richardm: could you please check to make sure? would be great if that were already the case
20:05:43 <richardm> ok
20:05:50 <anitsirk> thanks
20:06:10 <anitsirk> #action richardm checks if objectionable content notifications already go to institution admins besides site admins
20:06:22 <anitsirk> H31nz: we had a question earlier for you.
20:06:59 <anitsirk> Would you be willing to support iarenaza drafting a language pack release policy?
20:07:04 <H31nz> iarenaza, please send me an email about liase stuff?!
20:07:15 <anitsirk> cool. thanks H31nz
20:07:25 <iarenaza> H31nz: ok
20:07:25 <H31nz> I noticed it
20:07:34 <anitsirk> #action H31nz supports iarenaza with drafting a language pack release policy
20:07:39 <H31nz> iarenaza, cool
20:08:03 <anitsirk> is there anything else to discuss for the security topic?
20:08:17 <anitsirk> ehm. safety
20:08:22 <anzeljg> hi
20:08:26 <rkabalin> no, that is it from me
20:08:26 <anitsirk> hi anzeljb
20:08:30 <anitsirk> anzeljg
20:08:30 <dobedobedoh> Hi anzeljg
20:08:41 <anzeljg> what i've missed
20:08:41 <iarenaza> hi anzeljg
20:08:43 <H31nz> hi
20:08:45 <anitsirk> #info anzeljg joined the chat fro the developer meeting
20:09:10 <anitsirk> shall we move to the next topic then?
20:09:16 <rkabalin> yep
20:09:24 <fmarier> actually, we should bring back anzeljg's topic
20:09:35 <dobedobedoh> Yeah
20:09:36 <anitsirk> i wanted to hold that off for the moment, but sure.
20:09:40 <anitsirk> just a sec
20:09:53 <anitsirk> #info Graphs in Mahara Statistics proposal (anzeljg)
20:10:01 <anzeljg> yeah.
20:10:14 <anitsirk> anzeljg: we do not quite know what you wanted to discuss here. do you have some details please?
20:10:25 <anzeljg> I was and still am working on integrating a sort of questionnaires into Mahara
20:10:51 <anzeljg> and I stumbled upon pChart which is a framework for rendering graphs...
20:11:10 <anzeljg> I was thinking it will also be useful for rendering graphs in Mahara admin section?
20:11:40 <anitsirk> ah. so for showing the quantitative results from a survey immediately in mahara instead of having to download the data first?
20:11:58 <anzeljg> yes.
20:11:59 <fmarier> it looks pretty good. does it generate images or is it a javascript-based thingie?
20:12:11 <anzeljg> or getting the data from DB and showing it as a graph
20:12:32 <anzeljg> it generates images (i THINK THEY CAN ALSO BE CACHED)
20:12:34 <anitsirk> hi rangi :-)
20:12:44 <anitsirk> #info rangi joined the chat room for the meeting
20:12:46 <anzeljg> sorry for caps lock
20:13:22 <fmarier> anzeljg: cool, so it would probably be fairly easy to replace the one we currently use with it
20:13:37 <anzeljg> i think so
20:13:59 <fmarier> have you put that idea in a bug report somewhere or you wanted to discuss it here first?
20:14:17 <anzeljg> as i was looking through examples, it seemed like an easy thing to implement
20:14:33 <anzeljg> no - i'll put it there
20:14:35 <dobedobedoh> the graphs do look pretty good
20:14:58 <anitsirk> #info anzeljg thinks that pChart may be a suitable framework for rendering graphs in mahara, e.g. in the admin section
20:15:05 <H31nz> anzeljg, URL?
20:15:30 <anzeljg> sorry: http://www.pchart.net/
20:15:56 <H31nz> anzeljg, thanks
20:16:02 <anzeljg> no problem
20:16:51 <anzeljg> what is the status of getting skins into mahara core?
20:17:14 <anitsirk> dobedobedoh and richardm did not yet have time to look at them
20:17:19 <fmarier> anzeljg: that's part of topic 3 :)
20:17:23 <dobedobedoh> anzeljg: I'm really sorry, but I've not had a chance to look at your patches more than just at a glance :(
20:17:27 <fmarier> (on the agenda)
20:17:47 <anzeljg> ok
20:17:57 <anzeljg> another question from me
20:18:11 <anitsirk> for the pChart: shall we make an action item for anzeljg to put more details on the bug tracker item?
20:18:25 <anzeljg> i am creating a blocktype to show photos from Picasa and Flickr
20:18:30 <anzeljg> sound good
20:19:02 <anitsirk> #action anzeljg will put more details about using pChart as framework for rendering graphs in Mahara on the bug tracker
20:19:08 <anzeljg> ok
20:19:33 <anzeljg> I want to show photo thumbnails and i also want to use slimbox
20:20:03 <H31nz> the users will love this feature!!
20:20:03 <fmarier> anzeljg: have you thought of extending the image gallery?
20:20:16 <anzeljg> The thumbnails are showing perfect on view.php, but not showing when I edit view (block.php)
20:20:35 <anzeljg> Is this because I need to include javascript libraries into <head>?
20:20:59 <richardm> yeah, that is tricky I think
20:21:15 <anzeljg> ok, I'll try to figure it on my on...
20:21:16 <richardm> that's the case where you don't know what js you're going to need till you actually put a block on the page
20:21:54 <anzeljg> for now, it is working in that manner, so when i edit the view the placeholder image show and when i actuall view the Mahara view, the thumbnails show up...
20:21:59 <anitsirk> #info anzeljg is working on a blocktype to include Picasa and Flickr photos
20:22:00 <richardm> i think the way to do it might be to pull the js out of the file, send it back to the browser in the ajax reply & eval() it
20:22:30 <anzeljg> never done that. can you send me more details and examples on emial?
20:22:31 <richardm> yeah a placeholder is fine i think if it's obvious to the user that they need to look at the view
20:23:16 <anzeljg> I'll try to finnish it till nex developer meeting, so you'll be able to see some results.
20:23:23 <richardm> anzeljg: i haven't done it either, i think evan g was looking into it for his flickr block, but i don't know how he got on
20:23:25 <dobedobedoh> wb rkabalin :)
20:23:36 <rkabalin_> thanks, sorry
20:23:52 <fmarier> richardm: we never merged that code did we?
20:24:08 <richardm> not the flickr stuff, i pulled the gallery  bit out of it
20:24:18 <fmarier> that's what i thought
20:24:23 <anitsirk> #action anzeljg to further look into flickr and picasa photo block
20:24:31 <richardm> the flickr stuff needed an api key but it was installable without one, so i didn't merge it
20:25:07 <anitsirk> i think you usually need a key / approval from flickr if you want to access the photos
20:25:28 <anzeljg> i registered api key especially for Mahara and now i can pull images from flick (the user only has to copy the link with his username and set id -> from the browser)
20:25:30 <anitsirk> that way you always have an overview which app wants to do stuff with your photos
20:26:13 <fmarier> anzeljg: so you're planning on distributing the api key with the source code?
20:26:16 <richardm> the trouble with evan's patch was that the block didn't work without the api key, but the admin could still install it without being forced to enter one
20:26:29 <richardm> so users ended up seeing a block that didn't do anything
20:26:46 <anitsirk> fmarier: i wouldn't do that. i always thought every user has to generate that for their own account.
20:26:55 <anitsirk> BTW: how does Moodle do it for the flickr repository?
20:26:57 <fmarier> anitsirk: that's what i think as well
20:27:03 <anzeljg> yes, the api will be in the source code (with some kind of notice, that it is for mahara and a link to obtain a new one, if anyone needed it)
20:27:17 <iarenaza> fmarier: we did a similar thing with a concept block for LinkedIn, and the config for plugin allowed to specify the API key for the Mahara site.
20:27:24 <anitsirk> in Moodle i can access flickr and not just my photos, but i can't remember the settings
20:27:39 <anitsirk> iarenaza: which data did you get from linkedin
20:27:41 <fmarier> maybe there's an anonymous API which doesn't require a key?
20:27:49 <danp_> I think there is
20:27:51 <fmarier> Twitter has that
20:27:55 * anitsirk is firing up XAMPP to check flickr repository setting in a moodle install
20:28:04 <iarenaza> Very basic personal stuff (they didn't allow much else at the moment).
20:28:20 <danp_> there are two flickr repository plugins in Moodle
20:28:25 <danp_> which is pretty confusing
20:28:30 <anitsirk> iarenaza: can you see the updates of all your connections or just your own?
20:28:43 <rkabalin_> the API key should not go with the source definitely, it should be set in particular plugin settings
20:29:01 <iarenaza> when we tried it (~9 months ago) only your own updates.
20:29:38 <anzeljg> ok. so i can set up a blocktype config form, so the admin should/will insert api key?
20:29:53 <anitsirk> in moodle i have to provide an api key and the secret
20:29:54 <iarenaza> I still have the code around, but it doesn't work any longer (I must have broken something in the meantime)
20:30:00 <anitsirk> and i put it in for the entire install
20:30:01 <fmarier> anzeljg: should probably be done at the site level
20:30:12 <iarenaza> anitsirk: exactly like our LinkedIn block.
20:30:24 <dobedobedoh> and the janrain block
20:30:44 <richardm> anzeljg: ideally so the block doesn't even appear for inclusion in a view until you have a valid api key configured
20:30:51 <anitsirk> #iarenaza had created a LinkedIn block. but it would need a revision as it does not work at the moment
20:31:07 <iarenaza> anitsirk: a concept block, not a fully featured one :-)
20:31:08 <anitsirk> iarenaza: did you also work on a twitter block?
20:31:14 <iarenaza> nope
20:31:27 <anitsirk> what do you mean b concept block, iarenaza? i don't know that term.
20:31:31 <anitsirk> by
20:31:45 <fmarier> anitsirk: a prototype (i think)
20:31:54 <iarenaza> something to test that it works
20:32:00 <iarenaza> yep, a prototype
20:32:04 <anzeljg> so when (on site level) admin enters a valid flickr api key, the blocktype visibility/availability is set to true?
20:32:08 <anitsirk> ah. then prototype / proof of concept
20:32:10 <anitsirk> cool.
20:32:27 <fmarier> anzeljg: that would work
20:32:34 <anitsirk> users for MyPortfolio in NZ have asked for twitter, facebook integration
20:32:58 <anitsirk> anzeljg: that's how it works in moodle
20:33:18 <iarenaza> facebook was also on our radar, but it was bigger/more difficult
20:33:28 <anzeljg> wasn't aware, that it works in moodle...
20:33:37 <anitsirk> just in moodl 2
20:33:54 <anzeljg> oh. haven't seen that one up close and personal ;)
20:34:15 <rkabalin_> BTW if you need backward integration (reposting Mahara elements in facebook or twitter) then janrain family could do that
20:34:28 <anitsirk> the moodle 2 repository plugin for mahara should be working when moodle 2.1 comes out
20:34:43 <anitsirk> thanks for that info, rkabalin_
20:34:51 <iarenaza> anitsirk: that will be great!
20:34:58 <rkabalin_> http://www.janrain.com/products/engage/social-sharing
20:34:59 <anitsirk> #info by rkabalin_ : if you need backward integration (reposting Mahara elements in facebook or twitter) then janrain family could do that
20:36:00 * anitsirk is looking at the time. it's already 65 minutes and we still have 5 topics (two short ones probably)
20:36:14 <anitsirk> shall we continue to release date?
20:36:55 <anitsirk> or do we need more time for flickr etc.?
20:37:26 <danp_> I think you should move onto release date
20:37:32 <anitsirk> BTW: rkabalin_ did you integrate the mahara data posting to facebook?
20:37:34 <danp_> could pick up the flickr stuff on the forms
20:37:47 <anitsirk> #topic Picking a release date (francois)
20:38:21 <fmarier> ok, so last time we talked about releasing before the school year starts in the northern hemisphere
20:38:36 <rkabalin_> anitsirk: no, we only implemented janrain social login that is now in mahara-contrib
20:38:44 <anitsirk> thanks rkabalin_
20:38:53 <fmarier> one thing that would be nice is to actually give schools a bit of time to test and deploy _before_ the school year starts
20:39:07 <anitsirk> #agree
20:39:13 <anzeljg> #agree
20:39:18 <dobedobedoh> #agree
20:39:23 <rkabalin_> #agree
20:39:26 <iarenaza> #agree
20:39:30 <danp_> #agree
20:39:32 <fmarier> so how do people feel about bringing it back a few months.  say end of April / early May?
20:39:58 <dobedobedoh> That would presumably give time to get the skins, and separated institutions code in to 1.4 then?
20:40:12 <anitsirk> #info: shall we put the release date at end of April / early May so that schools in the northern hemisphere have time for testing etc. before a final install for the new school year?
20:40:12 <rkabalin_> yep
20:40:14 <fmarier> dobedobedoh: which leads to my next sub point :)
20:40:55 <anitsirk> i guess, we discuss the next topic then before making a final decision on the release date
20:41:01 <dobedobedoh> That would probably also suit european schools (at least UK) and give them an opportunity to test/pilot things at the end of the summer term before going live when school starts in September
20:41:02 <fmarier> basically, we need a bit of help. there's just so much we (richardm and I) can do
20:41:06 <anitsirk> #info Need help reviewing: skins, Google Apps and Live@Edu
20:41:53 <fmarier> so my question would be how can we make it easier for others to help out?
20:41:54 <H31nz> dobedobedoh, agree
20:42:20 <anzeljg> anitsirk: Live@Edu?
20:42:24 <fmarier> and what sort of things are people interested in doing?
20:42:26 <dobedobedoh> fmarier: It'd be good to have some guidance on how you'd like things reviewed.
20:42:36 <danp_> fmarier: I guess the question is, what do you need?
20:42:37 <iarenaza> anzeljg: the Microsoft equivalente of Google Apps
20:42:39 <anitsirk> eh. we meant the Windows live block
20:42:46 <anzeljg> ok
20:42:51 <dobedobedoh> i.e. modifying + patching when we review, or would you prefer passing feedback to the original author for example
20:42:52 <danp_> a rubber stamp?
20:42:54 <fmarier> we've got 4 patches that have been requested a few times:
20:43:04 <anitsirk> anzeljg: i thought to remember that it was also tested with live@edu like google apps for education
20:43:12 <fmarier> anzeljg's ones: skins, google apps, live@edu
20:43:24 <fmarier> and LUNS' instutional separate stuff
20:43:32 <anitsirk> i.e. walled garden
20:43:33 <fmarier> s/separate/separation/
20:43:58 <anzeljg> live@edu wasn't tested like google apps for education. not by me.
20:44:11 <anzeljg> i don't have an account or what is needed.
20:44:15 <anitsirk> anzeljg: thanks for that info. then we would need to find somebody with an account
20:44:33 <anitsirk> #info windows live (the google apps equivalent) was not yet tested with live@edu accounts
20:44:48 <fmarier> the first thing would be of course to test it (functionality-wise), then to do an initial code review and break these features down into a set of patches that can be easily reviewed
20:44:51 <anitsirk> #action if somebody has a live@edu account, testing the windows live plugin by anzeljg would be fantastic
20:44:52 <iarenaza> anitsirk: somebody with an admin account? or just a regular account?
20:45:09 <anitsirk> iarenaza: you should just need a regular account
20:45:16 <anitsirk> i think
20:45:28 <iarenaza> not that I have one, just to make sure I ask for the right kind of account ;-)
20:45:31 <fmarier> by initial code review, I mean: basic security stuff, scalibility, general coding style
20:45:39 <anitsirk> if i remember correctly, for google apps the educational accounts had different urls
20:46:04 <fmarier> but yeah the google / microsoft stuff is harder to test given that people need accounts on those
20:46:15 <anzeljg> i tested google apps for education with regualr account
20:46:29 <fmarier> ah, so you just need a gmail account then?
20:46:30 <anitsirk> the google apps plugin by anzeljg has been tested quite well compared to other things.
20:46:35 <anitsirk> fmarier: yep
20:46:44 <iarenaza> fmarier: not exactly, they are a bit different
20:46:49 <anitsirk> and it's been tested for google apps for education as well
20:47:07 <anzeljg> i meant regual google for eduation account!
20:47:10 <anitsirk> as google accounts and google apps accounts are different
20:47:15 <anzeljg> Dirk provided one for me...
20:48:04 <iarenaza> anzeljg: I can provide more on request if needed
20:48:26 <anzeljg> please do, so i can see how the things are working
20:48:47 <dobedobedoh> fmarier: As developers, what could we do to help with the integration of patches/code/features/etc ?
20:48:59 <anitsirk> #action iarenaza to provide anzeljg with google apps for education account(s) for further testing of the google apps plugin
20:49:02 <danp_> fmarier: I think the main thing required is 'empowerment'. I.e. if someone does a review they can be sure it helsp with the integration
20:49:04 <fmarier> dobedobedoh: that's what I want to talk about in the next topic
20:49:23 <danp_> rather than a review to hit the same bottleneck
20:49:32 <anitsirk> #topic quality improvements
20:49:34 <danp_> (sorry, that wasn't very kindly put!)
20:49:38 <anitsirk> #info unit tests
20:49:41 <anitsirk> #info code reviews
20:50:03 <anitsirk> #info everybody to run minimum acceptance tests before commiting (was also action item from last time)
20:50:11 <fmarier> danp_: i think that's fair, we currently are the bottleneck and we're hoping we can find ways to improve this :)
20:50:26 <anzeljg> anitsir: I had a google for education account. i need live@edu account?!?
20:50:47 <anitsirk> ok.
20:50:49 <fmarier> so just before we actually get into this topic, did we agree on the End of April -ish release date?
20:51:07 <iarenaza> anzeljg: oops, I don't have access to live@edu accounts :-(
20:51:15 <anitsirk> #action everybody and esp. iarenaza and anitsirk to find live@edu account for anzeljg's testing
20:51:44 <rkabalin_> fmarier: #agree
20:51:51 <dobedobedoh> fmarier: #agree
20:51:54 <fmarier> (it would mean postponing features to 1.5 if we can't merge things in time)
20:52:00 <iarenaza> fmarier: #agree
20:52:10 <anitsirk> #agree
20:52:15 <danp_> One thing about these account things - I think it is fair that a minimum requirement for merging is accounts to test with
20:52:34 <danp_> (an instituation could 'donate' an account
20:52:41 <anitsirk> #agreed release date for 1.4 set to end of April-ish
20:53:00 <dobedobedoh> Preferably one that would continue to exist so as to be available for bug triage etc
20:53:03 <fmarier> danp_: indeed. or maybe we can get a test account from Microsoft / Google
20:53:29 <fmarier> surely we're not the only project wanting to test similar plugins
20:53:37 <anitsirk> but we are not an educational institution and can only get a regular google account (at a cost)
20:53:39 <danp_> true
20:54:11 <iarenaza> In the case of Google Apps for Edu, it's the same as Google Apps for Business. And those are free for business of less than 25 employees, if I'm not mistaken
20:54:19 <rkabalin_> though we are developing open-source (i.e. public) product
20:54:24 <dobedobedoh> They're similar, but not necessarily the same
20:54:37 <anitsirk> iarenaza: we would have had to pay for an account of 2 people after 1 month
20:55:07 <iarenaza> anitsirk: are you sure? Maybe I'm mistaken :-)
20:55:31 <dobedobedoh> There's google apps free, and for business, and for education, and soon for non-profit
20:55:41 <dobedobedoh> They're all pretty much the same thing
20:55:44 <dobedobedoh> just with different features
20:55:47 <anitsirk> iarenaza: yep. i'm sure. we needed credit card info when we developed the google apps block for Moodle 2 and had to close the account before 30 days so that it wouldn'tbe charged
20:55:54 <dobedobedoh> But the free one is very limited - you can't add additinoal services in the same way
20:55:56 <fmarier> ok, so maybe we just need one for live@edu
20:56:11 <danp_> I think there is a general point about merging things with accounts/weird requirements
20:56:28 <anitsirk> google apps for _education_ are free in NZ, but not in the US for example as I learned in a meeting yesterday
20:56:41 <anitsirk> i'll see what i can find out about live@edu
20:56:54 <anitsirk> (and google apps)
20:56:56 <iarenaza> anitsirk: they are definitely free in ES too
20:57:02 <fmarier> anitsirk: can we give you an action point of finding out whether we can get free test accounts?
20:57:10 <anitsirk> yep
20:57:12 <fmarier> danp_ makes a good point
20:57:13 <anitsirk> was just typing that
20:57:28 <fmarier> i don't know what the answer is to that.
20:57:49 <fmarier> should they go into contrib?
20:57:59 <danp_> I don't think thats required
20:58:00 <anitsirk> #action anitsirk to find out how to obtain free google apps (for education) and live@edu accounts (consulting with iarenaza who says that they are free in ES)
20:58:11 <dobedobedoh> fmarier: That would make them less easily used :\
20:58:13 <danp_> I think if you really want your stuff merged you can find a way to help the maintainers test it
20:58:48 <fmarier> so basically it needs to come with a test account that can be used by developers?
20:59:34 <rkabalin_> danp_: agree
20:59:44 <richardm> the trouble with those ones that have expiry dates is we can't easily fix bugs in them once the account runs out
20:59:55 <danp_> true
21:00:18 <fmarier> can i suggest that as a first step, these plugins could be added to a git repo and that core changes (if any) be extracted from them to be considered first?
21:00:20 <anitsirk> i'd look into a persistant account. using test accounts is stressful
21:01:06 <danp_> fmarier: #agree
21:01:23 <rkabalin_> fmarier: #agree
21:01:30 <dobedobedoh> fmarier #agree
21:01:55 <anitsirk> #agreed as a first step, these plugins could be added to a git repo and that core changes (if any) be extracted from them to be considered first
21:02:02 <fmarier> and i'm happy to provide git help for anyone who needs to get started with it :)
21:02:03 <rkabalin_> ideally plugin developer may consider separating core changes into separate merge request
21:02:21 <fmarier> rkabalin_: yes, that's what i was thinking about
21:02:51 <rkabalin_> this can be added to plugin dev documentation
21:02:51 <fmarier> and this is a good transition to
21:02:53 <danp_> I'm not sure how keen I am on having all plugins requiring an account being in contrib. The thing is 'out of the box' integration is a big selling feature for many insituations, so I think its a worthwhile tradeoff
21:02:53 <anitsirk> #info fmarier can provide you with git help
21:02:59 <fmarier> #topic quality improvements
21:03:19 <fmarier> danp_: i don't think that should be a requirement either
21:03:50 <fmarier> maybe the default but if the service is popular enough, it should probably be built-in
21:04:15 <fmarier> google apps and live@edu should ideally be part of core
21:04:37 <anzeljg> what about zoho?
21:05:01 <anzeljg> somebody wanted it? how many people use it?
21:05:35 <dobedobedoh> I've not come across it before
21:05:51 <fmarier> i guess if a plugin starts in contrib and then lots of people use it, then it's probably a good candidate for inclusion in core (assuming it's not too hard to maintain and the quality is good)
21:06:47 <danp_> agreed
21:06:49 <fmarier> but we do need to be careful about unmaintained plugins, otherwise some of the core code might suffer from bitrot (like the solr plugin apparently)
21:06:50 <dobedobedoh> I think that's fair. Things like google apps and live@edu will most likely be widely used so added soonish
21:06:52 <anzeljg> sorry if it is a dumb question, but how will you know, that a lot of people is using it? is there a counter of some sort?
21:07:37 <fmarier> anzeljg: i don't really have a good answer, but i guess when lots of people ask "why is it not in core yet?" :)
21:07:42 <dobedobedoh> heh
21:07:49 <dobedobedoh> Is any of that data sent in the weekly stats?
21:07:55 <dobedobedoh> i.e. plugins in use
21:07:55 <iarenaza> forum posts will probably be a good indicator
21:08:22 <H31nz> iarenaza, #agree
21:08:37 <rkabalin_> and tracker issues as well ;)
21:08:53 <anitsirk> #agreed if a plugin starts in contrib and then lots of people use it, then it's probably a good candidate for inclusion in core (assuming it's not too hard to maintain and the quality is good)
21:08:57 <richardm> we often only get forum posts when things go bad, if everythings running smoothly, people stay quiet
21:09:16 <anzeljg> is it possible to count how many times it has been downloaded from git?
21:09:25 <fmarier> partners might know when their clients will ask for these plugins I guess
21:09:33 <anitsirk> though we may not see many "we want this plugin" in the mahara forums, but maybe rather on installations that we maintain for clients / projects etc.
21:09:37 <richardm> launchpad has a counter but I don't think gitorious does
21:10:02 <dobedobedoh> fmarier/richardm: Do we get a list of plugins-in-use from teh weekly stats push, and is it something that could be added perhaps?
21:10:33 <richardm> dobedobedoh: certainly it could be added
21:10:47 <richardm> most sites don't register though
21:10:50 <dobedobedoh> shame :(
21:11:02 <dobedobedoh> It may be more of an incenive to register
21:11:41 <anitsirk> #info there is not yet a list of plugins-in-use from the weekly stats push, but it could be added according to richardm though most sites don't register with mahara.org and thus the statistics don't show an accurate picture across all mahara installations. they can just be an indicator.
21:12:09 <richardm> yeah i guess i can add it soon, i've got to update mahara.org soon anyway
21:12:22 <anitsirk> can i make that an action item then, richardm
21:12:25 <richardm> ok
21:12:28 <anitsirk> thanx
21:12:32 <fmarier> should we move to the next topic?
21:12:57 <anitsirk> #action richardm to add a list of plugins-in-use for the weekly stats push
21:12:58 <danp_> yup
21:13:01 <anitsirk> yes, fmarier
21:13:07 <fmarier> #topic quality improvements
21:13:26 <anitsirk> #info unit tests and code reviews
21:13:47 <anitsirk> #info everybody to run minimum acceptance tests before commiting (from the last meeting)
21:14:14 <fmarier> the first thing is that I'm going to try to get in touch with Penny and get the unit test work she did merge into master
21:14:33 <fmarier> then we'll have unit tests running as part of our continuous integration tests
21:14:55 <fmarier> once that's in place, then we can start looking at writing tests and increasing our coverage
21:15:01 <rkabalin_> that would be cool
21:15:02 <anitsirk> #action fmarier is going to try to get in touch with Mjollnir` and get the unit test work she did merge into master
21:15:14 <fmarier> but since penny is not here, i guess there's not a lot to talk about yet
21:15:20 <dobedobedoh> That woudl be a good start. I tried writing some selenium tests a while ago but they break too easily and give lots of false negatives
21:15:28 <anitsirk> #info once unit tests are running as part of our continuous integration tests, we can start looking at writing tests and increasing our coverage
21:15:30 <dobedobedoh> They're also a pain to get 100% right
21:15:47 <danp_> heh, did she actually do that work in the end? We were supposed to work on it together at debconf, but mostly worked on drinking beer
21:16:05 <fmarier> the selenium tests can be a bit of a pain, but they are useful. i run through them on all DBs before I do a release for example
21:16:24 <fmarier> but dobedobedoh is right, getting them to be robust is a bit of a black art unfortunately
21:16:50 <dobedobedoh> They'd be more useable with the merge request I submitted too
21:16:52 <fmarier> danp_: i'm not sure what the status on it is, i was hoping to ask penny this morning :)
21:16:59 <waawaamilk> I have come to believe that selenium tests should be used sparingly
21:17:04 <anitsirk> #info fmarier runs selenium tests on all DBs before he does a release
21:17:29 <anitsirk> #info waawaamilk joined the dev meeting
21:17:38 <waawaamilk> evenin'
21:17:42 <H31nz> waawaamilk, Hello ;-)
21:17:46 <dobedobedoh> lo waawaamilk
21:17:49 <fmarier> morning waawaamilk :)
21:17:53 <anitsirk> Hi there somewhere in wellington :-)
21:17:57 <iarenaza> hi waawaamilk
21:18:03 * waawaamilk waves from high vantage point
21:18:08 <richardm> hi waawaamilk
21:18:14 <anzeljg> hi
21:18:33 <fmarier> so anyways, i'll find out where things are at unittest-wise and report on this at the next meeting
21:18:38 <dobedobedoh> cool
21:18:51 <fmarier> the other bit i wanted to talk about is code reviews
21:19:02 <anitsirk> #info code reviews
21:19:12 <fmarier> i think there are two reasons for doing them:
21:19:18 <fmarier> 1- improving the quality of the code
21:19:40 <fmarier> 2- learning / mentoring each other
21:19:57 <danp_> agreed
21:20:09 <dobedobedoh> There's also 3- security review
21:20:15 <dobedobedoh> and 4- removing old code
21:20:41 <fmarier> dobedobedoh: yes, i would include does in #1 but you're right in identifying them explicitly
21:20:46 <anitsirk> #reasons for code review: 1) improve the quality of the code, 2) learn / mentor each other, 3) security review, 4) remove old code
21:21:09 <anitsirk> #info reasons for code review: 1) improve the quality of the code, 2) learn / mentor each other, 3) security review, 4) remove old code
21:21:20 <fmarier> now, the current system doesn't really work
21:21:20 <rkabalin_> Gerrit is tool that falilitates doing that before commit goes to master
21:21:39 <waawaamilk> reasons against: slows team down, you guys don't have the bandwidth to do them
21:21:50 * waawaamilk puts on devils advocate hat
21:21:51 <anitsirk> #info Gerrit is tool that falilitates doing that before commit goes to master
21:22:05 <fmarier> so i wanted to propose using gerrit to try to change our process
21:22:19 <danp_> waawaamilk: all reasons I used against moodle moving to a 'pull model', but its worked fantastically
21:22:27 <rkabalin_> uppps.. sorry fmarier
21:22:37 <dobedobedoh> #link http://code.google.com/p/gerrit/
21:22:43 <fmarier> rkabalin_: no need to be sorry, thanks for bringing it up again :)
21:23:47 <dobedobedoh> Can gerritt co-exist with gitorious?
21:23:51 <fmarier> we did talk about this last time I think, but basically what i'd like to propose is that two people must sign off on a commit before it makes it to core
21:23:59 <waawaamilk> hm, gerrit sounds like it allows you to go a bit faster
21:24:10 <fmarier> dobedobedoh: yes, it works with any git repo
21:24:16 <fmarier> it's quite generic
21:24:17 <danp_> fmarier: #agree I think its a fantastic idea
21:24:18 <rkabalin_> I agree, we should definitely try it
21:24:27 <dobedobedoh> yup
21:24:31 <dobedobedoh> what they said
21:24:33 <fmarier> so 2 people signing off does include the author of the commit
21:24:49 <danp_> is there a 'queue' tool?
21:24:52 <fmarier> so really 1 reviewer
21:25:02 <anitsirk> #agreed using gerrit to try to change our process of signing of code http://code.google.com/p/gerrit/
21:25:20 <fmarier> danp_: yes, there's basically a website where you can see the stuff that needs to be reviewed and then there's email notifications, etc.
21:25:21 <anitsirk> #info 2 people signing off does include the author of the commit
21:26:17 <fmarier> of course, when you're unsure about something, you can always invite specific people to review your code, but otherwise anybody with commit access to the main repo will be a reviewer in gerrit
21:26:19 <richardm> because we don't have the bandwidth for 2 reviewers
21:26:55 <anitsirk> #info when you're unsure about something, you can always invite specific people to review your code, but otherwise anybody with commit access to the main repo will be a reviewer in gerrit
21:27:06 <danp_> hmm, wonder why nobody suggested this for Moodle
21:27:11 <dobedobedoh> Are you thinking of limiting approvals to @catalyst users?
21:27:14 <fmarier> once that's in place then gerrit will be the only committer to master and the stable branches
21:27:29 <dobedobedoh> Or any other developer with commit access?
21:27:30 <fmarier> dobedobedoh: no, approvals are done by all existing committers
21:27:31 <anitsirk> #info once that's in place then gerrit will be the only committer to master and the stable branches
21:27:50 <anitsirk> #info approvals are done by all existing committers and not just @catalyst users
21:28:37 <fmarier> so basically rkabalin_ can review dobedobedoh's code and richardm can review my code, but of course when it's not time critical, it might be worth mixing that up to get more out of it
21:28:52 <fmarier> e.g. rkabalin_ reviewing fmarier's code
21:29:14 <dobedobedoh> yup
21:29:15 <dobedobedoh> That's good :)
21:29:17 * dobedobedoh likes it
21:29:38 <rkabalin_> danp_: it was suggested for moodle on the last meeting, but no one paid much attention
21:30:10 <anitsirk> #info review example: member:rkabalin_ (LUNS) can review member:dobedobedoh's (LUNS) code and member:richardm (Catalyst) can review fmarier's (Catalyst) code, but of course when it's not time critical, it might be worth mixing that up to get more out of it, e.g. rkabalin_ reviewing fmarier's code.
21:30:11 <danp_> i've heard about it before, but didn't realise it did exactly that role
21:30:36 <rangi> as the community grows you can change the rule too
21:31:06 <rangi> for koha we moved it from 1 additional signoff to, 1 additional signoff from outside your organisation
21:31:19 <rangi> as the number of people signing off increased
21:31:24 <fmarier> you'll be able to log into gerrit using an OpenID account. i would suggest using your launchpad one (since it's also used for filing Mahara bugs) but any openID account should work
21:32:03 <anitsirk> #info review role can change with time as community grows / # of people signing off increases, e.g. from 1 additional signoff to 1 additional signoff from outside your organisation
21:32:33 <anitsirk> #info you'll be able to log into gerrit using an OpenID account. fmarier suggests using your launchpad one (since it's also used for filing Mahara bugs) but any openID account should work
21:32:34 <fmarier> #action fmarier will setup gerrit and let people know once it's up
21:33:02 <anitsirk> thanks fmarier
21:33:07 <fmarier> hopefully this new focus on reviews will help remove that bottleneck
21:33:23 <rkabalin_> yep, I am very positive about trying gerrit
21:33:37 <anitsirk> shall we move to our last two items? next meeting and any other business?
21:33:46 <rkabalin_> yep
21:33:48 <anitsirk> #topic Next meeting
21:33:50 <anzeljg> yes
21:33:52 <danp_> the great thing about it is it helps motivate reviews
21:34:01 <dobedobedoh> I guess we're swingin the meeting time by 12 hours again?
21:34:13 <fmarier> if you have any other ideas (after this meeting) about how we can remove barriers to contribution and further empower developers, please feel free to email me (francois@mahara.org), we are serious about wanting to share responsibilities for the project
21:34:19 <anitsirk> yes.
21:34:40 <anitsirk> #info if you have any other ideas (after this meeting) about how we can remove barriers to contribution and further empower developers, please feel free to email fmarier (mailto:francois@mahara.org), we are serious about wanting to share responsibilities for the project
21:35:32 <anitsirk> friday, 18 march would be friday evening for us in NZ --> maybe move it to thursday?
21:35:47 <fmarier> anitsirk: i'd say the week after
21:35:53 <dobedobedoh> So as not to interfere with Beer O'Clock ;)
21:35:57 <dobedobedoh> 24th?
21:35:58 <anitsirk> having a meeting after beer o'clock may not be the best foreverybody ;-)
21:36:18 <fmarier> yeah 24th in NZ works fine
21:36:23 <fmarier> 23rd elsewhere
21:36:25 <anitsirk> 24th is fine for me
21:36:27 <anitsirk> nope
21:36:33 <anitsirk> 24th in the morning for europe
21:36:38 <fmarier> ah
21:36:49 <fmarier> 24 for everybody then :)
21:37:07 <fmarier> does anybody have a problem with that date?
21:37:12 <H31nz> 0:00 cool time
21:37:16 <dobedobedoh> Works for me
21:37:17 <anitsirk> ?
21:37:25 <rkabalin_> fine with me
21:37:29 <anzeljg> fine
21:37:33 <H31nz> fine
21:37:36 <richardm> fine
21:37:37 <anitsirk> so 7:30 UTC?
21:37:40 <fmarier> so 20:30 NZ time?
21:37:45 <iarenaza> I have a lecture at that time, but I know you'll do fine without me :-)
21:37:50 <anitsirk> and 8:30 p.m. NZDT on 24 March?
21:37:58 <anitsirk> iarenaza: at 7:30 a.m.?
21:38:07 <iarenaza> 7:45 to 9:45
21:38:12 <anitsirk> that's early
21:38:17 <danp_> 8.30 for iarenaza isn't it?
21:38:27 <iarenaza> danp_ you are right
21:38:30 <anitsirk> shall we go for another day because iarenaza has a few action items?
21:38:37 <anitsirk> ah. that's not so bad then. ;-)
21:38:47 <anzeljg> I also have lecture from 8:15 till 9:55, but I think I can manage
21:38:52 <fmarier> anitsirk: did you check the times against world clock? because we'll be crossing the daylight savings boundary
21:38:53 <iarenaza> but classes start at 7:45 AM local time
21:39:01 <dobedobedoh> Previous day?
21:39:01 <anitsirk> arg. i din't
21:39:10 <anitsirk> do we switch so early?
21:39:19 <fmarier> i can't remember exactly when it happens
21:39:20 * anitsirk needs a minute to find the world time
21:39:31 <fmarier> but it's different times for europe and NZ
21:39:37 <iarenaza> it happens at the end of march for EU
21:39:39 <fmarier> different dates, even
21:39:50 <dobedobedoh> http://tinyurl.com/6hn9z78
21:39:53 <iarenaza> last weekend of march
21:39:54 * H31nz reads results later
21:40:02 <H31nz> gute nacht
21:40:06 <H31nz> bye
21:40:07 <iarenaza> bye H31nz
21:40:11 <dobedobedoh> guten nacht H31nz
21:40:12 <anitsirk> UTC 7:30 a.m. is 8:30 p.m. NZ
21:40:18 * anzeljg also has togo
21:40:24 <anzeljg> bye
21:40:30 <iarenaza> bye anzeljg
21:40:46 <fmarier> excellent
21:40:58 <anitsirk> is the 23rd better than so that iarenaza and anzeljg can attend?
21:41:05 <anitsirk> then
21:41:24 <fmarier> that works for me too
21:41:39 <iarenaza> no problem for me
21:41:40 <dobedobedoh> works for me
21:42:14 <rkabalin_> fine
21:42:15 <anitsirk> agreed for the 23rd at 7:30a.m. UTC/GMT and 8:30 p.m. NZDT then?
21:42:30 <anitsirk> #agreed for the 23rd at 7:30a.m. UTC/GMT and 8:30 p.m. NZDT
21:42:40 <anitsirk> #topic Any other business
21:42:52 <dobedobedoh> Did you still want to rotate the chair anitsirk?
21:43:01 <anitsirk> oh please ;-)
21:43:10 <iarenaza> anitsirk: as promised, initial brain dump at http://wiki.mahara.org/Language_Packs/Language_Pack_Release_Policy
21:43:26 <anitsirk> you shouldn't suffer through more of my mispalced lines
21:43:33 <anitsirk> ;-)
21:43:56 <anitsirk> #info initial brain dump at http://wiki.mahara.org/Language_Packs/Language_Pack_Release_Policy by iarenaza
21:44:21 <fmarier> iarenaza gets a prize for being the first one to resolve an action item ;-)
21:44:35 <anitsirk> #agree
21:44:50 <fmarier> where prize mostly consists of fame and glory :)
21:45:00 <iarenaza> After *only* two months
21:45:06 <fmarier> :)
21:45:07 <anitsirk> would anybody volunteer to chair the next meeting?
21:45:18 <anitsirk> iarenaza: better late than never :-)
21:46:11 <anitsirk> mhh. anybody?
21:46:13 <dobedobedoh> I can do it again if you like?
21:46:28 <anitsirk> that would be awefully nice, dobedobedoh
21:46:31 <dobedobedoh> cool
21:46:46 <rkabalin_> I could do that as well
21:47:06 <rkabalin_> if dobedobedoh will show me the steering ropes
21:47:19 <anitsirk> #agreed either dobedobedoh or rkabalin_ will chair the next developer meeting -> LUNS to decide internally
21:47:31 <rkabalin_> ok
21:47:39 <anitsirk> thanks for volunteering. And as only one chairs, the next will chair the following meeting ;-)
21:48:10 <anitsirk> i think it may help if everybody chairs once because then everybody knows the action commands and can use them themselves
21:48:20 <dobedobedoh> agreed
21:48:23 <fmarier> good point
21:48:34 <anitsirk> without the chair always repeating things with #info so that they appear in the minutes and we don't have to dig them out of the log
21:49:04 <iarenaza> agreed
21:49:51 <anitsirk> #agreed we will try to rotate meeting chairs because it will also help us to learn the chat commands for structuring meeting minutes
21:49:56 <dobedobedoh> definately :)
21:50:05 <anitsirk> shall we conclude then or do you have any other items?
21:50:23 <rkabalin_> nothing else from me
21:50:27 <dobedobedoh> nor me
21:50:31 <fmarier> nothing from me
21:50:48 <anitsirk> nothing from me either
21:50:51 <iarenaza> nothing from me
21:50:58 <waawaamilk> how much field testing do you guys do?
21:51:14 <anitsirk> what do you mean? asking users of mahara?
21:51:21 <waawaamilk> watching users of mahara use it
21:52:12 <anitsirk> watching not so much due to time, but i am fairly involved with myportfolio and get feedback from the teachers, do sessions with them.
21:52:29 <waawaamilk> a few days ago, I went and taught a teacher I know how to use myportfolio, since she had only been given a pamphlet and told they were supposed to use it this year
21:52:35 <anitsirk> we will learn more about it in the next months i believe because the moderation online part has gone live though test schools have not yet been selected
21:53:04 <anitsirk> hehe, she should ask to have a myportfolio taster session scheduled: http://tiny.cc/myportfoliotaster
21:53:22 <anitsirk> that's what the tasters are for and the ministry expands them heavily this year.
21:53:34 <waawaamilk> sure - but the real value is actually that as a developer watching it, I saw a ton of stuff that could be changed for the better
21:53:43 <anitsirk> there is a coordinator who takes care of them and we are several facilitators across NZ to teach the 2-hour sessions
21:54:32 <waawaamilk> I suggest that richardm or francois or someone should go along to such sessions
21:54:36 <waawaamilk> just to watch
21:54:48 <waawaamilk> or even to try and teach
21:55:28 <anitsirk> i think we could do some of that by reporting issues more detailed and making suggestions for improvement
21:55:33 <waawaamilk> the object is to get the developers inside the minds of the teachers
21:55:47 <rkabalin_> me and dobedobedoh were on mahara training once, that was quite useful
21:55:49 <waawaamilk> the problem is that users often don't know what they want
21:56:19 <waawaamilk> they _think_ they know and they make suggestions, but that doesn't necessarily map to their real behaviour, and you lose the underlying reason why they want it
21:56:30 <waawaamilk> it's far more informative to watch their behaviour
21:56:41 <waawaamilk> where do they click when they're looking for something?
21:56:54 <dobedobedoh> Yeah - we found that really helpful
21:56:57 <waawaamilk> what kinds of words do they use?
21:57:07 <waawaamilk> which bits do they claim are confusing?
21:57:26 <anitsirk> i am not sure if the taster sessions would be the best place though. i'd suggest more a session where there is not so much input, but where users do stuff on their own, e.g. as in a usability lab setting
21:57:47 <waawaamilk> how they think they can use the features, etc
21:58:18 <waawaamilk> sure, a proper usability thing is a great way to do this
21:58:26 <waawaamilk> but my guess is you won't get any budget for that
21:58:30 <waawaamilk> so you'll have to approximate
21:58:53 <waawaamilk> my opinion is that it's better to get _some_ feedback than none
21:59:02 <anitsirk> it doesn't have to be a proper lab
21:59:09 <dobedobedoh> d
21:59:15 <anitsirk> bye dobedobedoh
21:59:38 <iarenaza> time to go to bed here too :-)
21:59:41 <iarenaza> bye
21:59:47 <anitsirk> bye iarenaza
22:01:10 <anitsirk> shall we make an action item that we think about ways of improving getting feedback from users in the form of actually watching them and maybe also writing down what we have already done in an idea gathering step? waawaamilk has already suggested a couple of things, but we need to see how we can go about that.
22:01:34 <rkabalin_> yep
22:02:01 <waawaamilk> if you're running a session anyway, why not get one of them to go along as a quick trial?
22:02:27 <anitsirk> waawaamilk: the sessions i have planned so far for me aren't in wellington
22:02:43 <waawaamilk> where abouts are they?
22:02:54 <anitsirk> #action item for everybody: think about how to improve getting user feedback - not just written feedback, but watching users to study their behavior and get first-hand insight into how they use mahara
22:03:10 <anitsirk> christchurch and many are around hamilton and auckland run by somebody else
22:03:29 <fmarier> waawaamilk: i agree with what you are saying. and also about us not necessarily having budget for it :)
22:03:39 <waawaamilk> I heard from the teacher that the MoE were going to be doing some kind of intro for it, and she works at wainui college
22:03:46 <waawaamilk> maybe you could get into one of those sessions
22:03:58 <fmarier> waawaamilk: can you think of a convincing argument we could make next time someone fronts up some money for usability improvements?
22:04:33 <fmarier> i think it would be more valuable to have an evidence-based approach like that than some of the outside reviews we've had which have mostly picked up inconsistencies in the UI
22:04:38 <waawaamilk> fmarier: whether people can actually _use_ it is pretty important
22:07:04 <waawaamilk> I know this isn't my project, but if it was, I would think right now: "We're rolling this out to all these NZ schools, there are tons of teachers who are going to be working out how to use it, shouldn't we try and get inside their thoughts so we know the best ways to improve it?"
22:07:20 <anitsirk> agreed. juggling it with other things and budget as well as availability are issues that need to be taken into consideration.
22:07:30 <anitsirk> waawaamilk: we are trying to do that
22:08:03 <waawaamilk> anitsirk: I'm just suggesting rubbing developer's noses in it directly :)
22:09:05 <anitsirk> i'll bring it up for our next planning phase :-)
22:09:34 <anitsirk> but i think that looking at the time and the dwindling number of participants due to night in europe, we should conclude the meeting if there are no other items to discuss
22:10:23 <anitsirk> thanks all for coming. we will chat again for the next meeting on 23 march at 7:30 a.m. UTC / 8:30 p.m. NZDT.
22:10:27 <anitsirk> #endmeeting