#mahara-dev Meeting

Meeting started by robertl_ at 07:01:33 UTC (full logs).

Meeting summary

    1. robertl_ is Robert Lyon, Catalyst in Wellington, New Zealand (robertl_, 07:01:52)
    2. anitsirk is Kristina Hoeppner, Catalyst, Wellington, NZ (anitsirk, 07:01:52)
    3. mingard is Jono Mingard, Catalyst in Wellington, New Zealand (mingard, 07:02:04)
    4. aaronw is Aaron Wells of Catalyst IT's office in Wellington, New Zealand (aarowlaptop, 07:02:10)
    5. anzeljg is Gregor Anzelj, developer and translator, POVSOD, Ljubljana, Slovenia (anzeljg, 07:02:15)

  1. Items from last meeting (robertl_, 07:03:14)
    1. aarowlaptop and anitsirk to update readme file for Mahara 15.10 and 16.04 to say current things. (robertl_, 07:03:20)
    2. ghada is Ghada El-Zoghbi, Catalyst in Sydney, AU (ghada, 07:03:50)
    3. aarowlaptop to remove items from the upgrade script (robertl_, 07:04:06)
    4. Readme for 15.10 and 16.04 have been updated. 16.04 needs another update closer to the release date for actual browser support then. (anitsirk, 07:04:14)

  2. Discuss the latest release 15.10 (robertl_, 07:06:31)
    1. for 15.10 we took on some major overhaul of the design/layout of the site (anitsirk, 07:08:13)
    2. if you haven't seen Mahara 15.10 yet, check it out at http://demo.mahara.org (anitsirk, 07:09:38)
    3. http://demo.mahara.org (anitsirk, 07:09:59)
    4. now that we have bootstrap, we'll be able to do some more cool things I'm sure. (anitsirk, 07:11:41)
    5. Since some were already asking: We are not upgrading to Bootstrap 4 immediately when it becomes available. That will most likely be something for 16.10 when it will have matured a bit (if it's been released by then) as our front-en lead recommended. (anitsirk, 07:12:46)
    6. a huge thanks goes to the catalyst front-end team for making the changes. there are more to come, in particular in ripping out mochikit... (anitsirk, 07:14:14)
    7. we also had a number of new contributors to Mahara 15.10. (anitsirk, 07:15:29)
    8. the stats on the commits and others who were involved are available at https://mahara.org/interaction/forum/topic.php?id=7420 (anitsirk, 07:16:14)
    9. I'm still working on the user manual. it will get done. takes a bit longer than usual as every single screenshot needs to be replaced and also some text changed. i use this as an opportunity to start my manual instance from scratch so we can use the database for the demo site to get some more varied content in. (anitsirk, 07:17:35)
    10. the big new features are already documented (will add some images on the new themes). only mathjax is missing. (anitsirk, 07:18:35)

  3. Discuss SASS/JavaScript compilation options (whether to stick with gulp) (robertl_, 07:19:11)
    1. IDEA: is there a php alternative for compiling SASS and (possibly) concatenating javascript in the future since npm add complexity. (anitsirk, 07:22:38)
    2. there don't seem to be any good php options available that we know of. (anitsirk, 07:23:13)
    3. IDEA: PHP libsass extension might be a possibility, but it is a non-standard extension. (anitsirk, 07:24:23)
    4. https://github.com/sensational/sassphp works great, but you have to build it from source. (anitsirk, 07:25:25)
    5. IDEA: it would be good to concatenate and / or minify JS wherever possible. (anitsirk, 07:29:13)
    6. big third-party js is already minified. (anitsirk, 07:29:22)
    7. it would be helpful to have it uncompressed in dev mode and be able to minify Mahara-specific JS (anitsirk, 07:29:49)
    8. IDEA: have a minified JS version when production mode is on and the full version in dev mode. (anitsirk, 07:30:37)
    9. IDEA: going down this route would allow us to be more granular about how we use libraries. i.e. we wouldn't need to include the entirety of jQuery UI just to use one or two components (anitsirk, 07:32:26)
    10. IDEA: add a "make js" task and have the default "make" invoke "make css" and "make js" so that the tasks are run automatically. (anitsirk, 07:33:20)
    11. ACTION: mingard to talk to the Catalyst front-end developers to see what their ideas are on SASS and JS (mingard, 07:35:26)
    12. ACTION: mingard to talk to the Catalyst front-end developers to see what their ideas are on SASS and JS (robertl_, 07:36:24)

  4. Next meeting and chair (robertl_, 07:37:08)
    1. http://www.santagames.net/calendar/index.htm (mingard, 07:41:17)
    2. The 49th Mahara developer meeting will take place on 1 Dec 2015 at 8:00 UTC. Kristina is going to chair the meeting. http://www.timeanddate.com/worldclock/fixedtime.html?iso=20151201T08 (robertl_, 07:50:58)

  5. Any other business (robertl_, 07:51:27)
    1. https://github.com/agwells/maharacontrib-blocktype-clippy/blob/master/theme/raw/static/style/style.css#L3 (aarowlaptop, 07:54:13)
    2. Third-party plugins for blocktypes have icon trouble in 15.10. The icons use artefact/blocktype name pattern. E.g. I want to update the linkedinprofile plugin, so that means that the system searches for 'icon-linkedinprofile' icon in the CSS, which is not defined. (anitsirk, 07:57:36)
    3. https://github.com/MaharaProject/mahara/blob/master/htdocs/blocktype/lib.php#L299 (mingard, 08:04:57)
    4. https://git.mahara.org/mahara/mahara/blob/master/htdocs/theme/raw/sass/typography/_icons.scss (aarowlaptop, 08:05:35)
    5. https://git.mahara.org/mahara/mahara/tree/master/htdocs/theme/raw/sass/lib/font-awesome (aarowlaptop, 08:06:12)
    6. ACTION: improve options for selecting icon for blocktypes (robertl_, 08:14:52)
    7. IDEA: enhance the "Watched pages" block to configure it so as to display changes relating to users' friends since their last login (anitsirk, 08:18:35)
    8. https://github.com/MaharaProject/maharadroid/pull/8 (anzeljg, 08:25:26)
    9. MaharaDroid is being revamped to use Cordova (aka PhoneGap). Stay tuned. (anitsirk, 08:28:15)
    10. currently, the URL for merged patches still points to git.nzoss.org in launchpad (anitsirk, 08:32:52)
    11. https://git.mahara.org/scripts/mahara-scripts/blob/master/gerrit/change-merged (aarowlaptop, 08:34:15)


Meeting ended at 08:37:29 UTC (full logs).

Action items

  1. mingard to talk to the Catalyst front-end developers to see what their ideas are on SASS and JS
  2. mingard to talk to the Catalyst front-end developers to see what their ideas are on SASS and JS
  3. improve options for selecting icon for blocktypes


Action items, by person

  1. mingard
    1. mingard to talk to the Catalyst front-end developers to see what their ideas are on SASS and JS
    2. mingard to talk to the Catalyst front-end developers to see what their ideas are on SASS and JS


People present (lines said)

  1. aarowlaptop (114)
  2. anitsirk (97)
  3. mingard (80)
  4. robertl_ (68)
  5. anzeljg (64)
  6. ghada (11)
  7. waa (4)
  8. maharameet (3)


Generated by MeetBot 0.1.4.