07:01:33 <robertl_> #startmeeting
07:01:33 <maharameet> Meeting started Tue Oct 27 07:01:33 2015 UTC.  The chair is robertl_. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:01:33 <maharameet> Useful Commands: #action #agreed #help #info #idea #link #topic.
07:01:46 <robertl_> please introduce yourselves
07:01:52 <robertl_> #info robertl_ is Robert Lyon, Catalyst in Wellington, New Zealand
07:01:52 <anitsirk> #info anitsirk is Kristina Hoeppner, Catalyst, Wellington, NZ
07:02:04 <mingard> #info mingard is Jono Mingard, Catalyst in Wellington, New Zealand
07:02:10 <aarowlaptop> #info aaronw is Aaron Wells of Catalyst IT's office in Wellington, New Zealand
07:02:15 <anzeljg> #info anzeljg is Gregor Anzelj, developer and translator, POVSOD, Ljubljana, Slovenia
07:02:42 <robertl_> anyone else?
07:03:07 <anitsirk> seems to be it. don't know if ghada could join today or not
07:03:12 <robertl_> Right, here we go
07:03:14 <robertl_> #topic Items from last meeting
07:03:20 <robertl_> #info aarowlaptop and anitsirk to update readme file for Mahara 15.10 and 16.04 to say current things.
07:03:23 <ghada> hi
07:03:31 <anzeljg> hi
07:03:33 <robertl_> hi ghada
07:03:37 <anitsirk> hi ghada. could you please introduce yourself?
07:03:47 <anitsirk> robertl_: that's been done and merged
07:03:50 <ghada> #info ghada is Ghada El-Zoghbi, Catalyst in Sydney, AU
07:03:58 <robertl_> ok, cool
07:04:01 <robertl_> next item
07:04:06 <robertl_> #info aarowlaptop to remove items from the upgrade script
07:04:14 <anitsirk> #info Readme for 15.10 and 16.04 have been updated. 16.04 needs another update closer to the release date for actual browser support then.
07:05:05 <aarowlaptop> I updated the 15.10 version.php file so that it indicates that it only supports upgrades from 1.6.0
07:05:18 <aarowlaptop> but I didn't remove all the old upgrade sections from upgrade.php yet
07:05:34 <robertl_> so that will be a 15.10.1 thing then?
07:05:45 <aarowlaptop> yeah, we could do that for 15.10.1
07:06:26 <robertl_> ok, that leaves us with the big news
07:06:31 <robertl_> #topic Discuss the latest release 15.10
07:06:38 <anitsirk> Let's watch https://youtu.be/W94Uhc0JuO8?t=8m56s
07:07:02 <anitsirk> in lieu of not having real champagne here on irc ;-)
07:07:03 <robertl_> lol
07:07:31 <mingard> haha irc needs facebook-style stickers ...
07:07:39 <aarowlaptop> I have some red wine over in my kitchen. I'll just pour myself a little right now and pretend it's champagne...
07:07:59 <robertl_> for 15.10 we took on some major overhaul of the design/layout of the site
07:08:07 <mingard> and it looks gorgeous :D
07:08:13 <anitsirk> #info for 15.10 we took on some major overhaul of the design/layout of the site
07:08:21 <robertl_> and for a while there more things were broken than working
07:08:30 <anitsirk> and it's still accessible as well thanks to mingard and julius
07:08:58 <robertl_> but due to the massive effort things came together nicely in time for the normal October release
07:09:11 <anitsirk> it sure was a monumental tasks. super job, everyone.
07:09:38 <anitsirk> #info if you haven't seen Mahara 15.10 yet, check it out at http://demo.mahara.org
07:09:59 <anitsirk> http://demo.mahara.org
07:10:18 <ghada> fyi. I got our first upgrade to 15.10 just a few minutes ago.
07:10:26 <ghada> one of our clients is upgrading
07:10:38 <aarowlaptop> how did it go?
07:10:55 <ghada> i just got the quote approved. work yet to be done...
07:11:14 <anitsirk> ghada: great! we are also going to be busy over the next few weeks upgrading some sites.
07:11:25 <ghada> that's great to hear
07:11:32 <robertl_> the huge task was made slightly less painful by having the behat automated testing catch brokenness
07:11:41 <anitsirk> #info now that we have bootstrap, we'll be able to do some more cool things I'm sure.
07:11:42 <ghada> any way...sorry about the distraction.
07:11:47 <mingard> yes! thanks everyone for the behat tests
07:12:46 <anitsirk> #info Since some were already asking: We are not upgrading to Bootstrap 4 immediately when it becomes available. That will most likely be something for 16.10 when it will have matured a bit (if it's been released by then) as our front-en lead recommended.
07:12:53 <anitsirk> front-end I meant
07:13:25 <anitsirk> Big win I think: Someone on the forums already asked about Bootstrap and seems to be knowing how he can add some more functionality / flashiness.
07:14:01 <mingard> afaik bootstrap 3 will continue to be supported for the forseeable future, and bootstrap 4 won't be too different from bootstrap-sass (which we're already using)
07:14:14 <anitsirk> #info a huge thanks goes to the catalyst front-end team for making the changes. there are more to come, in particular in ripping out mochikit...
07:15:05 <anitsirk> mingard: that's good news. i heard that bootstrap 4 doesn't have panels anymore. so we'll need to think of something else for the places where we use panels now, e.g. the admin homepage and other places
07:15:29 <anitsirk> #info we also had a number of new contributors to Mahara 15.10.
07:16:14 <anitsirk> #info the stats on the commits and others who were involved are available at https://mahara.org/interaction/forum/topic.php?id=7420
07:16:29 <robertl_> yes it's always nice to see the varied institutions/people willing to contribute
07:17:32 <aarowlaptop> yep :)
07:17:35 <anitsirk> #info I'm still working on the user manual. it will get done. takes a bit longer than usual as every single screenshot needs to be replaced and also some text changed. i use this as an opportunity to start my manual instance from scratch so we can use the database for the demo site to get some more varied content in.
07:18:28 <robertl_> ok, shall we move on?
07:18:35 <anitsirk> #info the big new features are already documented (will add some images on the new themes). only mathjax is missing.
07:19:05 <anitsirk> sure
07:19:11 <robertl_> #topic Discuss SASS/JavaScript compilation options (whether to stick with gulp)
07:19:22 <robertl_> mingard, this was your topic
07:19:37 <mingard> yep
07:20:02 <mingard> i've heard aarowlaptop at least complaining about the extra complexity of having npm for compiling sass
07:20:17 <aarowlaptop> true
07:20:30 <robertl_> npm was better than the ruby option :)
07:20:45 <mingard> so i was wondering if there's a php alternative for compiling sass and (possibly) concatenating javascript in the future
07:20:58 <mingard> for example http://leafo.net/scssphp/
07:21:01 <aarowlaptop> I spent some time looking into for Catalyst's deployment process and I didn't find anything better than npm at present
07:21:13 <anitsirk> mingard: did you already talk with jen about that and see if she had any suggestions?
07:21:13 <mingard> (which may/may not be maintained)
07:21:35 <aarowlaptop> yeah
07:21:42 <robertl_> I believe the front-end devs felt the php option was not robust enough / was missing features or something
07:21:43 <mingard> anitsirk: no, that's a good point
07:21:47 <aarowlaptop> I think I tried scssphp, because it's the only SASS compiler written in PHP
07:22:04 <aarowlaptop> it was too slow
07:22:24 <aarowlaptop> the only way to get decent speed is to use the SASS compiler written in C (libsass I think it's called)
07:22:31 <mingard> ok then, it's quite possible npm is the best compromise
07:22:34 <aarowlaptop> the npm sass compiler is actually a thin wrapper around that
07:22:38 <anitsirk> #idea is there a php alternative for compiling SASS and (possibly) concatenating javascript in the future since npm add complexity.
07:22:51 <aarowlaptop> there is also a PHP module that acts as a wrapper around libsass, but I think it'd be harder to expect people to have that installed
07:23:13 <anitsirk> #info there don't seem to be any good php options available that we know of.
07:23:18 <mingard> the ideal would be to have a /css.php script which would build it on-the-fly in development and cache in production
07:23:21 <mingard> but that may not be possible
07:23:36 <aarowlaptop> If you used the PHP libsass extension, it'd be doable
07:23:40 <aarowlaptop> but it's a non-standard extension
07:24:04 <mingard> the latest update i found to that was in about 2013, so it's probably missing features too
07:24:07 <aarowlaptop> I think it was https://github.com/sensational/sassphp
07:24:23 <anitsirk> #idea PHP libsass extension might be a possibility, but it is a non-standard extension.
07:24:30 <mingard> oh actually that's much more recent
07:24:34 <aarowlaptop> yeah
07:24:38 <aarowlaptop> I think I even gave it a test run
07:24:42 <aarowlaptop> and it works great
07:25:03 <aarowlaptop> but you pretty much have to build it from source
07:25:14 <mingard> ok
07:25:25 <anitsirk> #info https://github.com/sensational/sassphp works great, but you have to build it from source.
07:26:03 <robertl_> so mingard, were you thinking of compressing/compiling javascript min files as well?
07:26:05 <aarowlaptop> so for now we're still saddled with npm. But it's worth keeping an eye on things to see if a good alternative arises
07:26:15 <mingard> alrighty, basically i was wondering how much people had thought about it and whether anything had been found
07:26:31 <mingard> robertl_: yes is the short answer
07:26:52 <mingard> sticking with npm would let us use things like browserify (which are great for modularising code)
07:26:53 <anitsirk> mingard: you could check with jen if anything had transpired over the last months since we talked about it.
07:27:21 <mingard> but even if we want a PHP solution I think it would be a good idea to concatenate and/or minify JS
07:27:26 <robertl_> so currently most of our big third party js is minified
07:27:44 <mingard> true
07:27:59 <mingard> but it would be helpful to have it uncompressed in dev mode
07:28:04 <robertl_> so it would be more to do with the mahara specific js files?
07:28:04 <mingard> like mochikit currently is
07:28:11 <mingard> and that too
07:28:38 <mingard> since we already have (for example) mahara.js, which is long and does all sorts of different things
07:29:08 <mingard> so it would be nice to split it up into a few utility files, but that would add more script tags to the page (which we already have a lot of on some pages)
07:29:13 <anitsirk> #idea it would be good to concatenate and / or minify JS wherever possible.
07:29:16 <aarowlaptop> hm
07:29:22 <anitsirk> #info big third-party js is already minified.
07:29:33 <aarowlaptop> well, it should be easy enough to add a step for that to the makefile & gulpfiles
07:29:41 <robertl_> oh, you could have is so when prod mode is off it uses the big version
07:29:49 <anitsirk> #info it would be helpful to have it uncompressed in dev mode and be able to minify Mahara-specific JS
07:29:51 <aarowlaptop> and then invoke it in the mahara-scripts release.sh script that packages up releases
07:30:03 <robertl_> but when prod mode is on it uses the .min.js version
07:30:26 <mingard> aarowlaptop: yeah, that's the sort of thing I was thinking
07:30:37 <anitsirk> #idea have a minified JS version when production mode is on and the full version in dev mode.
07:30:48 <mingard> it would also let us be a bit more granular about how we use libraries
07:30:48 <robertl_> which can be compiled via 'make js' or something
07:31:07 <mingard> instead of including the entirety of jQuery UI just to use one or two components
07:31:32 <aarowlaptop> yeah, I'd add a "make js" task
07:31:40 <aarowlaptop> and then have the default "make" invoke "make css" and "make js"
07:32:26 <anitsirk> #idea going down this route would allow us to be more granular about how we use libraries. i.e. we wouldn't need to include the entirety of jQuery UI just to use one or two components
07:32:54 <mingard> yup :)
07:33:20 <anitsirk> #idea add a "make js" task and have the default "make" invoke "make css" and "make js" so that the tasks are run automatically.
07:33:21 <mingard> that was pretty much it - just wanted to start a discussion about how we could improve our JS usage
07:34:27 <mingard> shall I chat to jen and the front-enders about it then?
07:34:43 <anitsirk> mingard: i'd say so. see what she and pat think.
07:34:56 <mingard> ok
07:35:26 <mingard> #action mingard to talk to the Catalyst front-end developers to see what their ideas are on SASS and JS
07:35:35 <mingard> that's the right command, right?
07:35:52 <robertl_> looks right to me
07:36:04 <anitsirk> mingard: don't know if you can do action. it might just be robertl_ who can do that. can't remember which ones needed to be invoked by the chair
07:36:18 <mingard> well, it's there for copy-pasting anyway
07:36:24 <robertl_> #action mingard to talk to the Catalyst front-end developers to see what their ideas are on SASS and JS
07:36:42 <robertl_> it'll sure be in there now
07:36:48 <anitsirk> :-)
07:37:07 <robertl_> so now to the most fun bit of the evening
07:37:08 <robertl_> #topic Next meeting and chair
07:37:34 <anitsirk> robertl_ I'll not put up my hand as I don't know what my connectivity will be like during the most likely week.
07:37:35 <robertl_> should the next meeting be in late Nov or early Dec?
07:38:30 <robertl_> I'm thinking the 1st of Dec could be good
07:38:40 <aarowlaptop> sure, everyone will probably still be around then
07:38:50 <robertl_> any counter offers?
07:38:54 <anitsirk> nope
07:38:59 <mingard> the 1st works for me
07:39:15 <anitsirk> ghada?
07:39:38 <ghada> dec 1 works for me as well.
07:40:01 <robertl_> ok so who wants to drive it?
07:40:17 <robertl_> sit in the imaginary big chair
07:40:50 <anitsirk> and be the first to open the first advent door in a virtual advent calendar (if we had one)
07:41:17 <mingard> http://www.santagames.net/calendar/index.htm
07:41:41 <anitsirk> here we go :-)
07:42:11 <mingard> i'm happy to host if no one else is volunteering
07:42:12 <anitsirk> i could potentially chair but might need a backup in case my connection is not that great
07:42:12 * waa waves
07:42:19 <anitsirk> hi waa
07:42:39 <waa> twitter said there was a meeting here
07:42:45 <waa> so I thought I would check
07:42:52 <anzeljg> :)
07:42:53 <robertl_> anitsirk, I can step in if your connection goes bad
07:42:53 <anitsirk> :-) want to chair the next one :-D waa?
07:43:22 <waa> I'm not sure anything would get done if I did :D
07:43:24 <anitsirk> robertl_ that would work. I'll not know until the day before
07:44:35 <robertl_> #info The 49th Mahara developer meeting will take place on 1 Dec 2015 at 7:00 UTC. Kristina is going to chair the meeting. http://www.timeanddate.com/worldclock/fixedtime.html?iso=20151201T07
07:44:52 <anzeljg> If possible, for me it's better at 5:00 UTC
07:45:06 <mingard> that would work better for me too
07:45:29 <robertl_> would that mean 5am for UK time?
07:45:55 <anzeljg> ok, not such a good idea...
07:46:41 <anzeljg> what about 8:00 UTC then?
07:46:51 <anitsirk> robertl_ no. it would be 8 a.m. uk time
07:47:00 <anitsirk> but i'll be in germany and thus 9 a.m. :-)
07:47:10 <anitsirk> oh sorry. didn't read anzeljg
07:47:21 <anitsirk> that would be 6 a.m. uk time then.
07:47:27 <anitsirk> and 7 a.m. europe
07:47:32 <mingard> huh, is germany only one hour different?
07:47:45 <anzeljg> anitsirk?
07:47:51 <anitsirk> oh dear. not anymore since they'll have turned clocks backwards. here we go: http://www.timeanddate.com/worldclock/fixedtime.html?iso=20151201T05
07:47:58 <anitsirk> it would be 6 a.m.
07:48:03 <anitsirk> is that what you meant, anzeljg?
07:48:19 <anzeljg> 5:== UTC is 6 a.m. for Europe yes
07:48:23 <anitsirk> it would be 6 p.m. nz
07:48:24 <anzeljg> and 5 a.m. for UK
07:48:46 <anitsirk> yes. which is rather early for the likes of rkabalin and potentially dajan if they wanted to join.
07:48:50 <mingard> how about 8:00 UTC then as anzeljg suggested?
07:49:08 <anzeljg> that would mean 8:00 UK and 9:00 Europe
07:49:20 <anitsirk> and 9 p.m. NZ and 7 p.m. sydney
07:49:30 <ghada> that works for me
07:49:32 <robertl_> that sounds ok to me
07:49:34 <anzeljg> +1
07:49:42 <anitsirk> either works for me.
07:49:58 <mingard> cool - 9pm means I can get to kung fu ;)
07:50:02 <aarowlaptop> sure
07:50:09 <robertl_> so how do I remove the last info message?
07:50:15 <mingard> hash undo?
07:50:17 <anitsirk> #undo robertl_
07:50:37 <robertl_> #undo The 49th Mahara developer meeting will take place on 1 Dec 2015 at 7:00 UTC. Kristina is going to chair the meeting. http://www.timeanddate.com/worldclock/fixedtime.html?iso=20151201T07
07:50:37 <maharameet> Removing item from minutes: <MeetBot.items.Info object at 0x25adc10>
07:50:58 <robertl_> #info The 49th Mahara developer meeting will take place on 1 Dec 2015 at 8:00 UTC. Kristina is going to chair the meeting. http://www.timeanddate.com/worldclock/fixedtime.html?iso=20151201T08
07:51:26 <robertl_> and that leaves us with ...
07:51:27 <robertl_> #topic Any other business
07:51:39 <anzeljg> I have a few
07:51:42 <robertl_> I have none
07:51:52 <robertl_> anzeljg, go for it
07:52:03 <anzeljg> There seems to be a problem with icons for 3rd party plugins in create/edit page navigation on the left.
07:52:11 <anzeljg> The icons use artefact/blocktype name pattern. E.g. I want to update the linkedinprofile plugin, so that means that the system searches for 'icon-linkedinprofile' icon in the CSS, which is not defined. BTW 'icon-linkedin' is defined and I could use that, but what if I wanted 'icon-linkedin-square' instead?
07:52:29 <anzeljg> See: htdocs/blocktype/lib.php, line 299
07:52:32 <anzeljg> ..
07:52:49 <aarowlaptop> anzeljg: Yeah, unfortunately the old system sorta broke with the bootstrap upgrade
07:53:00 <aarowlaptop> you have to provide a style.css file for the block to use a custom icon
07:53:20 <aarowlaptop> I made it work for my clippy block... let me see if I can find the file for that
07:53:31 <anzeljg> is it possible to have a function in the plugin lib.php file which overrides that somehow?
07:53:31 <anitsirk> anzeljg: that should work as well as that is an icon defined in bootstrap as well.
07:53:55 <mingard> anzeljg: that sounds like a good idea
07:54:13 <aarowlaptop> https://github.com/agwells/maharacontrib-blocktype-clippy/blob/master/theme/raw/static/style/style.css#L3
07:54:19 <anzeljg> anitsirk: yes, but the icons defined in bottstrap are linkedin and linkedin-square, but I would need linkedinprofile
07:54:24 <mingard> and it would be good to have an easy way (easier than creating a special CSS file) for doing icons which aren't included in font-awesome
07:54:59 <anitsirk> how do the other blocktypes handle that? or is it just third-party ones?
07:54:59 <aarowlaptop> Yeah, I would love to have it work with the old method.
07:55:06 <anzeljg> probably something like get_custom_icon()
07:55:08 <aarowlaptop> It's just the third-party ones
07:55:26 <aarowlaptop> hm
07:55:36 <mingard> maybe a function that returns an HTML string? so you could return "<span class='my-icon-class'></span>" or "<img src='my/icon/image.png' />"
07:55:52 <aarowlaptop> I think, to work with our Bootstrap stuff, the icon has to be put in there with a CSS style
07:55:59 <anzeljg> aarowlaptop: indeed, but If I use my cloud plugin wich has like 10 blocktypes and with no icons (and hidden labels)...
07:55:59 <aarowlaptop> but we could dynamically generate the style
07:56:36 <aarowlaptop> hidden labels?
07:56:50 <anitsirk> for accessibility?
07:57:06 <anzeljg> one (partial) way to go would be to just override the plugin name with the name of the icon, defined in font-awesome?
07:57:18 <mingard> hidden labels won't be needed, will they?
07:57:24 <anzeljg> if it is a 3rd party plugin
07:57:25 <aarowlaptop> so, the way the new template for the blocktypes is written, it just puts a class on the block picker called "icon-{blocktype}"
07:57:36 <anitsirk> #info Third-party plugins for blocktypes have icon trouble in 15.10. The icons use artefact/blocktype name pattern. E.g. I want to update the linkedinprofile plugin, so that means that the system searches for 'icon-linkedinprofile' icon in the CSS, which is not defined.
07:57:55 <anzeljg> arrowlaptop: icon-{blocktype.name} actually
07:57:56 <aarowlaptop> and then those are all defined in one of the core CSS stylesheets, with each one being mapped to a fontawesome icon
07:58:01 <aarowlaptop> yeah
07:58:21 <anitsirk> aarowlaptop: you could take a look at the "Latest changes you can view" and "My portfolios" blocktypes. they share the same icon iirc
07:58:48 <mingard> seems like it would make sense to have core blocktypes defining their own icon class too, rather than having them all in one stylesheet ...
07:58:59 <anzeljg> anitsirk: but those are icons for core stuff which are probably defined in CSS somewhere...
08:00:02 <aarowlaptop> so here's what I'm getting at
08:00:16 <robertl_> so have somthing like function get_icon() in blocktype/lib.php that the blocks can use?
08:00:19 <aarowlaptop> if you look at lines 3 to 5 in this file: https://github.com/agwells/maharacontrib-blocktype-clippy/blob/master/theme/raw/static/style/style.css#L3
08:00:50 <mingard> it would be good to be able to use font-awesome icons though
08:01:04 <aarowlaptop> you can use that to specify a particular image file as the icon for a blocktype
08:01:26 <aarowlaptop> and it's most conveniently placed in the style.css file of the blocktype
08:01:35 <anitsirk> we pretty much only use fontawesome now
08:01:46 <anitsirk> for icons.
08:01:46 <aarowlaptop> you can use the same technique for fontawesome as well
08:01:58 <aarowlaptop> just put some kinda fontawesome thing in that style instead of a content:url()
08:02:01 <anzeljg> how?
08:02:19 <mingard> i guess look it up in the font-awesome css and copy the character ...
08:02:22 <aarowlaptop> yep
08:02:25 <mingard> still doesn't seem like a good solution
08:02:29 <aarowlaptop> I can't recall the fontawesome syntax
08:02:29 <anzeljg> thnks.
08:02:30 <aarowlaptop> no, it's not
08:02:40 <aarowlaptop> I couldn't really get the front-end devs to understand this
08:02:50 <anzeljg> what about this:
08:02:59 <mingard> robertl_: yeah, a get_icon() function sounds good
08:03:11 <anzeljg> change line 299: 'name'           => $bt->name
08:03:36 <anzeljg> to something like: 'name'           => call_static_method(generate_class_name('blocktype', $namespaced), 'get_icon')
08:03:47 <anzeljg> where get_icon() is optional?
08:03:48 <anzeljg> ..
08:04:35 <aarowlaptop> line 299 of which file?
08:04:57 <mingard> https://github.com/MaharaProject/mahara/blob/master/htdocs/blocktype/lib.php#L299
08:04:57 <anzeljg> htdocs/blocktpye/lib.php (mentioned above)
08:05:16 <anzeljg> thanks mingard
08:05:27 <mingard> and then the default implementation of get_icon could just return the blocktype name
08:05:34 <aarowlaptop> ah, here's the scss file for all the core blocks
08:05:35 <aarowlaptop> https://git.mahara.org/mahara/mahara/blob/master/htdocs/theme/raw/sass/typography/_icons.scss
08:05:52 <mingard> heh, guess I should be using git.mahara.org rather than github ...
08:05:57 <robertl_> I see the artefact/lib.php has a get_icon() - so artefacts have this sort of thing
08:06:01 <aarowlaptop> hm, and it contains variables for fontawesome which are defined in... lib I think?
08:06:12 <aarowlaptop> https://git.mahara.org/mahara/mahara/tree/master/htdocs/theme/raw/sass/lib/font-awesome
08:06:32 <aarowlaptop> reviews.mahara.org mirrors the same to both github and git.mahara.org :)
08:06:48 <mingard> i know, but for the look of the thing ;)
08:07:33 <robertl_> so if we can get php to see variables here -> https://git.mahara.org/mahara/mahara/blob/master/htdocs/theme/raw/sass/lib/font-awesome/_variables.scss
08:07:38 <robertl_> that would be useful
08:07:44 <aarowlaptop> so, here's what the template for the blocktype list looks like https://git.mahara.org/mahara/mahara/blob/master/htdocs/theme/raw/templates/view/blocktypelist.tpl
08:08:40 <mingard> ah so literally icon-{$blocktype.name}
08:08:57 <aarowlaptop> yeah
08:09:02 <anzeljg> yes
08:09:04 <mingard> (would it be possible to get nice highlighting for .tpl files on gitlab?)
08:09:08 <aarowlaptop> now in theory we could add some logic to that template file
08:09:13 <aarowlaptop> might be :)
08:09:39 <aarowlaptop> I guess adding logic to the .tpl file would probably be the easiest thing...
08:09:52 <mingard> could we not just add an extra field when creating the blocktype entry?
08:10:04 <mingard> so it would be class="icon {$blocktype.icon}" or similar
08:10:08 <anzeljg> like $blocktype.icon?
08:10:14 <mingard> yeah
08:10:41 <mingard> since name is used for other stuff too
08:10:43 <anzeljg> actually, probably class="icon icon-{$blocktype.icon}"
08:10:47 <aarowlaptop> well, ideally I'd like a system that supports the old style, where the dev just puts in a "thumb.png" file
08:10:55 <aarowlaptop> as well as supporting new snazzy CSS-based icons
08:10:59 <mingard> ah I see
08:11:21 <aarowlaptop> the front-end devs disagreed, and thought there was no possible way anyone could ever want a block icon that is not part of the all-encompassing fontawesome ;)
08:11:26 <anzeljg> that would break the appearance?
08:11:32 <anzeljg> svg icons along png ones?
08:12:05 <mingard> not necessarily
08:12:06 <robertl_> have some get_icon() type function that checks to see of the thumb.png image exists otherwise see if .icon is set else return .name sounds like a plan
08:12:10 <aarowlaptop> that's sorta up to the graphic designer, I guess, to make sure that the blocktype's icon looks okay
08:12:12 <anzeljg> aarowlaptop: embed.ly one, which is not a part of fonawesome, but the blocktpye exists?
08:12:35 <aarowlaptop> yeah, and my own (joke) clippy block
08:12:43 <anzeljg> :)
08:13:15 <aarowlaptop> so, currently the blocktype "get_icon()" method (or whatever it's called) doesn't do anything
08:13:21 <aarowlaptop> it now gets ignored because of fontawesome
08:13:49 <robertl_> having a function decide which to show as icon would allow users to pick a font-awesome alternative font library as well
08:13:55 <aarowlaptop> but, we could probably add some support for it back in, by putting some logic into blocktypelist.tpl and/or into line 299 of htdocs/blocktype/lib.php
08:14:01 <mingard> yeah
08:14:13 <aarowlaptop> and I would be in favor of that
08:14:18 <anzeljg> +1
08:14:29 <aarowlaptop> okay, I'll see if I can get that in for 15.04.1
08:14:36 <mingard> 15.10?
08:14:39 <aarowlaptop> 15.10.1
08:14:52 <robertl_> #action improve options for selecting icon for blocktypes
08:15:10 <aarowlaptop> for now, the workaround is the blocktype's own style.css file, as per clippy
08:15:56 <anzeljg> ok
08:16:36 <anzeljg> Another AOB:
08:16:38 <anzeljg> The update of Watchlist blocktype. it will be funded. The client wants to ass some sort of functionality to the dashboard to display what has changed since the users' last login (similar to Moodle). I was thinking of creating new blocktype but Kristina suggested to add this functionality to Watchlist block instead. So the users wold be able to configure Watchlist block to display changes, related to user fiends since their last lo
08:16:39 <aarowlaptop> I'll file a launchpad bug
08:16:50 <anzeljg> ass = add
08:17:01 * anzeljg is embarassed
08:17:29 <aarowlaptop> lol, nw
08:17:35 * mingard is giggling far more than he should
08:17:52 <robertl_> improving the watchlist block will be good
08:18:35 <anitsirk> #idea enhance the "Watched pages" block to configure it so as to display changes relating to users' friends since their last login
08:18:36 <aarowlaptop> I guess the easiest thing would be to hook into the watchlist activity
08:18:41 <anzeljg> The client also wants that change as a part of Mahara core if possible?
08:18:56 <anitsirk> since not all watchlist items are currently from a friend's list, we might need to be able to have more than one block on the dashboard.
08:19:47 <aarowlaptop> I'm actually not familiar with the Moodle functionality in question
08:19:56 <aarowlaptop> but this sounds like a good idea :)
08:20:27 <anzeljg> aarowlaptop: when you login it displays that you have that many assessments, forum posts, etc. from your last login
08:20:30 <aarowlaptop> I think there's an event and/or an activity that gets triggered whenever something happens that would sent out a watchlist notificaiton
08:20:50 <aarowlaptop> so, you could add some code there to log those into a table for use in this block
08:20:58 <anzeljg> ok
08:21:05 <mingard> what is the watchlist block? i'm a bit confusedwhat we're talking about
08:21:09 <aarowlaptop> or you might be able to just look at the watchlist notifications directly?
08:21:23 <anzeljg> will have a look
08:21:29 <aarowlaptop> but it probably makes more sense to have separate records
08:21:42 <aarowlaptop> mingard: Well, I'm actually not too familiar with what the watchlist *block* does
08:21:45 <aarowlaptop> currently
08:21:53 <aarowlaptop> I know it lists pages that are on your watchlist
08:22:03 <robertl_> that's about it :)
08:22:12 <aarowlaptop> Whenever you're viewing a page in mahara, there's a link at the bottom that says "add this to my watchlist"
08:22:23 <mingard> ok :) regardless, this sounds like a good feature to have
08:22:25 <aarowlaptop> if you do that, then you get a notification whenever something gets updated on that page
08:22:29 <aarowlaptop> or when someone comments on the page
08:22:52 <aarowlaptop> so yeah, I guess currently the watchlist block just shows you which pages you are watching, but tells you nothing about whether they've been updated recently
08:23:12 <mingard> got it
08:23:13 <robertl_> there was a change to show the modification date
08:23:35 <robertl_> so it lists the most recently changed first and when it changed
08:23:35 <anitsirk> mingard: the button is now next to the title at the top under the "..." button
08:24:26 <ghada> sorry guys but I'm going to have to head out. I'll chat with you next time. Have a good evening!
08:24:31 <ghada> cheers.
08:24:36 <robertl_> cya ghada
08:24:41 <anitsirk> bye ghada
08:24:49 <anzeljg> bye ghada
08:24:58 <anzeljg> thank you all, I'll investigate first and try to build it.
08:25:12 <anzeljg> Last AOB:
08:25:14 <anzeljg> MaharaDroid Slovenian language updated. I sent a pull request, but there was no answer so far...
08:25:26 <anzeljg> https://github.com/MaharaProject/maharadroid/pull/8
08:25:27 <anzeljg> ..
08:25:58 <anitsirk> aarowlaptop: that would be one for you.
08:26:02 <aarowlaptop> me again :)
08:26:11 <anitsirk> anzeljg: there is a new maharadroid in the making...
08:26:14 <aarowlaptop> Sorry, I saw your pull request but I forgot to respond to it.
08:26:21 <anzeljg> np
08:26:31 <anzeljg> anitsirk: didn't know about that
08:26:38 <anitsirk> a prototype already exists and needs to be polished a bit before it can be released. we'll hope to have someone working on that soonish.
08:26:51 <aarowlaptop> Yes, we had a student from Victoria University doing a project to rewrite MaharaDroid in a different format
08:26:55 <anitsirk> a university student created a proof-of-concept in cordova so it could also be multi-platform
08:27:03 <aarowlaptop> oh yeah?
08:27:10 <anzeljg> cordova?
08:27:12 <aarowlaptop> er, whoops, misread that
08:27:21 <aarowlaptop> I thought you said a university student in Cordova ;)
08:27:35 <aarowlaptop> Cordova is another version of the framework known as PhoneGap
08:27:35 <anitsirk> hehe
08:27:48 <mingard> (a way of making cross-platform mobile apps in HTML)
08:27:56 <aarowlaptop> you basically write the app in Javascript, and this makes it cross-platform compatible to iOS and Android
08:28:15 <anitsirk> #info MaharaDroid is being revamped to use Cordova (aka PhoneGap). Stay tuned.
08:28:17 <anzeljg> and Windows Phone AFAIK
08:28:34 <aarowlaptop> but you know, it shouldn't be hard for me to merge in your Slovenian translation into the current version and publish a new build
08:28:55 <aarowlaptop> it's probably worth doing that since it may be a while before the new Cordova version gets published
08:29:00 <anzeljg> could you send me a preview apk file to check trnaslations... i have some doubts
08:29:06 <aarowlaptop> sure
08:29:16 <aarowlaptop> I haven't looked at his code too closely yet myself
08:29:33 <mingard> cordova can also build for blackberry, ubuntu phone, firefox os, webos and fireos ... if anyone is interested in those
08:29:37 <anitsirk> yes, it's a poc at this stage
08:29:44 <aarowlaptop> come to think of it, I would not be too surprised if he didn't write it with translation in mind... I'm not sure I pointed out the need for that to him
08:29:54 <anitsirk> aarowlaptop: he did
08:30:05 <aarowlaptop> oh, good
08:30:10 <mingard> is his code anywhere public?
08:30:10 <anitsirk> even mentioned it in the report
08:30:28 <aarowlaptop> I believe there's a version up on github... I'll see if I can find that
08:30:30 <anitsirk> mingard: we will know tomorrow. it's supposed to be on github, but we don't have the repo url yet
08:30:42 <mingard> cool - I'd be keen to have a look :)
08:30:55 <anitsirk> mingard: sure. want to come along to the meeting at 11?
08:30:55 <anzeljg> +1
08:31:07 <mingard> yep, was about to ask the time so thanks
08:31:11 <anitsirk> we have a catch-up with him and del who's going to take over as a side project
08:31:34 <mingard> oh hang on, this is different to the normal release celebration?
08:31:42 <anitsirk> mingard: that's after that
08:31:56 <anitsirk> so first the party and then the meeting
08:31:57 <mingard> ok :)
08:32:05 <anitsirk> it's all in the timing...
08:32:07 <anitsirk> :-)
08:32:17 <anzeljg> that's it from me
08:32:19 <anitsirk> i have a AOB
08:32:52 <anitsirk> #info currently, the URL for merged patches still points to git.nzoss.org in launchpad
08:33:00 <anitsirk> can we get this changed, aarowlaptop?
08:33:07 <anitsirk> it should point to git.mahara.org
08:33:18 <anitsirk> it's the merge notices from gerrit
08:33:32 <aarowlaptop> sure, can you file me a WR?
08:33:37 <aarowlaptop> I think the hook script is in mahara-scripts
08:33:44 <anitsirk> ok
08:34:15 <aarowlaptop> https://git.mahara.org/scripts/mahara-scripts/blob/master/gerrit/change-merged
08:34:48 <aarowlaptop> huh, I actually updated the script already, 5 months ago!
08:34:57 <aarowlaptop> I guess it didn't get deployed to gerrit
08:35:02 <aarowlaptop> or it got overwritten or something
08:35:22 <aarowlaptop> yeah, should be easy to fix tomorrow
08:35:36 <anitsirk> WR is set up
08:35:40 <anitsirk> that's it.
08:35:55 <robertl_> ok, so any more business?
08:35:58 <mingard> nothing from me
08:36:10 <anzeljg> no
08:36:34 <robertl_> aarowlaptop, anitsirk ?
08:36:39 <anitsirk> nope
08:37:24 <robertl_> ok, time to call it done
08:37:29 <robertl_> #endmeeting