#mahara-dev Meeting

Meeting started by anitsirk at 07:03:18 UTC (full logs).

Meeting summary

    1. anitsirk is Kristina Hoeppner, Catalyst in Wellington, New Zealand (anitsirk, 07:03:27)
    2. yuliya is Yuliya Bozhko from Totara Learning Solutions in Brighton, UK (yuliyabozhko, 07:03:39)
    3. ghada is Ghada El-Zoghbi, Catalyst IT, Sydney, Australia (ghada, 07:03:56)
    4. robertl_ is Robert Lyon, Catalyst in Wellington, New Zealand (robertl_, 07:04:05)

  1. Items from last meeting (anitsirk, 07:05:16)
    1. Everyone attempt to add bugs to the HTML export blueprint (anitsirk, 07:05:16)
    2. aarowlaptop is Aaron Wells in Wellington, New Zealand, Catalyst IT (aarowlaptop, 07:05:41)
    3. Exporting the proper CSS in the HTML export is doable. working out what theme is needed and where the css lives is simple-ish enough. it zipping it up and getting the html header of the exported page to add/display the css lines that is a bit tricky (anitsirk, 07:10:44)
    4. aarowlaptop to collate the Mahara registration stats again (anitsirk, 07:12:33)
    5. https://docs.google.com/spreadsheets/d/1rc8vhsRmm3uz68plJ2qbey77UCk5KIEwWDXeTfIjBbI/edit?usp=sharing (aarowlaptop, 07:13:35)
    6. https://mariadb.com/kb/en/mariadb/mariadb-vs-mysql-compatibility/ if anyone interested (yuliyabozhko, 07:22:54)
    7. 2/3 of registered sites are on MySQL. Probably a good indicator of what the rest is on as well. (anitsirk, 07:25:54)

  2. Do we need to continue support for upgrades from Mahara 1.1? (Kristina) (anitsirk, 07:34:15)
    1. not having to support direct upgrades from Mahara 1.1 would reduce the maintenance burden and potentially allow us to remove some old legacy code in the upgrade script. (anitsirk, 07:41:51)
    2. ACTION: aarowlaptop and anitsirk to update readme file for Mahara 15.10 and 16.04 to say current things. (anitsirk, 07:50:32)
    3. ACTION: aarowlaptop to remove items from the upgrade script (anitsirk, 07:58:14)
    4. AGREED: the minimum version from which Mahara can be upgraded directly is being raised to 1.6 (from formerly 1.1) unless a major issue arises. (anitsirk, 07:59:09)
    5. removing pre-1.6 upgrade code does not only mean for core mahara but also includes plugins that are shipped with Mahara. (anitsirk, 08:00:46)

  3. Mahara release candidate for 15.10 (Kristina) (anitsirk, 08:02:11)
    1. The Mahara 15.10 release candidate 1 was published yesterday. More info can be found at https://mahara.org/interaction/forum/topic.php?id=7392 (anitsirk, 08:02:11)
    2. https://mahara.org/interaction/forum/topic.php?id=7392 is the link to the news post about Mahara 15.10 RC1. (anitsirk, 08:02:12)
    3. We invite everyone to test Mahara and give it a thorough check so we can erradicate any major issues before the 15.10.0 release. (anitsirk, 08:02:12)
    4. http://master.dev.mahara.org can be used if you don't have your own test site, but you'll be limited in what you can try out as you won't have site admin access. (anitsirk, 08:02:12)

  4. New Mahara Partner Programme (anitsirk, 08:06:09)
    1. The new Mahara Partner Programme is live. (anitsirk, 08:06:10)
    2. https://mahara.org/partners has information about it. Now both companies offering Mahara services as well as other organisations can apply to be partners if they actively contribute to the Mahara project. (anitsirk, 08:06:10)

  5. Next meeting and chair (anitsirk, 08:12:07)
    1. The 48th Mahara developer meeting will take place on 27 October 2015 at 7:00 UTC. Robert Lyon is going to chair the meeting. http://www.timeanddate.com/worldclock/fixedtime.html?iso=20151027T07 (anitsirk, 08:19:22)

  6. Any other business (anitsirk, 08:19:32)


Meeting ended at 08:21:16 UTC (full logs).

Action items

  1. aarowlaptop and anitsirk to update readme file for Mahara 15.10 and 16.04 to say current things.
  2. aarowlaptop to remove items from the upgrade script


Action items, by person

  1. aarowlaptop
    1. aarowlaptop and anitsirk to update readme file for Mahara 15.10 and 16.04 to say current things.
    2. aarowlaptop to remove items from the upgrade script
  2. anitsirk
    1. aarowlaptop and anitsirk to update readme file for Mahara 15.10 and 16.04 to say current things.


People present (lines said)

  1. anitsirk (106)
  2. aarowlaptop (72)
  3. ghada (38)
  4. robertl_ (26)
  5. yuliyabozhko (18)
  6. maharameet (2)


Generated by MeetBot 0.1.4.