07:03:18 <anitsirk> #startmeeting
07:03:18 <maharameet> Meeting started Wed Sep 30 07:03:18 2015 UTC.  The chair is anitsirk. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:03:18 <maharameet> Useful Commands: #action #agreed #help #info #idea #link #topic.
07:03:26 <anitsirk> Welcome to the 47th Mahara developer meeting.
07:03:27 <anitsirk> Please introduce yourself using "#info" at the start so that this can be recorded for the minutes.
07:03:27 <anitsirk> #info anitsirk is Kristina Hoeppner, Catalyst in Wellington, New Zealand
07:03:39 <yuliyabozhko> #info yuliya is Yuliya Bozhko from Totara Learning Solutions in Brighton, UK
07:03:56 <ghada> #info ghada is Ghada El-Zoghbi, Catalyst IT, Sydney, Australia
07:04:05 <robertl_> #info robertl_ is Robert Lyon, Catalyst in Wellington, New Zealand
07:04:33 <anitsirk> aarowlaptop?
07:05:14 <anitsirk> well, let's continue. he'll probably come back later.
07:05:16 <anitsirk> #topic Items from last meeting
07:05:16 <anitsirk> #info Everyone attempt to add bugs to the HTML export blueprint
07:05:41 <aarowlaptop> #info aarowlaptop is Aaron Wells in Wellington, New Zealand, Catalyst IT
07:05:49 <anitsirk> I haven't done anything. Been a bit too busy testing patches for 15.10 RC and working on partner programme and a few other things.
07:06:19 <ghada> i haven't done anything either
07:06:49 <robertl_> I took a look to how easy it would be to get the HTML export of pages to use the correct css and it doesn't look too difficult, but then again it's not a few hours type of fix either
07:07:31 <anitsirk> robertl_ does it help with bootstrap now or did it get more complicated?
07:08:12 <robertl_> it was always a bit complicated - it currently uses the css that lives in a special dir under the export/html path
07:08:27 <robertl_> rather than the actual css under the theme
07:09:08 <robertl_> working out what theme is needed and where the css lives is simple-ish enough
07:09:59 <robertl_> it zipping it up and getting the html header of the exported page to add/display the css lines that is a bit tricky
07:10:44 <anitsirk> #info Exporting the proper CSS in the HTML export is doable. working out what theme is needed and where the css lives is simple-ish enough. it zipping it up and getting the html header of the exported page to add/display the css lines that is a bit tricky
07:11:04 <robertl_> but not too bad - it just needs some time/love to get it sorted out :)
07:11:53 <anitsirk> thanks for the info. it doesn't look like anything else is needed to discuss, is there?
07:12:33 <anitsirk> #info aarowlaptop to collate the Mahara registration stats again
07:13:11 <aarowlaptop> I gathered the latest stats this evening
07:13:18 <aarowlaptop> and I've uploaded them into another Google spreadsheet
07:13:35 <aarowlaptop> https://docs.google.com/spreadsheets/d/1rc8vhsRmm3uz68plJ2qbey77UCk5KIEwWDXeTfIjBbI/edit?usp=sharing
07:15:04 <aarowlaptop> Out of about 110 sites who have given us updated data, there are about 20 who are still on PHP 5.3
07:15:06 <yuliyabozhko> =-O PHP 5.3.10
07:15:27 <aarowlaptop> another 30 on PHP 5.4
07:15:27 <anitsirk> wow. already a bunch of 15.10 testing ones
07:16:04 <aarowlaptop> Since all the 15.10dev ones are Ubuntu & Postgres, I'm betting most of those are test sites from the Mahara core team ;)
07:16:31 <aarowlaptop> I stripped out the domain names from the spreadsheet for anonymity purposes. I guess next time I should try to strip out the ones that are obviously dev sites
07:17:04 <aarowlaptop> It's also interesting to note that there are quite a few sites running on CentOS and RedHat
07:17:44 <yuliyabozhko> and one lonely Windows NT :D
07:18:15 <aarowlaptop> and 68% of them are mysql sites
07:18:29 <anitsirk> aarowlaptop: 3 were not from us. :-)
07:18:47 <aarowlaptop> oh, that's good
07:19:03 <yuliyabozhko> is MariaDB officially supported?
07:19:43 <aarowlaptop> MariaDB is supported to the extent that it lives up to its promise to be 100% compatible with MySQL
07:19:56 <robertl_> supported by proxy :)
07:20:18 <aarowlaptop> I think we might mention it in the README now?
07:20:39 <aarowlaptop> nope
07:20:48 <yuliyabozhko> I think early versions are compatible, but later ones are less so
07:21:01 <aarowlaptop> interesting
07:21:31 <yuliyabozhko> like 5.5 should be fine, but I would not vouch for 10.0
07:21:42 <yuliyabozhko> I guess it needs to be tested
07:21:58 <aarowlaptop> there are only a few MariaDB's in there so far
07:22:03 <aarowlaptop> I see about 10 at a glance
07:22:47 <anitsirk> is there anything that we would need to action having those numbers now?
07:22:54 <yuliyabozhko> https://mariadb.com/kb/en/mariadb/mariadb-vs-mysql-compatibility/ if anyone interested
07:23:57 <robertl_> and I see you can have both on a machine which will be good for testing purposes  -> https://mariadb.com/kb/en/mariadb/installing-mariadb-alongside-mysql/
07:24:04 <aarowlaptop> I guess the one takeaway from this is that 2/3 of our users are apparently on MySQL
07:24:38 <aarowlaptop> so we should probably start doing more MySQL testing
07:25:28 <robertl_> indeed ... if only it wasn't sooo slow comapred to postgres
07:25:47 <yuliyabozhko> yeah, was going to say the same robertl_
07:25:51 <ghada> robertl_: i've never noticed
07:25:54 <anitsirk> #info 2/3 of registered sites are on MySQL. Probably a good indicator of what the rest is on as well.
07:26:11 <aarowlaptop> yeah, that's what is blocking us from doing automated mysql testing the same as postgres right now
07:26:20 <aarowlaptop> we need to find a quicker way to "reset" the database between tests
07:26:27 <ghada> i see.
07:27:01 <aarowlaptop> I think with postgres we do a "createdb -T" between tests, which quickly copies one database to another
07:27:17 <robertl_> dropping/installing mahara on mysql is far slower than postgres
07:27:33 <aarowlaptop> but in MySQL we have to do a mysqldump, which exports it to SQL, and then re-import that, and that's a lot slower
07:27:40 <robertl_> yeah that create database with template is soo sweet in postgres
07:27:43 <aarowlaptop> likewise, the installer runs a lot slower in mysql
07:28:19 <aarowlaptop> so I guess if we solved either of those, we'd be good. Either get the installer to run as fast in mysql as it does in postgres, or find a much faster way to duplicate a database
07:28:39 <anitsirk> maybe system admins for mahara should get a crash course in "why you should be using postgres instead of mysql" ;-)
07:28:46 <ghada> ok. but that's to do with testing / developing
07:28:53 <yuliyabozhko> haha, second that!
07:28:55 <ghada> how about actually running Mahara once it's installed?
07:29:18 <aarowlaptop> ghada: What do you mean?
07:29:40 <ghada> the issues we're facing with speed have to do with running tests.
07:29:45 <aarowlaptop> yes
07:30:08 <ghada> I'm wondering if mysql is slower when it comes to running Mahara in production - i.e. no tests
07:30:12 <aarowlaptop> ah, that
07:30:39 <aarowlaptop> I have no idea. But that's also a good point. When we're doing performance testing in Mahara, we should also consider MySQL performance testing.
07:30:48 <aarowlaptop> and load testing
07:30:55 <yuliyabozhko> I just find that it is slower to spin up, but once DB "wakes up" it is kind of ok
07:31:08 <aarowlaptop> that recent issue with the deadlocks in MySQL, for instance
07:31:50 <aarowlaptop> another possibility is to try to get more community engagement from our MySQL users. That's how the deadlock issue got solved.
07:32:38 <ghada> right.
07:33:43 <aarowlaptop> so... I guess that's all I've got on this topic. :)
07:33:58 <aarowlaptop> It's also good to see we've only got the one registered site running it on Windows. ;)
07:34:07 <anitsirk> thanks, aarowlaptop.
07:34:15 <anitsirk> #topic Do we need to continue support for upgrades from Mahara 1.1? (Kristina)
07:34:15 <anitsirk> Recently, a question came up and aarowlaptop mentioned that we still support direct upgrades from Mahara 1.1 on to the current supported versions of Mahara. I'm wondering if that is still necessary seeing that people aren't on those old versions anymore.
07:34:45 <aarowlaptop> Oh, these stats don't actually show anyone registered prior to 1.9.
07:34:52 <ghada> well, we're not collecting that data
07:35:09 <aarowlaptop> but let me check what the earliest version that phones in to mahara.org is...
07:35:59 <robertl_> I feel it is not necessary as one can always download/checkout an older version and do upgrades in steps
07:36:04 <anitsirk> it's 1.4
07:36:28 <ghada> we've still got a client running 1.4
07:36:40 <anitsirk> and that was released over 4 years ago.
07:36:45 <aarowlaptop> the oldest site still phoning in to mahara.org is 1.5
07:36:45 <ghada> i'm trying to get them to upgrade over the summer
07:36:57 <anitsirk> aarowlaptop: i saw a 1.4 one ;-)
07:37:13 <aarowlaptop> oh yeah, there are a cople
07:37:15 <aarowlaptop> couple
07:37:36 <anitsirk> so back to the question...
07:37:38 <aarowlaptop> that's probably the version that we added the stats collection code to
07:37:38 <robertl_> so we could advertise anything below say 1.8 upgrade to that point first then to 1.10 then to 15.10 say
07:37:59 <anitsirk> aarowlaptop: i think that already existed before then.
07:38:03 <aarowlaptop> or we could just raise the cutoff to 1.4
07:38:24 <anitsirk> the user manual does not list it as a new feature for 1.4
07:38:25 <ghada> so, what's the issue we're trying to solve by eliminating 1.1?
07:39:01 <ghada> that is, upgrades from 1.1?
07:39:03 <anitsirk> testing that full upgrade path before each release is one i can think of.
07:39:21 <ghada> yes, that's a good one
07:39:24 <aarowlaptop> just reducing the maintenance burden, basically
07:39:28 <robertl_> not have to keep all the code in lib/db/upgrade.php
07:39:50 <aarowlaptop> potentially there might be some old legacy code we could get rid of, like functions that only get called in lib/db/upgrade.php
07:40:11 <ghada> so, are we going to try and make the jump version 1.4?
07:40:18 <ghada> or later?
07:40:43 <anitsirk> what version would be a logical step?
07:40:52 <ghada> i'm thinking 1.6
07:40:54 <anitsirk> one that had a lot of things added like 1.6 or 1.8?
07:41:19 <ghada> 1.8 is also a logical one
07:41:51 <anitsirk> #info not having to support direct upgrades from Mahara 1.1 would reduce the maintenance burden and potentially allow us to remove some old legacy code in the upgrade script.
07:41:51 <ghada> anyone?
07:41:58 <aarowlaptop> hm
07:42:07 <aarowlaptop> I'm not really sure what criteria to go by
07:42:22 <robertl_> i'd say 1.6 and then we could make it drop a version each new release maybe
07:42:34 <aarowlaptop> I guess one thing we could do, is say X versions before the current one
07:42:43 <aarowlaptop> yeah, 1.6 was the first six-monthly release, right?
07:42:59 <ghada> well, to jump to 1.8, users had to redo a lot of their themes.
07:43:10 <anitsirk> i'd go with aarowlaptop's suggestion because dropping one version per release may be a bit too quick looking at our support cycle
07:43:16 <ghada> a lot of people would naturally jump to 1.8 before proceeding onto the others
07:43:43 <anitsirk> ghada: good point. 1.6 was a huge release featurewise, but not necessarily themewise.
07:43:51 <anitsirk> 1.8 brought in the new icons
07:44:55 <ghada> this is  for release 16.04, right?
07:44:57 <anitsirk> and 1.8 is still fairly recent which is a good jump point
07:45:27 <robertl_> well it could be for the 15.10.0 release if people are happy
07:45:36 <anitsirk> why not already 15.10? i don't think we say anywhere officially that we support upgrades directly from 1.1, do we, aarowlaptop? you know that stuff better
07:46:07 <aarowlaptop> it says it in the README file
07:46:24 <aarowlaptop> but I don't think it would be too big a deal to change that prior to the .0 release
07:46:32 <anitsirk> and it just concerns the direct upgrades. from what i've seen in the forums, people have problems upgrading directly also from later versions and thus go version to version.
07:47:13 <aarowlaptop> yeah, there was a bug reported in the forums recently, that occurred if you did a direct upgrade but could be avoided if you did a step-by-step upgrade
07:47:28 <robertl_> yeah that will always be an option
07:47:39 <robertl_> and can be added to the README
07:48:18 <aarowlaptop> yeah, the README already tells you to do a multi-step upgrade if you're on a version prior to 1.1.0 ;)
07:48:38 <anitsirk> by the way: the readme file for master should probably get a "draft" status as it's not finalized esp. in regards to browsers. IE 9 is still mentioned. i thought we even took that out for 15.10?
07:49:27 <aarowlaptop> oh did we?
07:49:28 <anitsirk> and firefox is also on a very old version mentioned in there...
07:49:30 <aarowlaptop> that should be updated then
07:49:47 <aarowlaptop> okay, so let's have a look at & clean up the README file tomorrow
07:49:50 <anitsirk> yeah. we need to give that readme a once over for 15.10 and also 16.04
07:49:58 <anitsirk> sounds good, aarowlaptop
07:50:32 <anitsirk> #action aarowlaptop and anitsirk to update readme file for Mahara 15.10 and 16.04 to say current things.
07:51:10 <anitsirk> do we need a vote on whether to drop direct upgrade support for 1.1 or is everyone agreed?
07:51:16 <ghada> as for the jump starting point, it's a toss up for me between 1.6 and 1.8
07:52:08 <aarowlaptop> I'm for 1.6, I think
07:52:10 <anitsirk> shall we table the jump start until the next meeting so someone can take a look and see which one would be preferable?
07:52:23 <ghada> i agree that we should remove support for upgrades from 1.1.
07:52:30 <ghada> yes anitsirk. That's a good idea
07:52:32 <aarowlaptop> I'd be okay with just calling it at 1.6 now
07:52:55 <anitsirk> robertl_ and yuliyabozhko?
07:53:25 <robertl_> I'm happy with 1.6 as it'll scare the wider community less I feel
07:53:25 <yuliyabozhko> 1.6 for now sounds good
07:53:40 <yuliyabozhko> but would be good to have a look at it a bit more for the next meeting
07:54:33 <anitsirk> or maybe rather since the next dev meeting would be after the 15.10.0 release that a decision is made within a week from today?
07:55:20 <aarowlaptop> we could always cut it at 1.6 now, and if we want to bump it to 1.8 we could do that later
07:55:24 <anitsirk> Because maybe who knows a version before the big changes came in would be a better choice upgradewise?
07:55:28 <yuliyabozhko> true. then 1.6 might be better as Robert said not to scare users too much :)
07:55:53 <ghada> I'm ok with 1.6.
07:56:21 <aarowlaptop> If this somehow turned out to be a mistake, it would be easy to add/remove stuff from lib/db/upgrade.php to move the min upgrade back or forth
07:56:34 <anitsirk> ok. so 4 out of 4 are for bumping it to 1.6. let's go with that unless something else transpires before the .0 release
07:56:43 <aarowlaptop> sounds like a plan!
07:56:49 <anitsirk> who's going to look into removing items from the upgrade script?
07:57:20 <aarowlaptop> I'd like to, but I'm pretty busy...
07:57:39 <aarowlaptop> shouldn't be hard to do, though
07:57:43 <aarowlaptop> I guess I can do it
07:57:52 <anitsirk> thanks, aarowlaptop.
07:58:04 <robertl_> will it include removing stuff from plugin upgrades?
07:58:14 <anitsirk> #action aarowlaptop to remove items from the upgrade script
07:58:18 <robertl_> if they are pre 1.6 updates
07:59:09 <anitsirk> #agreed the minimum version from which Mahara can be upgraded directly is being raised to 1.6 (from formerly 1.1) unless a major issue arises.
07:59:28 <aarowlaptop> robertl_: Yeah
07:59:51 <aarowlaptop> I'll want to remove the pre-1.6 upgrade code for lib/db/upgrade.php, and from the upgrade.php for all plugins
08:00:46 <anitsirk> #info removing pre-1.6 upgrade code does not only mean for core mahara but also includes plugins that are shipped with Mahara.
08:01:10 <anitsirk> is that all on this topic?
08:01:48 <aarowlaptop> I've got nothing else :)
08:02:00 <ghada> me too
08:02:09 <anitsirk> alright. then let's move on to the more exciting things.
08:02:11 <anitsirk> #topic Mahara release candidate for 15.10 (Kristina)
08:02:11 <anitsirk> #info The Mahara 15.10 release candidate 1 was published yesterday. More info can be found at https://mahara.org/interaction/forum/topic.php?id=7392
08:02:12 <anitsirk> https://mahara.org/interaction/forum/topic.php?id=7392 is the link to the news post about Mahara 15.10 RC1.
08:02:12 <anitsirk> #info We invite everyone to test Mahara and give it a thorough check so we can erradicate any major issues before the 15.10.0 release.
08:02:12 <anitsirk> http://master.dev.mahara.org can be used if you don't have your own test site, but you'll be limited in what you can try out as you won't have site admin access.
08:03:58 <anitsirk> hopefully, we'll get plenty of people testing over the next week or tw
08:03:59 <anitsirk> o
08:04:22 <anitsirk> it's exciting to see how 15.10 has shaped up over the last half year
08:04:38 <anitsirk> and actually even longer since the front-end devs started already during last summer!
08:05:07 <anitsirk> it's been a major piece of work. on launchpad, there is pretty much only 1 bug number for a massive amount of work.
08:06:00 <anitsirk> since i seem to be the only one talking, i guess we can move on to the next topic that i wanted to mention.
08:06:09 <anitsirk> #topic New Mahara Partner Programme
08:06:10 <anitsirk> #info The new Mahara Partner Programme is live.
08:06:10 <anitsirk> https://mahara.org/partners has information about it. Now both companies offering Mahara services as well as other organisations can apply to be partners if they actively contribute to the Mahara project.
08:07:02 <anitsirk> Except for yuliyabozhko, everybody else in the meeting is with catalyst and thus already in the partner programme.
08:07:13 <ghada> :)
08:07:15 <aarowlaptop> :)
08:07:16 <anitsirk> so maybe not much discussion needed here either.
08:07:27 <yuliyabozhko> yeah :)
08:07:32 <ghada> have you had any queries about it?
08:07:39 <anitsirk> ghada: oh yes. :-)
08:07:50 <ghada> that's fantastic!
08:08:04 <ghada> how many people / companies have showed interest?
08:08:12 <anitsirk> yep. now only need to find out how the companies are planning on contributing.
08:08:22 <anitsirk> so quite a bit of emailing and phone calls.
08:08:43 <ghada> that's great
08:08:50 <anitsirk> as well as with existing partners and inviting people to be new partners and supporters of whom we already know that they are active and would be great to have in the programme
08:09:14 <aarowlaptop> cool
08:09:19 <anitsirk> i look forward to the contributions and having partners more involved
08:09:53 <anitsirk> also need to work out a way of tracking all the information. spreasheets here i come...
08:09:55 <anitsirk> ;-)
08:09:59 <robertl_> FYI: the 'Mahara Business Partners' link under Partner programme tracks is pointing to wrong place
08:10:08 <anitsirk> oops.
08:10:21 <robertl_> it's pointing to edit page
08:10:32 <anitsirk> you mean the pdf download?
08:10:38 <anitsirk> yeah. that's not looking good. :-(
08:10:42 <anitsirk> will change it right now
08:11:10 <anitsirk> nobody said anything so far. :-(
08:11:32 <anitsirk> done.
08:12:01 <anitsirk> thanks, robertl_
08:12:07 <anitsirk> alright. onto the next topic:
08:12:07 <anitsirk> #topic Next meeting and chair
08:12:14 <anitsirk> Who wants to chair?
08:12:19 <anitsirk> and when?
08:12:34 <anitsirk> We could to 28 October 2015 at the same time
08:12:48 <anitsirk> that would be http://www.timeanddate.com/worldclock/fixedtime.html?iso=20151028T07
08:13:20 <anitsirk> would that work for you, aarowlaptop, ghada, robertl_ and yuliyabozhko?
08:13:34 <yuliyabozhko> I should be just back to NZ by then
08:13:40 <aarowlaptop> I'm taking another Improv class that meets up on Wednesday nights
08:13:40 <yuliyabozhko> works for me
08:13:47 <ghada> yes, even one hour earlier works too
08:14:04 <aarowlaptop> so my Wednesday evenings 7-9pm are booked
08:14:13 <anitsirk> ghada: you preferred wednesday. is that still the case or would thursday work as well or rathe tuesday or does that not work for you aarowlaptop?
08:14:20 <yuliyabozhko> I can do any day
08:14:37 <ghada> I've got a meetup on Thursdays
08:14:48 <anitsirk> ok. so what about tuesdays?
08:14:48 <ghada> Tuesday would work
08:14:56 <aarowlaptop> Tuesday works for me
08:15:00 <anitsirk> robertl_?
08:15:45 <robertl_> any day other than monday should be fine
08:15:54 <anitsirk> ok. le'ts make it tuesday then.
08:16:06 <anitsirk> having established that everyone would be able to attend, who wants to chair? :-D
08:18:11 <anitsirk> anybody?
08:18:35 <robertl_> ok, I can chair the next one
08:18:45 <anitsirk> thank you, robertl_.
08:18:55 <ghada> thanks robertl_
08:19:01 <aarowlaptop> cheers robertl_
08:19:22 <anitsirk> #info The 48th Mahara developer meeting will take place on 27 October 2015 at 7:00 UTC. Robert Lyon is going to chair the meeting. http://www.timeanddate.com/worldclock/fixedtime.html?iso=20151027T07
08:19:32 <anitsirk> #topic Any other business
08:19:32 <anitsirk> Gregor had a number of items that he wanted to discuss, but unfortunately, he is not able to attend. Since there were still a lot of open questions, I asked him to write forum posts for the suggestions so they can be discussed.
08:19:39 <anitsirk> Does anybody else have any other business?
08:20:04 <ghada> no, i don't have anything.
08:20:39 <aarowlaptop> nope
08:20:49 <anitsirk> and the silence of everybody else probably means the same.
08:21:13 <anitsirk> so let's wrap this meeting up. thanks everyone for attending and have a great time testing Mahara 15.10.
08:21:16 <anitsirk> #endmeeting