#mahara-dev Meeting

Meeting started by anitsirk at 08:03:16 UTC (full logs).

Meeting summary

    1. Welcome to the 42nd Mahara developer meeting. Please introduce yourself using #info at the start of the line so that we know who's attending today / tonight. (anitsirk, 08:03:19)
    2. anitsirk is Kristina Hoeppner, Catalyst IT in Wellington, NZ (anitsirk, 08:03:20)
    3. yuliya is Yuliya Bozhko from Totara Learning Solutions, Wellington, NZ (yuliyabozhko1, 08:03:29)
    4. tobiasz_ is Tobias Zeuch, developer at fluidOps, Walldorf, Germany (tobiasz_, 08:03:37)
    5. anzeljg is Gregor Anželj, developer and translator, Ljubljana, Slovenia (anzeljg, 08:03:39)
    6. robertl_ is Robert Lyon, Catalyst IT in Wellington, NZ (robertl_, 08:04:01)
    7. aarowlaptop is Aaron G. Wells of Catalyst IT in Wellington, New Zealand (aarowlaptop, 08:04:24)

  1. Items from last meeting (anitsirk, 08:05:13)
    1. Everyone have a look at annotations and smartevidence patches from nigel and ghada as high priority ones for 1504 (anitsirk, 08:05:13)
    2. sonn is Son Nguyen, Catalyst IT, Wellington, NZ (sonn, 08:07:01)
    3. robertl_ share a speadsheet of issues to review with everyone (anitsirk, 08:07:36)
    4. yuliyabozhko1 add some info on RTL support to wiki (anitsirk, 08:09:22)
    5. https://wiki.mahara.org/index.php/Developer_Area/Specifications_in_Development/Better_RTL_Support (yuliyabozhko1, 08:09:31)
    6. https://wiki.mahara.org/index.php/Developer_Area/Language_strings (aarowlaptop, 08:12:12)
    7. the tips on the RTL support page on the wiki are some tips / guidelines for coding and reviewing code. (anitsirk, 08:19:13)
    8. sonn and yuliya figure out how to create a dialect language code and set up translations for it (anitsirk, 08:21:56)
    9. custom language codes can't be set up in Launchpad. (anitsirk, 08:23:19)
    10. ACTION: yuliyabozhko1 will try to contact Launchpad and check if there is a way to get a custom language code set up. (anitsirk, 08:25:53)
    11. robertl_ create a Wiki page about HTML export improvements and set up a blueprint in launchpad (anitsirk, 08:26:23)
    12. https://wiki.mahara.org/index.php/Developer_Area/Import//Export/HTML_Export#Adjustments (anitsirk, 08:26:23)
    13. https://blueprints.launchpad.net/mahara/+spec/improve-html-export (anitsirk, 08:26:23)
    14. ACTION: robertl_ to create bugs / wishlist items for improving the HTML export. (anitsirk, 08:33:21)

  2. GitLab acquired Gitorious: What does this mean for us? (Kristina) (anitsirk, 08:33:50)
    1. GitLab acquired Gitorious and Gitorious will cease to exist in its current form at the end of May. (anitsirk, 08:33:51)
    2. https://about.gitlab.com/2015/03/03/gitlab-acquires-gitorious/ (anitsirk, 08:33:51)
    3. To my knowledge, Gitorious had been chosen because it is entirely open source (in contrast to Github for example). (anitsirk, 08:33:51)
    4. IDEA: If we want to stay independent an continue with our work flow, one possibility would be to simply host the repositories on a server. Most of our work flow is done through Gerrit these days (except the user manual and translations) (anitsirk, 08:33:51)
    5. IDEA: Alternatively, we could install GitLab on a server and maybe even move to using that for code review instead of Gerrit (eventually). (anitsirk, 08:33:51)
    6. IDEA: four options: migrate our "official" repo to GitLab, to Github, to some other third-party git service, or to a Catalyst server (anitsirk, 08:38:35)
    7. IDEA: have clones on non-Catalyst servers for the sake of maintaining Mahara's OS-ness (anitsirk, 08:41:51)
    8. https://gitlab.com/groups/mahara (aarowlaptop, 08:42:05)
    9. https://github.com/maharaproject/ (aarowlaptop, 08:43:06)
    10. IDEA: Just use github as the new official location for the active repositories, because it's available, easy to use, and popular (aarowlaptop, 08:46:51)
    11. IDEA: Keep copies of the inactive repositories in gitlab, and sync the active ones to gitlab as well, to hedge our bets (aarowlaptop, 08:47:20)
    12. IDEA: And if someone finds a really-really-really open git option, we can always switch to that (aarowlaptop, 08:47:44)
    13. all repositories could be stored in gerrit. One of its functionalities is just to act like a git repository (anitsirk, 08:48:48)
    14. This would have the added benefit of being able to use gerrit to code review changes in those other repositories (anitsirk, 08:49:02)
    15. For gerrit repo's other than the core "mahara", we could set up different permissions to give people direct "push" access, for when code review isn't really appropriate. (aarowlaptop, 08:49:50)
    16. ACTION: Everyone: Review the possible options for the official mahara code repository that aarowlaptop mentioned and weight advantages and disadvantages. (anitsirk, 08:52:07)

  3. Mahara 15.04 release (Kristina) (anitsirk, 08:52:34)
    1. The Mahara 15.04 release candidate 1 has been available for testing for almost a week. (anitsirk, 08:52:34)
    2. If you don't have a test server available, you can use http://master.dev.mahara.org and report issues on the bug tracker. (anitsirk, 08:52:34)
    3. https://bugs.launchpad.net/mahara/+filebug (anitsirk, 08:52:34)
    4. we are still planning on releasing mid April. As usual, it'll depend on testing and any major issues... (anitsirk, 08:58:08)

  4. Next meeting and chair (anitsirk, 08:58:46)
    1. robertl_ is going to chair the 43rd Mahra developer meeting on 23 April 2015 at 8:00 UTC. (anitsirk, 09:04:04)
    2. http://www.timeanddate.com/worldclock/fixedtime.html?msg=43rd+Mahara+developer+meeting&iso=20150423T08&p1=1440 (anitsirk, 09:04:14)

  5. Any other business (anitsirk, 09:04:22)
    1. If you want to get an article into the next newsletter, please send it to newsletter@mahara.org latest on Monday, 30 March 2015. (anitsirk, 09:05:35)


Meeting ended at 09:06:01 UTC (full logs).

Action items

  1. yuliyabozhko1 will try to contact Launchpad and check if there is a way to get a custom language code set up.
  2. robertl_ to create bugs / wishlist items for improving the HTML export.
  3. Everyone: Review the possible options for the official mahara code repository that aarowlaptop mentioned and weight advantages and disadvantages.


Action items, by person

  1. aarowlaptop
    1. Everyone: Review the possible options for the official mahara code repository that aarowlaptop mentioned and weight advantages and disadvantages.
  2. robertl_
    1. robertl_ to create bugs / wishlist items for improving the HTML export.
  3. yuliyabozhko1
    1. yuliyabozhko1 will try to contact Launchpad and check if there is a way to get a custom language code set up.


People present (lines said)

  1. anitsirk (97)
  2. yuliyabozhko1 (41)
  3. aarowlaptop (41)
  4. robertl_ (34)
  5. tobiasz_ (9)
  6. anzeljg (4)
  7. sonn (2)
  8. maharameet (2)


Generated by MeetBot 0.1.4.