08:03:16 <anitsirk> #startmeeting
08:03:16 <maharameet> Meeting started Thu Mar 26 08:03:16 2015 UTC.  The chair is anitsirk. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:03:16 <maharameet> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:03:19 <anitsirk> #info Welcome to the 42nd Mahara developer meeting. Please introduce yourself using #info at the start of the line so that we know who's attending today / tonight.
08:03:20 <anitsirk> #info anitsirk is Kristina Hoeppner, Catalyst IT in Wellington, NZ
08:03:29 <yuliyabozhko1> #info yuliya is Yuliya Bozhko from Totara Learning Solutions, Wellington, NZ
08:03:37 <tobiasz_> #info tobiasz_ is Tobias Zeuch, developer at fluidOps, Walldorf, Germany
08:03:39 <anzeljg> #info anzeljg is Gregor Anželj, developer and translator, Ljubljana, Slovenia
08:04:01 <robertl_> #info robertl_ is Robert Lyon, Catalyst IT in Wellington, NZ
08:04:08 <anitsirk> tobiasz_: congrats on the new job. hope you've had a good time so far.
08:04:24 <aarowlaptop> #info aarowlaptop is Aaron G. Wells of Catalyst IT in Wellington, New Zealand
08:04:25 <tobiasz_> thanks, I did :)
08:04:30 <anitsirk> :-)
08:04:45 <anitsirk> anzeljg: are you still here?
08:05:11 <anitsirk> Ok. Let's move on.
08:05:13 <anitsirk> #topic  Items from last meeting
08:05:13 <anitsirk> #info Everyone have a look at annotations and smartevidence patches from nigel and ghada as high priority ones for 1504
08:05:13 <anitsirk> That was done. We merged the annotations feature, but pushed back the infrastructural work for adding page / collection categories as that needed some more work.
08:05:41 <sonn> Hi
08:05:41 <anitsirk> hi sonn. please introduce yourself.
08:05:42 <anzeljg> hi sonn
08:06:09 <robertl_> yep - and I think there was a few small things for annotations that we made new bug reports for
08:06:24 <anitsirk> yep. those are supposed to be fixed during the rc
08:06:53 <anitsirk> anything else on this?
08:07:01 <sonn> #info sonn is Son Nguyen, Catalyst IT, Wellington, NZ
08:07:35 <anitsirk> robertl_: you are up next then.
08:07:36 <anitsirk> #info robertl_ share a speadsheet of issues to review with everyone
08:08:14 <robertl_> that I guess was the google spreadsheet we used during release
08:08:19 <anitsirk> yep
08:08:34 <anitsirk> so that was done as well. :-)
08:08:43 <robertl_> Well that is all pretty much finished up - just a few rc stuff on it
08:08:55 <yuliyabozhko1> cool
08:09:00 <robertl_> which should get done before major release
08:09:22 <anitsirk> #info yuliyabozhko1 add some info on RTL support to wiki
08:09:31 <yuliyabozhko1> https://wiki.mahara.org/index.php/Developer_Area/Specifications_in_Development/Better_RTL_Support
08:09:41 <yuliyabozhko1> feel free to correct/add anything
08:10:05 <yuliyabozhko1> these are the tips we are using in our team at Totara
08:10:24 <aarowlaptop> cool
08:10:58 <yuliyabozhko1> I was not sure how Mahara handles RTL in Javascript
08:11:04 <yuliyabozhko1> so let a TODO there
08:11:08 <aarowlaptop> hm, we could probably merge some of that in to the existing page about lang strings
08:11:09 <yuliyabozhko1> if anyone wants to expand
08:11:23 <anitsirk> can wait for an offline answer if the following is obvious to everybody else: we already have a language pack. what's the difference between the good and the bad string besides the way actual strings are called in files?
08:12:02 <yuliyabozhko1> good and bad is not about strings, but the way of doing things :)
08:12:12 <aarowlaptop> https://wiki.mahara.org/index.php/Developer_Area/Language_strings
08:12:22 <robertl_> the proper way to code for strings by the looks of it
08:12:38 <robertl_> code for lang strings that is
08:13:16 <robertl_> I suspect there isn't any hard rules for RTL in the mahara javascript code
08:13:21 <anitsirk> that'll be a massive change i guess with the over 5725 strings we have. is it?
08:14:03 <yuliyabozhko1> anitsirk: I am not sure what you mean...
08:14:21 <anitsirk> let's leave it for after the meeting. i might be mixing things up.
08:14:34 <yuliyabozhko1> we don't need to change anything in exsiting code. these are just the guidelines
08:14:35 <robertl_> but I guess a way to handle the issues with js is for js to handle the adding/removing of css classes rather than direct text
08:14:36 <yuliyabozhko1> :)
08:15:18 <yuliyabozhko1> Moodle does smth like : if (Y.one('body').hasClass('dir-rtl')) {
08:16:24 <yuliyabozhko1> as I understand we add dir=rtl in <html> tag, so that can be used too
08:16:52 <tobiasz_> is the "dir-rtl" class used in mahara already?
08:16:58 <robertl_> so yep - it's something to think about when getting the js to manipulate the DOM
08:17:00 <yuliyabozhko1> yep
08:18:01 <anitsirk> What is the next step?
08:18:15 <yuliyabozhko1> anyway, these are just some tips to keep in mind during review and coding
08:18:57 <robertl_> a possible step is to find out weak points in mahara for rtl stuff
08:19:13 <anitsirk> #info the tips on the RTL support page on the wiki are some tips / guidelines for coding and reviewing code.
08:19:37 <anitsirk> robertl_ i think we already have at least one bug for that.
08:19:44 <robertl_> ok
08:20:10 <anitsirk> e.g. https://bugs.launchpad.net/mahara/+bug/1049400
08:20:30 <anitsirk> shall we move on?
08:20:41 <yuliyabozhko1> yep, that's all from me
08:20:44 <tobiasz_> are there guidelines about where to apply the different float-style?
08:21:03 <yuliyabozhko1> a bit here https://wiki.mahara.org/index.php/Developer_Area/Specifications_in_Development/Better_RTL_Support#Right-to-left_language_support
08:21:21 <yuliyabozhko1> but would be good to list css styles that need mirroing
08:21:24 <tobiasz_> ok, thanks
08:21:56 <anitsirk> #info sonn and yuliya figure out how to create a dialect language code and set up translations for it
08:21:56 <yuliyabozhko1> I will see if I can expand a bit on that
08:22:05 <anitsirk> sorry yuliyabozhko1
08:22:36 <yuliyabozhko1> hmm, I tried to have a look at the end of last month. and it appears that custom language code are not as functional as I thought
08:22:45 <yuliyabozhko1> they are basically for replacing existing ones
08:23:14 <yuliyabozhko1> so, I am not sure we can do anything here with Launchpad
08:23:19 <anitsirk> #info custom language codes can't be set up in Launchpad.
08:24:07 <anitsirk> did you try to contact anyone at Launchpad to see if they could create one?
08:24:29 <anitsirk> or would they have to be really only the official lang codes that exist through ISO (I think it was that)?
08:24:33 <yuliyabozhko1> nope, I didn't even think about that :) maybe Sonn did something in this direction?
08:24:41 <anitsirk> don't think so.
08:24:54 <anitsirk> in an earlier conversation they had only said that it's not possible yet.
08:24:56 <yuliyabozhko1> could you put it on the next agenda?
08:25:02 <yuliyabozhko1> ah, ok
08:25:13 <anitsirk> sure. following up with them would be good. maybe something has changed since then?
08:25:19 <anitsirk> it was only a very short comment.
08:25:34 <yuliyabozhko1> cool. i can do that for the next meeting
08:25:53 <anitsirk> #action yuliyabozhko1 will try to contact Launchpad and check if there is a way to get a custom language code set up.
08:25:57 <anitsirk> thank you, yuliyabozhko1.
08:26:03 <yuliyabozhko1> np :)
08:26:21 <anitsirk> since sonn is not here, i think there is nothing else on this for the moment.
08:26:23 <anitsirk> #info robertl_ create a Wiki page about HTML export improvements and set up a blueprint in launchpad
08:26:23 <anitsirk> https://wiki.mahara.org/index.php/Developer_Area/Import//Export/HTML_Export#Adjustments
08:26:23 <anitsirk> https://blueprints.launchpad.net/mahara/+spec/improve-html-export
08:27:01 <robertl_> so yeah - I didn't really get much further with this - other than to make a blueprint page and some basic notes
08:27:31 <robertl_> I'll try and get some launchpad bugs filed once I look into it more
08:27:41 <anitsirk> great. thanks.
08:28:14 <robertl_> but I'm feeling the most useful thing will be to try and see if the page's actual theme
08:28:18 <robertl_> can be exported
08:28:28 <robertl_> rather than it just reverting to the raw theme
08:28:35 <anitsirk> yes. that would be great. and i guess also the skin.
08:28:41 <robertl_> and also if skins as well
08:28:44 <robertl_> yep
08:29:02 <robertl_> so the html export 'looks' like it did on the site
08:29:07 <aarowlaptop> yes
08:29:23 <aarowlaptop> which in theory doesn't seem like it should be too hard
08:30:16 <robertl_> exactly - if it can zip up the assets of the raw theme
08:30:35 <robertl_> it should be able to zip up the assets of other themes as well
08:32:34 <robertl_> that's all I've got on this topic for now
08:32:39 <anitsirk> robertl_ do you want an action item for creating the bugs?
08:32:58 <robertl_> yes please - it's more likely to happen that way :)
08:33:21 <anitsirk> #action robertl_ to create bugs / wishlist items for improving the HTML export.
08:33:50 <anitsirk> #topic GitLab acquired Gitorious: What does this mean for us? (Kristina)
08:33:51 <anitsirk> #info GitLab acquired Gitorious and Gitorious will cease to exist in its current form at the end of May.
08:33:51 <anitsirk> https://about.gitlab.com/2015/03/03/gitlab-acquires-gitorious/
08:33:51 <anitsirk> This means that we need to discuss where to keep our main repository.
08:33:51 <anitsirk> #info To my knowledge, Gitorious had been chosen because it is entirely open source (in contrast to Github for example).
08:33:51 <anitsirk> #idea If we want to stay independent an continue with our work flow, one possibility would be to simply host the repositories on a server. Most of our work flow is done through Gerrit these days (except the user manual and translations)
08:33:51 <anitsirk> #idea Alternatively, we could install GitLab on a server and maybe even move to using that for code review instead of Gerrit (eventually).
08:33:51 <anitsirk> Or...?
08:36:06 <yuliyabozhko1> well, that probably depends on Catalyst resources?
08:36:37 <robertl_> so I'm guessing whatever is used there will need to be some simple to use public interface for it
08:37:14 <aarowlaptop> The way I see it, we have basically three options
08:37:46 <aarowlaptop> We could migrate our "official" repo to GitLab, to Github, to some other third-party git service, or to a Catalyst server
08:37:52 <aarowlaptop> four options ;)
08:38:20 <robertl_> heh
08:38:26 <aarowlaptop> For the Mahara code itself, gerrit is essentially the "official" repo, and we can just use the plugin to mirror it to other locations for convenience
08:38:35 <anitsirk> #idea four options: migrate our "official" repo to GitLab, to Github, to some other third-party git service, or to a Catalyst server
08:39:12 <aarowlaptop> I think it would be good to have an "official" clone of everything on a non-Catalyst server, for the sake of maintaining Mahara's OS-ness
08:40:12 <robertl_> as well as availability - as having mirrors in more than one country can be useful
08:40:14 <anitsirk> +1
08:40:16 <aarowlaptop> That said, we could set up syncing for mahara-scripts and the manual, as we do for Mahara itself
08:40:43 <aarowlaptop> Probably one thing we should do is look through all the repo's in gitorious and determine how many we're still actively using
08:41:00 <yuliyabozhko1> I am not too sure how it all works right now, so have nothing to offer, sorry :)
08:41:08 <aarowlaptop> sure
08:41:17 <anitsirk> we should keep everything though somewhere since gitorious will be gone. a backup is always good.
08:41:27 <aarowlaptop> I mean, one nice thing about git itself, is that *any* copy of the repository is a full copy as good as any other.
08:41:36 <aarowlaptop> Yes
08:41:50 <aarowlaptop> I have actually already used the "migrate to gitlab" button in gitorious to copy all the gitorious repositories to gitlab
08:41:51 <anitsirk> #idea have clones on non-Catalyst servers for the sake of maintaining Mahara's OS-ness
08:42:05 <aarowlaptop> https://gitlab.com/groups/mahara
08:42:44 <aarowlaptop> I have lately started using the Mahara github account more, for some Mahara side projects
08:43:04 <aarowlaptop> well, for the Moodle plugins
08:43:06 <aarowlaptop> https://github.com/maharaproject/
08:43:51 <yuliyabozhko1> yep, I use that one too
08:44:52 <anitsirk> would be good to have those plugins also in the "official" place
08:45:32 <aarowlaptop> I suggest we make Github the "official" location for the active repositories, since it's the easiest to use out of these options, and it's quite popular amongst open source projects
08:45:34 <anitsirk> aarowlaptop: does the gitorious login just work for gitlab with all the same permissions?
08:45:36 <tobiasz_> are there a lot of changes from gitorious to gitlab? It's also free and offers the basic functionality, right?
08:45:42 <aarowlaptop> anitsirk: I can't recall
08:46:00 <aarowlaptop> tobiasz_: GitLab has a commercial offering, and a community offering
08:46:10 <aarowlaptop> the community one is open source but lacks some features of the commercial one
08:46:22 <aarowlaptop> I think what I've migrated Mahara to is the community version
08:46:51 <aarowlaptop> #idea Just use github as the new official location for the active repositories, because it's available, easy to use, and popular
08:47:16 <anitsirk> aarowlaptop: you said that gerrit actually has the codebase. so why not use that as official location?
08:47:20 <aarowlaptop> #idea Keep copies of the inactive repositories in gitlab, and sync the active ones to gitlab as well, to hedge our bets
08:47:22 <tobiasz_> ok, thanks. Just wondering about the non-official plugins. I think, there might be some hosted on gitorious and if there is a migration button, that's probably the easiest way to keep those alive
08:47:44 <aarowlaptop> #idea And if someone finds a really-really-really open git option, we can always switch to that
08:47:47 <anitsirk> plugins don't have to sit under the maharaproject account. they can sit anywhere.
08:48:04 <yuliyabozhko1> aarowlaptop:  :)
08:48:16 <aarowlaptop> anitsirk: We could store all the repositories in gerrit. One of its functionalities is just to act like a git repository
08:48:38 <aarowlaptop> This would have the added benefit of being able to use gerrit to code review changes in those other repositories
08:48:48 <anitsirk> #info all repositories could be stored in gerrit. One of its functionalities is just to act like a git repository
08:49:02 <anitsirk> #info This would have the added benefit of being able to use gerrit to code review changes in those other repositories
08:49:26 <aarowlaptop> For gerrit repo's other than the core "mahara", we could set up different permissions to give people direct "push" access, for when code review isn't really appropriate.
08:49:50 <aarowlaptop> #info For gerrit repo's other than the core "mahara", we could set up different permissions to give people direct "push" access, for when code review isn't really appropriate.
08:50:17 <anitsirk> I suggest to ponder the options until the next meeting (which will be before the end of may deadline) and see if there is a best solution or if there is a mix of things.
08:50:20 <aarowlaptop> I had some hesitation about putting everything in gerrit, but I can't remember exactly what it was...
08:50:34 <yuliyabozhko1> just feels not quite right to me :)
08:50:57 <aarowlaptop> Okay, in the meantime, we've got everything copied into gitlab
08:51:07 <aarowlaptop> we can always copy it elsewhere quite easily
08:51:19 <aarowlaptop> that's what git excels at ;)
08:51:22 <yuliyabozhko1> sounds good
08:52:07 <anitsirk> #action Everyone: Review the possible options for the official mahara code repository that aarowlaptop mentioned and weight advantages and disadvantages.
08:52:33 <anitsirk> let's move on.
08:52:34 <anitsirk> #topic Mahara 15.04 release (Kristina)
08:52:34 <anitsirk> #info The Mahara 15.04 release candidate 1 has been available for testing for almost a week.
08:52:34 <anitsirk> No critical issues were found so far, but we don't know how many people have already been able to test.
08:52:34 <anitsirk> Please give it a thorough testing on your own test server.
08:52:34 <anitsirk> #info If you don't have a test server available, you can use http://master.dev.mahara.org and report issues on the bug tracker.
08:52:34 <anitsirk> https://bugs.launchpad.net/mahara/+filebug
08:53:55 <anitsirk> many new features got in.
08:54:04 <anitsirk> tobiasz_: sorry that one of your inbox ones didn't make it.
08:54:44 <robertl_> there have been a few minor issues filed by people on launchpad - but expect there should be more :)
08:55:28 <robertl_> though we do now have behat testing - so maybe less issues/bugs slipping thru
08:55:43 <tobiasz_> yeah, I didn't look much into those lately, but I'll see if I can help getting them into the next release
08:56:16 <anitsirk> great. the next release will look very different. the inbox won't have tables anymore. quite a bit of redesign with the bootstrap framework stuff.
08:56:58 <tobiasz_> and thanks to robertl_ for helping on getting the other one into the release
08:57:15 <robertl_> no worries
08:58:08 <anitsirk> #info we are still planning on releasing mid April. As usual, it'll depend on testing and any major issues...
08:58:17 <anitsirk> so: test away :-)
08:58:46 <anitsirk> #topic Next meeting and chair
08:58:46 <anitsirk> What about 23 April 2015? The times will have changed. 8 UTC will be 9 a.m. UK and 10 a.m. rest of Europe and 8 p.m. NZ. Would that work or should we go one hour earlier?
08:59:30 <robertl_> 8pm NZ sounds ok to me
08:59:48 <aarowlaptop> me too
08:59:48 <anitsirk> anzeljg: what would work well for you? 10 a.m. or 9 a.m.?
09:00:01 <yuliyabozhko1> I am on leave, flying from Boston to Iceland that day, so won't make it, sorry :)
09:00:11 <anzeljg> both, but I'm not sure if I will be able to attend anyway...
09:00:22 <anitsirk> yuliyabozhko1: wow. nice trip
09:00:33 <yuliyabozhko1> :D so excited
09:01:00 <anitsirk> i guess we'll stick to 8 UTC then.
09:01:04 <anitsirk> who wants to chair?
09:01:30 <anzeljg> sorry, but I have to leave. bye.
09:01:35 <anitsirk> bye anzeljg
09:02:05 <anitsirk> aarowlaptop, robertl_, yuliyabozhko1?
09:02:19 <yuliyabozhko1> I won't be around that day
09:02:28 <anitsirk> sorry again.
09:02:41 <anitsirk> attention span is very short tonight. :-(
09:02:49 <robertl_> aarowlaptop, you want to do it or shall I?
09:02:58 <yuliyabozhko1> I am nearly falling asleep too :P
09:03:15 <aarowlaptop> I would be honored to let you do this one, robertl_ ;)
09:03:21 <yuliyabozhko1> HAHA
09:03:29 <robertl_> ok I'll chair it
09:03:36 <anitsirk> thank you, robertl_.
09:03:36 <yuliyabozhko1> thanks, robertl_
09:03:48 <aarowlaptop> thanks
09:04:04 <anitsirk> #info robertl_ is going to chair the 43rd Mahra developer meeting on 23 April 2015 at 8:00 UTC.
09:04:14 <anitsirk> http://www.timeanddate.com/worldclock/fixedtime.html?msg=43rd+Mahara+developer+meeting&iso=20150423T08&p1=1440
09:04:22 <anitsirk> #topic Any other business
09:04:50 <yuliyabozhko1> I don't think I have anything
09:05:09 <aarowlaptop> nothing
09:05:27 <anitsirk> robertl_?
09:05:32 <robertl_> nothing from me
09:05:35 <anitsirk> i have a short one.
09:05:35 <anitsirk> #info If you want to get an article into the next newsletter, please send it to newsletter@mahara.org latest on Monday, 30 March 2015.
09:05:43 <anitsirk> that's it.
09:05:59 <anitsirk> i guess that then concludes our latest meeting. have a nice evening.
09:06:01 <anitsirk> #endmeeting