#mahara-dev Meeting

Meeting started by rkabalin at 08:02:23 UTC (full logs).

Meeting summary

    1. anitsirk is Kristina Hoeppner at Catalyst IT, Wellington, NZ (anitsirk, 08:03:26)
    2. rkabalin - Ruslan Kabalin, Lancaster University, UK (rkabalin, 08:03:49)
    3. aarow is Aaron Wells at Catalyst IT, Wellington, NZ (aarow, 08:04:05)
    4. anzeljg is Gregor Anželj developer and translator from Ljubljana, Slovenia (anzeljg, 08:04:06)

  1. Items from last meeting (rkabalin, 08:04:57)
    1. sonn2 will create development specification and security investigation for replacing file browser with elfinder (rkabalin, 08:05:21)
    2. ACTION: sonn2 will create development specification and security investigation for replacing file browser with elfinder (rkabalin, 08:07:00)

  2. Mahara Tech Lead (Kristina) (rkabalin, 08:08:46)
    1. Aaron Wells is the new tech lead for the Mahara Project. (rkabalin, 08:10:43)

  3. Dropping support for Debian/Ubuntu packages (Aaron) (rkabalin, 08:12:32)
    1. IDEA: Drop support for Debian and Ubuntu packages due to few users and not enough developers to maintain the packages. (anitsirk, 08:20:50)
    2. If anyone wants to become the package maintainer, please let us know. rkabalin and dobedobedoh will also discuss it. (anitsirk, 08:21:52)
    3. ACTION: rkabalin and dobedobedoh discuss if we have resources/time to maintain Mahara Debian package and report on the next meeting (rkabalin, 08:21:53)

  4. Security releases for 1.5 and 1.6 (Kristina) (rkabalin, 08:23:10)
    1. Mahara 1.5.9 and 1.6.4 were published on Monday, 15 April 2013, and we encourage everyone to upgrade their system. (anitsirk, 08:23:20)
    2. more info at https://mahara.org/interaction/forum/topic.php?id=5365 (anitsirk, 08:24:33)
    3. https://mahara.org/interaction/forum/topic.php?id=5365 (anitsirk, 08:24:51)

  5. Release of Mahara 1.7 (Aaron, Kristina) (rkabalin, 08:25:39)
    1. Mahara 1.7 stable will be released this week. We are working on getting the last bits and pieces together. (anitsirk, 08:26:14)
    2. new features can be discovered on the bug tracker or in the manual at http://manual.mahara.org/en/1.7/genindex.html#N and then "New in Mahara 1.7". (anitsirk, 08:26:36)

  6. Pluggable page layouts? (Aaron) (rkabalin, 08:29:27)
    1. https://mahara.org/interaction/forum/topic.php?id=5360 (anitsirk, 08:31:06)
    2. IDEA: Make page layouts another plugin type to be more flexible. This goes back to the discussion in https://mahara.org/interaction/forum/topic.php?id=5360 about masonry style or one that is more known to Mahara users. (anitsirk, 08:34:46)
    3. ACTION: Aaron to look into the feasibility of a common CSS "abstraction layer" for multiple layout plugins (aarow, 08:40:21)
    4. clarification on the layout by rkabalin: whaever layout plugin you are using, it should always produce consistent elements and styles. Location, size might be different, but say column should always be "div" with class "column", irrespective of layout... (anitsirk, 08:45:23)

  7. Next meeting and chair (rkabalin, 08:46:03)
    1. The 26th Mahara Developer Meeting will be held on the 28th of May at 8 p.m. UTC (rkabalin, 08:52:59)
    2. http://www.timeanddate.com/worldclock/fixedtime.html?msg=26th+Mahara+Developer+Meeting&iso=20130528T20 (rkabalin, 08:53:09)
    3. anitsirk will chair next 26th Mahara developers meeting (rkabalin, 08:55:21)

  8. Any other business (rkabalin, 08:55:39)
    1. Mahara gear available at http://cafepress.com/mahara to show your support and / or way of contributing to the project (anitsirk, 08:58:42)


Meeting ended at 09:07:18 UTC (full logs).

Action items

  1. sonn2 will create development specification and security investigation for replacing file browser with elfinder
  2. rkabalin and dobedobedoh discuss if we have resources/time to maintain Mahara Debian package and report on the next meeting
  3. Aaron to look into the feasibility of a common CSS "abstraction layer" for multiple layout plugins


Action items, by person

  1. dobedobedoh
    1. rkabalin and dobedobedoh discuss if we have resources/time to maintain Mahara Debian package and report on the next meeting
  2. rkabalin
    1. rkabalin and dobedobedoh discuss if we have resources/time to maintain Mahara Debian package and report on the next meeting
  3. UNASSIGNED
    1. sonn2 will create development specification and security investigation for replacing file browser with elfinder
    2. Aaron to look into the feasibility of a common CSS "abstraction layer" for multiple layout plugins


People present (lines said)

  1. rkabalin (74)
  2. anitsirk (54)
  3. aarow (33)
  4. anzeljg (6)
  5. maharameet (3)
  6. dobedobedoh (3)


Generated by MeetBot 0.1.4.