08:02:23 <rkabalin> #startmeeting
08:02:23 <maharameet> Meeting started Tue Apr 16 08:02:23 2013 UTC.  The chair is rkabalin. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:02:23 <maharameet> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:02:41 <rkabalin> Hello and welcome to 25th Mahara dev meeting
08:03:22 <rkabalin> please introduce yourself using #info tag
08:03:26 <anitsirk> #info anitsirk is Kristina Hoeppner at Catalyst IT, Wellington, NZ
08:03:49 <rkabalin> #info rkabalin - Ruslan Kabalin, Lancaster University, UK
08:04:05 <aarow> #info aarow is Aaron Wells at Catalyst IT, Wellington, NZ
08:04:06 <anzeljg> #info anzeljg is Gregor Anželj developer and translator from Ljubljana, Slovenia
08:04:57 <rkabalin> #topic Items from last meeting
08:05:21 <rkabalin> #info sonn2 will create development specification and security investigation for replacing file browser with elfinder
08:05:38 <anitsirk> i don't think sonn has started on that yet.
08:05:51 <aarow> yeah, I haven't heard anything from him about it since then
08:06:20 <rkabalin> shall we move it to the next meeting
08:06:24 <aarow> he was staying home sick today, so I think the "sonn" in this channel is just his work computer on idle
08:06:36 <rkabalin> I see
08:07:00 <rkabalin> #action sonn2 will create development specification and security investigation for replacing file browser with elfinder
08:07:15 <rkabalin> just in order not to miss it next time
08:07:59 <rkabalin> the second item is about aquaman helping sonn2
08:08:03 <rkabalin> which is the same
08:08:09 <anitsirk> yep
08:08:30 <rkabalin> ok, next topic
08:08:46 <rkabalin> #topic Mahara Tech Lead (Kristina)
08:08:50 <anitsirk> Aaron Wells is the new tech lead for the Mahara Project. He's been a developer in the Catalyst eLearning team for some time now working primarily on Moodle in the past. He received his approval for code reviewer  on 12 March outside of a developer meeting so he could take up his responsibilities and also support getting the release candidate of Mahara 1.7 out.
08:08:51 <anitsirk> Aaron is already active in the community supporting users with answers to their technical questions and just got the latest security release out.
08:08:52 <anitsirk> If you have any questions, fire away. ;-)
08:09:05 <anitsirk> you know him here as aarow
08:09:06 <aarow> oh, yep, that's me :)
08:09:45 <anzeljg> is aarow replacing elky then?
08:10:00 <anitsirk> elky wasn't the tech lead
08:10:13 <anzeljg> oh i see...
08:10:16 <rkabalin> nice to hear that we have a new tech lead for the Mahara Project, congratulations to Aaron
08:10:33 <aarow> yeah, actually Hugh (aquaman) was the Mahara technical lead before me
08:10:43 <rkabalin> #info Aaron Wells is the new tech lead for the Mahara Project.
08:11:06 <anzeljg> aarow congrats!
08:11:13 <aarow> thanks :)
08:11:17 <rkabalin> Is Hugh still working for Catalyst?
08:11:38 <anitsirk> rkabalin: no. he works for a security company now. that's what his master's thesis was on.
08:11:39 <aarow> no, he moved to a security company here in Wellington in January
08:11:49 <rkabalin> I see
08:12:03 <anitsirk> but he's still active supporting the project in esp. security-related questions.
08:12:10 <rkabalin> ok, moving further unless anyone has questions to Aaron
08:12:32 <rkabalin> #topic Dropping support for Debian/Ubuntu packages (Aaron)
08:13:15 <rkabalin> Aaron, the chair is yours
08:13:21 <aarow> Yes, since Francois left Catalyst we've had increasing difficulty maintaining the Debian & Ubuntu packages
08:13:44 <aarow> since he was our main resource who was familiar with the Debian & Ubuntu packaging system, and he's a Debian Developer
08:14:35 <aarow> since we seem to have relatively few installs of the packages, and since we don't currently have the resources to maintain them, it seems like the best use of our resources is to drop support for them
08:15:27 <anitsirk> there wasn't anyone in the forum answering your post, was there, aarow?
08:15:27 <rkabalin> Me and dobedobedoh are still in the packaging team and have experience maintaining the packages
08:15:28 <aarow> but I wanted to check with the community to see if anyone had any thoughts or preferences on the matter
08:15:45 <aarow> oh, would one of you want to maintain the packages then?
08:15:45 <rkabalin> though, it might be difficult time-wise
08:16:28 <rkabalin> let me think, we might be able to do that
08:16:38 <aarow> It's also worth noting, Debian dropped us from wheezy, because we had fallen behind on patching reported bugs, and because of the low number of installs
08:17:06 <anitsirk> what are the advantages os being in Debian, aarow?
08:17:28 <aarow> well, it is an easy way for people to discover and install Mahara
08:17:44 <rkabalin> yep
08:17:56 <rkabalin> and make easy updating
08:18:47 <aarow> and we don't have any hard numbers on how many people are using the packages
08:19:00 <aarow> just the numbers from the "popularity contest" package, which is optional
08:19:23 <aarow> there are around 35 Debian users in popcon, and around 30 active Ubuntu users in popcon
08:20:01 <rkabalin> so, you suggest to drop support then aarow
08:20:33 <aarow> yes, unless we can find someone in the community who wants to do it
08:20:39 <rkabalin> shall we decide that on the next meeting, I will dicuss it with Andrew and we will see if we have resources/time to maintain it
08:20:47 <aarow> sure
08:20:50 <anitsirk> #idea Drop support for Debian and Ubuntu packages due to few users and not enough developers to maintain the packages.
08:21:01 <anitsirk> that sounds great, rkabalin
08:21:15 <aarow> yes, thanks :)
08:21:52 <anitsirk> #info If anyone wants to become the package maintainer, please let us know. rkabalin and dobedobedoh will also discuss it.
08:21:53 <rkabalin> #action rkabalin and dobedobedoh discuss if we have resources/time to maintain Mahara Debian package and report on the next meeting
08:22:17 <rkabalin> anitsirk, yep, sure, anyone welcome
08:22:54 <rkabalin> next topic?
08:23:00 <anitsirk> sure
08:23:10 <rkabalin> #topic Security releases for 1.5 and 1.6 (Kristina)
08:23:20 <anitsirk> Just a quick note about the latest security release.
08:23:20 <anitsirk> #info Mahara 1.5.9 and 1.6.4 were published on Monday, 15 April 2013, and we encourage everyone to upgrade their system.
08:23:31 <anitsirk> that's all i wanted to say.
08:24:11 <anzeljg> BRB
08:24:33 <anitsirk> #info more info at https://mahara.org/interaction/forum/topic.php?id=5365
08:24:47 * rkabalin written down that we need to upgrade our mahara
08:24:51 <anitsirk> #link https://mahara.org/interaction/forum/topic.php?id=5365
08:25:09 <anitsirk> rkabalin: :-)
08:25:14 <rkabalin> thanks anitsirk
08:25:39 <rkabalin> #topic Release of Mahara 1.7 (Aaron, Kristina)
08:25:49 <anitsirk> Also just a quick note.
08:26:14 <anitsirk> #info Mahara 1.7 stable will be released this week. We are working on getting the last bits and pieces together.
08:26:36 <anitsirk> #info new features can be discovered on the bug tracker or in the manual at http://manual.mahara.org/en/1.7/genindex.html#N and then "New in Mahara 1.7".
08:27:18 <anitsirk> do you want to add anything, aarow?
08:27:38 * rkabalin written down that we need to upgrade our mahara to 1.7 at some point
08:27:57 <aarow> nope, that about covers it :)
08:28:09 <rkabalin> thanks everyone who is working on that at the moment
08:28:52 <rkabalin> shall we go to the next topic?
08:29:21 <anitsirk> sure.
08:29:27 <rkabalin> #topic Pluggable page layouts? (Aaron)
08:30:06 <aarow> Well, we've been considering a couple of alternatives to improve the current Page layouts
08:30:23 <aarow> Kristina posted some forum threads asking for people's preferences about two of them
08:30:40 <aarow> one idea I was brainstorming during this was, would it make sense to turn Page layouts into another plugin type?
08:31:00 <aarow> So I was wondering whether folks had any thoughts about that. :)
08:31:06 <anitsirk> #link https://mahara.org/interaction/forum/topic.php?id=5360
08:31:28 <rkabalin> might worth doing that (another plugin type), I like the idea
08:32:24 <aarow> I guess it may be challenging for the theme designers
08:32:30 <rkabalin> making layout design more flexible
08:32:56 <anitsirk> aarow: yes, it will be because they are so different.
08:33:08 <rkabalin> may layout be a part of the theme?
08:33:54 <anitsirk> rkabalin: could that mean that you have two versions of the same theme then?
08:34:32 <aarow> well, Page layout is a bit too behaviorally complex to make sense as part of the theme, I think
08:34:40 <rkabalin> no, I meant that someone who develop the theme, potentially can develop a matching layout
08:34:46 <anitsirk> #idea Make page layouts another plugin type to be more flexible. This goes back to the discussion in https://mahara.org/interaction/forum/topic.php?id=5360 about masonry style or one that is more known to Mahara users.
08:34:48 <aarow> the challenge for theme designers, would be making sure that their CSS is able to deal with multiple types of Page layouts
08:35:37 <rkabalin> then all layouts should attemt to use the same set of CSS definitions
08:36:24 <rkabalin> and ideally have some absraction output layer that is the same to all of them
08:36:49 <anitsirk> the difference between the two styles is that masonry is more flexible and works well on any type of device because it is fully responsive, but it doesn't give you absolute control over where to place items. whereas our current layout plus mike kelly's enhancements would allow you easier positioning of blocks next to each other (with the caveat: when viewed on a computer screen). when you go smaller and have device detection on, the blocks will move.
08:37:12 <aarow> that's the difference between the two specific layouts Kristina was talking about in that forum thread
08:39:01 <aarow> rkabalin: I'll run your idea about the abstraction, by our theme designers
08:39:31 <rkabalin> thanks aarow
08:40:21 <aarow> #action Aaron to look into the feasibility of a common CSS "abstraction layer" for multiple layout plugins
08:44:13 <rkabalin> what I mean is whaever layout plugin you are using, it should always produce consistent elements and styles. Location, size might be different, but say column should always be "div" with class "column", irrespective of layout...
08:45:15 <rkabalin> ok, next topic?
08:45:23 <anitsirk> #info clarification on the layout by rkabalin: whaever layout plugin you are using, it should always produce consistent elements and styles. Location, size might be different, but say column should always be "div" with class "column", irrespective of layout...
08:45:38 <anitsirk> yes, go for it, rkabalin
08:45:39 <aarow> sure, next topic :)
08:46:03 <rkabalin> #topic Next meeting and chair
08:46:32 <rkabalin> in May or June?
08:47:12 <rkabalin> any suggestions?
08:47:19 <anitsirk> I guess in about 6 weeks?
08:47:46 <anitsirk> there hasn't been much to discuss in the last meetings, so 4 weeks is probably too soon.
08:47:47 <rkabalin> that could be 28th of May
08:48:18 <anitsirk> would work for me.
08:48:27 <aarow> me too
08:49:37 <anitsirk> i can chair it if there are no other volunteers
08:49:57 <rkabalin> #info The 2th Mahara Developer Meeting will be held on the 28th of May at 8 p.m. UK time
08:50:08 <anitsirk> rkabalin: uk or UTC?
08:50:44 <anzeljg> rkabalin: edit latest info line
08:50:45 <rkabalin> I always struggle with this timeadndate site
08:50:57 <rkabalin> #undo
08:50:57 <maharameet> Removing item from minutes: <MeetBot.items.Info object at 0x129c610>
08:51:43 <anitsirk> did you mean http://www.timeanddate.com/worldclock/fixedtime.html?msg=26th+Mahara+Developer+Meeting&iso=20130528T20 ?
08:51:47 <dobedobedoh> Only our second dev meeting?
08:51:53 <anitsirk> nah, 26th ;-)
08:52:59 <rkabalin> #info The 26th Mahara Developer Meeting will be held on the 28th of May at 8 p.m. UTC
08:53:09 <rkabalin> #link http://www.timeanddate.com/worldclock/fixedtime.html?msg=26th+Mahara+Developer+Meeting&iso=20130528T20
08:53:14 <rkabalin> thanks anitsirk
08:53:18 <anitsirk> np
08:53:56 <rkabalin> anitsirk, do you want to chair?
08:54:07 <anitsirk> sure, if there are no other takers.
08:54:47 <rkabalin> ok
08:55:21 <rkabalin> #info anitsirk will chair next 26th Mahara developers meeting
08:55:39 <rkabalin> #topic Any other business
08:56:11 <anitsirk> I have one
08:56:41 <rkabalin> go ahead
08:56:54 <anitsirk> Did you see the new character scenes Evonne made at http://cafepress.com/mahara ?
08:57:32 <rkabalin> looks cool
08:57:34 <rkabalin> :D
08:58:01 <anitsirk> maybe some people will wear some of the gear at MaharaUK...
08:58:26 <rkabalin> good idea
08:58:42 <anitsirk> #info Mahara gear available at http://cafepress.com/mahara to show your support and / or way of contributing to the project
08:59:02 <anitsirk> that's all from me.
08:59:57 <rkabalin> Though £18 for the t-shirt :), are they are NorthFace or Jack Wolfskin?
09:00:10 <rkabalin> with Mahara print on it :)
09:00:40 <anitsirk> rkabalin: that's the cafepress price I'm afraid.
09:00:58 <rkabalin> I see
09:02:08 <rkabalin> Just of curiosity, what percentage Mahara project gets from each sale?
09:02:26 <rkabalin> just to know if I would really support Mahara that way
09:02:49 <anitsirk> rkabalin: $1 per tshirt i think. we kept the markup low because of the base price.
09:03:05 <dobedobedoh> Aww - Mahara has no babygrow products (Moodle does - http://www.cafepress.com/moodle.27158269)
09:03:45 <anitsirk> if you know of another site that has better prices, ships worldwide etc., let us know.
09:04:20 <anitsirk> dobedobedoh: we do, too.
09:05:13 <anitsirk> dobedobedoh: go to http://www.cafepress.com/mahara/9953038 there are three different sizes :-)
09:05:20 <anitsirk> do you want to tell us something ;-)
09:05:28 <dobedobedoh> heh no
09:05:31 <rkabalin> thanks anitsirk anyway, i think I will buy something
09:05:51 <rkabalin> anyone has anything else to discuss?
09:07:18 <rkabalin> #endmeeting