#mahara-dev Meeting

Meeting started by dobedobedoh at 07:34:17 UTC (full logs).

Meeting summary

  1. What should go into 1.4? (dobedobedoh, 07:37:20)
    1. http://wiki.mahara.org/Roadmap/1.4/1.4_Wishlist (lamiette, 07:40:16)
    2. http://wiki.mahara.org/Contributors (anitsirk, 07:42:39)
    3. http://wiki.mahara.org/Roadmap/1.4/1.4_Wishlist <- those (lamiette, 07:57:16)
    4. AGREED: Usability enhancements, and Institution Separation for 1.4 subject to governance group agreement. Gregor's skins patch and PDF export my go in dependant on time (dobedobedoh, 08:01:04)

  2. Release Policy (dobedobedoh, 08:01:12)
  3. Sanitisation of language packs (dobedobedoh, 08:08:11)
    1. ACTION: iarenaza to draft language pack release policy (dobedobedoh, 08:14:51)
    2. AGREED: 1.5 hour meeting (dobedobedoh, 08:16:29)

  4. Commit access policy (dobedobedoh, 08:16:36)
    1. AGREED: fmarier> 1) new developer proposed at developer meetings (dobedobedoh, 08:35:22)
    2. AGREED: 1) new developer proposed at developer meetings (dobedobedoh, 08:42:44)
    3. AGREED: 2) people get to vote based on contributions (dobedobedoh, 08:42:44)
    4. AGREED: 3) the sponsor monitors commit for a bit afterwards (dobedobedoh, 08:42:44)
    5. AGREED: 4) developer status expires after a year but is renewable indefinitely (dobedobedoh, 08:42:44)
    6. AGREED: 5) ultimate decision is with the lead developer (dobedobedoh, 08:42:48)
    7. AGREED: 6) those present at a developer meeting with commit access are entitled to vote. (dobedobedoh, 08:42:50)
    8. AGREED: Drop point 5 (dobedobedoh, 08:45:13)
    9. AGREED: 7) consensus decision rules (dobedobedoh, 08:47:58)
    10. IDEA: should large features include reasonable testing in the future? (dobedobedoh, 08:53:05)
    11. ACTION: Mjollnir` to merge phpunit branch into master (dobedobedoh, 09:02:13)

  5. Next Meeting (dobedobedoh, 09:03:18)
    1. AGREED: next meeting 14th Dec @ 7:30pm GMT / 15th Dec @ 7:30am NZST (dobedobedoh, 09:08:47)
    2. ACTION: dobedobedoh to put minutes on wiki.mahara.org (dobedobedoh, 09:11:26)


Meeting ended at 09:12:26 UTC (full logs).

Action items

  1. iarenaza to draft language pack release policy
  2. Mjollnir` to merge phpunit branch into master
  3. dobedobedoh to put minutes on wiki.mahara.org


Action items, by person

  1. dobedobedoh
    1. dobedobedoh to put minutes on wiki.mahara.org
  2. iarenaza
    1. iarenaza to draft language pack release policy
  3. Mjollnir`
    1. Mjollnir` to merge phpunit branch into master


People present (lines said)

  1. dobedobedoh (126)
  2. fmarier (110)
  3. Mjollnir` (100)
  4. dm (70)
  5. richardm (45)
  6. anitsirk (36)
  7. iarenaza (28)
  8. aguri (24)
  9. lamiette (21)
  10. rkabalin (14)
  11. maharameet (3)
  12. adi_b (2)


Generated by MeetBot 0.1.4.