07:34:17 <dobedobedoh> #startmeeting
07:34:17 <maharameet> Meeting started Wed Nov 10 07:34:17 2010 UTC.  The chair is dobedobedoh. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:34:17 <maharameet> Useful Commands: #action #agreed #help #info #idea #link #topic.
07:34:20 <dobedobedoh> #chair lamiette
07:34:20 <maharameet> Current chairs: dobedobedoh lamiette
07:34:40 <lamiette> awesome :)
07:34:57 <lamiette> are we waiting on others?
07:34:59 <anitsirk> do we know who is in the room right now as some have their computers on at all times but may not be sitting in front of them?
07:35:04 <Mjollnir`> i'm here! stop panicing!
07:35:13 <dm> hehe
07:35:14 <fmarier> hi Mjollnir`
07:35:18 <dobedobedoh> Morning
07:35:27 <dobedobedoh> <-- is here in the UK
07:35:31 <anitsirk> hehe, and you are even shown as away, Mjollnir ;-)
07:35:39 <Mjollnir`> still?
07:35:44 <dobedobedoh> The agenda items we have submitted are:
07:35:46 <anitsirk> yep
07:35:46 <dobedobedoh> 1) What should go into 1.4 (e.g. fully-separate institutions?)
07:35:47 <dobedobedoh> 2) Release policy
07:35:47 <dobedobedoh> 3) Commit access policy
07:35:47 <dobedobedoh> 4) Testing and code review
07:35:49 <dobedobedoh> 5) Sanitisation of language packs
07:35:52 <dobedobedoh> 6) Forum code of conduct
07:35:54 <dobedobedoh> 7) Next Meeting
07:35:57 <dobedobedoh> 8) Any Other Business
07:36:05 <lamiette> show of hands for the logs ?
07:36:29 <fmarier> i'd like to propose that we close the meeting in an hour and defer anything we haven't talked about to the next meeting
07:36:36 <dobedobedoh> seconded
07:36:38 <anitsirk> good idea
07:36:56 <rkabalin> agree
07:36:57 <fmarier> except for (7) of course :)
07:36:57 <Mjollnir`> fast game's a good game
07:36:58 <lamiette> yup
07:37:20 <dobedobedoh> #topic What should go into 1.4?
07:37:52 <rkabalin> Walled Garden ;)
07:37:59 <fmarier> so the main thing that Richard and I are working on at the moment is usability enhancements
07:38:49 <fmarier> another thing that I want to get to is to review the patches from luns related to separating institutions
07:39:10 <dobedobedoh> Both of those sound good to me :) - especially the walled gardens
07:39:46 <fmarier> i personallly dislike the term walled garden because it makes me think of toxic DRM-filled ecosystems :)
07:40:06 <dobedobedoh> Do we have any target date for 1.4?
07:40:07 <fmarier> but i have nothing against the feature of course :)
07:40:13 <anitsirk> is http://wiki.mahara.org/index.php?title=Developer_Area/Specifications_in_Development/Walled_Gardens&highlight=walled+garden still the best place to check upon what you mean by "walled garden"?
07:40:16 <dobedobedoh> heh I'm sure that we can rename it
07:40:16 <lamiette> http://wiki.mahara.org/Roadmap/1.4/1.4_Wishlist
07:40:20 <Mjollnir`> is there a public spec for the usability stuff ?
07:40:27 <Mjollnir`> excuse my out-of-touch-ness
07:40:27 <anitsirk> fmarier: better than "creepy treehouse effect" ;-)
07:40:28 <richardm> One thing we should also point out it that we don't really officially get to decide what goes in at all
07:40:29 <fmarier> Mjollnir`: not sure
07:40:43 <Mjollnir`> richardm: que?
07:40:52 <richardm> It's supposed to be decided by the 'steering group'
07:40:56 <lamiette> Mjollnir`: http://wiki.mahara.org/Roadmap/Usability - from the wiki
07:41:04 <richardm> Don reminded fmarier & me of that recently
07:41:23 <dobedobedoh> Who is the steering group composed of?
07:41:32 <dm> does the steering group actually meet regularly though?
07:41:42 <richardm> Nope they never meet
07:41:42 <Mjollnir`> is that different ffrom the governance group?
07:41:51 <anitsirk> the governance group is richard wyles, nolen smith, don christie and mike o'connor
07:41:56 <richardm> er sorry i mean the governance group
07:42:06 <Mjollnir`> i used to be on the governance group, i think my membership silently lapsed
07:42:19 <fmarier> but more importantly, what are people looking at pushing into 1.4?
07:42:39 <anitsirk> http://wiki.mahara.org/Contributors
07:42:40 <fmarier> we were thinking of a release in the first half of next year
07:42:51 <fmarier> (obviously really vague)
07:43:01 <aguri> richardm: that being so, i think the governance group are very reliant on the developers giving them good advice to make decisions
07:43:08 <fmarier> and part of it depends on what goes into the release
07:43:10 <dobedobedoh> Well, as per the commit access policy, we're can only submit new features when they're signed off by fmarier, richardm or Mjollnir`
07:43:12 <anitsirk> Mjollnir: the last i had seen it was those plus nigel
07:43:17 <richardm> aguri: yes, as dm pointed out they never meet
07:43:39 <richardm> But they can veto stuff i guess
07:43:46 <anitsirk> yep
07:43:57 <richardm> practically speaking that means richard wyles can veto stuff
07:44:03 <richardm> no one else really cares
07:44:16 <dm> well - he can only veto if the others in the gov group agree
07:44:17 <anitsirk> i wouldn't say so, richardm
07:44:19 <fmarier> dobedobedoh: that's one of the things i was hoping to talk about in "testing and code review"
07:44:42 <lamiette> so the commit access policy would need to include this extra level where things might not make it through
07:44:53 <rkabalin> Regarding walled garden, we have updated it with upstream version last time in June. Our idea was, when you guys have resources to review it, we can allocate the time to have it up to date with master again and then we can proceed with revision.
07:45:17 <fmarier> rkabalin excellent
07:45:28 <fmarier> it will certainly help
07:45:59 <fmarier> so was there anything else that people were planning/hoping to get into 1.4?
07:46:11 <dobedobedoh> We have nothing else at present that I'm aware of
07:47:09 <richardm> I'm tempted to say Gregor Anzelj's skins stuff too
07:47:10 <fmarier> richardm: i think you were also hoping to get to the skins patch?
07:47:14 <fmarier> :)
07:47:23 <Mjollnir`> adi and i were hoping to use some of our innovation budget for leap2a import for normal users
07:47:25 <richardm> Yeah I don't know if I'll get time
07:47:26 <Mjollnir`> we certainly can't do that this year, but maybe if se
07:47:37 <anitsirk> richardm: wasn't that close to getting in anyway?
07:47:41 <aguri> fmarier: we have PDF export proposed to go in at some point  http://wiki.mahara.org/Developer_Area/Specifications_in_Development/PDF_Export
07:47:44 <Mjollnir`> we start planning we could get it in next year, depending on what you mean by "early next year"
07:47:51 <richardm> Oh btw, Feb is more likely when 1.4 will come out
07:48:01 <Mjollnir`> then no
07:48:19 <richardm> That's when we're expected to have to release the usability stuff
07:48:42 <anitsirk> in time for the new school year in NZ
07:49:06 <fmarier> Mjollnir`: how much more time would you need to get your stuff in?
07:49:25 <Mjollnir`> well we basically have to pitch for budget and time off projects to do it
07:49:37 <Mjollnir`> and we're both very busy with a big project until probably .. end of feb at least :(
07:49:47 <Mjollnir`> uless we can find a way to do a day a week on it or something.. i'm not sure
07:50:06 <Mjollnir`> adi_b: ? are you here ?
07:50:16 <adi_b> yes
07:50:26 <fmarier> aguri: is the PDF export stuff started or is it in the planning stages at this point?
07:50:34 <Mjollnir`> do we think this is at all possible?
07:50:35 <adi_b> I�don't think we'll be able to do it before march
07:50:39 <Mjollnir`> ok
07:50:51 <aguri> fmarier: planning now although there is budget.  have been discussing with richardm
07:50:55 <dobedobedoh> So usability is definitely in for 1.4; and WG is a hopeful. Innovation is unlikey given the Feb timescale
07:50:56 <Mjollnir`> we should discuss this internally
07:51:32 <dobedobedoh> bah - I meant leap2a import
07:51:35 <aguri> fmarier: we will be looking for feedback/refinement on that spec from the wider community - baring in mind we have limited budget for great ideas
07:51:46 <Mjollnir`> innovation is where budget comes from )
07:52:39 * aguri likes the sound of this "innovation" feature :p
07:52:43 <dobedobedoh> what about Gregro's skins patch? Likely for 1.4?
07:53:22 <richardm> I'd like to do it, but I'm not sure.  it's a monolithic patch that doesn't merge cleanly
07:53:30 <Mjollnir`> what's the skins patch ?
07:53:47 <richardm> lets you choose colours & fonts for views
07:53:49 <richardm> very cool
07:53:55 <dobedobedoh> nice
07:54:17 <rkabalin> sounds interesting
07:54:35 <richardm> basically it's like view themes but the way wwe should have done it
07:54:43 <Mjollnir`> why didn't we d... oh nevermind
07:55:25 <dobedobedoh> So is the general consensus that pdf won't be ready, nor will leap2a import; institution separation and usability will be and skins are on the fence?
07:55:26 <richardm> yeah i'll try to get a working version of it up somewhere where you guys can check it out
07:55:44 <anitsirk> that'd be great
07:56:01 <aguri> dobedobedoh: there's a good chance PDF will be ready
07:56:03 <lamiette> richardm: was the Usability link I pasted earlier - on the Roadmap - an adequate outline for the changes .nz is working on atm?
07:56:29 <richardm> lamiette: no it's the first 3 items on that 1.4 wishlist page
07:56:33 <Mjollnir`> is pdf export a proper export plugin ?
07:56:35 <richardm> more if we get time
07:57:13 <aguri> Mjollnir`: that idea is being circled.
07:57:16 <lamiette> http://wiki.mahara.org/Roadmap/1.4/1.4_Wishlist <- those
07:57:21 <Mjollnir`> er
07:57:29 <Mjollnir`> not making it an export plugin seems .. kind of wrong
07:57:41 <Mjollnir`> even if you're only going to initially allow view exports
07:57:46 <Mjollnir`> it should still be a plugin imo
07:59:35 <dobedobedoh> So can we #agree some points that we'd like to see in 1.4 then?
07:59:39 * dobedobedoh is conscious of the time
07:59:46 <iarenaza> Hi
07:59:59 <Mjollnir`> hi iarenaza :)
08:00:04 <aguri> Mjollnir`: i know lamiette was discussing doing it that way - can't quite remember where we left it on last discussion.  but your view noted.
08:00:23 <fmarier> dobedobedoh: i think: usability, institution separation are in; skins, pdf export hopefully
08:00:41 <Mjollnir`> adi and i are talking about leap2a tomorrow morning and will report back on how possible it is
08:00:55 <fmarier> Mjollnir`: cool
08:01:03 <dobedobedoh> Great :)
08:01:04 <dobedobedoh> #agree Usability enhancements, and Institution Separation for 1.4 subject to governance group agreement. Gregor's skins patch and PDF export my go in dependant on time
08:01:12 <dobedobedoh> #topic Release Policy
08:01:35 <fmarier> so basically i put that topic in just as a reminder that now is the time to get your new features in :)
08:02:01 <dobedobedoh> heh :)
08:02:08 <fmarier> but also, to let people know that if you've fixed an important bug on master, please propose it for 1.3 as well
08:02:22 <fmarier> we do want to fix important bugs on the stable branch as well
08:02:31 <Mjollnir`> are we still supporting 1.2 ?
08:02:45 <fmarier> Mjollnir`: yes, but only for security stuff
08:02:49 <Mjollnir`> ok
08:02:55 <Mjollnir`> i will stop putting leap2a patches there then :)
08:03:13 <dobedobedoh> Do we have any documentation on the release policy?
08:03:14 <fmarier> as in, feel free to put a major bugfix on there too, but we make no guarantee other than security fixes
08:03:40 <fmarier> dobedobedoh: http://wiki.mahara.org/Developer_Area/Release_Policy
08:03:45 * dobedobedoh finds it :)
08:03:53 <fmarier> (scroll down to Point Release)
08:04:11 <iarenaza> I don't know if this is related to release policy but, what's the policy on (non-english) languages?
08:04:25 <fmarier> iarenaza: what do you mean?
08:04:50 <iarenaza> I'm not really sure :)
08:05:24 <Mjollnir`> heh
08:05:52 <iarenaza> Right know non-english languages look like something "apart"m that have an indepedent life
08:06:02 <dobedobedoh> There's no tie between language pack versions and mahara versions at present is there?
08:06:19 <fmarier> dobedobedoh: there is, we have different branches in the git repos under mahara-lang
08:06:25 <dobedobedoh> ah right
08:06:51 <dm> iarenaza: I'd like to see if we can get AMOS to do Mahara lang as well
08:06:57 <anitsirk> dobedobedoh: you can see that a bit also at http://wiki.mahara.org/Language_Packs
08:07:03 <dm> just need to wait for David to get it all sorted for 2.0
08:07:12 <Mjollnir`> how embedded in to moodle coe is amos? is it being managed in its own project somewhere ?
08:07:21 <dobedobedoh> antisirk: Cheers - I wasn't aware of the version in there
08:07:23 <dm> its's a moodle plugin
08:07:32 <dm> but we could run a moodle site that created mahara langs
08:07:44 <dm> have you seen amos?
08:07:45 <Mjollnir`> what sort of plugin ?
08:07:53 <Mjollnir`> dm: i haven't seen it but i read the technical spec
08:07:59 <fmarier> since we're talking about translations, i think it might be time to move the #topic to (5)
08:08:04 <dm> can't remember - might be in local
08:08:11 <dobedobedoh> #topic Sanitisation of language packs
08:08:19 <dm> I did have a look at it/install it a while back
08:08:19 <fmarier> dobedobedoh: thanks :)
08:08:34 <dm> but we'd run our own Amos install which would be a mahara site
08:08:36 <dm> sorry
08:08:37 <dm> moodle site
08:08:41 <dm> pointing at mahara git repo
08:08:54 <richardm> yeah it'd be very cool to have some site where people can translate strings
08:09:24 <richardm> i think the old translation tool of davids is quite hard to install currently
08:09:30 <iarenaza> Mjollnir`: I think David M has a repo on github with AMOS code
08:09:36 <dm> yeah
08:09:42 <dm> iarenaza: yes
08:10:04 <dm> It might be easier for us to use when David does the work to support contrib modules
08:10:14 <dm> at the moment it only supports moodle core
08:10:33 <fmarier> also, i think it's worth pointing out this tool that richardm wrote: http://langpacks.dev.mahara.org/
08:10:35 <iarenaza> richardm: we keep up to date patches of the old tool in a git repo, so we can use it internally (we maintain the Basque lang pack)
08:10:59 <fmarier> it cleans up language packs and makes sure that there is nothing else but strings in them (for security reasons)
08:11:07 <dobedobedoh> fmarier: You raised language pack sanitisation - what else did you have in mind?
08:11:08 <dm> cool
08:11:40 <richardm> iarenaza: ah right, that's awesome, but most of the translators find it too hard to install i think
08:11:45 <fmarier> i think it checks for general brokenness as well (like invalid utf-8 characters and syntax errors)
08:11:55 <dm> great!
08:12:04 <fmarier> dobedobedoh: i just wanted to point out richard's tool
08:12:12 <fmarier> we link to these tarballs from the wiki now
08:12:16 <iarenaza> richardm: that's true (and doesn't help with help files translations)
08:12:37 <richardm> fmarier: yeah, there's nothing to stop people installing the originals though
08:13:01 <fmarier> richardm: true, but we're no longer linking to the raw unsanitised ones
08:13:10 <fmarier> so they're harder to find
08:13:23 <lamiette> we only have about 15mins left btw
08:13:30 <dobedobedoh> is there anything more to discuss on language packs?
08:13:32 <Mjollnir`> surely we could go for 1.5h
08:13:38 <Mjollnir`> i will be on the train until 10 :)
08:13:52 <fmarier> Mjollnir`: you've got interwebs on the train?
08:13:56 <iarenaza> richardm: maybe it's time for a language pack "release policy" (aka, telling translators not to publicise non-blessed sites)
08:14:27 <fmarier> iarenaza: can you draft it?
08:14:47 <iarenaza> Ok :)
08:14:49 <Mjollnir`> fmarier: tethered, yes
08:14:51 <dobedobedoh> #action iarenaza to draft language pack release policy
08:14:56 <richardm> :)
08:15:31 <fmarier> ok, so do we want to extend the meeting to 1.5 hours to cover the remain agenda items or stick to 1 hour?
08:15:44 <Mjollnir`> +1 for extend
08:15:47 <dobedobedoh> +1
08:15:51 <rkabalin> +1
08:15:52 <aguri> NZ people can call on that one
08:15:54 <lamiette> sure +1
08:15:55 <anitsirk> +1
08:15:58 <richardm> +1
08:16:04 <Mjollnir`> AOL!
08:16:06 <iarenaza> +1
08:16:11 <dm> +1
08:16:26 <fmarier> alright, let's move to (4) ?
08:16:29 <dobedobedoh> #agreed 1.5 hour meeting
08:16:36 <dobedobedoh> #topic Commit access policy
08:16:49 <fmarier> ah we skipped (3) as well :)
08:16:54 <fmarier> fair enough
08:17:00 <dobedobedoh> heh - I assumed that you'd renumbered ;)
08:17:15 <fmarier> so, the existing "commit policy" is not really a policy and is a bit random
08:17:26 <fmarier> what do people think we should have to make sure it's fair?
08:17:57 <dm> do you mean "who to give commit access" to?
08:18:10 <dm> or do you mean what type of commits are allowed?
08:18:23 <lamiette> I was going to ask about that - for contributing in terms of bug fixes, medium sized modifications and larger pieces of contrib/features etc
08:18:37 <lamiette> I assume the bug tracker, forum and wiki of course
08:18:52 <fmarier> dm: i meant write access to the main repo
08:19:03 <dobedobedoh> And how can we track those submissions - the status etc. Ensure that they're not forgotten
08:19:15 <fmarier> dm: the other one i suppose is kinda covered in the release policy?
08:19:19 <lamiette> dobedobedoh: yeah
08:20:06 <fmarier> dobedobedoh: i'm experimenting at the moment with a code review tool called gerrit. it seems better than the merge request stuff on gitorious
08:20:14 <dm> The way Moodle "used" to work was - a new dev comes along - suggests a bunch of patches in the tracker....the existing devs get sick of cherry-picking small stuff - give dev access to commit
08:20:22 <Mjollnir`> are we generally happy with gitorious ?
08:20:23 <dm> that works quite well with smaller numbers of devs
08:20:25 <dobedobedoh> fmarier: Great. The merge request stuff on gitorious is a pain to use
08:20:28 <dobedobedoh> Apart from the lack of CIA
08:20:48 <Mjollnir`> dm: i htink that model worked pretty well, no ?
08:20:50 <dobedobedoh> dm: I quite like that way myself
08:20:52 <lamiette> maybe a topic for next meeting could be "contributing" - for general stuff, contrib etc
08:20:59 <dm> yeah - worked well for a long time
08:21:03 <richardm> yeah i don't like the gitorious merge requests either
08:21:05 <dobedobedoh> has it changed then?
08:21:11 <rkabalin> fmarier: gerrit is cool stuff BTW, I saw a presentation on UKUUG
08:21:11 <dm> moodle?
08:21:12 <Mjollnir`> mahara is still way way small enough for this to work, imo
08:21:13 <dm> it's changing
08:21:15 <fmarier> lamiette: can you create a new wiki page for the next meeting and add it there?
08:21:17 <Mjollnir`> the problem with moodle is just that of scale I think
08:21:28 <Mjollnir`> we don't have that problem yet
08:21:30 <iarenaza> I wonder if having partial commit access is a good thing (i.e., being able to commit to auth plugins only, or just a single plugin, etc.)
08:21:46 <iarenaza> Would it be worth it?
08:21:51 <lamiette> it doesnt' seem like we have a particularly large ocntrigb at the moment:  http://gitorious.org/mahara-contrib
08:21:51 <dobedobedoh> That's probably only possible using the contrib repo
08:21:56 <lamiette> (sorry all, slow irc problems)
08:22:08 <dm> probably not - if we don't want to give full access -we should be cherry-picking
08:22:16 <fmarier> iarenaza: we have separate access for contrib and core, but nothing more granular
08:22:34 <Mjollnir`> I think splitting stuff out is probably overkill at this point
08:22:38 <dm> definately
08:22:42 <dobedobedoh> agreed
08:22:43 <richardm> yeah is it easy to make it granular on gitorious?
08:22:44 <fmarier> Mjollnir`: agreed
08:22:45 <Mjollnir`> if we do'nt trust someone enough to have full acess, cherry pick or merge like dan says
08:22:54 <Mjollnir`> ARGH TUNNEL
08:23:24 <dobedobedoh> I don't think git gives that sort of granularity on a per-directory level. It's not svn ;)
08:23:37 <richardm> yeah thats what i thought
08:23:43 <dm> you can do it using some hook architecture I think
08:23:43 <fmarier> yeah i would tend to agree with dobedobedoh, but i might be wrong
08:23:43 <iarenaza> dobedobedoh: yes, you can do it (using the hooks)
08:24:00 <dobedobedoh> gitorious doesn't support hooks
08:24:00 <dm> moodle/petr was looking at it
08:24:03 <fmarier> anyways, sounds like overkill right now
08:24:13 <Mjollnir`> you can do it with hooks
08:24:22 <Mjollnir`> oh sorry, lag
08:24:31 <iarenaza> e.g., gitosis can do it out of the box
08:25:20 <fmarier> do we have an actual case where this would have been useful or are we just talking hypothetically?
08:25:50 <Mjollnir`> hypothetically i tink
08:25:54 <Mjollnir`> in which case we sould move ov
08:25:55 <Mjollnir`> on
08:25:57 <richardm> yeah we haven't had problems with badly broken stuff yet, hypothetical
08:26:12 <dobedobedoh> So the general consensus is to accept patches and cherry-pick commits, and give access as appropriate?
08:26:27 <Mjollnir`> #yes
08:26:27 <fmarier> how do we define "as appropriate" ?
08:26:35 <Mjollnir`> voting ?
08:26:40 <dm> #yes
08:26:41 <dobedobedoh> Who gets to vote?
08:26:41 <richardm> yep, i'm happy to try out gerrit though if fmarier sets it up!
08:26:43 <dobedobedoh> #yes
08:26:54 <Mjollnir`> dobedobedoh: existing people with commit acces s?
08:27:01 <fmarier> should we propose giving commit access at developer meetings for example?
08:27:11 <dm> good idea
08:27:14 <aguri> i propose the lead developer decides
08:27:14 <fmarier> (assuming we do them regularly)
08:27:15 <dobedobedoh> Yeah good idea
08:27:17 <dm> if we have them regularly enough
08:27:21 <aguri> i.e. person with the biggest headache when it goes wrong
08:28:09 <fmarier> ubuntu has a nice system where new members create a wiki page pointing to their commits / contributions then that is taken to the community board meetings
08:28:12 <fmarier> and voted on
08:28:24 <dobedobedoh> If we're moving to granting access based on these meetings, will that affect Catalyst's internal work?
08:28:25 <Mjollnir`> that sounds good to me - having one person decide seems like a bottleneck
08:28:39 <dm> I wouldn't think so
08:28:50 <aguri> cause of the thousands applying
08:28:54 <dm> internal work happens on seperate git branches
08:29:05 <dm> review happens before upstream commit
08:29:07 <richardm> yeah apart from small bug fixes
08:29:08 <fmarier> dobedobedoh: i think catalyst people are competent enough to pass the test :)
08:29:23 <dobedobedoh> heh cool :) Just thought I'd best raise it
08:29:35 <Mjollnir`> aguri: i don't think there's anything wrong with being optimistic
08:29:39 <fmarier> and avoiding double standards is good
08:30:26 <richardm> so we should call a meeting from now on if we need to give commit access to someone new?
08:30:43 <fmarier> richardm: i think we were assuming regular meetings
08:30:47 <fmarier> like monthly
08:30:50 <anitsirk> i wouldn't do that but schedule it during the regular meeting
08:31:00 <dobedobedoh> I was thinking monthy meetings
08:31:04 <anitsirk> second fmarier
08:31:22 <richardm> right, just mentioning because i (possibly rahsly) gave commit access to eugene & alan from catalyst recetnly
08:31:30 <richardm> better change my policy ")
08:31:37 <dm> hehe
08:31:44 <dobedobedoh> Do we need to propose and find a seconder? That's probably a bit OTT for the moment
08:31:47 <Mjollnir`> that's mcnatty eh
08:31:51 <Mjollnir`> that's awesome
08:31:55 <aguri> richardm: alan!  yeah i retract my earlier proposal ;)
08:32:00 <iarenaza> Oops, looks like pidgin crashed on me...
08:32:07 <dm> I don't think there's a problem - as long as the person that "vouches" for the person that gets access monitors their commits for a bit to make sure
08:32:18 <dobedobedoh> iarenaza: The minutes will be online at the end of the meeting
08:32:35 <iarenaza> thx
08:33:20 <fmarier> would anybody have any objection to moving to commit access and developer status expiring after a year, but renewable indefinitely by the developer?
08:33:22 <Mjollnir`> i think monitoring is a good idea
08:33:33 <anitsirk> dm: shouldn't that happen anyway also for those who are being voted on, e.g. for a bit of time before they are up for voting to get commit access?
08:33:36 <dobedobedoh> If we can do that, that'd be a good idea
08:33:39 <fmarier> basically this is to reduce inactive developers who don't care
08:33:56 <fmarier> as long as people want to hang on to their credentials, they can
08:33:58 <Mjollnir`> sounds reasonable to me
08:33:58 <iarenaza> fmarier: i think that's a good idea
08:34:04 <dm> anitsirk: yes - but after giving access we should still monitor for a little bit
08:34:11 <dobedobedoh> dm: Definately
08:34:25 <anitsirk> dm: sure.
08:34:28 <iarenaza> otherwise you can end up with dozens of inactive accounts (and the potential risk of being compromised)
08:34:35 <dm> fmarier: +1
08:34:40 <fmarier> ok, so to sum things up:
08:34:43 <dm> moodle suffers with this problem
08:34:52 <dm> will hopefully be cleaned up with 2.0 changes
08:34:53 <fmarier> 1) new developer proposed at developer meetings
08:34:59 <dm> (changes after 2.0 release I mean)
08:35:08 <fmarier> 2) people get to vote based on contributions
08:35:17 <dobedobedoh> #agrere fmarier> 1) new developer proposed at developer meetings
08:35:19 <fmarier> 3) the sponsor monitors commit for a bit afterwards
08:35:22 <dobedobedoh> #agree fmarier> 1) new developer proposed at developer meetings
08:35:40 <dobedobedoh> heh - does everyone agree before I #agree those ;)
08:35:46 <fmarier> 4) developer status expires after a year but is renewable indefinitely
08:35:57 <Mjollnir`> agree
08:36:03 <richardm> yep
08:36:14 <iarenaza> I know this is a bit controversial, but will there be a policy to remove commit access before the account expires?
08:36:18 <rkabalin> agree
08:36:29 <dobedobedoh> and 5) ultimate decision is with the lead developer ?
08:36:47 <richardm> iarenaza: do you think we need one?
08:36:54 <iarenaza> I hope not so
08:37:08 <fmarier> i think we just handle that on a case by case basis if it comes up
08:37:13 <iarenaza> ok
08:37:41 <anitsirk> well, wouldn't you need a policy and if it is "handled case by case" if an account is for indefinitely after the first year of trial period?
08:37:56 <aguri> "people get to vote based on contributions" does this == people already with commit
08:37:59 <fmarier> anitsirk: actually i meant you can renew every year
08:38:10 <dobedobedoh> aguri: Yeah - that's what was suggestee
08:38:14 <fmarier> but you can always renew
08:38:24 <anitsirk> ah. that makes more sense. thanks fmarier
08:38:37 <fmarier> aguri: i'm not sure i understand your question
08:38:54 <fmarier> you mean "who are the voters" ?
08:39:38 <aguri> fmarier: yeah, perhaps i misunderstood your intent
08:39:38 <richardm> let's get all our mates to stack the irc meetings!
08:39:39 <anitsirk> who decides on whether the lead developer's developer status is renewed or not if the lead developer always has the last word? (just hypothetical)
08:39:57 <aguri> governance group
08:40:17 <fmarier> anitsirk: any developer can renew their status
08:40:21 <aguri> and above them, president bush
08:40:34 <fmarier> we're talking self-renewal
08:40:49 <fmarier> this is just so that inactive people will let theirs expire
08:41:22 <dobedobedoh> And are we talking about only those present at a meeting get to vote - we're missing a few today after all
08:41:54 <anitsirk> i would say only those at the meeting because otherwise you may be chasing people
08:41:58 <fmarier> dobedobedoh: i think that makes sense
08:42:08 <dobedobedoh> Okay. I've got 6 points for agreement. Any more to add?
08:42:17 <anitsirk> if somebody objects, they can raise an agenda point for the next meeting
08:42:28 <fmarier> the people that will be running for it will be on the agenda so anybody can voice their objections prior to the meeting to another developer
08:42:29 <iarenaza> anitsirk: good idea
08:42:44 <dobedobedoh> #agree 1) new developer proposed at developer meetings
08:42:44 <dobedobedoh> #agree 2) people get to vote based on contributions
08:42:44 <dobedobedoh> #agree 3) the sponsor monitors commit for a bit afterwards
08:42:44 <dobedobedoh> #agree 4) developer status expires after a year but is renewable indefinitely
08:42:48 <dobedobedoh> #agree 5) ultimate decision is with the lead developer
08:42:50 <dobedobedoh> #agree 6) those present at a developer meeting with commit access are entitled to vote.
08:42:59 <dobedobedoh> Anything more to discuss on commit access policy?
08:43:01 <fmarier> do we need (5) ?
08:43:24 <rkabalin> 5 and 2 should be combined
08:43:45 <iarenaza> dobedobedoh: does the developer have to do anything to renew the commit access? If so, what?
08:44:02 <iarenaza> (just to make it clear for people)
08:44:08 <Mjollnir`> voting = majority rule ? or consensus ? r single transferable vote? por something else
08:44:10 <dobedobedoh> fmarier had the suggestion - I presume that there's a way within gitorious to set expiry?
08:44:12 <fmarier> iarenaza: click on a link in email
08:44:22 <iarenaza> fmarier: good enough for me :)
08:44:46 <fmarier> Mjollnir`: maybe we start with consensus?
08:44:51 <dobedobedoh> So drop (5) or combine with (2)? Probably enough just to drop it
08:44:59 <richardm> yep drop 5
08:45:04 <Mjollnir`> i think consensus too
08:45:13 <dobedobedoh> #agree Drop point 5
08:45:15 <dobedobedoh> I think consensus
08:46:21 <dobedobedoh> Shall I may an agree point on that?
08:46:37 <dm> consensus is good - if a person objected they would need to give a reason though
08:46:41 <aguri> governance group will need to ok this i suspect
08:47:01 * aguri doesn't imagine it will be a problem tho
08:47:05 <dm> yeah
08:47:07 <anitsirk> did they have anything to do with giving commit access up to now or do you mean the procedure, aguri?
08:47:13 <dm> shuold be straight forward
08:47:58 <dobedobedoh> #agree 7) consensus decision rules
08:48:08 <dobedobedoh> Anything more to discuss on commit access policy?
08:48:48 <dobedobedoh> Do we have time for testing and code review; and forum code of conduct?
08:49:20 <Mjollnir`> is anyone at all interested in the phpunit branch being merged, and startin to write tests ?
08:49:28 <Mjollnir`> or are we happyw ith just doing functional testing
08:49:48 <fmarier> Mjollnir`: more tests would be great
08:50:17 <Mjollnir`> it probably needs a bit of work to get it up to date with master .. so i will do it if people can commit to writing tests
08:50:23 <fmarier> so i've summarized this commit access discussion here: http://wiki.mahara.org/Developer_Area/Git_Repository_Policy
08:50:29 <Mjollnir`> i would love to have a code coverage policy eventually
08:50:46 <dobedobedoh> And similarly documentation policy
08:50:57 <Mjollnir`> yeah
08:51:00 <Mjollnir`> documentation = woe
08:51:17 <dobedobedoh> I've not succeeded in getting mahara to go through any of the main phpdoccers and come out in a reasonable format yet
08:51:42 <Mjollnir`> i have a proposal for that, but let's finish testing first
08:52:00 <Mjollnir`> if people want to  and can commit to writing tests, i'll merge the phpunit branch, anyone interested ?
08:52:06 <Mjollnir`> or move on :)(
08:52:09 <Mjollnir`> -(
08:52:17 <dobedobedoh> I'd be interested in writing tests
08:52:35 <rkabalin> me too
08:52:35 <dm> I think it should go in
08:52:58 <dm> it would be nice to have a policy for new features to require tests before commit to head...but that might be going too far at this stage
08:53:05 <dobedobedoh> #idea should large features include reasonable testing in the future?
08:53:10 <dobedobedoh> snap
08:53:13 <dm> heh
08:53:19 <Mjollnir`> i would love that
08:53:23 <dm> problem with that is funding
08:53:32 <Mjollnir`> that's a misnomer i think
08:53:42 <dm> maybe
08:53:43 <Mjollnir`> if it is a core policy , then it becomes a non negotiable part of a quote
08:53:58 <dm> except some clients will say "we don't want to pay for it to go into core"
08:54:11 <dm> so if it's quoted as a seperate item it gets excluded
08:54:12 <aguri> Mjollnir`: increasing the cost of development is not a good way to encourge funding - at this stage of the project
08:54:19 <aguri> so that needs to be balacned
08:54:26 <Mjollnir`> dm: sure, that's ben a problem for ages and the way to get around that is to convince them of hte long term costs
08:54:44 <dm> yeah - found that really hard to do with Intel(one example)
08:55:24 <dm> we try - and I think it should be something we aim for, but shouldn't be a hard requirement for inclusion in head
08:55:30 <dm> (at this stage anyway)
08:55:33 <dobedobedoh> Also, if the tests are there, it should be easier for non-catalyst to get features master to some degree
08:56:04 <Mjollnir`> i think we need to be a little bit careful about sacrificing quality hrere
08:56:12 <Mjollnir`> not just testng
08:56:25 <Mjollnir`> but in general
08:56:26 <dm> always
08:56:37 <dm> if the quality isn't there it shouldn't go in head
08:56:39 <dm> that's easy
08:57:03 <richardm> i'm a little bit worried about time spent maintaining tests (and ultimately catalyst has to pay for that, so the governance group will have an opinion on this)
08:57:14 <fmarier> if the testing requirements are low enough (e.g. it should have a basic selenium test) then i think there's no problem in making that a requirement
08:57:18 <Mjollnir`> maintaining?
08:57:25 <fmarier> it would only increase quotes by an hour or two
08:57:37 <dm> ?
08:57:39 <dobedobedoh> selenium tests are pain to maintain :\
08:57:51 <dm> fmarier: I would expect tests to take a lot longer than an hour for features
08:57:54 <Mjollnir`> i definitely prefer phpunit to selenium :)
08:57:57 <dm> to do them well.
08:58:02 <richardm> dobedobedoh: yeah true, i had to change a few recently when link text changed
08:58:32 <fmarier> dm: yes, to do them well (which we should encourage) but we could have a very minimal requirement
08:58:40 <fmarier> so that it's not too onerous
08:58:56 <dm> that's hard to define
08:58:58 <dobedobedoh> Initially, having the phpunit stuff in master would be a good starting point
08:59:00 <fmarier> the existing test suite is not all that great, but it has caught a few bugs already
08:59:06 <dobedobedoh> Without that, we can't write any tests
08:59:19 <dobedobedoh> (except selenium)
08:59:47 <dobedobedoh> We seem to have pretty much exhaused our 1.5 hrs
09:00:14 <fmarier> btw, you should all get launchpad emails about membership expiring for all of us 1 year after you were made a member of the team
09:00:23 <fmarier> i'll be expiring first (next month)
09:00:30 <dm> cool!
09:00:36 <fmarier> so i'll get to test the self-renewal stuff :)
09:00:45 <lamiette> good test case
09:00:52 <fmarier> and if it doesn't work, i'll have to beg richardm to get me back into the team
09:00:57 <iarenaza> XD
09:01:01 <dobedobedoh> So should we agree to phpunit going into master and then see how we fair over the next month with writing tests?
09:01:03 <richardm> good luck with that fmarier
09:01:14 <dm> +1 to phpunit going in master
09:01:19 <aguri> fmarier: i think something to work towards would be a documented set of quality assuarance requirements for things to get into core.
09:01:22 <aguri> whatever might go in that
09:01:22 <fmarier> richardm: i can bribe you with some good Quebec beer I'm sure
09:01:48 <richardm> sure, if it doesn't do any harm & create more work for me i have no objection to phpunit
09:01:58 <lamiette> fmarier: wouldn't you need to be voted back on the island?
09:01:58 <Mjollnir`> theoeretically it should create less work :)
09:02:13 <dobedobedoh> #action Mjollnir` to merge phpunit branch into master
09:02:18 <Mjollnir`> yep
09:02:18 <richardm> Mjollnir`: cool, i'm happy
09:02:39 <dobedobedoh> Anything more to add before we discuss next meeting?
09:03:14 <fmarier> i think we need to discuss the next meeting, our time is up
09:03:18 <dobedobedoh> #topic Next Meeting
09:03:26 <dobedobedoh> A month from now is Wednesday 8th December
09:03:40 <dobedobedoh> We should probably switch our time
09:03:44 <lamiette> shall anything remaining to be pushed to the next meeting agenda
09:04:19 <dobedobedoh> how does 7:30PM GMT (Thursday @7:30AM NZST) sound?
09:04:26 <dobedobedoh> lamiette: I think that's the best idea
09:04:27 <fmarier> lamiette: i think we've covered pretty much everything
09:04:30 <Mjollnir`> fine for me
09:04:32 <rkabalin> sounds good
09:04:39 <dm> sounds good!
09:04:53 <dobedobedoh> Any objections to that time?
09:04:54 <aguri> thanks to lamiette and dobedobedoh for running this!
09:05:15 <anitsirk> i'd suggest to expand on the agenda points a little so that people may be able to prepare and wrap their head around the agenda topics, e.g. link to existing policy, example, proposed change; this may help to talk about these points in the proposed timeframe
09:05:30 <Mjollnir`> more preparataion would be good
09:05:34 <dobedobedoh> anitsirk: I agree - and for the proposer to put their name beside the item
09:05:34 <fmarier> can we move it to the week after?
09:05:49 <dobedobedoh> 15th/16th
09:05:57 <fmarier> yeah
09:05:57 <anitsirk> dobedobedoh: good idea
09:06:07 <dobedobedoh> works for me
09:06:12 <dm> fmarier: fine with me
09:06:14 <fmarier> anitsirk: good idea
09:06:22 <rkabalin> 16th would be better
09:06:29 <lamiette> that's fine for me
09:06:33 <anitsirk> fine
09:06:40 <Mjollnir`> difficult
09:06:51 <Mjollnir`> but i can if everyone else agrees
09:06:55 <dobedobedoh> So 7:30pm Wed 15th Dec (GMT) / 7:30am Thu 16th Dec (NZST)?
09:07:02 <Mjollnir`> wait, 15th or 16th
09:07:03 <dobedobedoh> Doesn't have to be a wednesday )
09:07:18 <anitsirk> 15th for europe
09:07:21 <anitsirk> 16th for nz
09:07:25 <rkabalin> 15th evening is diffcult for me
09:07:50 <rkabalin> what about 16th for europe?
09:07:53 <Mjollnir`> :(
09:08:03 <Mjollnir`> bad for me
09:08:14 <rkabalin> or 14th?
09:08:18 <fmarier> 14th/15th?
09:08:18 <anitsirk> 14th for europe and 15th for nz?
09:08:23 <Mjollnir`> 14th ok
09:08:25 <dobedobedoh> wfm
09:08:26 <anitsirk> :-)
09:08:38 <iarenaza> ok
09:08:46 <richardm> ok
09:08:47 <dobedobedoh> #agree next meeting 14th Dec @ 7:30pm GMT / 15th Dec @ 7:30am NZST
09:08:47 <Mjollnir`> ok are we done?  I MUST POWDER MY NOSE
09:08:48 <dm> ok
09:08:58 <dobedobedoh> We'll skip AOB unless anyone has anything really urgent to add
09:09:15 <anitsirk> Mjollnir`did you get off at the right train station?
09:09:26 <fmarier> dobedobedoh: are you going to dump the meeting log on the wiki?
09:09:49 <dobedobedoh> I'll dump the link to the logs
09:09:52 <dobedobedoh> I can dump the contents too
09:10:04 <fmarier> where is it hosted?
09:10:11 <dobedobedoh> meetbot.mylittleproject.co.uk
09:10:22 <dobedobedoh> on my vserver
09:10:41 <fmarier> would be good to have a file attachment on the wiki in case your vserver goes away
09:10:45 <dobedobedoh> sure thing
09:10:49 <dobedobedoh> I'll add it there too
09:11:13 <dobedobedoh> Could we have a CNAME for meetings.mahara.org or something similar?
09:11:14 <anitsirk> thanks for chairing, dobedobedoh and lamiette
09:11:26 <dobedobedoh> #action dobedobedoh to put minutes on wiki.mahara.org
09:11:30 <Mjollnir`> anitsirk: http://twitter.com/#!/kevinmoilar/status/2283891331170305
09:11:31 <fmarier> dobedobedoh: sure, send me details via email francois@mahara.org
09:11:35 <dobedobedoh> will do
09:11:40 <Mjollnir`> that is RIDICULOUS
09:12:00 <fmarier> hahaha
09:12:03 <anitsirk> Mjollnir`: awesome
09:12:08 * Mjollnir` at work now :)
09:12:15 <dobedobedoh> I'll end the meeting then unless there's anything pressing to add?
09:12:22 <Mjollnir`> #EOM
09:12:24 <iarenaza> nothing from here
09:12:26 <dobedobedoh> #endmeeting