07:03:09 <anitsirk> #startmeeting The 65th Mahara developer meeting
07:03:09 <mahara-meetbot> Meeting started Thu Apr 26 07:03:09 2018 UTC and is due to finish in 60 minutes.  The chair is anitsirk. Information about MeetBot at https://wiki.mahara.org/wiki/Developer_Area/Developer_Meetings/Chair_Duties#Meetbot_commands.
07:03:09 <mahara-meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
07:03:09 <mahara-meetbot> The meeting name has been set to 'the_65th_mahara_developer_meeting'
07:03:21 <anitsirk> Welcome to the 65th Mahara developer meeting. Please introduce yourself with #info
07:03:32 <anitsirk> #info anitsirk is Kristina Hoeppner, Catalyst in Wellington, NZ
07:03:42 <ghada> #info ghada is Ghada El-Zoghbi @ Catalyst IT, Sydney, AU
07:04:00 <rebeccablundell> #info rebeccablundell is Rebecca Blundell, Catalyst in Wellington, NZ
07:04:29 <anitsirk> robertl_ and Dmitrii_ ?
07:05:09 <robertl_> #info robertl_ is Robert Lyon, Catalyst in Wellington, NZ
07:06:01 <anitsirk> There are no outstanding items from the last meeting. Therefore, let's move on to the first topic.
07:06:02 <anitsirk> #topic Mahara 18.04
07:06:04 <anitsirk> drumroll
07:06:10 <anitsirk> champagne corks
07:06:17 <robertl_> woot!
07:06:18 <anitsirk> standing ovation.
07:06:20 <rebeccablundell> :D
07:06:20 <anitsirk> applause
07:06:24 <anitsirk> #info Congratulations to everyone. We released Mahara 18.04 on 6 April 2018. It comes with a lot of new features.
07:06:24 <anitsirk> http://manual.mahara.org/en/18.04/new.html
07:06:24 <anitsirk> #info Thanks you for having created new features and also fixed bugs for this latest version of Mahara.
07:06:24 <anitsirk> Do you have any questions for this release?
07:06:48 <anitsirk> It's been a rather big release again.
07:06:51 <ghada> so none of the LTI features went into it ?
07:07:06 <anitsirk> ghada: nope. not yet. they were not ready yet for inclusion.
07:07:15 <anitsirk> #info we needed to move quickly with 18.04 due to the GDPR
07:07:35 <anitsirk> #info Therefore, we released at the beginning of the month, which cut our normal release time short by a few weeks.
07:08:16 <ghada> I think I incorrectly told a client that the lti sso is working now in Mahara ...
07:08:29 <anitsirk> oh that
07:08:35 <anitsirk> sorry. that's been in there already since 17.04
07:09:01 <ghada> oh - then i didn't lie !! yeah!
07:09:16 <anitsirk> :-)
07:09:28 <robertl_> yeah it's the LTI being full replacement for xmlrpc is not yet done
07:09:29 <anitsirk> i meant the assignment submission features via LTI
07:09:38 <ghada> right
07:09:41 <Dmitrii_> #info Dmitrii_ is Dmitrii Metelkin, Catalyst in Melbourne, AU
07:10:02 <ghada> so how many sites have upgraded so far?
07:10:07 <anitsirk> it's also good to see the progress you guys over in Australia have made for the cloud compatibility
07:10:36 <anitsirk> ghada: we've upgraded the majority of the community sites (mahara.org will come soon) and a heap of demo sites.
07:10:47 <anitsirk> some client sites are under way to get done before the 25th of May.
07:11:17 <anitsirk> i suspect that more people in the EU will upgrade. It feels like there've been more immediate questions about upgrading than we normally get in the forums shortly after a release
07:12:22 <anitsirk> Do you have any other questions for the release?
07:13:33 <ghada> nope
07:13:57 <rebeccablundell> Has there been a good response from EU people about the GDPR stuff?
07:14:20 <anitsirk> I haven't heard much from the EU yet I'm afraid.
07:14:40 <anitsirk> They might all be heads down and upgrading rather than talking about it. ;-)
07:15:08 <anitsirk> The UK team may hear a bit more at today's "Mahoodle for assessment" event at Cranfield University.
07:15:21 <anitsirk> If there aren't any more questions, let's move on to the next topic.
07:15:24 <anitsirk> #topic Outlock for Mahara 18.10
07:15:24 <anitsirk> #info We already have a few new features merged into the future Mahara 18.10 branch:
07:15:24 <anitsirk> https://bugs.launchpad.net/mahara/+bugs?field.searchtext=&orderby=-importance&field.status%3Alist=FIXCOMMITTED&field.milestone%3Alist=85083&field.tag=nominatedfeature
07:15:24 <anitsirk> #info A number more are in active development. Amongst them are:
07:15:24 <anitsirk> #info 1. Isolated institutions that GregorA is working on: https://reviews.mahara.org/8518
07:15:24 <anitsirk> #info 2. Assignment submission via LTI: MattC from us is working on that.
07:15:25 <anitsirk> #info 3. Institution tags for which Maria is the main developer on that: https://reviews.mahara.org/#/q/owner:maria.sorica%2540catalyst-eu.net+status:open
07:15:25 <anitsirk> #info Soon we are going to start looking into more tagging features to add all content based on one or more tags to a page automatically
07:16:55 <anitsirk> There is some great things coming in 18.10 :-)
07:17:15 <rebeccablundell> cool
07:17:39 <anitsirk> #info The full UX review had to be stalled for a couple of reasons, but we are going to pick them up again starting next week and will put some things onto the roadmap for 18.10.
07:17:49 <robertl_> And because a bunch are already  started we should get them in :)
07:18:21 <anitsirk> robertl_ maybe even something of the timeline.
07:19:16 <robertl_> yes - we should have more time to get that progressed at a faster rate
07:19:29 <anitsirk> roisin, our student intern turned part-time-student-coming-in-during-holidays made some progress this week together with cecilia and robertl_ it looks like we are getting closer to having an initial feature that can be used. :-)
07:19:41 <Dmitrii_> is there any documentation about UX review?
07:20:03 <rebeccablundell> yes, I would be interested to see UX stuff too :)
07:20:07 <anitsirk> Dmitrii_: not shared publicly yet
07:20:45 <anitsirk> it is still very much in progress and doesn't have much / any documentation around the mock-ups as we had to put it on hold rather quickly
07:21:21 <anitsirk> but once we pick up again, i want to get some things out. also what roisin has done / what the idea is about the timeline. time has moved a bit too fast over the last couple of months to get all that sorted.
07:21:55 <Dmitrii_> ok. Makes sense.. thanks
07:22:24 <anitsirk> i do want to make it available soon so others can also ponder it. will let you know once we have it.
07:23:44 <anitsirk> I guess that's it for this topic. Or are there any other things to discuss?
07:24:11 <anitsirk> robertl_ I suspect PHP 7.2 will become a bigger area to watch out for?
07:24:35 <robertl_> yes, anything above php 7.1 will cause some headaches
07:24:46 <rebeccablundell> Oh, yeah, I never followed up after I accidently upgraded and everything broke :/
07:25:30 <rebeccablundell> I can do it again and bug report if people would like...
07:25:43 <Dmitrii_> hehe " accidentally upgraded " :) the good motivation
07:25:44 <robertl_> yes that would be great
07:25:44 <anitsirk> rebeccablundell: yes, please. but maybe in a VM? ;-)
07:26:05 <rebeccablundell> Ah, yes, a VM could be my friend
07:26:16 <robertl_> it is easier to fix things when the problem is described :)
07:26:50 <rebeccablundell> :)
07:27:15 <anitsirk> #idea One thing I forgot to mention: We are looking into upgrading Bootstrap 3 to Bootstrap 4. By the amount of work involved, it looks more like something for 19.04, but we'll know a bit more in a few weeks once our front-end devs had more time to investigate.
07:28:00 <anitsirk> panels are a thing of the past and long live the cards. so lots of rewriting besides all the other class changes. apparently, panels and the navigation are going to be our biggest concerns.
07:28:08 <Dmitrii_> https://www.tecmint.com/install-different-php-versions-in-ubuntu/ - useful for those who wants to have several php version in one VM (or locally)
07:28:17 <Dmitrii_> https://www.tecmint.com/install-different-php-versions-in-ubuntu/ - useful for those who wants to have several php versions in one VM (or locally)
07:28:51 <anitsirk> cool. that info will come in handily.
07:28:58 <rebeccablundell> thanks Dmitrii_
07:30:08 <anitsirk> #topic To text or not to text?
07:30:09 <anitsirk> #idea We've had the Mahara developer meetins for a while now. Today marks the 65th. We've always held them on IRC because the official chat channel for Mahara is on there. The question is: Shall we continue using IRC or move to a voice channel, webinar style like so we can talk rather than type and discuss the agenda items?
07:31:05 <Dmitrii_> nothing stops us to have a trial in a new format...
07:31:36 <rebeccablundell> I like the idea of trying.
07:31:38 <robertl_> text is useful when the kids are watching 'my little pony' in the background - but trying new format sounds ok
07:31:57 <anitsirk> lol
07:32:19 <Dmitrii_> haha :) kids... sure kids...
07:32:26 <anitsirk> too there aren't noisecancelling microphones
07:32:26 <robertl_> hehe
07:33:00 <anitsirk> shall we give it a go for the next meeting and see how it goes?
07:33:16 <rebeccablundell> I can lend you an SM58 robertl_ - best you can get for noisy places, I'm afraid!
07:33:32 <ghada> the problem is the background noise that you guys will hear ...
07:33:42 <ghada> but, let's try it
07:33:56 <Dmitrii_> +1
07:34:24 <anitsirk> #action anitsirk to look into web conference tool to use for next dev meeting.
07:34:38 <anitsirk> There are a few options that spring to mind. Just need to select one and then go from there.
07:34:52 <anitsirk> which brings us nicely to the next topic.
07:34:59 <anitsirk> #topic Next meeting an chair
07:35:15 <anitsirk> How about 7 June 2018 at 7 UTC? https://www.timeanddate.com/worldclock/fixedtime.html?iso=20180607T07&p1=1440
07:35:47 <anitsirk> That's a little over a month (we could also go with the week after) but still plenty time before the next feature freeze
07:36:53 <rebeccablundell> Thursday's don't always work for me (choir practice), but I didn't sign up for the next concert, so I think it's OK
07:37:11 <anitsirk> we can move to a different weekday, like tuesday or wednesday
07:37:37 <anitsirk> so: which weekday would be better? doesn't matter to me
07:37:54 <ghada> doesn't matter to me either.
07:38:07 <anitsirk> Dmitrii_ and robertl_ ?
07:38:09 <robertl_> either Wed or Thurs works for me better
07:38:12 <rebeccablundell> all OK for me except maybe Thurs
07:38:29 <anitsirk> then what about wednesday either the 6th or the 13th of june?
07:38:35 <Dmitrii_> Wed is better for me
07:39:33 <rebeccablundell> either or..
07:40:00 <Dmitrii_> Sorry I have to go off line...
07:40:09 <anitsirk> thanks for coming, dima
07:40:48 <anitsirk> How about the 13th then (it's not a friday :-) )?
07:40:55 <rebeccablundell> hah
07:41:21 <anitsirk> and while you are pondering the date, who wants to chair?
07:41:47 <robertl_> wed 13th sounds ok for me
07:41:55 <rebeccablundell> I could, if someone will tell me the basics :)
07:42:25 <anitsirk> thanks, rebeccablundell. we can talk about it beforehand since it'll be different to previous meetings as we are not using irc.
07:42:44 <anitsirk> #info The next Mahara developer meeting will take place on 13 June 2018 and will be chaired by rebeccablundell
07:42:46 <anitsirk> https://www.timeanddate.com/worldclock/fixedtime.html?iso=20180613T07&p1=1440
07:43:01 <anitsirk> does anybody have any other business to discuss?
07:43:10 <rebeccablundell> yep, all good. I have experience chairing spoken meetings!
07:43:17 <robertl_> we could even do a test run with a few of us
07:43:18 <anitsirk> :-)
07:44:03 <anitsirk> yup, good idea. but we all need to connect from home instead of the office
07:44:10 <ghada> i don't have other business
07:44:15 <anitsirk> to check bandwidth etc.
07:44:16 <anitsirk> thanks, ghada
07:44:22 <anitsirk> me neither for once
07:44:54 <robertl_> nothing else from me
07:44:56 <ghada> anitsirk - I'm a bit surprised
07:45:24 <anitsirk> me, too, ghada. me, too. and you know why i don't have one? Because I made the meeting question a proper item. :-D
07:45:50 <anitsirk> Then thank you very much for coming along to our developer meeting. Have a nice evening.
07:45:53 <anitsirk> #endmeeting