07:01:22 <robertl_> #startmeeting 61st Mahara Developer Meeting
07:01:22 <mahara-meetbot> Meeting started Thu Jun 15 07:01:22 2017 UTC and is due to finish in 60 minutes.  The chair is robertl_. Information about MeetBot at https://wiki.mahara.org/wiki/Developer_Area/Developer_Meetings/Chair_Duties#Meetbot_commands.
07:01:22 <mahara-meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
07:01:22 <mahara-meetbot> The meeting name has been set to '61st_mahara_developer_meeting'
07:01:33 <robertl_> Hello everyone and welcome
07:01:40 <robertl_> Please introduce yourself with #info
07:01:47 <Gregor_Pirker> #info Gregor Pirker, Danube University Krems, Austria
07:01:50 <robertl_> #info robertl_ is Robert Lyon, Catalyst in Wellington, New Zealand
07:02:22 <cecilia> #info cecilia is Cecilia Vela, Catalyst in Wellington, New Zealand
07:02:41 <dmitriim> #info dmitriim is Dmitrii Metelkin from Catalyst Australia, Melbourne
07:03:53 <robertl_> ok looking at the agenda we begin with topics from last meeting
07:04:03 <robertl_> #topic dajan to get in touch with Emily Lenel and Nicolas Thorel to explain the CAS issues that they are having
07:04:23 <robertl_> but as dajan is not here yet we will have to skip that
07:05:01 <robertl_> so that brings us straight into anitsirk's topic
07:05:20 <robertl_> Apologies from anitsirk - she is unable to make the meeting but she has left me some notes to post, so here goes:
07:05:31 <robertl_> Hello everyone. anitsirk here. Sorry I can't be here today. But I thought I send through an update and have robertl post it.
07:05:38 <robertl_> The development work for Mahara 17.10 is well under way.
07:05:51 <robertl_> #info Features that have already been accepted as new features in 17.10 are marked with "nominatedfeature" on Launchpad and can be viewed via https://bugs.launchpad.net/mahara/+bugs?field.milestone%3Alist=81641&field.tag=nominatedfeature
07:06:02 <robertl_> #link https://bugs.launchpad.net/mahara/+bugs?field.milestone%3Alist=81641&field.tag=nominatedfeature
07:06:27 <robertl_> please feel free to take a look at that
07:07:14 <robertl_> #info At the moment, the Catalyst team in Wellington is focussing on the AAIM project: Advanced Analytics in Mahara. That is a project started by University of Sussex and Dublin City University to expand the statistics in Mahara.
07:07:33 * robertl_ puts robertl_ hat on again
07:07:52 <robertl_> yep this is the work I'm involved with at the moment
07:08:04 <robertl_> #info You can find out more about the project in a recent presentation by DCU and U of Sussex at https://www.slideshare.net/enhancingteaching/aaim-project-advanced-analytics-in-mahara
07:08:18 <robertl_> #info The statistics area will be greatly expanded and also consolidated to provide easier navigation and more unified navigation for site and institution statistics.
07:11:52 <robertl_> #info You can see all related functionality that is in review and that has already been merged into the codebase at https://reviews.mahara.org/#/q/project:mahara+branch:master+topic:Analytics
07:11:52 <robertl_> currently there is one patch already merged that has moved the stats from Admin home menu to the institution section for the site stats
07:11:52 <robertl_> so if people want to check that out and let me know if there are any problems with that that would be good
07:11:52 <robertl_> so I've done lots of taking - anyone have any questions?
07:12:28 <cecilia> no questions from me
07:13:19 <dmitriim> no questions
07:13:19 <robertl_> Another bit of big work we are taking on is updating the elasticsearch stuff
07:13:22 <robertl_> #info We are also upgrading Elasticsearch to version 5.
07:14:19 <robertl_> currently we use 1.7.x elasticsearch server and Elasitca to connect with it - but 1.7 is way old so are trying to get Mahara working with 5.x
07:14:38 <robertl_> and looking to use the elasticsearch-php plugin instead
07:15:32 <robertl_> we are hoping to make it more integrated with Mahara so we can farm off complex searches to it rather than doing them on the database level
07:16:05 <robertl_> and to begin with we are wanting to do more complex statistics reports this way
07:16:56 <robertl_> if people have ideas of what other bits of Mahara would benefit from elasticsearch feel free to mention them here
07:18:20 * robertl_ feels the view access rules could benefit
07:18:28 <ghada> #info ghada is Ghada El-Zoghbi at Catalyst IT, Sydney.
07:18:44 <robertl_> hi ghada
07:18:53 <ghada> hi robertl_
07:18:56 <ghada> sorry, was in a meeting
07:19:40 <robertl_> it's mostly been me posting info from anitsirk as she is not present
07:19:49 <robertl_> and then me commenting on things :)
07:21:01 <robertl_> if no one has thoughts on elasticsearch I'll move onto LTI and assignment submission
07:21:14 <robertl_> #info Another piece of work we are engaged in is the expansion of the LTI functionality to also include assignment submission. You can read the ideas at https://wiki.mahara.org/wiki/Developer_Area/Specifications_in_Development/MNet_replacement/LTI_implementation soon we'll make a proposal for the initial development phase.
07:21:54 <robertl_> The proposal will presented to Instructure who's involved in this project as funding partner.
07:22:57 <robertl_> One of the long term goals since I stared is to remove MNet from Mahara and to do that we need to move the assignment submission functionality to webservices and LTI in particular
07:23:42 <robertl_> initially that will mean duplicating the existing functionality but going forward would mean more options/goodness
07:24:40 <robertl_> So if there are things that you want to see Assignment Submission do please let us know
07:26:36 <ghada> do you think we'll have most of this done for 17.10 ?
07:27:32 <robertl_> Not sure - I'd like to be well down the track on getting existing functionality ported to LTI
07:28:51 <robertl_> but who knows as I've not yet looked into how complex that is on the Mahara side
07:29:11 <robertl_> nor what needs to be set up on the Moodle/Canvas/etc side
07:29:49 <ghada> ok
07:30:15 <robertl_> I do believe that Instructure are keen to gets things done
07:30:37 <robertl_> so things should go at a faster pace than in the past
07:30:42 <ghada> are they funding this phase as well?
07:31:17 <robertl_> I believe they want to
07:31:45 <ghada> excellent!
07:32:35 <robertl_> any other questions about this? or shall we move on?
07:32:43 <ghada> let's move on
07:32:57 <robertl_> #info Our Australia team is making progress on getting Mahara ready for cloud storage. If you want to help test this feature, you can find it at https://reviews.mahara.org/#/c/7676
07:33:15 <robertl_> would anyone from au want to talk to this?
07:33:52 <ghada> well, i've had a go at reviewing it.
07:34:17 <ghada> Ilya - the dev who create it - has resigned .
07:34:30 <ghada> so, someone will need to pick up the work.
07:34:51 <ghada> unfortunately, i can't pick it up as I'm up to my ears in other work.
07:35:01 <robertl_> ghada, from your testing - was it mostly ok
07:35:10 <robertl_> or was it needing lots of love?
07:35:33 <dmitriim> me too... as there are plenty of client work
07:35:37 <ghada> i didn't really get a chance to test it in action
07:36:13 <ghada> the testing was just generic testing to get my feet wet ..
07:36:20 <dmitriim> ghada, how much work still needs to be done?
07:36:52 <ghada> I'm not sure to tell you the truth dmitriim
07:37:04 <dmitriim> I'm really keen to work on it if I get a chance
07:37:28 <ghada> that would be great dmitriim ... if you get the chance
07:37:40 <robertl_> hmm, I might see if I can get our tester to do some basic testing as well
07:37:56 <ghada> that would really help robertl_
07:38:43 <dmitriim> but code still need some love, right?
07:38:44 <robertl_> I'd like to keep that patch ticking along even if people can't work on it at the moment
07:38:52 <ghada> yes dmitriim
07:39:26 <dmitriim> ok
07:40:10 <ghada> These other 2 plugins will also need to be properly tested:
07:40:17 <ghada> https://git.catalyst-au.net/elearning/mahara-module_objectfs
07:40:18 <ghada> https://git.catalyst-au.net/elearning/mahara-module_aws
07:40:29 <ghada> I've put a note in the review
07:42:12 <robertl_> and as per usual
07:42:14 <robertl_> #info There are a few more new features in review at the moment. So take a look there. It would be fantastic if you helped test them at https://reviews.mahara.org
07:42:46 <robertl_> I realise people are busy so is more if you get time thing
07:43:12 <robertl_> #info You can still submit code for new features until the end of July 2017 to be taken into consideration for the October release.
07:43:45 <robertl_> and that concludes my cutting/pasting of anitsirk's info :)
07:44:08 <ghada> good job robertl_
07:44:20 <robertl_> so brings me to ask does anyone else have a topic to discuss?
07:44:49 <ghada> i have a question...
07:45:11 <ghada> is there a video on setting up lti integration with canvas ?
07:45:14 <ghada> or Moodle?
07:45:42 <robertl_> good question
07:46:58 <ghada> it's no big deal. i just thought it would be nice to actually see it in action
07:46:59 <robertl_> and I'm sure there should be
07:47:17 <ghada> kristina had done one for smartevidence.
07:47:18 * robertl_ can't find anything in manual
07:47:30 <ghada> i just thought she would have done one for the lti integration
07:47:47 <robertl_> I only see http://manual.mahara.org/en/17.04/external/externalapps.html
07:49:13 <robertl_> but I'm sure when she reads over the meeting notes she will either make one and/or point you to it :)
07:49:25 <ghada> I'm sure she will!
07:49:40 <ghada> well, i don't have anything else.
07:50:17 <robertl_> anyone else with something?
07:50:54 <robertl_> ok then
07:50:59 <robertl_> #topic Next meeting and chair
07:51:07 <Gregor_Pirker> Yes, I have one question, I plan to upgrade the mahara´s on the University krems in the middle of July at the moment I have some problem´s with a Mahara 16.10.1 1.) With Mahara Mobile App, IPhones have no problems to connect but Androids cannot. 2.) I cannot insert a Link in A Picture in the editor mode of a view. Is that solved in the high Versions of Mahara or should I open a topic iin the forum?
07:52:40 <robertl_> Gregor_Pirker, how do you mean insert a link in a picture?
07:53:27 * robertl_ is not sure what you are meaning there
07:54:01 <robertl_> with the Mahara mobile issue what version of the app is being used?
07:54:04 <Gregor_Pirker> if I open a normal text block in a view and insert a Picture you cannot linked that
07:56:09 <Gregor_Pirker> please wait a second I will look for
07:57:29 <robertl_> are you meaning ending up with HTML like <p><a href="http://google.com"><img alt="dt.jpg" src="http://mahara-devel/artefact/file/download.php?file=293&amp;view=47&amp;embedded=1&amp;text=156" width="74"></a></p> ?
07:57:59 <robertl_> where the image has an <a> .. </a> link tag around it?
07:58:35 <Gregor_Pirker> yes
07:59:10 <Gregor_Pirker> If I insert it manuel with html it function but not with the editor symbol
07:59:59 <Gregor_Pirker> there are info about the version of the app but it was in the core of 16.10.1
07:59:59 <robertl_> That seems to work for me in 17.04+ if I add the image via icon and then focus on image and click the link icon
08:00:36 <Gregor_Pirker> thanks
08:00:39 <robertl_> make a forum post about it to remind me to check with other version
08:00:48 <robertl_> versions that is
08:01:33 <Gregor_Pirker> :-) okay i will do it
08:01:48 <robertl_> with the Mahara app - I know there have been fixes to it since it was first released
08:03:08 <robertl_> so make a forum post about that mentioning your issues and I'll ask alexey, who has worked on the app more about it
08:03:48 <robertl_> #action robertl_ to follow up on Gregor_Pirker issues
08:03:54 <dmitriim> sorry guys.. I have to go... thanks robertl_
08:04:11 <Gregor_Pirker> okay :-) Maybe it can be soved if i make the update but i will make a post
08:04:21 <robertl_> ta
08:04:27 <Gregor_Pirker> thanks robertl_
08:05:13 <robertl_> ok back to the next meeting stuff
08:05:27 <robertl_> first: when will be a good time?
08:05:59 <robertl_> how does July 27th sound?
08:06:37 <Gregor_Pirker> sound´s good for me
08:06:40 <ghada> sure, that works
08:06:48 <cecilia> good for me
08:07:17 <robertl_> and at the same time 7:00 UTC ?
08:07:32 <ghada> ye[
08:07:34 <ghada> ye[
08:07:38 <ghada> i can't type!!
08:07:40 <ghada> yes, that works
08:08:09 <robertl_> sooo00ooo the big question - who wants to chair the meeting :)
08:08:10 <Gregor_Pirker> yes it is okay :-)
08:09:51 <robertl_> no one?
08:10:58 <robertl_> ok, I'll do it again
08:11:08 <robertl_> let you all off the hook ;)
08:11:15 <robertl_> #info The 62nd Mahara developer meeting will take place on 27 July 2017 at 7:00 UTC. Chair will be Robert Lyon. https://www.timeanddate.com/worldclock/fixedtime.html?iso=20170727T07&p1=1440
08:11:35 <robertl_> and so finally
08:11:35 <robertl_> #topic Any other business?
08:11:46 <robertl_> none from me
08:11:54 <cecilia> nothing from me
08:12:03 <Gregor_Pirker> none from me
08:12:09 <ghada> nope
08:12:35 <robertl_> Thank you very much for all the discussion today. See you in person, online and very latest at the next dev meeting.
08:12:44 <robertl_> #endmeeting