21:04:26 <anitsirk> #startmeeting
21:04:26 <anitsirk> Welcome to the 58th Mahara developer meeting and Happy New Year!
21:04:26 <anitsirk> Please introduce yourself by putting #info at the start of the line for the minutes.
21:04:26 <anitsirk> #info anitsirk is Kristina Hoeppner, Catalyst, Wellington
21:04:38 <robertl_> #info robertl_ is Robert Lyon, Catalyst in Wellington, New Zealand
21:04:51 <mingard> #info mingard is Jono Mingard, Powershop in Wellington, New Zealand
21:04:54 <anzeljg> #info anzeljg is Gregor Anželj, developer and translator, POVSOD, Ljubljana, Slovenia
21:05:18 <ghada> #info ghada_l is Ghada El-Zoghbi, Catalyst IT in Sydney, Australia
21:05:42 <cecilia> #info cecilia is Cecilia Vela, Catalyst IT in Wellington, New Zealand
21:05:55 <anitsirk> #topic Congratulations
21:06:23 <anitsirk> This is not an official topic, but seeing that two of our devs have just become fathers and made it public online, I think I can say this.
21:06:40 <anitsirk> Congrats to aaronw and rkabalin and their partners.
21:06:49 <mingard> wow, congrats!
21:06:59 <anitsirk> hello Gregor_Pirker. we are just at the introductions.
21:07:05 <Gregor_Pirker> Hi all sry for the delay
21:07:07 <ghada> great news. congratulations!
21:07:08 <robertl_> congrats for them
21:07:16 <anzeljg> congrats to both
21:07:28 <anitsirk> aaronw was in December and rkabalin just now in January a few days ago.
21:07:40 <anitsirk> so if you see them bleary-eyed, you'll know why. ;-)
21:08:01 <anitsirk> #topic Topics from previous meeting
21:08:01 <anitsirk> There is only one.
21:08:01 <anitsirk> #info robertl_ Progress of 17.04 release
21:08:23 <robertl_> 17.04 is coming along nicely
21:08:36 <robertl_> We've been fixing issues with mahara mobile and have been progressing nicely eliminating the mochikit library
21:08:36 <robertl_> as well as fixing bugs as per usual
21:09:04 <robertl_> There are some nice new logo icons getting in as well
21:09:36 <robertl_> and there will be more stuff to get in as well
21:11:27 <anitsirk> yeah. so from our catalyst side we are looking into a revamped nav. you can see the mock-up at https://seafile.catalyst.net.nz/f/5a8f6b3d02/
21:12:25 <anitsirk> we also have a finalized idea for combining pages and collections and will share those mock-ups shortly. not sure if we can manage to get that in as well as it's much more work than the nav. we'll have to see.
21:12:37 <anitsirk> #info We are planning on revamping the navigation for Mahara to modernize it and make it more accessible than in the horizontal form.
21:12:37 <anitsirk> #info Wireframing is at https://seafile.catalyst.net.nz/f/5a8f6b3d02/
21:12:41 <mingard> cool - I'll be interested to see how well having expanding menu sections works in practice
21:12:56 <robertl_> The new team is working well
21:12:56 <robertl_> and we've been able to tap into help outside the Mahara team a bit more recently
21:13:22 <anitsirk> me too. :-) the idea for the nav is that it's context sensitive, meaning that when you are in an area in "Content" and you click the menu, it'll expand the "Content" area directly.
21:13:22 <anzeljg> how will it looked the combined menus of main nav and view creation menu of blocks?
21:13:48 <anzeljg> look (not looked)
21:14:10 <anitsirk> anzeljg: the main nav is tucked away entirely on the left with just the two or three icons depending on whether you are an admin or not.
21:14:52 <anitsirk> so you'll see more of your page content even
21:15:02 <robertl_> we could even swap them around :)
21:15:28 <anitsirk> robertl_ what do you mean?
21:15:37 <ghada> i having problems with my internet... did i miss anything?
21:15:55 <robertl_> have view creation as a top menu on that page
21:16:10 <robertl_> but I'm just been cheeky
21:16:16 <anzeljg> +1 for that
21:16:17 <mingard> if there are just a couple of icons (one if the "mahara" logo is considered a "home" link) would it work to just have a single menu link at the top rather than the sidebar? just a thought
21:16:40 <anitsirk> ghada: did you see the link to seafile?
21:17:03 <robertl_> mingard, you mean like the hamburger icon on mobile devices?
21:17:12 <mingard> yeah
21:17:14 <anitsirk> mingard: not sure about the mahara logo as people can have their own logo on the site and may not use the mahara one.
21:17:37 <anitsirk> mingard: the idea for the bar on the left was that in the future people could use it to "bookmark" other things that they want to have accessible quickly
21:17:39 <mingard> well, i mean that the majority of people understand that the site logo link goes to "home"
21:17:47 <mingard> ooh, OK that sounds really useful
21:18:10 <robertl_> yeah that would be cool
21:18:34 <robertl_> give the menu links a 'pin' option
21:18:39 <anitsirk> yep
21:19:01 <anitsirk> #idea use the new menu bar on the left to pin favorite places in Mahara.
21:19:03 <robertl_> record it against usr account prefs db table
21:19:12 <robertl_> yeah I can see that working
21:19:30 <anitsirk> robertl_ I think that was your idea originally. :-D
21:19:47 <anitsirk> no wonder it's a good one.
21:19:48 <mingard> just depends how granular you want to be (can someone pin an individual journal then delete it?)
21:20:42 <anitsirk> mingard: we haven't gotten to thinking further around that yet. that would be phase 2. want to see what people would like to see once we have it
21:20:57 <mingard> makes sense :)
21:20:58 <robertl_> hmm, pin artefacts/views etc, interesting idea
21:21:11 <anitsirk> it could be anything they'd like to pin, not just individual menu items, but potentially also their most favorite collection / journal etc.
21:21:30 <anitsirk> we can already pin artefacts in the login block with the "profile" tag, but not many use that as it's not so obvious.
21:21:34 <mingard> that's where i'd see it being most useful
21:22:04 <anitsirk> we'll keep that as follow-on feature for sure :-)
21:22:45 <anitsirk> any other questions?
21:23:05 <anitsirk> #topic Mahara re-branding
21:23:12 <anitsirk> so robertl_ already mentioned it briefly.
21:23:18 <anitsirk> #info As you may have seen by now, we re-branded at the beginning of the year introducing a new logo and brand colors for Mahara. We felt it was time to update our logo, make it more modern and bring it into the year 2017. :-)
21:23:25 <anitsirk> #info You can find the brand guidelines on mahara.org at https://mahara.org/view/view.php?id=133484
21:23:25 <anitsirk> https://mahara.org/view/view.php?id=133484
21:23:25 <anitsirk> The logos are there that you can use on Mahara itself and elsewhere. We'll upload a few more in the coming days, including the secondary logo (the one without the text).
21:23:25 <anitsirk> #info If you have any questions for the logo or other aspects of the brand, please let me know.
21:23:45 <mingard> looks awesome!
21:23:51 <anitsirk> so far we've received very positive feedback to the new logo and look. like yours. :-)
21:24:07 <anitsirk> it's been fantastic to see it appreciated so much. evonne did an outstanding job!!!
21:24:38 <anitsirk> anzeljg had a good question via email.
21:25:23 <anitsirk> #info In the past people could use the "Mahara font", i.e. KingsThings to write other words to look like Mahara.
21:26:02 <anitsirk> #info This is not possible anymore and not desirable. The text "Mahara" in the logo is a custom font derived from an existing one but that tweaked to make it look like it does right now.
21:26:10 <anzeljg> not necessarily words, but the name of their mahara installation, like "listovnik" in Slovenian, for listovnik.sio.si
21:26:24 <anitsirk> #info Any other text should be in OpenSans, which is the official font for Mahara.
21:27:21 <anitsirk> we did not create a full font.
21:27:45 <anitsirk> i think it would be good if other instances had their own distinct logo.
21:28:24 <anitsirk> <anzeljg> your Listovnik one looks great and fits the entire site.
21:28:53 <anitsirk> we don't use the custom letters anywhere else in Mahara, not even on mahara.org, but use OpenSans uncustomized instead.
21:29:03 <anzeljg> yeah. but initially we had the one with kingthings font
21:30:06 <anzeljg> and mahara 1.9 or 1.10 still runs on listovnik :(
21:30:15 <anzeljg> we are preparint hte upgrade thoug...
21:30:33 <anitsirk> anzeljg: sounds great to upgrade. all the best with it!
21:30:36 <robertl_> anzeljg, good to hear
21:31:02 <robertl_> lots of good things in since 1.10
21:31:09 <anzeljg> I know!
21:31:22 <anitsirk> #info We are also in the process of updating the logos in the existing themes of all supported versions of Mahara, but will also make the old logos available in case you can't just update the logo yet on your own instance.
21:32:10 <anitsirk> yeah. definitely lots of changes. it's always interesting using an old version of Mahara. I'm missing so much and see even subtle design changes. always moving forward...
21:32:29 <anitsirk> are there any questions for the logo or brand?
21:32:50 <anzeljg> will there be update to raw and/or default theme to reflect the updated branding?
21:32:59 <anzeljg> something similar to official webpage?
21:33:32 <anitsirk> #info anzeljg: raw should be as stripped down as possible. so that'll only mean color adjustments.
21:33:52 <anzeljg> ok
21:33:55 <anitsirk> #info for default: We haven't planned that yet but also at minimum color adjustments as the current green is not a brand color anymore
21:34:32 <anzeljg> I would like to see banner wich is used for search on mahara official webpage somwhere. I like it a lot!
21:34:37 <anitsirk> we are also slowly replacing logos online in the various services. i still have a few to go that i know of. but we'll keep our character logos for now.
21:35:02 <anitsirk> if you find a place where the logo should be changed, please let me know. i might miss a page or a few.
21:35:37 <anitsirk> so that was 1 new thing for 2017. Another one is that we have a developer to consider for +2 reviews.
21:35:38 <anitsirk> #topic Develop application from Dmitrii
21:35:38 <anitsirk> #info Dmitrii is a developer in the Catalyst Melbourne office and has done a bunch of Mahara work in the past year. So we thought it's time for him to put his application forward to become an approved dev.
21:35:38 <anitsirk> https://wiki.mahara.org/wiki/User:Dmitriim
21:36:31 <anitsirk> Unfortunately, Dima can't be here this evening. So we'll see if you have any questions that he would need to answer before all other approved devs present here can reach a decision.
21:37:01 <anitsirk> only other approved devs have a vote. today that would be robertl_, ghada and mingard. others can ask questions though :-)
21:37:39 <robertl_> I've been reviewing code from him for a while now and am happy with what he has been producing
21:37:40 <anitsirk> ghada is having trouble with her internet connection tonight so she may not be able to see everything here. but she already did the secret ballot via email.
21:37:58 <anitsirk> and she's workin with Dima and reviewing his code.
21:38:18 <ghada> i've worked with dima on the projects / contributions. I was his lead on most of the work. And he does impress me with how quick he picks up the code.
21:38:18 <mingard> i had a look through his patches and am also happy with it
21:38:57 <robertl_> and his getting out a security fix recently was very good
21:39:13 <ghada> yeah, that was good and very timely too.
21:39:47 <anitsirk> i verified a few of his patches and have seen his replies and how he approaches changes. it was great to see all that unfold in short spans of time and thoughtfully.
21:40:21 <anitsirk> yeah. he stepped up to the plate there and helped very quickly so robertl_ could then do the code review and we could get things out quickly.
21:40:55 <anitsirk> so, robertl_, ghada and mingard. what is your vote?
21:40:56 <ghada> does anyone have any questions for Dima?
21:41:07 <anitsirk> ghada. oops. yes. of course. questions first
21:41:15 <anitsirk> i don't have any.
21:41:16 <mingard> not me
21:41:24 <ghada> me too.
21:41:35 <anitsirk> anzeljg or Gregor_Pirker or cecilia?
21:41:37 <robertl_> nor I
21:41:41 <anzeljg> not from me
21:41:46 <cecilia> not me
21:41:47 <Gregor_Pirker> not from me
21:42:03 <ghada> vote then ?
21:42:10 <anitsirk> ghada: yes please
21:42:20 <ghada> yes from me.
21:42:30 <mingard> yes from me too
21:42:46 <ghada> drum roll...
21:42:47 <robertl_> I say 'yes' to giving the +2
21:42:50 <anitsirk> #info ghada, mingard and robertl_ had reviewed Dmitrii's patches and robertl_ and ghada had worked with him more closely. there were no questions for him.
21:43:16 <anitsirk> #info all three present approved Mahara devs agreed to give Dmitrii Metelkin +2 privileges.
21:43:26 <anzeljg> congrats to Dmitrii
21:44:03 <anitsirk> #agreed Dmitrii Metelkin becomes the latest approved Mahara dev and can now merge changes and do releases amongst other things. :-)
21:44:21 <anitsirk> yeah. congratulations also from me, Dima.
21:44:23 <ghada> excellent!
21:44:29 <anitsirk> i'll let him know.
21:44:39 <Gregor_Pirker> also from me :-)
21:45:17 <anitsirk> now for our favorite topic of the day...
21:45:24 <anitsirk> #topic Next meeting and chair
21:45:36 <ghada> navigation ?
21:46:02 <anitsirk> ghada: we talked about that earlier when robertl_ mentioned the 17.04 changes. you may have missed it.
21:46:16 <ghada> yes, i did miss it... oh well..
21:46:22 <anitsirk> it was better to discuss back then rather than wait as we were talking about 17.04 anyway.
21:46:29 <anitsirk> ghada: i'll send you the backlog.
21:46:36 <robertl_> anitsirk, does accepting dmitrii to +2 include for security patches?
21:46:37 <ghada> ok. thank you
21:46:37 <anzeljg> oh?? I thought gada wants to point out, that navigation is her favourite topic...
21:46:39 <anzeljg> sill y me
21:46:40 <anzeljg> :)
21:46:42 <anitsirk> robertl_ yes
21:46:52 <ghada> ;-)
21:47:01 <anitsirk> robertl_ It means all the things :-)
21:47:27 <anitsirk> i see what's happening here: procrastination as nobody wants to volunteer for the next chair ;-)
21:47:32 <anitsirk> anyway.
21:47:38 <anitsirk> i was thinking 8 March 2017: https://www.timeanddate.com/worldclock/fixedtime.html?iso=20170308T08&p1=1440
21:48:08 <robertl_> ok I believe I've added him to the right groups in gerrit now
21:48:17 <anzeljg> actullay I am in class on wednesdays otherwise I could volunteer
21:48:18 <anitsirk> we'll be busy in february finalizing new features and can talk individually. 8 March will be in feature freeze and moving towards release candidate.
21:48:23 <anitsirk> robertl_ lol.
21:48:47 <anitsirk> he should be in all that you are. and also on launchpad.
21:49:07 <robertl_> if that is not correct can he let me know asap
21:49:14 <anitsirk> anzeljg: would a different day be better then?
21:49:26 <anitsirk> robertl_ i'll mention it in my email
21:49:47 <anitsirk> it doesn't have to be wednesday. could be tuesday or thursday if that worked better for people
21:49:50 <anzeljg> tuesday or thursdy works better
21:49:58 <anitsirk> cecilia, robertl_, Gregor_Pirker, ghada, mingard?
21:50:11 <cecilia> any day is good for me
21:50:15 <mingard> i can't do tuesday but thursday works
21:50:21 <ghada> either is fine with me
21:50:59 <robertl_> thurs sounds fine to me
21:51:03 <Gregor_Pirker> I can both :-)
21:51:04 <anitsirk> so what about https://www.timeanddate.com/worldclock/fixedtime.html?iso=20170309T08&p1=1440 ?
21:51:10 <anzeljg> https://www.timeanddate.com/worldclock/fixedtime.html?iso=20170309T08&p1=1440 then and I volutneer
21:51:11 <anitsirk> thursday at today's time?
21:51:22 <ghada> yep, that works for me.
21:51:27 <mingard> works for me
21:51:52 <cecilia> for me too
21:51:59 <anitsirk> anzeljg: perfect. thank you so much.
21:52:01 <robertl_> ok by me
21:52:01 <Gregor_Pirker> for me too
21:52:01 <anzeljg> i guess procrastination can end now...
21:52:07 <anitsirk> :-)
21:52:29 <anitsirk> #agree anzeljg will chair the 59th Mahara developer meeting on 9 March 2017 at 8 UTC.
21:52:36 <anitsirk> #topic Any other business
21:52:41 <anitsirk> Does anybody have anything else?
21:52:51 <anzeljg> no
21:53:09 <Gregor_Pirker> I have one question
21:53:27 <anitsirk> go ahead
21:54:01 <Gregor_Pirker> annitsirk have post last meetin a link from provider for https zertificats please can you post again :-9?
21:54:04 <Gregor_Pirker> :-)
21:54:18 <anitsirk> Gregor_Pirker: do you mean Let's Encrypt?
21:54:27 <anitsirk> https://letsencrypt.org/
21:54:29 <Gregor_Pirker> i think so
21:54:45 <Gregor_Pirker> thanks :-)
21:54:48 <anitsirk> np.
21:55:06 <anitsirk> #info Let's Encrypt https://letsencrypt.org/ offers an easy way of generating SSL certificates.
21:55:16 <mingard> it's great :)
21:55:18 <mingard> no other business from me
21:55:41 <robertl_> no other business from me
21:56:01 <anitsirk> ghada or cecilia?
21:56:13 <ghada> none from me
21:56:20 <cecilia> not from me
21:56:46 <anitsirk> great. then that concludes our 58th Mahara developer meeting. Thank you very much everyone for coming. CU online.
21:56:50 <anitsirk> #endmeeting
21:56:51 <robertl_> dumm test line