07:56:13 <aarow_> #startmeeting 55th Mahara developer meeting
07:56:13 <mahara-meetbot> Meeting started Wed Aug  3 07:56:13 2016 UTC and is due to finish in 60 minutes.  The chair is aarow_. Information about MeetBot at https://wiki.mahara.org/wiki/Developer_Area/Developer_Meetings/Chair_Duties#Meetbot_commands.
07:56:13 <mahara-meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
07:56:13 <mahara-meetbot> The meeting name has been set to '55th_mahara_developer_meeting'
07:56:55 <sonn> #info sonn is Son Nguyen, Catalyst IT, Wellington, NZ
07:56:56 <aarow_> Good evening everyone. Please introduce yourself with the “#info” command
07:57:05 <robertl_> #info robertl_ is Robert Lyon, Catalyst in Wellington, New Zealand
07:57:06 <aarow_> #info aarow_ is Aaron Wells at Catalyst IT in Wellington, NZ
07:57:07 <ghada> #info ghada_l is Ghada El-Zoghbi from Catalyst IT, Sydney, Australia
07:57:25 <aarow_> anyone else here? :)
07:58:06 <aarow_> I guess not. Okay, let’s get started. Not a lot on the agenda for this meeting.
07:58:06 <antonella> #info antonella is Antonella De Chiara from France
07:58:21 <aarow_> Oh, hi Antonella!
07:58:43 <antonella> hello ^_^
07:58:46 <sonn> Hi Antonella
07:58:49 <aarow_> First, topics from previous meetings
07:59:08 <aarow_> #topic From previous meeting: aaronw_ and robertl_ to discuss the details of how to get a build branch for Mahara releases going to support those who can't use composer.
07:59:20 <robertl_> I've not had a chance to look into the composer issue as I've been on holidays and been busy with doing some smart evidence work
07:59:36 <aarow_> And I haven’t done much on it yet either
07:59:55 <aarow_> Okay, so I’ll table that one for next time. I think we mostly spec’ed it out pretty good at the last meeting
08:00:05 <robertl_> but I agree it needs to be done for the simplesamlphp stuff at the very least
08:00:15 <aarow_> yes
08:00:34 <aarow_> #action robertl_ and aaronw_ haven’t made progress on it yet
08:00:41 <aarow_> next topic
08:01:05 <aarow_> #topic From previous meeting: anitsirk to update the "How to contribute" wiki section that new features should have the topic set and include "(feature)".
08:01:24 <aarow_> #info Kristina marked this “done”: https://wiki.mahara.org/wiki/Developer_Area/Contributing_Code#Submitting_commits_for_review
08:01:31 <sl-yairspi> #info sl-yairspi is Yair Spielmann, Moodle and Mahara developer, Synergy Learning, Belfast, NI.
08:01:42 <robertl_> hi sl-yairspi
08:01:43 <aarow_> Hi sl-yairspi!
08:01:48 <sonn> Hi
08:01:50 <antonella> hi !
08:01:53 <sl-yairspi> Hi
08:02:04 <aarow_> So, those were the only items specified on the agenda for this meeting.
08:02:20 <robertl_> I guess new topics are in order
08:02:31 <aarow_> Actually next is supposed to be the next meeting and chair
08:02:38 <sonn> :)
08:02:47 <aarow_> Anyone want to volunteer to chair the next meeting?
08:02:54 <robertl_> well this will be a quick meeting :)
08:02:54 <aarow_> Or maybe we should schedule it first
08:02:58 <sonn> I can do it
08:03:04 <sonn> for the first time
08:03:17 <robertl_> sold to sonn, thanks
08:03:33 <ghada> this was a short meeting...
08:03:35 <aarow_> Oh, good
08:03:41 <sonn> yes it is
08:03:46 <aarow_> How about Wed September 7 for the next one?
08:03:51 <aarow_> 0800 UTC again?
08:04:03 <antonella> ok !!
08:04:12 <sonn> fine for me
08:04:19 <sl-yairspi> sounds good
08:04:21 <ghada> let me see what that will be sydney time
08:04:32 <aarow_> #topic Next meeting and chair
08:04:49 <aarow_> should be the same as this one, unless daylight saving kicks in
08:05:11 <aarow_> let me get the world time dealie for this...
08:05:41 <aarow_> http://www.timeanddate.com/worldclock/fixedtime.html?iso=20160907T08&p1=1440
08:05:50 <aarow_> #agreed sonn volunteered to chair
08:06:10 <aarow_> ghada: That’ll be 6pm in Sydney
08:06:24 <ghada> yep, that works for me.
08:06:42 <aarow_> #agreed Wed 7 Sept, 0800 UTC for the next meeting: http://www.timeanddate.com/worldclock/fixedtime.html?iso=20160907T08&p1=1440
08:06:46 <aarow_> okay, last topic
08:06:55 <aarow_> #topic: Any other business?
08:07:04 <aarow_> Anyone have anything else they want to discuss?
08:07:13 <robertl_> Minor security releases next week
08:07:19 <robertl_> It isn't long after the last minor release but a few secuirty bugs have surfaced and so we plan to do another release early next week - so if you know of things that need fixing get them in now :)
08:07:22 <sonn> yeah
08:07:43 <aarow_> #info We’re planning to do another security release early next week
08:08:13 <aarow_> Any others?
08:08:19 <ghada> behat tests?
08:08:28 <ghada> i'm really struggling with the instructions in the wiki
08:08:44 <aarow_> Oh, which part?
08:08:45 <ghada> can someone do a step by step instructions on how to set them up?
08:08:51 <robertl_> ghada, did you get the updated Firefox?
08:09:38 <aarow_> this page? https://wiki.mahara.org/wiki/Testing/Behat_Testing/Setup
08:10:52 <sonn> I have a docker image for behat testing
08:11:14 <sonn> I will add it to wiki page
08:11:23 <aarow_> You still there, ghada?
08:12:16 <ghada> yes, but still having a lot of issues
08:12:16 <ghada> i tried to update the wiki as I went along with issues i found
08:12:17 <ghada> for example, permissions were a big thing
08:12:17 <ghada> do you guys run them on a headless vm?
08:12:17 <ghada> if i could get my environment set up, i'd like to introduce behat tests to the patches i submit
08:12:18 <ghada> maybe you can document that. i don't mind using docker
08:12:18 <ghada> just anything that works.
08:12:19 <ghada> hi aaorw_: yes...
08:12:51 <aarow_> Oh, maybe I was having a network hiccup, I just now saw all your messages at once
08:13:05 <ghada> no, i think it was me.
08:13:09 <aarow_> I’ve also got some code I was working on to make jenkins run the tests in a Docker image
08:13:25 <aarow_> I should probably make that a bit more portable, and then we could use it for this
08:13:37 <aarow_> I’ll take a look at the wiki tomorrow and see if I can straighten that page out
08:13:47 <aarow_> #action aarow_ to update the Behat Testing setup page
08:13:51 <ghada> thank you aarow_ and sonn
08:14:42 <ghada> that's all i had.
08:15:28 <aarow_> okay, any other topics? :)
08:15:46 <robertl_> SmartEvidence
08:15:46 <robertl_> Work is in progress to get more of the SmartEvidence stuff fleshed out - there are some patches in reviews
08:15:53 <robertl_> https://reviews.mahara.org/#/q/status:open+project:mahara+branch:master+topic:%22Smart+evidence%22
08:15:58 <robertl_> Feel free to test them - but note it is still a work in progress - though I guess I'll need to write some test instructions :)
08:16:13 <robertl_> I guess I should do that tomorrow
08:16:14 <aarow_> #topic: SmartEvidence has a bunch of patches in review: https://reviews.mahara.org/#/q/status:open+project:mahara+branch:master+topic:%22Smart+evidence%22
08:16:29 <aarow_> #info Still in WIP though
08:17:05 <robertl_> It adds a evidence matrix page to a collection that uses smart evidence
08:18:12 <ghada> so that collection shows up in the matrix - is that what you mean?
08:19:14 <robertl_> it adds a 'page' to a collection that displays all the pages on it horizontally and the competencies vertically
08:20:13 <ghada> ah, so the matrix is made up of the pages in the collection
08:20:52 <robertl_> yep - it's a big table with first row the page titles and the first column the competencies
08:21:07 <ghada> it'll be great to get smartevidence into mahara!
08:21:16 <aarow_> yep, finally
08:21:31 <aarow_> Any other topics?
08:21:38 <ghada> nope
08:22:31 <robertl_> do we have any feature freeze like stuff coming up?
08:22:34 <sonn> none from me
08:22:46 * robertl_ sees what the timeline looks like
08:22:51 <aarow_> We are now, in fact, in feature freeze
08:23:45 <aarow_> for the 16.10 release
08:23:59 <robertl_> so release candidate 1 should be out at the end of this month
08:24:17 <aarow_> #topic: Feature freeze for 16.10 is on
08:24:35 <robertl_> wow that has come up quick
08:24:38 <aarow_> #topic 16.10rc1 should be out at the end of this month
08:24:41 <aarow_> yeah, it always does
08:24:43 <aarow_> :)
08:25:05 <aarow_> Okay, If no one has any other topics…
08:25:14 <robertl_> none from me
08:25:54 <aarow_> Then I declare this meeting closed
08:25:57 <aarow_> #endmeeting