#mahara-dev: 53rd Mahara developer meeting

Meeting started by anitsirk at 08:01:58 UTC (full logs).

Meeting summary

    1. anitsirk is Kristina Hoeppner, Catalyst in Wellington, shaky NZ (anitsirk, 08:02:23)
    2. robertl_ is Robert Lyon, Catalyst in Wellington, New Zealand (robertl_, 08:02:29)
    3. mingard is Jono Mingard, Powershop in Wellington NZ (mingard, 08:02:31)
    4. ghada is Ghada El-Zoghbi, Catalyst in Sydney, AU (ghada, 08:02:42)
    5. Gregor Pirker, Donau University Krems, Austria (Gregor_Pirker, 08:02:46)

  1. Topics from previous meeting (anitsirk, 08:05:07)
    1. all items have been dealt with. :-) (anitsirk, 08:05:22)
    2. Dropping support for PHP 5.3 in 16.10: https://bugs.launchpad.net/mahara/+bug/1576448 (anitsirk, 08:05:27)
    3. Adopting PSR-2 for Mahara's PHP coding standard: https://bugs.launchpad.net/mahara/+bug/1576074 (anitsirk, 08:05:34)
    4. Yair Spielmann, Synergy Learning (Belfast), Moodle and (sometimes) Mahara developer. (sl-yairspi, 08:05:36)
    5. PHP Namespaces in 16.10: https://bugs.launchpad.net/mahara/+bug/1576075 (anitsirk, 08:05:43)
    6. German "du" translation: Discussed and awaiting feedback from Ralf Hilgenstock as main German translator (anitsirk, 08:05:55)
    7. mingard in favor of having an industry standard JS coding standard (anitsirk, 08:07:51)
    8. IDEA: in that context also think about extra things like how HTML elements are constructed / defined in JS as well as formatting (anitsirk, 08:08:16)
    9. http://jscs.info/overview has a bunch of different presets - as far as i know airbnb and google are the most widely used ones (mingard, 08:09:11)

  2. Mochikit purging (anitsirk, 08:11:39)
    1. a while ago, mingard started on the process of purging mochikit JS from Mahara and developed a tool for it. (anitsirk, 08:12:08)
    2. https://github.com/binary-koan/state-of-mahara (anitsirk, 08:12:17)
    3. Our Jen at Catalyst spent some time this week reviewing mingard's work to determine the next steps. (anitsirk, 08:12:51)
    4. https://wiki.mahara.org/wiki/Developer_Area/MochiKit_in_Mahara (anitsirk, 08:12:59)
    5. basically, it's still a lot of work to get rid of Mochikit in Mahara as it is everywhere as we had already established before. (anitsirk, 08:13:50)
    6. the good news is that we can progress step by step. (anitsirk, 08:14:06)
    7. anzeljg is Gregor Anzelj, developer and translator, POVSOD, Ljubljana, Slovenia (anzeljg, 08:16:31)
    8. Jen also updated https://reviews.mahara.org/#/c/5542/ to the latest master so we can look into getting this in sooner rather than later (anitsirk, 08:16:40)
    9. IDEA: we could add a deprecation notice to admin index page and get it out in a minor release to alert plugin developers to the fact that mochikit functionality is being deprecated. (anitsirk, 08:23:54)
    10. IDEA: we also could have a basic function to check plugins - if they have any of the basic moochikit syntax in them then warn with -deprecated- message (anitsirk, 08:27:55)
    11. https://mochi.github.io/mochikit/doc/html/MochiKit/index.html (robertl_, 08:28:39)
    12. List of Mochikit functions is available at https://mochi.github.io/mochikit/doc/html/MochiKit/index.html (anitsirk, 08:29:07)
    13. If you want to help with the purging of Mochikit, please let the core team know. (anitsirk, 08:31:07)

  3. MNet replacement (anitsirk, 08:34:32)
    1. Moodle has been talking about removing / replacing MNet for quite some time. We've met with them now already back in late 2014 to come up with a plan of how to approach this. (anitsirk, 08:35:53)
    2. https://wiki.mahara.org/wiki/Developer_Area/Specifications_in_Development/MNet_replacement (anitsirk, 08:36:01)
    3. there are a number of chunky pieces of work to make the replacement happen. (anitsirk, 08:36:22)
    4. Piers of Catalyst finished the tech side of the connection manager (anitsirk, 08:36:50)
    5. the connection manager is in review at https://reviews.mahara.org/#/q/status:open+project:mahara+branch:master+topic:%22connection+manager%22 (anitsirk, 08:37:04)
    6. https://reviews.mahara.org/#/q/status:open+project:mahara+branch:master+topic:%22connection+manager%22 (anitsirk, 08:37:04)
    7. another important piece to the puzzle is to make SAML an integral part of core mahara. Currently, it still needs to be installed separately. The patches for that are available at https://reviews.mahara.org/#/q/status:open+project:mahara+branch:master+topic:SimpleSAML (anitsirk, 08:37:38)
    8. https://reviews.mahara.org/#/q/status:open+project:mahara+branch:master+topic:SimpleSAML (anitsirk, 08:37:39)
    9. Piers also tackled removing the reliance on MNet for the Mahara assignment submission plugin. That is not yet merged into the plugin or in review as we'll need to check a couple things before putting that out there. (anitsirk, 08:39:02)
    10. the making of simplesaml as part of mahara relies on doing a: make ssphp (anitsirk, 08:41:30)
    11. https://github.com/brendanheywood/moodle-auth_saml2 (anitsirk, 08:44:04)
    12. components requiring composer could be a problem for some site admins that only have limited access to their server as some hosting companies allow deploying plugins by git pull only. Sometimes it even has to be done by disk when the institution is completely closed to the internet. (anitsirk, 08:48:07)
    13. a workaround for the limitation of everything needing to be in a git branch or not having direct internet access to pull other components, the code could be compiled locally and the pushed into git for deployment. (anitsirk, 08:56:12)
    14. ACTION: anitsirk to bring up the composer issue for the SAML work and see if we want to proceed or make changes. (anitsirk, 08:57:52)
    15. IDEA: if the workaround works well, would there be other components that could be installed via composer rather than kept in the repository? (anitsirk, 08:58:22)

  4. Next meeting and chair (anitsirk, 09:00:34)
    1. next meeting will be on 29 June 2016 at 8 UTC http://www.timeanddate.com/worldclock/fixedtime.html?iso=20160629T08 and chair will be anitsirk (anitsirk, 09:08:02)

  5. Any other business (anitsirk, 09:08:11)
    1. aarow moved our meetbot to a server so it doesn't run off someone's computer anymore. thank you, dobedobedoo (Andrew Nicols) for hosting it for many years. (anitsirk, 09:10:21)


Meeting ended at 09:11:30 UTC (full logs).

Action items

  1. anitsirk to bring up the composer issue for the SAML work and see if we want to proceed or make changes.


Action items, by person

  1. anitsirk
    1. anitsirk to bring up the composer issue for the SAML work and see if we want to proceed or make changes.


People present (lines said)

  1. anitsirk (117)
  2. ghada (42)
  3. mingard (20)
  4. robertl_ (19)
  5. anzeljg (13)
  6. sl-yairspi (10)
  7. mahara-meetbot (3)
  8. Gregor_Pirker (3)


Generated by MeetBot 0.1.4.