#mahara-dev: 52nd Mahara Developer Meeting

Meeting started by anitsirk at 07:16:35 UTC (full logs).

Meeting summary

    1. anitsirk is Kristina Hoeppner, Catalyst, Wellington in New Zealand (anitsirk, 07:16:47)
    2. robertl_ is Robert Lyon, Catalyst in Wellington, New Zealand (robertl_, 07:16:49)
    3. aaronw_ is Aaron Wells, Catalyst IT, Wellington NZ (aaronw_, 07:16:54)
    4. Yair Spielmann, Synergy Learning, in Belfast, Northern Ireland (sl-yair, 07:17:35)
    5. ghada is Ghada El-Zoghbi, Catalyst IT, Sydney, Australia (ghada, 07:17:37)
    6. Gregor_Pirker is Gregor Pirker, Danube University Krems, Krems, Austria (Gregor_Pirker, 07:17:41)

  1. Items from last meeting (anitsirk, 07:17:53)
    1. since both mingard and anzeljg aren't here (yet), we'll postpone their items until later or next time. (anitsirk, 07:17:54)

  2. Drop support for PHP 5.3? (anitsirk, 07:18:08)
    1. IDEA: drop support for PHP 5.3 officially in Mahara 16.10. It is getting old. (anitsirk, 07:21:16)
    2. some of our dependencies are starting to drop support for 5.3 (anitsirk, 07:23:43)
    3. http://php.net/eol.php (aaronw_, 07:26:46)
    4. AGREED: Drop support for php 5.3 in 16.10, unless we come across some big reason to keep it. (anitsirk, 07:29:26)

  3. Switch to PSR-2 coding standard? (anitsirk, 07:29:36)
    1. http://www.php-fig.org/psr/psr-2/ (aaronw_, 07:30:07)
    2. good idea to move to widely recognized coding standards. we'll need to assess the effort needed to do so. (anitsirk, 07:45:10)
    3. IDEA: run an autoformatter on all the existing code (excluding external libraries) and commit in one big commit (anitsirk, 07:45:30)
    4. ACTION: aaronw to file a bug to switch to the PSR-2 coding standard (anitsirk, 07:48:44)

  4. Namespaces and autoloading (anitsirk, 07:49:04)
    1. IDEA: move all of Mahara's library code into namespaces, so we can use an autoloader (anitsirk, 07:50:13)
    2. one downside to changing the code format is that it'll make it harder to apply patches. it's just whitespace changes, though, so it shouldn't be too big of a problem (anitsirk, 07:51:00)
    3. IDEA: so basically, the way this would go is that we'd put all of our library files under namespace \Mahara and then artefacts would be \Mahara\Artefact, etc and then we could register an autoloader, that would automatically know which PHP file to load, based on the namespace and our file layout thus removing our need for most require() statements (anitsirk, 07:54:08)
    4. unfortunately there's no autoloader for standalone functions, so aaronw_ would also like to move all the standalone functions like artefact_get_descendants into static functions of a utility class, so they could be autoloaded too (anitsirk, 07:54:55)
    5. IDEA: for backwards compatibility we could provide a compatibility library that maps the standalone function names to the new static functions (anitsirk, 07:55:21)
    6. ACTION: aaronw_ to think about how a change to namespaces would affect 3rd-party libraries and whether they'd need to move to namespaces as well. (anitsirk, 07:58:56)
    7. ACTION: aaronw_ to file a bug around namespaces. but no changes will be made until we have a solution to avoid breaking 3rd-party libraries as best as possible (anitsirk, 08:01:30)
    8. Moodle faced a similar issue and provided a couple of transition versions in which third party plugins could behave as before if they wanted. (anitsirk, 08:01:49)

  5. Mahara 16.04 release (anitsirk, 08:06:22)
    1. This release is a nice small one but does have some cool new features. (anitsirk, 08:07:47)
    2. http://manual.mahara.org/en/16.04/genindex.html#N (anitsirk, 08:07:49)
    3. we also integrated the Open Badges displayer plugin that discendum had developed. it's now in core. (anitsirk, 08:08:32)
    4. the big feature is HTML5 media player, which ZHAW in switzerland sponsored. (anitsirk, 08:08:54)
    5. I also gave a presentation on the big new features last week https://slides.com/anitsirk/count-down-to-mahara-1604 (in the recording it starts at around minute 4) (anitsirk, 08:09:47)
    6. the release of 16.04 also means that support for 1.10 is dropped. we will have one more minor point release for that version but not more. (anitsirk, 08:13:46)

  6. Next meeting and chair (anitsirk, 08:15:24)
    1. http://www.timeanddate.com/worldclock/fixedtime.html?iso=20160526T07 (anitsirk, 08:15:49)
    2. the 53rd Mahara developer meeting will take place on 26 May 2016 at 8:00 UTC and anitsirk will be chairing the meeting. http://www.timeanddate.com/worldclock/fixedtime.html?iso=20160526T08 (anitsirk, 08:25:09)

  7. Any other business (anitsirk, 08:25:18)
    1. alja, a UX designer who works with anzeljg, has come up with some wireframes and ideas that I'll put together with our current ideas and upload within the next two weeks. (anitsirk, 08:27:20)
    2. feedback from the partners in the european portfolio project: The Mahara 15.10 is very nice designed and userfriendly and they like it very much (anitsirk, 08:30:37)
    3. aaronw_ resurrected the script that allows pulling translations from git into the langpack site so that we now have the up-to-date czech translation in (anitsirk, 08:32:53)
    4. ACTION: anitsirk to discuss the german "du" translation with aaronw_ and whether git would be the solution to make the up-to-date translation available. (anitsirk, 08:35:02)


Meeting ended at 08:35:42 UTC (full logs).

Action items

  1. aaronw to file a bug to switch to the PSR-2 coding standard
  2. aaronw_ to think about how a change to namespaces would affect 3rd-party libraries and whether they'd need to move to namespaces as well.
  3. aaronw_ to file a bug around namespaces. but no changes will be made until we have a solution to avoid breaking 3rd-party libraries as best as possible
  4. anitsirk to discuss the german "du" translation with aaronw_ and whether git would be the solution to make the up-to-date translation available.


Action items, by person

  1. aaronw_
    1. aaronw_ to think about how a change to namespaces would affect 3rd-party libraries and whether they'd need to move to namespaces as well.
    2. aaronw_ to file a bug around namespaces. but no changes will be made until we have a solution to avoid breaking 3rd-party libraries as best as possible
    3. anitsirk to discuss the german "du" translation with aaronw_ and whether git would be the solution to make the up-to-date translation available.
  2. anitsirk
    1. anitsirk to discuss the german "du" translation with aaronw_ and whether git would be the solution to make the up-to-date translation available.


People present (lines said)

  1. anitsirk (110)
  2. aaronw_ (89)
  3. ghada (46)
  4. robertl_ (23)
  5. sl-yair (16)
  6. Gregor_Pirker (8)
  7. dobedobedoh (5)
  8. maharameet-nz (4)


Generated by MeetBot 0.1.4.