#mahara-dev Meeting

Meeting started by mingard at 08:05:14 UTC (full logs).

Meeting summary

    1. Welcome to the 44th Mahara developer meeting. Please introduce yourself using #info at the start of the line so that we know who's attending today / tonight (mingard, 08:05:24)
    2. mingard is Jono Mingard, Catalyst IT in Wellington, NZ (mingard, 08:05:30)
    3. anitsirk is Kristina Hoeppner, Catalyst IT, Wellington, NZ (anitsirk, 08:05:37)
    4. anzeljg is Gregor Anželj, developer and translator from Ljubljana, Slovenia (anzeljg, 08:05:39)
    5. yuliya is Yuliya Bozhko from Totara Learning, Brighton, UK (yuliya, 08:05:53)
    6. rkabalin is Ruslan Kabalin, Lancaster University, UK (rkabalin, 08:05:58)
    7. robertl_ is Robert Lyon, Catalyst IT in Wellington, NZ (robertl_, 08:06:10)
    8. ghada is Ghada El-Zoghbi, Catalyst IT in Sydney, AU (ghada, 08:06:13)

  1. Items from last meeting (mingard, 08:06:36)
    1. yuliyabozhko1 will try to contact Launchpad and check if there is a way to get a custom language code set up (mingard, 08:06:45)
    2. Launchpad does not allow for custom language packs that don't conform to ISO to be translated online. However, we can still upload the po files and make them available via langpacks.mahara.org (anitsirk, 08:11:19)
    3. langpacks.mahara.org will be updated asap with the de_du langpack. (anitsirk, 08:11:44)
    4. robertl_ to create bugs / wishlist items for improving the HTML export (mingard, 08:12:13)
    5. , translators need to manually push their de_du po file for each branch to launchpad (son, 08:12:49)
    6. son, Son Nguyen, Catalyst IT, Wellington, NZ (son, 08:13:54)
    7. ACTION: robertl_ to finish creating bugs for HTML export before the next meeting (mingard, 08:15:54)
    8. anitsirk to get GitLab ball rolling (mingard, 08:17:16)
    9. The official Mahara repositories are now at https://git.mahara.org (anitsirk, 08:17:43)
    10. the repositories are mirrored to Github and to https://git.nzoss.org in case one of the others goes down. (anitsirk, 08:18:09)
    11. aarow is going to update the wiki so that we have the new links there. (anitsirk, 08:18:29)
    12. since nobody is pushing to the repositories directly (at least the mahara codebase), account creation is only upon request. all code for Mahara goes through Gerrit. (anitsirk, 08:19:06)
    13. aarowlaptop to upgrade reviews gerrit soon (mingard, 08:22:05)
    14. Gerrit is upgraded. (anitsirk, 08:22:51)
    15. add php version to mahara.org/stats to see what versions people are using (a mahara dev) (mingard, 08:25:30)
    16. aarow has been making progress on this - see https://bugs.launchpad.net/mahara/+bug/1447865 (anitsirk, 08:26:26)
    17. https://wiki.php.net/rfc/php7timeline (ghada, 08:36:42)
    18. whether to backport this to 1.9, 1.10 and 15.04 is yet to be decided (mingard, 08:41:28)

  2. Next meeting and chair (mingard, 08:41:54)
    1. rkabalin is going to chair the 45th Mahara developer meeting on 25 June 2015 at 8:00 UTC (mingard, 08:44:38)
    2. http://www.timeanddate.com/worldclock/fixedtime.html?msg=45th+Mahara+developer+meeting&iso=20150625T08&p1=1440 (mingard, 08:44:53)

  3. Any other business (mingard, 08:45:40)
    1. The Mahara wiki was upgraded to a newer version (anitsirk, 08:46:02)
    2. the Mahara user manual was upgraded to a newer version of Sphinx. Unfortunately, we could not yet resolve a bunch of PDF generation errors that may have been caused by a translation. (anitsirk, 08:46:37)
    3. Therefore, we suspended the PDF generation for the time being until we can find the apostrophe or other little thing that's causing it. Since the translation export only happens once a day, it's a long process and the error messages are a bit cryptic. (anitsirk, 08:47:22)
    4. Submissions for the next Mahara newsletter are due by 26 June 2015. (anitsirk, 08:50:54)


Meeting ended at 08:53:36 UTC (full logs).

Action items

  1. robertl_ to finish creating bugs for HTML export before the next meeting


Action items, by person

  1. robertl_
    1. robertl_ to finish creating bugs for HTML export before the next meeting


People present (lines said)

  1. mingard (71)
  2. anitsirk (56)
  3. robertl_ (28)
  4. yuliya (23)
  5. ghada (23)
  6. son (14)
  7. rkabalin (6)
  8. mahara-jenkins (4)
  9. maharameet (3)
  10. tonyjbutler (1)
  11. anzeljg (1)


Generated by MeetBot 0.1.4.