08:02:22 <yuliyabozhko> #startmeeting
08:02:22 <maharameet> Meeting started Thu Feb 26 08:02:22 2015 UTC.  The chair is yuliyabozhko. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:02:22 <maharameet> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:02:23 <sonn> ok
08:02:28 <ghada> #info ghada-l is Ghada El-Zoghbi at Catalyst IT, Sydney
08:02:31 <yuliyabozhko> Please introduce yourselves
08:02:38 <yuliyabozhko> #info yuliya is Yuliya Bozhko from Totara Learning Solutions, Wellington, NZ
08:02:39 <sonn> #info sonn is Son Nguyen, Catalyst IT, Wellington, NZ
08:02:56 <robertl_> #info robertl_ is Robert Lyon, Catalyst IT, Wellington, NZ
08:03:03 <anitsirk> #info anitsirk is Kristina Hoeppner, Catalyst IT, Wellington, NZ
08:03:16 <yuliyabozhko> right, seems to be everyone?
08:03:21 <yuliyabozhko> nigelc: are you here?
08:03:36 <sonn> he was
08:03:46 <yuliyabozhko> I will assume he'll come back :)
08:03:58 <yuliyabozhko> so..
08:04:01 <yuliyabozhko> #topic Items from last meeting
08:04:07 <yuliyabozhko> #info Feature freeze (patches should be in gerrit by now)
08:04:14 <yuliyabozhko> This is pretty much self explanatory :)
08:04:20 <yuliyabozhko> Feature freeze started in the first week of February. All patches should be in review now...
08:04:28 <robertl_> there are a bunch of stuff in reviews
08:04:29 <yuliyabozhko> And all we need to do is review, review, review :D and merge ;)
08:04:37 <anitsirk> yup. Now it's time to go through all the reviews.
08:04:42 <yuliyabozhko> anything with high priority?
08:04:52 <anitsirk> Call to code reviews and testing...
08:04:58 <robertl_> and hopefully we will be able to get all the big things in by 1504
08:05:12 <anitsirk> annotations and smartevidence patches from nigel and ghada
08:05:15 <yuliyabozhko> yep. would be good to know which ones must go into release
08:05:28 <anitsirk> they would be great to get in amongst some others as they are the ground work for bigger things.
08:05:36 <yuliyabozhko> cool
08:05:48 <ghada> you had a spreadsheet for the last release with high priority items
08:06:00 <ghada> are you going to create something like that this time?
08:06:10 <yuliyabozhko> #action everyone have a look at annotations and smartevidence patches from nigel and ghada as high priority ones for 1504
08:06:25 <ghada> pressure is on!
08:06:39 <yuliyabozhko> I try to review when I have time, although I don't too much of it :)
08:06:41 <anitsirk> robertl_ ^
08:06:49 <robertl_> trying to find url
08:06:51 <ghada> i've submitted another patch today.
08:06:59 <ghada> i'm having issues with the leap2A import/export
08:07:05 <yuliyabozhko> https://reviews.mahara.org/#/c/4123/
08:07:08 <ghada> just confused.
08:07:54 <robertl_> https://docs.google.com/spreadsheets/d/1zHS0I3a79JsbtpD-NgdksA8OwS0Dt0VVN78nP5a7-KM/edit?usp=sharing
08:08:14 <yuliyabozhko> and this one ? https://reviews.mahara.org/#/c/4216/
08:08:26 <robertl_> if people can see that - the highlighted ones are the top priority
08:08:39 <yuliyabozhko> thanks robertl_
08:08:48 <yuliyabozhko> #link https://docs.google.com/spreadsheets/d/1zHS0I3a79JsbtpD-NgdksA8OwS0Dt0VVN78nP5a7-KM/edit#gid=0
08:09:08 <robertl_> so if there are other patches you think need to be added/highlighted please feel free to do so
08:09:23 <anitsirk> hi tonyjbutler
08:09:24 <robertl_> I believe people have editing rights
08:09:35 <yuliyabozhko> yep, I think so
08:09:35 <tonyjbutler> hi everyone
08:09:58 <robertl_> though now the meeting notes will be on the web anyone will be able to edit :(
08:10:21 <anitsirk> hehe. robertl_ better make a backup of the file every day
08:10:30 <yuliyabozhko> can you make it so that people request access?
08:10:50 <yuliyabozhko> or what anitsirk suggested :)
08:11:07 * robertl_ wonders if full url can be scrubed from minutes?
08:11:26 <anitsirk> i think dobedobedoh who runs meetbot could do that
08:11:29 <yuliyabozhko> it will be in IRC log anyway
08:11:44 <robertl_> ah
08:11:49 <anitsirk> but we don't publish the logs as far as i know. so only people who are signed in
08:12:01 <yuliyabozhko> hmmm...
08:12:24 <ghada> i think in Google docs you can lock it and only share with certain people.
08:12:29 <anitsirk> alternative 3: create another spreadsheet and send us the url via mail ;-)
08:12:36 <yuliyabozhko> good idea :D
08:12:37 <anitsirk> or that
08:12:39 <ghada> yep
08:12:40 <sonn> I can see the IRC log without login
08:13:10 <yuliyabozhko> #action robertl_ create speadsheet of issues to review and email it to everyone
08:13:14 <yuliyabozhko> :) here you go
08:13:37 <nigelc> #info nigelc1 is Nigel Cunningham, Catalyst IT, Melbourne, AU
08:13:42 <anitsirk> or in that case, just use the existing one and change the perms
08:13:42 <robertl_> I've just taken a copy of the sheet for backup purposes
08:13:54 <robertl_> will try and invite peoples to that one
08:14:00 <yuliyabozhko> that would be great
08:14:13 <yuliyabozhko> moving on or anything else here?
08:14:21 <nigelc> Sorry - IRC cut out on me because I closed the VPN, but Pidgin only told me when I went to ask if the meeting was still on because it was awfully quiet :)
08:14:26 <ghada> hi nigelc1
08:14:31 <yuliyabozhko> hi Nigel
08:14:56 <anitsirk> hi nigelc1
08:15:14 <yuliyabozhko> do we have any dates like UI freeze, QA period?
08:15:19 <yuliyabozhko> I am not too sure
08:15:26 <anitsirk> yes, we do
08:15:42 <anitsirk> https://wiki.mahara.org/index.php/6MonthlyCycle
08:15:52 <anitsirk> but we'll have to push the ui freeze out a bit.
08:15:58 <nigelc> Hi guys. Sorry - was catching up on the log so far :) Now I'm with you.
08:15:59 <anitsirk> features need to be put in first ;-)
08:16:27 <anitsirk> good to have you here, nigelc
08:16:40 <yuliyabozhko> so, UI freeze starts mid March?
08:16:50 <nigelc> Re the smart evidence patches, I've been told I've been doing too much Mahara, so not sure how useful I'll be able to be.
08:17:01 <anitsirk> yuliyabozhko: yes, probably a week to 2 weeks delayed.
08:17:07 <yuliyabozhko> cool
08:17:21 <robertl_> doing too much mahara - no such thing :)
08:17:41 <anitsirk> which can still work because if we do a better job before the RC1, there won't be too many more RC before the final release :-)
08:17:54 <yuliyabozhko> right
08:18:11 <robertl_> hopefully with the automated testing means less fixing of things in RC as well
08:18:11 <yuliyabozhko> should we add anything about this to meeting minutes?
08:18:11 <nigelc> :) I've been putting a lot of work into the timeline support. Have a working prototype for just rearranging blocks on front page. Will tidy up and put into Gerrit soon.
08:18:43 <anitsirk> nigelc: sounds great. unfortunately, we won't be able to review it for a while though as it won't get into 15.04.
08:18:44 <nigelc> Need more tests.
08:18:59 <yuliyabozhko> yeah, I was just about to ask that...
08:19:09 <yuliyabozhko> if it was supposed to get into 1504
08:19:30 <nigelc> antisirk: Didn't want in 15.04. Only a prototype at this stage.
08:20:03 <anitsirk> nigelc: do you think you'll have it in a working condition for Mahara Hui?
08:20:15 <anitsirk> Would be great to play with it then
08:20:24 <yuliyabozhko> ok. if there is nothing on feature freeze, I am moving to the next topic :) - Mahara Hui
08:20:37 <yuliyabozhko> #info Mahara Hui - have you signed up yet?
08:20:42 <nigelc> antisirk: Yes, but I haven't been told I'm going yet.
08:21:00 <anitsirk> i keep my fingers crossed.
08:21:18 <robertl_> I believe I'm allowed to go is that right anitsirk ?
08:21:41 <yuliyabozhko> ah, everyone can go, but me :(
08:21:48 <anitsirk> robertl_ sure you are. we'll discuss this next week when aarow is back.
08:21:57 <robertl_> cool
08:22:14 <yuliyabozhko> #link https://maharahui.org.nz
08:22:18 <yuliyabozhko> If you haven't signed up yet, you should do so :)
08:22:20 <anitsirk> we are looking into scheduling a couple or so dev / new feature sessions.
08:23:10 <anitsirk> catalyst nz people: we'll look into that internally. so please speak with me first.
08:23:46 <yuliyabozhko> anything else here?
08:24:25 <yuliyabozhko> cool. moving on
08:24:26 <anitsirk> we have a good line up of presentations :-)
08:24:46 <yuliyabozhko> now I feel bad that I am going to miss it :P
08:24:56 <yuliyabozhko> #topic Mahara templates and RTL language support - ways we could improve it
08:25:03 <yuliyabozhko> I don't know much about it. Found a page on wiki with a gigantic TODO :)
08:25:09 <yuliyabozhko> https://wiki.mahara.org/index.php/Developer_Area/Specifications_in_Development/Better_RTL_Support
08:25:17 <yuliyabozhko> so, not much info there :)
08:25:34 <yuliyabozhko> if anyone interested, I can share some knowledge from Totara team related to CSS styles, string concatenation, mylti-byte characters support, etc... I think it would nicely apply to Mahara as well.
08:25:57 <yuliyabozhko> so I can add some info to that page and everyone can have a look later
08:26:13 <anitsirk> yuliyabozhko: that would be great.
08:26:31 <yuliyabozhko> #action yuliya add some info on RTL support to wiki
08:27:29 <yuliyabozhko> well, if anyone has some ideas/suggestions here, we will be happy to hear them
08:27:46 <robertl_> yeah - I feel not much love goes toward RTL support - as I tend to test in english/french/german langs
08:27:52 <anitsirk> sorry, by RTL is rustier than Japanese
08:28:02 <anitsirk> by = my
08:28:12 <nigelc> I can help with testing (Hebrew... not that I use it a lot!).
08:28:21 <anitsirk> good to know, nigelc
08:28:30 <ghada> and i can help a bit with Arabic
08:28:46 <robertl_> do we know which mahara RTL lang packs are up to date?
08:28:49 <ghada> but very rusty
08:29:05 <yuliyabozhko> yeah, would be good when patch is tested to check how things look in RTL
08:29:09 <anitsirk> nigelc: we only have 3950 lang strings in hebrew to go. so you should be fine seeing at last 30% of mahara in hebrew :-)
08:29:27 <anitsirk> ghada: arabic is even better: it's already at 50% :-)
08:29:37 <robertl_> because testing things with an out of date lang pack can be annoying
08:29:38 <nigelc> So we've at least got the ability to check it. After all, we don't have to know the languages wonderfully. We just have to be able to make sure the wrapping is being done correctly and so on.
08:29:50 <yuliyabozhko> yep, definitely
08:29:59 <yuliyabozhko> that's what  I usually do
08:30:00 <nigelc> antisirk: My Hebrew is Biblical, probably not so useful for translating strings!
08:30:12 <yuliyabozhko> but there is one issue with language packs that I found
08:30:35 <anitsirk> nigelc: i wasn't suggesting you'd translate. i have knowledge of modern german, but when robertl_ asked me to translate something on the spot it was rather difficult as i don't know the terminology that is normally used.
08:30:55 <anitsirk> our translators are great in expanding and keeping our lang packs up-to-date.
08:31:11 <nigelc> Ok.
08:31:13 <ghada> ok, so it's just display, wrapping that you need. i can do that.
08:31:34 <yuliyabozhko> does everyone know that you can test RTL with any language?
08:31:58 * nigelc wonders what RTL English would look like.
08:32:02 <yuliyabozhko> you just need to add string wiht a key 'thisdirection' to langconfig and set it to RTL
08:32:13 <yuliyabozhko> it looks RTL, nigelc1
08:32:14 <yuliyabozhko> :
08:32:17 <yuliyabozhko> :)
08:32:19 <robertl_> I note that some third party plugins can handle RTL but I'm not sure if we are utilising it in mahara
08:32:37 <nigelc> ?noitcerid
08:32:46 <yuliyabozhko> lol, no
08:32:55 <anitsirk> also: if someone knows how we could trick Launchpad into creating a second German lang pack (for the informal German) without compromising other German-like languages like Austrian, please let me know. The German community wanted to create an informal lang pack for some time now, but we haven't been able to set it up in Launchpad as that doesn't allow for it.
08:33:03 <yuliyabozhko> it's not about words themselves, it's about layout
08:33:23 <robertl_> I'd imagine things like tinymce would use RTL in it's editor
08:33:34 <robertl_> do we deal with that?
08:33:35 <anitsirk> yup. I think there's button for it
08:33:36 <yuliyabozhko> anitsirk: you need to upload master template for new language
08:33:42 <nigelc> Oh of course. I am out of practice :)
08:33:58 <anitsirk> yuliyabozhko: we can't even create a lang code for that. i think that was the problem.
08:34:09 <yuliyabozhko> you can have custom lang codes
08:34:14 <anitsirk> there is no "de_du" and "de_sie"
08:34:22 <anitsirk> in launchpad?
08:34:50 <yuliyabozhko> I am pretty sure you can
08:34:52 <anitsirk> sonn: do you have the url to the question at hand?
08:35:05 <sonn> looking for it
08:36:08 <anitsirk> https://answers.launchpad.net/launchpad/+question/250277
08:36:30 <sonn> ta anitsirk, my network is too slow
08:36:30 <anitsirk> oh. they did answer it's not possible. sorry. didn't remember that.
08:36:53 <anitsirk> and never got back on the dialect question.
08:37:39 <yuliyabozhko> well, for Totara social I have "If necessary, you may define custom language codes for this project."
08:38:28 <yuliyabozhko> why Mahara project doesn't have it?...
08:38:42 <anitsirk> yuliyabozhko: where do you do that?
08:38:52 <anitsirk> in the local folder on your instance?
08:38:56 <robertl_> https://translations.launchpad.net/mahara/+custom-language-codes
08:39:05 <yuliyabozhko> on project transaltion page https://translations.launchpad.net/PROJECTNAME
08:39:12 <yuliyabozhko> yep that one!
08:39:21 <yuliyabozhko> I don't have access to that page :)
08:40:01 <anitsirk> robertl_ would that be pushed to the langpack page though? would it overwrite something in the other files?
08:40:02 <yuliyabozhko> anitsirk: is that what you looked for?
08:40:11 <anitsirk> i don't know yet.
08:40:17 <robertl_> I
08:40:20 <yuliyabozhko> you first create a code
08:40:25 <anitsirk> i just asked ralf if he remembers the projects where he saw the dialects set up.
08:40:26 <yuliyabozhko> then you need to upload a template for it
08:40:32 <robertl_> I've no idea yet - first time I've seen the page
08:40:39 <anitsirk> i think it might be best to just ask them how they did it and then see if that would work.
08:41:02 <yuliyabozhko> you want German to be parent lang pack?
08:41:06 <anitsirk> we need - at least for german - a proper "du" lang pack and not a work around where the import may not know where files go ;-)
08:41:54 <yuliyabozhko> import takes what you give it... it will just take translated strings and make a language pack
08:41:59 <anitsirk> i think we discussed the parenting. the only difficulty is that you'd have to so many strings wouldn't be translated so you'd not have a good overview of which ones would need to be translated.
08:42:08 <yuliyabozhko> you don't even have to have any translations when you strart
08:42:17 <anitsirk> ralf is very efficient in translating and copying and so i think it was easier for him to just do a full lang pack.
08:42:17 <robertl_> this should be an action point I guess - find out about custom codes
08:42:30 <yuliyabozhko> yep, that's the problem with parent lang packs
08:42:53 <anitsirk> robertl_ this issue is already on sonn's list :-)
08:43:03 <yuliyabozhko> but you can start with exporting german lang pack and importing it into dialect, then overwriting whatever you need
08:43:05 <robertl_> ok
08:43:23 <anitsirk> yuliyabozhko: for that we need to find out how to set up a dialect on launchpad :-)
08:43:39 <anitsirk> then we would be sorted i think.
08:43:50 <yuliyabozhko> custom language code? I thought that's why you needed it
08:44:21 <anitsirk> i don't know what the difference is.
08:44:30 <yuliyabozhko> language code is really just a space where you upload your translations
08:44:31 <nigelc1> Would it be feasible to have 2 entirely separate sets of translations, one 'formal' and one 'informal', and you pick whether you want the formal or informal 'style' in a setting. Then you can use German twice without any other hackery.
08:44:50 <anitsirk> yes, but we can't set the up in launchpad at the moment. that's the problem.
08:44:50 <yuliyabozhko> yes, that's what I am suggesting
08:45:06 <anitsirk> the reply on the question i posted earlier said it's not possible and we didn't get a reply back on the dialects.
08:45:36 <anitsirk> sorry that this has been taking over the discussion.
08:45:42 <yuliyabozhko> launchpad doesn't care about lang codes. they are used merely for people to know what they are translating
08:45:56 <yuliyabozhko> anyway, lat me know if you need help
08:46:06 <anitsirk> thanks, yuliyabozhko.
08:46:10 <yuliyabozhko> I spent 2 weeks setting up TS languages recently
08:46:26 <yuliyabozhko> I know how it works :P and I am not proud of it >.<
08:46:36 <yuliyabozhko> next topic!
08:46:37 <anitsirk> yuliyabozhko: can you then please make an action item for sonn to talk with you? maybe you two can figure it out?
08:46:46 <yuliyabozhko> yep
08:46:49 <sonn> ta yuliyabozkho, I will
08:46:54 <anitsirk> awesome. thank you.
08:47:13 <yuliyabozhko> #action sonn and yuliya figure out how to create a dialect lang code and set up translations for it
08:47:19 <yuliyabozhko> #topic Mahara export to HTML - could do with some love
08:47:24 <yuliyabozhko> what is it about? :)
08:47:32 <anitsirk> who suggested it?
08:47:34 <robertl_> I added that in
08:47:49 <robertl_> because I had to fix a bug with it recently
08:48:05 <robertl_> I noticed how bad looking the exported html is
08:48:17 <robertl_> yet we have nice themes in mahara
08:48:20 <ghada> yep, i can confirm that
08:48:33 <anitsirk> yes, the theme is not exported. everything is just in raw, right?
08:48:38 <yuliyabozhko> hmm, I don't even know how it works tbh :)
08:48:59 <anitsirk> yuliyabozhko: portfolio -> Export -> HTML -> Unzip the file and see it in raw. :-)
08:49:14 <robertl_> so I was thinking it would be nice to get a roadmap of how we could improve it
08:49:18 <yuliyabozhko> yep, I know where it is in UI, I don't know how it works on backend :)
08:49:33 <yuliyabozhko> robertl_: good idea
08:50:12 <yuliyabozhko> what do we need for that?
08:50:24 <robertl_> it holds some image files separate to raw theme and I noticed some were out of date .gif instead of .png
08:51:03 <robertl_> so i'm thinking it needs to be more flexible and get things from themes direct
08:51:25 <robertl_> I guess first thing would be to have a wiki page
08:51:28 <robertl_> to record
08:51:33 <robertl_> thoughts
08:51:46 * robertl_ goes to add one
08:51:52 <yuliyabozhko> if you have some ideas, would you like to write up?
08:52:06 <yuliyabozhko> :) do we need a bug as well?
08:52:32 <yuliyabozhko> #action robertl_ create a wiki page about HTML export improvements
08:52:49 <ghada> i ran into a bug with it yesterday. https://bugs.launchpad.net/mahara/+bug/1425424
08:52:54 <robertl_> I think - start with wiki page then we can work out what bugs we need to file from that
08:53:32 <ghada> i put in a fix but now i think it's probably something else - the image directories it was trying to copy didn't actually exist.
08:53:33 <yuliyabozhko> cool. it's all yours then ;)
08:53:36 <anitsirk> robertl_ could you please set up a blueprint in launchpad and add the link to the wiki page there?
08:53:41 <anitsirk> that would then make associating bugs easier
08:53:52 <robertl_> ghada - point 3 I've made a work around patch
08:53:52 <yuliyabozhko> yep. that's a good point
08:54:13 <ghada> ok
08:54:27 <yuliyabozhko> #action robertl_ set up a blueprint in launchpad on HTML export and add the link to the wiki page there
08:54:32 <robertl_> the render of block avoids ajaxify if in export mode
08:55:16 <yuliyabozhko> is this all on this, robertl_?
08:55:24 <robertl_> yep
08:55:28 <yuliyabozhko> cool. thanks
08:55:30 <anitsirk> should those items be separate bugs so that we don't change status without having fixed everything else?
08:56:04 <robertl_> I'd already fixed 3, and 4 patches in review
08:56:29 <ghada> oh, i didn't know that. i had submitted one yesterday for it.
08:56:36 <robertl_> https://reviews.mahara.org/#/c/4303/
08:56:57 <yuliyabozhko> you probably need to coordinate with each other :)
08:57:08 <robertl_> https://reviews.mahara.org/#/c/4302/
08:57:25 <ghada> i did try to do a search in launchpad if there was one already for it.
08:57:29 <ghada> just not good enough i guess...
08:57:54 <robertl_> but yeah - I'll take a look at your patch ghada and see what can can be merged with mine
08:58:19 <ghada> i can remove the stuff to do with the export and just leave the lang strings.
08:58:27 <ghada> so we only use your patch
08:59:03 <robertl_> ok
08:59:26 <yuliyabozhko> right. next topic?
08:59:35 <yuliyabozhko> #topic next meeting date and chair
08:59:37 <robertl_> I've a few other patches to fix things so they work with ajaxify  rather than turn ajaxify off for them
09:00:44 <yuliyabozhko> next meeting, I would suggest March 26th, exactly 4 weeks from now
09:00:52 <yuliyabozhko> It is Thursday same as today's meeting
09:01:05 <anitsirk> sounds good to me
09:01:12 <robertl_> sounds fine to me
09:01:13 <sonn> ok to me
09:01:23 <nigelc1> Yes
09:01:32 <yuliyabozhko> Same time? It is ok for everyone?
09:01:39 <tonyjbutler> fine by me
09:01:54 <anitsirk> yup
09:01:57 <yuliyabozhko> #info The next Mahara dev meeting will take place on 26 March 2015 at 8:00 UTC http://www.timeanddate.com/worldclock/fixedtime.html?msg=42nd+Mahara+Developer+Meeting&iso=20150326T08
09:02:08 <yuliyabozhko> Who would like to chair?
09:02:08 <ghada> yep
09:02:33 <yuliyabozhko> :)
09:02:37 <anitsirk> ghada: was that an (accidental) yes to the question? ;-)
09:02:43 <yuliyabozhko> haha
09:03:00 <yuliyabozhko> I think I put the link in too early :P
09:03:20 <ghada> no..
09:03:32 <anitsirk> i can chair if nobody wants to
09:03:33 <ghada> :-[
09:03:52 <robertl_> chair sold to anitsirk
09:03:57 <ghada> thanks anitsirk
09:03:58 <yuliyabozhko> #info  anitsirk will chair the 42nd Mahara dev meeting on 26 March 2015
09:03:59 <robertl_> :)
09:04:02 <yuliyabozhko> awesome
09:04:06 <anitsirk> is it an armchair, robertl_?
09:04:19 <robertl_> it's an easy chair :)
09:04:20 <yuliyabozhko> robertl_ it's better be good :)
09:04:29 <yuliyabozhko> #topic Any other business
09:04:34 <yuliyabozhko> Anyone has anything?
09:04:40 <anitsirk> none from me today
09:04:47 <yuliyabozhko> I've got nothing
09:04:52 <ghada> nope
09:05:00 <nigelc1> Nope
09:05:00 <sonn> nothing from me
09:05:02 <robertl_> naught from me
09:05:13 <yuliyabozhko> I guess this it is then. thanks everyone!
09:05:17 <yuliyabozhko> #endmeeting