#mahara-dev Meeting

Meeting started by anitsirk at 08:01:52 UTC (full logs).

Meeting summary

    1. Welcome to the 39th Mahara developer meeting. (anitsirk, 08:01:56)
    2. anitsirk is Kristina Hoeppner, Catalyst IT, Wellington (anitsirk, 08:01:56)
    3. yuliya is Yuliya Bozhko from Totara Learning Solutions in Wellington, NZ (yuliyabozhko, 08:02:10)
    4. tobiasz_ is Tobias Zeuch, developer at KIT, Karlsruhe, Germany (tobiasz_, 08:02:12)
    5. robertl is Robert Lyon, Catalyst IT, Wellington, NZ (robertl, 08:02:18)
    6. aarowlaptop, Aaron G. Wells at Catalyst IT in sunny Wellington New Zealand (aarowlaptop, 08:02:22)

  1. Items from last meeting (anitsirk, 08:03:07)
    1. aarowlaptop update the wiki with "Signed-off" line necessity changes (anitsirk, 08:03:07)
    2. ghada-l is Ghada El-Zoghbi at Catalyst IT, Sydney (ghada, 08:03:45)
    3. aarowlaptop updated the documentation on the wiki so that the signed-off-by line is not needed in git commit messages anymore. (anitsirk, 08:04:50)
    4. I've also updated gerrit to no longer require the Signed-off-by line. This seems to have had the unintentional side effect that now, if you *do* use a Signed-off-by line, and it's below the Change-Id line, gerrit gets upset. (aarowlaptop, 08:05:00)
    5. https://wiki.mahara.org/index.php/Developer_Area/Contributing_Code for the changes in documentation (anitsirk, 08:06:52)
    6. https://reviews.mahara.org/#/c/4106/ (aarowlaptop, 08:08:07)
    7. You can have a signed-off-by line below the Change-ID. aarowlaptop double-checked. (anitsirk, 08:08:38)
    8. aarowlaptop will compare all aspects of Smarty and Twig and write wiki on this change proposal (anitsirk, 08:09:05)
    9. in discussions with Catalyst front-end developers, we decided to go with Twig. this change will not be implemented for 15.04, but we are looking into doing it for the 15.10 release. (anitsirk, 08:10:42)
    10. https://reviews.mahara.org/#/q/message:Twig+status:abandoned,n,z (aarowlaptop, 08:11:09)
    11. https://reviews.mahara.org/#/q/status:abandoned+project:mahara+branch:master+topic:twig,n,z (yuliyabozhko, 08:11:15)
    12. IDEA: introduce new templates and CSS framework in 15.10. since providing two different ways of doing things (css and templates) could be very difficult to maintain, we were pondering a long-term support release for 15.04 (anitsirk, 08:17:33)
    13. part of the patches for Twig that already exist included functionality to convert Dwoo templates to Twig ones mostly automatically. (anitsirk, 08:20:21)
    14. Backwards compatibility is a possibility, but would only be considered if it is commissioned work as it can be quite tricky to maintain 2 systems at once. (anitsirk, 08:21:52)
    15. leave CSS framework proposal up to the front-end experts to hash it out with aarowlaptop (anitsirk, 08:23:42)
    16. http://www.gumbyworld.com/wp-content/themes/duotive-three/images/home-large-gumby.png (aarowlaptop, 08:25:35)
    17. ACTION: aarowlaptop to investigate Gumby and Bootstrap a bit to make a final decision which CSS framework to choose. (anitsirk, 08:26:11)
    18. We did discuss some concerns about whether going to a framework like that, would discourage community theme developers by making the development process harder. (anitsirk, 08:32:12)
    19. Switching to a css framework that needs compiling such as Gumby / Bootstrap means that you write SASS and then compile it into CSS. There are tools available to assist with that process. (anitsirk, 08:35:45)
    20. Decision still needs to be made whether pre-compiled CSS is being shipped in git or not. (anitsirk, 08:36:07)

  2. Put a "Copy" button on a copyable page (robertl) (anitsirk, 08:37:07)
    1. IDEA: One of the small things we plan to add to mahara is a 'copy page' button directly onto the page itself to make copying of pages easier. (anitsirk, 08:37:46)
    2. https://bugs.launchpad.net/mahara/+bug/745418 for the idea (anitsirk, 08:37:57)
    3. ACTION: robertl to make forum post in the open discussion forum about the copy button on pages to see if people have other / additional ideas that should be kept in mind. (anitsirk, 08:41:26)
    4. IDEA: a user should need to confirm the copying of a page / collection so that they don't accidentally copy the pages as they will then also have all the artefacts and would need to delete those manually. (anitsirk, 08:47:31)

  3. Next meeting and chair (anitsirk, 08:57:11)
    1. The next mahara dev meeting will take place on 22 January 2015 at 8:00 UTC. (anitsirk, 09:00:15)
    2. http://www.timeanddate.com/worldclock/fixedtime.html?msg=40th+Mahara+Developer+Meeting&iso=20150122T08 (anitsirk, 09:00:16)
    3. robertl will chair the 40th Mahara dev meeting on 22 January 2015. (anitsirk, 09:01:20)

  4. Any other business (anitsirk, 09:01:28)
    1. Tomorrow is the last day to send through any items for the January newsletter. (anitsirk, 09:02:26)
    2. Send articles to newsletter@mahara.org (anitsirk, 09:02:44)


Meeting ended at 09:05:00 UTC (full logs).

Action items

  1. aarowlaptop to investigate Gumby and Bootstrap a bit to make a final decision which CSS framework to choose.
  2. robertl to make forum post in the open discussion forum about the copy button on pages to see if people have other / additional ideas that should be kept in mind.


Action items, by person

  1. aarowlaptop
    1. aarowlaptop to investigate Gumby and Bootstrap a bit to make a final decision which CSS framework to choose.
  2. robertl
    1. robertl to make forum post in the open discussion forum about the copy button on pages to see if people have other / additional ideas that should be kept in mind.


People present (lines said)

  1. anitsirk (104)
  2. aarowlaptop (82)
  3. yuliyabozhko (36)
  4. ghada (24)
  5. robertl (23)
  6. tobiasz_ (9)
  7. son (4)
  8. maharameet (2)


Generated by MeetBot 0.1.4.